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Trademarks
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Source Code
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Disclaimer

CYPRESS MAKES NO WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, WITH REGARD TO THIS MATERIAL,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE. Cypress reserves the right to make changes without further notice to the materials described
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The chapter gives short overview of this document.

This document describes the first steps how to use the FR81S emulation system. It describes also the software
and hardware installation procedure.

Further information can be found in the following manuals:

® ‘SOFTUNE Workbench Installation Manual for V6’ for information about the installation procedure of the
software

. ‘MB2100-01-E Hardware Manual’ (SS01-00026-1E.pdf) for information about the embedded emulator
®  Specific user guides for Starter Kit, e.g. FMEMCU- UG-910092-10 for SK-91580-001-MC

B Short version explanation for getting started FR81_tools_ReadMe.pdf

The FR81S emulation system allows the designer immediately to start with the software development before his
own final target system is available.
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2. Hardware Requirements
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The chapter lists the required hardware for the MB91460 emulation system.
The FR81S emulator system consists of

B The embedded emulator MB2100-01-E including mini USB cable for power supply

B Debug interface cable
B FR81S StarterKit, e.g. SK-91580-001-MC

Figure 2-1. General overview of MB2100-01-E connections

(1)
User system

[EgTwE e Oy

DEBUG WF .h -

[0 D] O

DEBUG IF_READY

Host computer

@)

Emulator

(1) Debug interface cable (2m)

The optional debug interface cable (5m) or other cables can also be used.
(2) Mini USB cable

Commercially available mini UCB cables can also be used.
When using a commercial product, use a cable that has been certified for USB 2.0.
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3. Software Installation
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This chapter describes the software installation procedure
This installation procedure is valid for Windows 7/Vista/XP/2000. For other operating systems and for further

details, please refer to the SOFTUNE Workbench installation manual for V6 and to the hardware manual of the
Emulator MB2100-01-E

3.1 Notes on Win7 operating system

3.1.1 User Account Control (UAC) function of Windows 7

When the UAC function is enabled, the USB driver will not be installed automatically. Therefore, the UAC
function must be disabled when installing SOFTUNE Workbench.

To disable the UAC function, click on [Control Panel] > [User Accounts and Family Safety] > [User Account] >
[User Account Control settings].

Then move the Slider to Never Notify (see Figure 3-1)
Figure 3-1. UAC Settings Window

"5 User Account Control Settings omelak |

Choose when to be notified about changes to your computer ‘

User Account Control helps prevent potentially harmful programs from making changes to your computer,
\ote about Uzer Account Contre

rol settings

Always notify

Never notify me when:

®  Programs try to install software or make changes to
my computer

® [make changes to Windows settings

) Not recommended. Choose this only if you need to
use programs that are not certified for Windows 7
because they do not support User Account Control.

Never notify

&k Cancel
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3.2

3.3

3.3.1

FERFORM Software Installation

The UAC function prevents programs that require administrator privileges from being installed automatically into
the system by a virus, illegal operation, operational error or other factors.

Therefore, it is recommended to turn the function back on after installing SOFTUNE.

MultiVersionManager

When MultiVersionManager (MVM) is used, it is hecessary to turn off UAC. (Both installation, uninstallation, and
use)

General Issues before Installation

Before installation of the Softune Workbench following issues must be done:

m  |f a former Softune Workbench version was installed, please uninstall this version separately and use
remove the old registry files by using a registry cleaner tool (e.g. CCleaner).

B When several Softune Workbench propack versions ought to be installed, it is recommended to install the
Softune MultiVersionManager tool (see chapter 3.3.1 ).

B For installation local administrator rights are required.

O WinXP: after successful installation user can change the settings from “administrator mode” to “user
mode”

0  Win7: Additionally turn of UAC feature (see chapter 3.1 )

®  When MultiVersionManager (MVM) is used, it is necessary to turn off UAC. (Both installation, uninstallation,
and use)

B When using different MCU families (8/16/32bit MCUSs) different installation paths for different propack
versions for the corresponding MCU families must be applied.

[ 8bit MCU: SoftuneV3\896s-rev3xxxxx
00 16bit MCU: SoftuneV3\907s-rev3xxxxx
O 32bit MCU: SoftuneV6\911s-rev6xxxxx
Note: revision number is given in the installer name of the corresponding SOFTUNE installer version.

B The updated USB driver wdapi1021.dll file for Win7 is replaced by every new installation. After an
installation please rename wdapi1021.dll to wdapi1021_old.dll and copy wdapil021_32.dll into
“C:AWindows\sysWOW®64” and change filename to wdapi1021.dll.

SOFTUNE Workbench

There are two possibilities to install SOFTUNE Workbench.

B The standard installation by execution of setup.exe.

B |nstallation of the MultiVersionManager.

Advantage of the MultiVersionManager: different propack versions of one MCU family can be installed in parallel.
But take into account, that different installation paths must be used.

Installation with MultiVersionManager

To use different SOFTUNE propack versions of one MCU family the MultiVersionManager must be installed. In
the following steps the installation is explained:

®  |f MultiVersionManager is uninstalled, execute its installation file:
CD_Image\SOFTUNE MVM\SOFTUNE_MVM_VO0xLOx.exe

®  After successful installation, open the tool in Windows Start [Start] > [Programs] > [SOFTUNE
MultiVersionManager]

B To install a SOFTUNE propack version, click on [SOFTUNE V6] tab > [Regist & Delete...] button.
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=
SOFTUNE 43| SOFTUINE 5| SOFTUNE V6
~FR-V
HotReisizred | | Hot Resisered | [ HocResered| | Mot Registered|
Reqist & Delete... |
~FR
REVAII0IZ | | HotRegstered || Hot Begitered| | HotRegstesed |
Reqst E\I\Qe]ete... |
LCloge |
n

Select in the [Where to register] any “Not Registered” line for installation and enter the setup.exe path of the
corresponding propack (e.g. “..\911s-rev600012\CD_Image”.

Register and delete x|

—"Where to register — Title
CvSotune V3000 | | Nt Redistered %l
G aftuneh REY 00022

C:ASaftune REVI0002C | .o oo

(Mot Heqiztered IEZ"\ j Refer.. |

—w'here to install

DEta | IE:HSthune Refer... |
IWI Wimztalll.. | Cancel |

%Specify installer CO

05 911s-revE00011r01 |
=05 91 1s-reva00012
- - _confidentisl
EI@ _D_Image
{5 Bin

The [Title] text field is filled automatically by the SOFTUNE revision number.
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x
—Yrhere to reqizter t Title

C:4SoftuneByevB0001 2 IH EVEODO02 %l

Mot Begistered

Mat Reqgisterad — Install CO

Mot Registerad s

II:H_mu:uae_dataI:uas j Fefer... |
—w'here to install
Dt I IE:HSthuneE Refer... |
Ingtall... I Wrirrstal... | Cancel |
[ ]

Enter an installation path, which is only valid for this propack version C:\Softune6\911s-revXXXXXX.

Wwhere bo ingtall

IE:'\SthuneE'xE'l'ls-revE[ Refer... |

[~

Cancel |

Irgtall...

ninztalll.. |

Press on [Install..] button to execute installation.
]

Installation of SOFTUNE Workbench is finished. For starting the tool it will be found under [Start] >
[Programs] > [SOFTUNE MultiVersionManager] > [SOFTUNE MultiVersionManager].

For uninstallation of one version use also the MultiVersionManager

£2 SOFTUNE Mym (¥01L03)

SOFTUNE V3| SOFTUNE v SOFTUNE E |

— FB-¥

%]

bt Begistered | | HotBegtered| | ot Begstesed | | HotBegstesed |

Regist& Delete.. |
—FR

REE Eﬁﬂﬂﬂ 12 | HotRemstered | | Hot Registered | | Hot Eegistered |

Help LCloze
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Software Installation

B After successful installation you can open an installed propack by selection of the [SOFTUNE V6] tab and
press on enabled button in the [FR] line

The updated USB driver wdapil021.dll file for Win7 is replaced by every new
installation. After an installation please rename wdapil021.dll to wdapil021 old.dll
and copy wdapi1021_32.dIl into “C:\Windows\sysWOW&64” and change filename to
wdapil021.dll.

3.3.2 Installation without MultiVersionManager

The development with Cypress MCU needs SOFTUNE Workbench as Integrated
Development Environment (IDE).

The following instructions are necessary for the installation of SOFTUNE Workbench:

Note 1:  To install the software under Windows 7/Vista/XP/2000, the user requires
administration authority. Please refer to chapter 3.1 .

®  On the CD image you will find a folder ,SOFTUNE*
®  Unpack the ,CD_Image* from minimum Propack911s-rev600011.zip to a local device on your computer
®  After the unpacking, execute ,Setup.exe” to install SOFTUNE Workbench
®  Follow the instructions of the setup program
®  Select a specific path for the installation, e.g. C:Program Files/ SOFTUNE6
®  With the installation a SOFTUNESG folder will be created
®  When finished the installation, check for following files:

a. 9ll.csv

b. FSDIO200.csv

c. Folder Flash®
from following link:

http://www.cypress.com/16Ix

The updated USB driver wdapil021.dll file for Win7 is replaced by every new
installation. After an installation please rename wdapil021.dll to wdapil021 old.dll
and copy wdapi1021_32.dIl into “C:\Windows\sysWOWG64” and change filename to
wdapil021.dll.

FR Family FR81S Series, Emulation System, Doc. No. 002-04887 Rev. *A 11
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4. Installation of the Emulation System
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This chapter describes, what should be considered and checked before power-up the emulation system. Also the
start-up procedure of the emulation system is described.

In order to properly install the emulation system, follow the following steps.

Features MB2100-01-E

For emulation and debugging of the FR81S devices the embedded emulator MB2100-01-E is used.
In the next chapters the features of the MB2100-01-E embedded emulator are explained. For further explanation
refer to ‘MB2100-01-E Hardware Manual’ (SS01-00026-1E.pdf)

Checking the delivered product

Before using the product, confirm that the following components are included in the box:

B 1x Emulator unit

®  1x USB cable (USB-ECOM520: Elecom Co. Ltd.)

®  1x Debug interface cable (2m) (MB2100-201-E)

®  1x Coaxial connector

®  1x (HRM-300-126B (40): HIROSE ELECTRIC Co., Ltd.)

B 1x Operation manual (English version, this manual)

B 1x Operation manual (Japanese version)

Appearance and part names

In Figure 2-1 and Table 4-1 the external appearance and component names of the embedded emulator MB2100-
01-E are shown.

FR Family FR81S Series, Emulation System, Doc. No. 002-04887 Rev. *A 12



Installation of the Emulation System

Figure 4-1. External Appearance of MB2100-01-E

() BB e E 8 B 80

DEBUG IIF FUFIﬂJ > «— (9

2)
MB2100-01-E
Embedded Emulator
DEBUG I/F  READY ON

(

OPTION POWER
I S O] o
POWER / UsB EXTRA
= i = 1 e ®
[/ (7)
(3) 4) (5) (6)
Table 4-1. External Appearance of Embedded Emulator MB2100-01-E
No. Name Description

Connects to the user system using the debug interface
cable.

Connector part number: HRM-200-2S-C(40) from
HIROSE ELECTRIC Co., Ltd.

1) Debug interface connector

Connector for connecting to optional components. This
connector also doubles as the product maintenance port.
) Option connector Take care to avoid touching metal parts of this connector
with your hand or other objects when the connector is not
connected.

This light is on when the power is on and off when the
(3) POWER LED power is off.
The light is off when the USB suspended.

Indicates the communication status of the debug

“) DEBUG I/F LED interface bus. The light turns on during communication.
Indicates the communication status of the USB bus. The

®) USB LED light turns on during communication.

©) READY LED This light turns on when the emulator and the host
computer are able to communicate.
This light turns on when operating with various functions
of the debugging software. See the SOFTUNE

) EXTRALED Workbench Operation Manual of the debugging software
for details.

8 POWER switch Turns the power to the emulator on and off.

p
9) USB connector Connects to the host computer using a mini USB cable.

The debug interface cable is a cable with SMA coaxial connectors that uses a 1.5D-2V (characteristic impedance
50Q) wire core. The maximum permissible communication speed from the MCU to the emulator is 50Mbps
regardless of the cable length. In Table 4-2. Cable Length and Communication Speed for Embedded Emulator
MB210100-01-E

the cable length and maximum communication speed for emulator is shown.

FR Family FR81S Series, Emulation System, Doc. No. 002-04887 Rev. *A 13



Installation of the Emulation System

Table 4-2. Cable Length and Communication Speed for Embedded Emulator MB210100-01-E

Cable length Maximum permissible communication speed, Emulator side
2 morless 25 Mbps
5m or less 12.5Mbps
10 mor less 6.25 Mbps
4.1.3 General Specifications
In the following table the main specifications for the emulator are shown.
Table 4-3. Emulator specifications
Item Specification
Name Emulator
Part number MB2100-01-E
Power supply 5V / 500mA (USB bus powered)
Debug interface bus communication Single wire UART (NRZ or phase-modulated encoding).
scheme The encoding scheme used is determined by the MCU.
Host computer communication scheme USB 2.0 compliant
\L/lel?e;ommunication speed (theoretical 480 Mbps (Hi-Speed),12 Mbps (Full-Speed)
Operating temperature +5°Cto+40°C
Operating humidity 20 % to 80 % (no condensation)
Storage temperature 0°Cto+70°C
Storage temperature 20 % to 80 % (no condensation)
External dimensions 84'8.(D) ) _53'6 (W) 213 (H.) mm .
(not including connectors, switches, or other protruding parts.)
Weight 709
4.2 Connecting and installation of MB2100-01-E

The following steps have to be established for getting the embedded emulator MB2100-01-E.

Attention: The USB driver for Windows 7 operating system must be installed separately. The
USB drivers must be downloaded from

http://www.cypress.com/16Ix

Please follow the instructions of the USB drive installation guide, before executing next steps

Installation Steps:

B Pick up the USB cable which is packed with the emulator.

B Plug in the mini-USB interface of the USB cable into emulator

FR Family FR81S Series, Emulation System, Doc. No. 002-04887 Rev. *A
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Figure 4-2. Connection to MiniUSB Interface of Emulator

®  Connect the counter side of the USB cable to your host computer

B Windows will “Found New Hardware: MB2100-01-E” and the windows hardware wizard should start

automatically

Note2: The installation procedure may differ with different operating systems.

® Do not connect to Windows Updates to search for Software

Figure 4-3. Windows Hardware Wizard Found New Hardware (1)

Welcome to the Found New
Hardware Wizard

Windows will search for current and updated software by
looking on your computer, on the hardware installation CD, or on
the Windows Update Web site (with your permission).

Read our privacy policy

Can Windows connect to Windows Update to search for
software?

€ Yes, this time only
€ Yes, now and every time | connect a device
@ No, not this time

Click Next to continue.

I Next > | Cancel

®  Select: install from a list or specific location

Figure 4-4. Windows Hardware Wizard Found New Hardware (2)

Found New Hardware Wizard

This wizard helps you install software for.

MB2100-01-€

{ ') If your hardware came with an installation CD
&2 or floppy disk. insert it now.

‘What do you want the wizard to do?

" Install the software automatically [Recommended)
@ instal from a fist or specific location {Advanced]

Click Next to continue.

<Back [ New> | Cancel |

m  Select ,search for the best driver®

®  The driver path can be found under ../Softune6/Drivers

FR Family FR81S Series, Emulation System, Doc. No. 002-04887 Rev. *A
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Figure 4-5. Windows Hardware Wizard Found New Hardware (3)

Please choose your search and installation options. \\

(% Search for the best driver in these locations.

€ Dont search. | wil choose the driver to install

&

Use the check boxes below to imit or expand the defaut search, which includes local
paths and removable media. The best driver found will be installed.

I Search removable media ficppy. CD-ROM..)
¥ Include this location in the search:

l: Program Files\Softune6\Drivers

:_I Browse I

Chooss this option to salact the device driver from a list. Windows doss not guarantee that
the driver you choose will be the best match for your hardware.

®  Click Next for installing driver

®  Maybe a window occurs for installation software, please click on ,Continue Anyway*

Figure 4-6. Windows Hardware Wizard Found New Hardware (4)

A\

The software you are instaling for thes hardware:
FUJITSU Microcontrolier Board

has not passed Windows Logo testing to verfy its compataliy
vith Windows XP. (Tl me why this testing is mporant )
Continuing your installation of this software may impair
ot destabilize the corect operation of your system
either immediately or in the future. Microsoft strongly
recommends that you stop this installation now and
contact the hardware vendor for software that has
passed Windows Logo testing.

Continue Anyway | [TETOP instaliation J

®  Windows completing the installation by copying some files ,Finish” to close the window

Figure 4-7. Windows Hardware Wizard Found New Hardware (5)

Completing the Found New
Hardware Wizard

he software for

m FUNITSU USB Driverfor OCDE

The wizard has finished instal

Chck Finish 1o close the wizard,

B The hardware installed and ready to be used

FR Family FR81S Series, Emulation System, Doc. No. 002-04887 Rev. *A
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Note3: The Software driver is necessary for using the MB2100-01-E embedded
emulator. If the automatically installation of the driver was not finished successfully,
you should install it manually.

Note4: There is an emulator update available since November 2010. If you have not
yet updated the emulator Software (SW), follow these steps:

B Please contact Cypress to get the SW update files

®  Unpack the Softune6_MB2100_20101105.zip to a local storage

®  Copy the files Wv911e3.dll and SiDRVo.dll from folder "bin" into your local SOFTUNE folder ..\Softune6\Bin
®  Copy the file Lib\911\EmIOcd_911.MHX and into your local..\Softune6\Lib.

With starting the Softune Workbench environment the next time an update is generated. This is an update of the
MB2100 emulator SW. Please do not interrupt the update process!

B Pick up the co-axial cable which is packed with the emulator
®  Connect the emulator and the StarterKit with the co-axial cable to the SMA connector

Figure 4-8. Debug Cable Connection to Emulator

Figure 4-9. Debug Cable Connection to StarterKit

The hardware setup is finished. Keep Power SW off.
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This chapter gives an introduction how to get started with Cypress SOFTUNE Workbench.

5.1 New Project in SOFTUNE Workbench
PREPARING A NEW PROJECT
This chapter describes how to set up a new project in Cypress SOFTUNE Workbench.

51.1 Getting template project

In order to start a new user project use the template project for the specific devices. Sample Software is available
from CD image or under following link:

http://www.cypress.com/16Ix

A specific template project can be downloaded from web site. This project includes the startup code, header files
and short descriptions of the usage.

Note5: Please always read the readme.txt file for the explanation of the SW sample
project.

5.1.2 Setup own project
Follow the next steps to create your own application project (this is an example for MB91F787 template project)
B Save the “91780_template_91787-v11” template project to a local storage.

®  Copy the folder within in the local storage and rename ‘Copy of 91780_template_91787-v11’ into
‘91780_my_application_91787-v10’
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Figure 5-1. Renaming of Project

W "vll‘rr;)m’t\‘;l RB1_MotorControl\Software \91780 template 91787 -vil ;
He Edt wew Fyvortes ook eb | &
Qe - Q- T JPsewan &;wl.@ ¥ X 9@
Agdress [ C: Projects PR3 1_MotorControl\Saftware'91730_template_91737+11 ~| EJce
Folders X || tame o i Sae | Type £
2 ) 91780_rit_91787+10_20100729 af|20ebug Fie Folder ?
® D Deng Opre Fle Folder 7
D prc D"C Ele Eolder 8
& src M S 91750 _tevplate_91787.da 1KB DAT Fie 7
® D G1730_template 91787-v10 91780 _template_91787.p13 2KB PR)Fie ?
= ) 91790 | 81787011 91780_template_91787.wsp 1KB WSPFie 6
20 > 4iKB Text Document ?
D b
s gL ?
(CI= g
= 0 Copy of 91730_template_91787-v11
# ) Dedug
D ee
® ) External_RDC_sample_nosenal
L) Fles_for_SW8
® ) From_Habara
« | < J 1|
17 objects (Disk free space: 92,7 G3) 1s.62¢8 | % My Computer 7
m  Enter ,91780_my_application_91787-v10“ folder
®  Rename ,91780_template_91787.prj* into ,91780_my_application_91787.prj*
®  Rename ,91780_template_91787.wsp*“ into ,91780_my_application_91787.wsp*
®  Rename ,91780_template_91787.dat" into ,91780_my_application_91787.dat"
m  Edit,my_application.prj“ by using an editor program
0 Rename all ,template“ into ,my_application
m  Edit ,my_application.wsp“ by using an editor program
0 Rename all ,template” into ,my_application
Figure 5-2. Edit .wsp and .prj file
i) $1780_my _spehcaton_ST7E7weo | B8 31780 my_appication 5178754 | 91780_my_spplication_31787wep | Ml 91780_my_apphcation_31787 pr
i [CPUTYPE] 1 [CPUTYPE]
2 é::uSer:.s;-Bll 2 CpuSerise=311
3 3
3 4 [PrjFile]
5 5 Counc=1
6 )v FILE-0=91780 my application 91787.pxj
7 7 ActivePrj=21720 my applicaticn 81787.px]
; [SubPri-91780_template 31787.pzr]] ] [SubPrj-91780_my applicacion_%1787.pxj]
10 Councw=0 10 Counc=0
. 11
12 [DekState] iz [DebStace]
13 AutoSavewsl 13 AutoSaves]i
14 Exec=0 14 Execm)
15 Autoload=l 15 RutoLoad=1l
16 i&
17 [DirInfe)] 17 [DirInfa]
18 WSP=C:% projects\MotorControlh91780 temp] 18 WSP=C:\ projects\MotorControll8i780 my ap
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®  Start Softune Workbench and open the project via File -> Open Workspace...

B |n the browse window please go to the local path off the project and select my_application.wsp

Note6: It is also possible to start the Softune Workbench and open the workspace
via Drag&Drop into the Softune window

B The project opens and the project structure will be displayed on the left side (explorer view) of the
SOFTUNE screen such as shown in Figure 5-3.

Figure 5-3. Project structure in SOFTUNE Workbench

--iE 91780_my_application_91787.abs
-5 Source Files
_fr.c
inikial_clock.c
Inkerrupt_routine,c
mair.c
|ﬁ_°| skartup, asm
veckors.c
23 Include Files
-5 Dependencies
[ _fr.h
B _fr.h
(W mb21780.0
[Bl mbo17a0.h
[ wectors.h
] Debug

The top level is the Workspace itself: “my_application”. The next level contains the ABS-File of the Project, which
contains the compiled program data. The source files, their dependencies and the debugger settings follow.

® Do not miss the Target MCU selection at the project setting, when opening the project development, (the
project setting can be checked by “MCU” tab of Setup Project Window which is opened by the selecting
[Project] -> [Setup Project].)

Figure 5-4. Setup MCU

Setup Project §|
Target of setting: General  MCU ]OfOH Compiler ] fizsembler ] Linker ] Librariar 4| *
|Debug ﬂ Chip Glassification:

W =) e |

[FRS1 twith FPL x| MOU chanee..

Target MCL:
Set GPU Infor mation..
Mode pin:
‘P.utnmatic ﬂ
Bus mode:
‘Inval\d ﬂ

Ok Cancel ‘ Apply

B For editing the source code files, open them by double-click on the file, e.g. main.c

B Now a text editor window will open, which shows the contents of “Main.c”. It will look like this:
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Figure 5-5. Main.c in Editor Mode

Bie Edi ew Frojct Debug Setup Window Help

I e T | Slefe 2] & R Al Al
sl | 8 || &R/ [=[EE

[1= B Werkspace'31 760 _my_apphcation_S1787

= B 91780_my_application_41787.abs
ey _appl X

t
) itermn soutec extern woid initial_clock(void);}

864
fman.c| e,
) st {4 L
é;\:hdznk‘; -L in function)
=1 &3 Dependendies
"j':;-lmh = \paran HOHE}
r] T 2| .
8 Db = \return return value

o
void main(uoid)}
s6(¢)

PORTEN_GPORTEN = 1; #7 global input enablel

_set_il(x1F); F7IH =3 )
G 77 Interrupt enable |

initial_clock(); 44 initialize clock settings}
while(1)}
WOTCPRY = BxaS: £4 WAW WOT Clear }

__wait_nop();}

iE

Fsbi FhEzEvE

MERFTE

5.1.3 Entering code for own application

The development can begin by editing application code into the files. For modular coding style you can add own
*.c files by right mouse click on folder “Source Files” in explorer view. Header file (*.h) must not be added to
project, they will be included as dependencies. Interrupt definition is done in the file “vectors.c”.

514 Compiling the project

®  When finished coding, the project can be build by the buttons or by selecting [Project] ->
[Build] or [Make]

B |n the information window below edit window the state of compiling is shown. In case of warning or errors,
this is shown here.

Figure 5-6. Error Window after Compiling

main.c

*** C:\Documents and Settings\MSTRIE\Desktop{91780_my_application_91787-v11\srcimain.c(107) E4020B: identifier "hallo" is undefined

** C:\Documents and Settings\MSTRIE\Desktop\91780_my_application_91787-v11\srcimain.c(108) E4065B: expected a """

** C:\Documents and Settings\MSTRIE\Desktop{91780_my_application_91787-v11\src\main.c[108] ¥/1177B: warning: variable "wdtcpr1" was declared but never referenced
2 errors d d in the pilation of "C:\D and Settings\MSTRIE\Desktop\91780_my_application_91787-v11\srcimain.c".

startup.asm

initial_clock.c

Error detected.

®  With double-click on the error notification the SOFTUNE opens the file and indicates the line of error such as
shown
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Figure 5-7. Error Indication of SOFTUNE Workbench

s SOFTONE WOTKbEncH = 917601y _application =91 767
Ele Edt Vew Projsct Debug Setup Window Help

Blalelelo _IM SJEIF|E] | |[orren e spiesi <] oss e <l || &R/ =] el %
NEEIER &8 %l == EE
[ ain.c
extern void initial_clock(void);}
vectors.c Fax
(3 tnclude Files 88 o
=18 Dependencies %% Main Function)
@ frh .
[ _frh *x \param NOME{
& mb91780.0 .
@ mbo1780.4 *x \return return value NONE}
@ vectors.n o
(&8 Debug void main(void)}
6( ()
PORTEN_CPORTEN = 13 #7 global input enable
__set_il(Bx1F); £7 TM = 31
G #7 Interrupt enable |
initial_clock(); 77 initialize clock settings)
InitIrqlevels{);}
while(1)
UDTCPR = Bxas; £7 W7W DT Clear |
__wait_nop();}
&l m ] B
)
HSFEINE WIS E VA |
frc [a]
Interrupt_routine.c

main.c

ng application 81787y T\srchmain.c{107] E 40205 identifier *hella" is undefined 4
C:\Documents and Selllngs\MSTRIE\Desk\up\Ql7Bﬂ my_application_81787-v1T\srcimain.c{108) E40655: expected a " 1
CAD: t

0_my_application_91787-1 Tisrcimain.c(114) W1 01 2E: waming: parsing restarts here after previaus syntax crror
2 erors tetecied n he compilation of "C: \Dncnmenls and Sett 780_my_ _91787-v1Tisreimain.c".

'startup.asm
initial_clock.c

N T 2
=

When finished the compiling process with “No Error” the debugging process can be started.

5.1.5 Linker Settings
5.1.5.1 Fill Option

By employment of the —fill option unused area can be filled with a pattern.
There two use cases:
B Fill RAM area with pattern for stack overflow check

B Fill unused ROM area for illegal code instruction detection

For second case in general it is recommended to search for 1-byte instruction in “instruction maps” within the

programming manual. In the Figure 5-8 one 1-byte instruction map is shown, which that the instruction “BE” is
illegal.
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Figure 5-8. Instruction Map from Programming Manual

Higher 4 bits
[ 1 2 3 4 5 & 7 g 9 A B c D E E
o |wariF[sT R BANDL  [BOAL (ADDNz i4 | LSR 24 R
Ri @RI3A) BA@Ri [RdER
T |ouH STHA | EETE I EEG (ADDNZ || | SRz R
@RIIF)LR |@R13R) Ba@Ri [BdeR B4R
2 |LDUE STBRI, ANDRjR |OR Rj.Fi |ADDNRH| | LSRR R
@RIBA)LR |@f1zA)
3 |lD@RAis. |51 AL ANDCCR  |ORCCR  |ADDSF | [MOV RiRs
wdispf)Ri | @(R15ud8) B B #s10 CALL
4 |0 @RIRT [STRLEA [AND R}, @Ri| OF R.@Ri_|ADD #i4.Rj |L5L#ut R labsl12
5 5 |[DURgRiR [STHR.@R [ANDH ORH (ADDz % |52 %u.R
E Ri@Ri Ri.@Ri
[ & |LDUE@RiR |STB F@m [ANDS L5l RR
.
o 7 |rerert Referto ) STILM #ud [Rerers ADDCRj, MOV Rs, Ri
= AFFENDIKEZ |AFEENDXE2 || D epiR14, STRig@ [ LDUH STH LDUB STB [ a=eenon e 2|
@ b vl I @R Ri@R14, | @R14, | Ri@R, - biesaRi
8 |omav DoV ! displl) disp@)Ri | disp@) dispd) R | dispd) ASR SR
@dlI0R13 |R1Z.@d10
3 |DMOVH g@at, [DMOVH [(ASRZ
R13 RiZ.@de #u4 R
A |DMCVE@ <, |DMOVE CNF RiF) |A5R RiRi BLT.D label
R13 RI3,@dE @R
B |DMOV DMV MOVR.Ri |LD:20 MULU R ffF [MOLUH BGED
@d10.@-R15 | @R 15+ @d10 #20,Ri Rj.R CALL:D
C oMoV DOV LDRES fabel12
@d10.ER13+ | @R132.2410 @Ri+A
D |DMCVH @a, [DMOVH STRES
P PYERP i
E |OMOVE DMCVE
@3, @R13+ |@R13:, @d

| E—
To fill unused Rom area in Softune Workbench following steps must be done:

Enter [Project] > [Setup Project] > tab [Linker], select category “General” and enter within “Other Option” text field
the —fill option for 1-byte fill pattern as follows (see Figure 5-9):

-fill <start address>/<end address>,<pattern>
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Figure 5-9. Fill Pattern Settings

x
Target of zetting; ML I C/C++ Compilell .&ssemblerLibrarianI 14 I ’I
IDebug

Categary: IGeneraI "I

r Outputs start message

| template ¢

¥ Dutputs debug infarmation

Entry Paint; I
Wiarning Lewel: ILE."\.-'E| 1 "I

v Control of default option file
Otker Option:
-5 INTVECT /const=0x000FFCO0

Bk FlLASH  mamst= INEORI
-fill 0x00070000/0x001 /FFFF.0<BE
-fill 0x00330000,/0:0033FFFF 0BE|

Ll v

Qption:
-g il
A2
-ra _|MR&k 01 =0:0001 00000=0002FFFF
« ILI -0 _ MR OO =0:00070000/0=001 FFFFF ;l

0k I Cancel | Apply |

After confirmation of new linker settings in vectors.c one more interrupt vector must be added for illegal
instruction interrupt (see below) and the corresponding interrupt handler must be defined.

After finishing these steps the .abs file will be filled with the pattern in unused ROM areas and the illegal
instruction handling can be checked even during debug session.

#pragma intvect Vectors Isr Illegal InstructionHandler 14 ///<
Illegal Instruction

__interrupt void Vectors Isr Illegal InstructionHandler (void)

{
// disable interrupts
__DIO;
// halt system or wait for watchdog reset
while (1)
{
__wait nop();
}
}
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Debugging in SOFTUNE Workbench

Evaluation and Debugging with Softune Workbench
This chapter describes how to start debug a project in Cypress SOFTUNE Workbench.

Create and edit setup file
Before starting a debug session, some setups have to be done.

m  Click the “Debug” of the explore window with right mouse click and select [Add Setup]->[New] with the right
click

Figure 5-10. Setup New Debug Session

main.c

El skartup,asm

veckars,c

(2 Include Files

1428 Dependencies

W _fr.h

W _fr.h

[ mb21730.h

[ mb21730.h

[ vectors.h

SR Db
] addsetsp » %
Refirence. ..

Property...

®  Now it is possible to insert an own name for the setup file

Figure 5-11. Setup New Debug Session, Name

Create New setup

Setup Mame:

Note7: In case of existing setup file, you can also edit this by right mouse click
and select [Edit]

®  Follow the Setup Wizard and click on “Next” when following settings are done:
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Iltem Setup Value
Debug Type Emulator Debugger
ICE Type MB2100-01 (Default)
Monitor program Auto-loading Checked
Device Type UsB

Oscillation Frequency

Depends on oscillation frequency (e.g. 4MHz)

Length DEBUG I/F cable

Depends on your cable length

Software Brake

Depend on your debugging

Specification batch file

Default: Not specified

Auto load

Checked

Batch file (before/after)

Default: Not specified
e.g. insert a .prc file which should be loaded before or after loading file

Select setting item

Select All

5.2.2 Start debug session

Before starting the debugging with On Chip Debugger, please check hardware connection which is described in
the chapter “4.2 Connecting and installation of MB2100-01-E”

B Power on the emulator. The “Power” LED of Emulator turns on and also “READY” LED of Emulator turns on

with blue colour.

Note8: In this point, Board power keeps off

Figure 5-12. Power on of MB2100-01-E

m  Start the debug session via [Debug] -> [Start Debug] from SOFTUNE GUI menu or by double-click on .sup

file

B SOFTUNE asks for “Power on Reset”

B Power on the StarterKit before clicking “OK” on sub-window
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Figure 5-13. "Power on Reset": Sub-window for

softune 11 E

"'-l., The target could not be connected,
P}

Please input power-on resek,

Cancel |

0 Debug mode is started

5.2.3 Executing and debugging the application

For executing and debugging your application some first introduction explanations follow.

B Select [Debug]->[Run]->[Go], press F5 or the button the execute/run your application

®  For stopping [Debug]->[Abort], or the @l button. The emulator system now is being halted. The execution
can be continued by entering the “Go”-Mode again.

B Set a breakpoint or sequence by pressing right mouse click into window (-> [Break]) or setting an red X such
as shown in Figure 5-14.

m  Select [View]->[Trace] for tracing the application
®  Mark a variable and click right mouse button -> [Watch] to watch a variable value changed

In Figure 5-14 a short overview of the debug functionality is given. For further explanations refer to Cypress
SOFTUNE Workbench feature description documents.

Figure 5-14. Short Overview for Debug Functionality

Step over Step out Reset Stop

Stepinto
Run

2 SOFTU I Workbe-.ch - 91780_m_application_71787 : Debug

\S ol a;;aj_ | Dlzi@] »wle) o] slalmw ] | ol
1Y — 3 3 fomss 2

Viorkspece $1780_my_spokcaton ST

Add
project
files *.c
and ".h

Double click to Break window

start debug

/1
Set breakpoint
Right mouse .
clicktogetinto iafmEr_————————"|
option list
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5.24 Automatic Flash Synchronisation

Usually during active debug session loading new compiled code is only possible, when the debug session is
stopped and the “reset” button in the GUI is pressed. In order to synchronize the changed software code with the
code inside the Flash automatically during stopped debug session, following setps must be done: Stop debug
session, enter [Setup] > [Debug Environment] > [Debug Environment...], tab [Load] and enable the tick of the
functionality [Synchronize after load] (see Figure 5-15). After that save the setting changes by close the window
with the ‘OK’.

Figure 5-15. Flash Synchronisation Function in ‘Setup Debug Environment’ Window

i Setup debug environment ] x|

E:-:ecutionl Event I Watch | Radix ] Emulationl Monitoringl Directory
Tab | Error output I Frequencyl Break I Response speed

— Specification batch file before/after load

Before: I Browse...

_Browse.. |
After: I Browse... |

™ Only debug information

[V Synchrorize after load |

| D]\ I Cancel
L4\

5.2.5 High Speed Mode

Usually the Standard clock is selected for the debug communication, which corresponds to the baud rate: Main
clock frequency divided by 8 (500kBaud @ 4MHz Main clock). In addition to standard baud rate the high speed
mode can be selected. The baud rate for communication direction from MCU to PC is rated to ‘PLLCK / 2’ (e.g.
40MHz baud rate @ 80MHz PLLCK clock).
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D5U type = OCDU
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Maker ID = 0=0400

CPU family ID = 0x0Z00
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Dewvice wersion ID = 0Oxl
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PLL clock E 79995045 Hz |30 MHz)
gL o 18 I Ty

Communication mode = High(High)
Communication type = 0Oxl

Commnnication dewice = U3SE

[

_:J Enmrl

To enter into high speed mode several steps must be executed:

Open the command windows as follows: [View] > [Command]. Enter “show system” into text field and some
system information is prompted. In the line with text ‘PLL clock’ the left value marked in 88l shows the real VCO
clock (e.g. ~80MHz in Figure 5-16). The right value corresponds to selected frequency of high speed mode.

After detection of the frequency the debug session must be stopped. Then the high speed mode can be enabled
by clicking [Setup] > [Debug Environment] > [Debug Environment] > Tab [Frequency] > [Enable]
(see Figure 5-17). Enter the integer value of the PLL clock command window line and press on ‘OK’ button.
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Figure 5-17. High Speed Mode Selection in Setup Debug Evironment

Setup debug environment | 5]

Execution] Event Wa!chl Radix | Emula!ionl Monitoringl Directory
Tab I Erm routputl Load  Frequency IBreak | Response speed

Frequency

Frequency: D'e4 ] MHz :I

>al

0K I Cancel

5.3 Integration of external text editor

Integration of external text editor is also supported, which can be used for programming source code and
jumping to erroneous code line by double clicking error message in the output window.

Following settings must be done for selection of alternate editor:
Click on [Setup] > [Editor...]

Enter a title for text editor

Brows for the execution file (.exe) of editor

Enter option settings. -n%l "%f"

Select text editor folder as execution directory

Click on button [Set]

The select your new text editor in the selection box [Available Editor].

© N o g kM w0 NP

Click on [OK] for final confirmation
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Figure 5-18. Text Editor Settings

x
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Execute Filename: IE:"uF'ru:ugram FileshMHaotep Erowsze. . |
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| = Line Murmber 4
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54 Script Files (Procedure Files)

A procedure file is a batch file which can be executed at any time while the Softune Workbench is in Debug
session, and can be used to control the debug session in order it follows the fixed list of commands previously
programmed by the user.

We recommend that you store the procedure into the /prc folder of your Softune Workbench project.
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6 C:, TEMP',91570,91570_dma_91577-¥10°prc
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Example of usage:

As an example let’'s suppose we want to execute a procedure file called mb91570_read_clock_settings.prc
which needs two parameters (p1, p2).

In this case the parameters are the quartz xtals which are connected to the device:
Main xtal clock: 4 MHz, Sub-clock xtal: 32768 Hz

Then the procedure file input parameters are: PO = 4000000, P1=32768

A maximum of 10 parameters are allowed (PO, ..., P9)

This procedure file configures the system clocks and print-out the results in the command window. The clock
settings which are configure with this procedure file are listed below:

CPU frequency to MCLK/2 = 2 MHz

External interface clock TCLK =1 MHZ

Peripheral clocks PCLK PCLK2 = 500 KHz

To execute an existing procedure file follow these steps:
1. Open a debug session: Debug-> Start Debug

2. Open a Command Window: View-> Command

3. For executing the procedure files, two options are possible:
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®  |f the procedure file has no input parameters, then just drag and drop the procedure file to the Softune
Workbench environment while it is in Debug session (not the case of our example)

m  |f the procedure file has input parameters, in the command window type the following command sequence:
set radix/decimal

[Press/Click ENTER]

batch prc/mb91570 read clock settings.prc, 4000000, 32768

[Press/Click ENTER]

where:

batch: command to execute procedure files

prc: path inside the Softune Workbench project were the procedure file is stored
mb91570_read_clock_settings.prc: name of the procedure file

4000000: Parameter 0 (P0)

32768: Parameter 1 (P1)

If hexadecimal basis is preferred to enter the data, then enter the following command sequence:
set radix/hexadecimal

[Press/Click ENTER]

batch prc/mb91570 read clock settings.prc, 3D0900, 8000

[Press/Click ENTER]

Same results are expected. See the picture below for details:
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Figure 5-19. Usage of Batch File in Command Window
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HCLK [Hz] (CPU, RAM, FLASH) : 2000000
TCLK [Hz] (external Bus IF) : 1000000
PCLK [Hz] (Peripheral Bus) : 500000
PCLK2 [Hz] (Peripheral Bus 2): 500000
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Ibalch pre/mb31570_read_clock_settings.prc,D'4000000,D'32768

= | EMevl

75: L2:

76: addz #-1, rl

77: bne:d Lz

78: sth r0, B{rl3, rl)

Batch commands are not case sensitive. Then set radix/hexadecimal and SET
RADIX/HEXADECIMAL will get the same results.

If a file is not found or a command is not recognized, the command window will display an error message like

following (see the picture below):
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Figure 5-20. Usage of Batch File in Command Window (2)
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Further information might be found in the FR Family Softune Workbench Command Reference Manual
(FscmdE.pdf) document which can be downloaded from the FSEU website.

55 External Text Editor Notepad++
If as alternate text editor Notepad++ (NPP) is applied, then several settings are be recommended.
Following NPP plugins are recommended for comfortable software development:
®  Plugin Function list: All functions within a selected source file are listed within additional window

B Plugin Open CTags: Jump to function, variable definitions and #Defines by pressing “Alt+space” key and
pressing one more time “space” bar for jumping to definition.

B Plugin QuickText: Automatic completion of brackets by pressing “Tab” key after entering keyword.
E.g.“while”.is entered and “tab” key is pressed , then all brackets for while-loop are added.

®  Replacement of tab by spaces: In [Settings] > [Options ...] > tab [Language Menu/Tabs] select replacement
of tab width by ‘4’ spaces.

B Auto completion: Click on [Settings] > [Options ...] > tab [Backup/Auto Completion] and enable [Auto
Completion] feature.

FR Family FR81S Series, Emulation System, Doc. No. 002-04887 Rev. *A 35



6. SOFTUNE Trouble Shooting

(CIPHESS

PERFORM

The chapter describes trouble shooting for different scenarios with SOFTUNE.

1. Prompt: “The target could not be connected. Please input power-on reset after starting setup is reviewed”
®  Check, if external watchdog causes reset in MCU.
Figure 6-1. Trouble Shooting (1)

Softune907 X

' The target could not be connected.
ol Fleass input power-on reset
after starting setup is reviewed.

| 2K | Annuler

2. When debug session is started, SOFTUNE crashes and application is closed

®  Was the USB driver for MB2100-01-E updated (e.g. required for Win7)? If not, please download from
following link and follow the driver installation guide:

http://www.cypress.com/16Ix

m  |f USB driver update installed and either SOFTUNE was reinstalled or a new version was installed, please
do following steps:

0 Replace “SiUSB.dII” manually from the new USB driver update into the “Softune\bin” folder

OO0 Enter folder “c:\windows\SysWOW®64” and rename original “wdapixxxx.dll” (e.g. wdapi1021.dll) to
“wdapixxxx_old.dllI”. Then copy "wdapixxxx_32.dll" from unzipped “SiUSBdrvr_xxxx\bin” folder into
“c:\windows\SysWOW®64” folder and rename this file to the original filename “wdapixxxx.dll” (in this
case: “wdapi1021.dIl").

® Do you have administrator rights on your user account? If not, then set user account to administrator.

®  |s the User Account Control (UAC) feature (min. Win7) enabled? Please disable UAC (see 3.1.1 ).
®  |f a new SOFTUNE

B Final step: Reopen SOFTUNE and start debug session.
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3.  Prompt: “E4403W: Target MCU not found. Specify CPU information file?...”
Figure 6-2. Trouble Shooting (2)

softuneatr x|

] E4403W: Target MCU not Found. Specify CPU information File?
L3 MB91FS26LS - "91520_ram_91526ls. pri'[Debug]

Mo | Cancel |

®  Did you update the SOFTUNE “.csv” and “FLASH?” files from web page link
http://www.cypress.com/16Ix
Please follow guidelines in “Readme.txt” of the csv-update.

4. In debug session application is running and when application runs without debugger, a reset is caused
periodically.

®  Check, if internal watchdog is handled resp. disabled (please check hardware manual of the corresponding
MCU series).

5.  Prompt: “The connection cannot be established to the target MCU.”

Figure 6-3. Trouble Shooting (3)
softunegrl x|

L] "_q,, *4* F04165: The connection cannot be established to the target MCL,
L

®  Power off hardware system and debugger and power on again.

®  Any ROM area might be not defined correctly. Please use Cypress Flash Programmer tool, if MCU can be
programmed via UART interface. Switch MCU mode pins into “serial write mode” (see Table 6-1)Apply .mhx
file from the MCU specific template project and start Flash programming by pressing button [Full Operation
(D+E+B+P)] (see chapter 7. ). Starting debug session with the template project resp. the original project
should be possible again. In this case check resp. change ROM area settings.

B Check, if mode pins are in “user mode” (see Table 6-1). Change settings, if incorrect and make a Power-On
reset on target hardware.

Table 6-1. Mode Pin Settings

Operation mode MD1 MDO P006
User mode 0 1 -
Serial writer mode 1 0 1
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7. Flash Programming of MCU
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For programming the MCU via serial interface following steps are listed:

Note9: To flash the MCU via serial interface may some jumper settings are

necessary, therefore refer to specific user guide of the SarterKit.

®  |nstall the newest FR Flash Programmer.

® Connect the UARTO of the board via UART’A’ or UART’B’ connector to the PC.

m  Start the FR Flash Programmer.

®  Select the Target, Frequency and the (HEX)-File (.mhx) as the following picture shows.

Figure 7-1. FR Flash Programmer

R Microcontroller with Flash Memory Programmer

Target Microcontroller IMBEHF?S?
Crystal Frequency |4MH2
Hex File IS‘I?Bﬂ_ternp\ate_m?ﬂ?.mhx

~Command to COM1

Full Operation(D+E+B+F)

Download | Erase |

Blank Check |

Prograr & Serify | Bead & Compare |

Copy!

g [ 3

Start Address 0g0000H
End Address 1?FFFFH
Flash Memany Size 120000H

~Option

SetEnvironmment | Help |

Check UM |

IR

pre)
Y011.L24 b2 FU]ITSU

B The next step is to switch into programming mode. For the programming mode the MDO pin has to be on low
level and the MD1 pin on high level. In default all switches of dip switch from StarterKit are on OFF-setting.

Put the switch 2 to the ON-setting to get the programming mode as the following picture shows.

Figure 7-2. Dip Switch for Programming Modes
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Flash Programming of MCU

®  Press the “Full Operation” button to start programming, press the RESET button and click on ‘OK’.
CAUTION: DO NOT INTERRUPT OR CUT OFF POWER DURING ERASE!!!

B When the download was not successful (message on PC) check the jumper settings of UART and the cable
connections.

m  After a successfully downloaded program, put all switches of dip switch back to the OFF-position and push
the RESET button.

The application is flashed in the MCU and starts after the reset.
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