
Help Desk Using Cisco UCCX
TECHNOLOGY DESIGN GUIDE

February 2014



Table of Contents

Table of Contents
Preface ........................................................................................................................................3

CVD Navigator .............................................................................................................................4
Use Cases .................................................................................................................................. 4
Scope ......................................................................................................................................... 4
Proficiency .................................................................................................................................. 4

Introduction .................................................................................................................................1
Technology Use Case—IP-based Help Desk ............................................................................... 1
Design Overview  ........................................................................................................................ 2

Solution Details ....................................................................................................................... 2

Deployment Details ......................................................................................................................4
Preparing the Platform for Cisco Unified CCX ............................................................................. 4
Installing Cisco Unified CCX ........................................................................................................ 7
Configuring the Help Desk ........................................................................................................ 18
Configuring the Cisco Finesse Application ................................................................................ 32
Cisco Unified Intelligence Center (CUIC) ................................................................................... 38
Configuring the Dashboard ....................................................................................................... 39
Creating and Editing Reports .................................................................................................... 43

Appendix A: Product List ...........................................................................................................49



Preface February 2014
3

Preface
Cisco Validated Designs (CVDs) provide the foundation for systems design based on common use cases or 
current engineering system priorities. They incorporate a broad set of technologies, features, and applications to 
address customer needs. Cisco engineers have comprehensively tested and documented each CVD in order to 
ensure faster, more reliable, and fully predictable deployment.

CVDs include two guide types that provide tested and validated design and deployment details:

• Technology design guides provide deployment details, information about validated products and 
software, and best practices for specific types of technology.

• Solution design guides integrate or reference existing CVDs, but also include product features and 
functionality across Cisco products and may include information about third-party integration.

Both CVD types provide a tested starting point for Cisco partners or customers to begin designing and deploying 
systems using their own setup and configuration.

How to Read Commands
Many CVD guides tell you how to use a command-line interface (CLI) to configure network devices. This section 
describes the conventions used to specify commands that you must enter.

Commands to enter at a CLI appear as follows:

configure terminal

Commands that specify a value for a variable appear as follows:

ntp server 10.10.48.17

Commands with variables that you must define appear as follows:

class-map [highest class name]

Commands at a CLI or script prompt appear as follows:

Router# enable

Long commands that line wrap are underlined. Enter them as one command:

police rate 10000 pps burst 10000 packets conform-action set-discard-class-
transmit 48 exceed-action transmit

Noteworthy parts of system output or device configuration files appear highlighted, as follows:

interface Vlan64

  ip address 10.5.204.5 255.255.255.0

Comments and Questions
If you would like to comment on a guide or ask questions, please use the feedback form.

For the most recent CVD guides, see the following site:

http://www.cisco.com/go/cvd/collaboration

http://cvddocs.com/feedback/?id450-COL-14
http://www.cisco.com/go/cvd/collaboration
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CVD Navigator
The CVD Navigator helps you determine the applicability of this guide by summarizing its key elements: the use cases, the 
scope or breadth of the technology covered, the proficiency or experience recommended, and CVDs related to this guide. 
This section is a quick reference only. For more details, see the Introduction.

Use Cases
This guide addresses the following technology use cases:

• IP-based Help Desk—Organizations need a simple method for 
their employees to contact their internal support departments 
and an easy way to manage their help desk from a central 
location, without replicating costly components at their remote 
sites.

For more information, see the “Use Cases” section in this guide.

Scope
This guide covers the following areas of technology and products:

• Unified communications applications, such as IP telephony and 
contact center

• Telephony call agent

• Contact center server

• Finesse application

• Cisco Unified Intelligence Center

• Virtualized servers

• IP telephones

• Integration of the above with LAN and data-center switching 
infrastructure

For more information, see the “Design Overview” section in this 
guide.

Proficiency
This guide is for people with the following technical proficiencies—or 
equivalent experience:

• CCNA Voice—3 to 5 years designing, installing, and 
troubleshooting voice and unified communications 
applications, devices, and networks

• VCP VMware—At least 6 months installing, deploying, scaling, 
and managing VMware vSphere environments

To view the related CVD guides,  
click the titles or visit the following site: 

http://www.cisco.com/go/cvd/collaboration

Related CVD Guides

VALIDATED
DESIGN

Uni�ed Communications
Using BE6000 Technology
Design Guide

http://www.cisco.com/go/cvd/collaboration
http://www.cisco.com/go/cvd/collaboration
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Introduction
Historically, the ability to easily add functionality into the telephony environment for corporate help desks has 
been challenging. Traditional contact center solutions have been difficult to implement because of the additional 
hardware components required, and the complexity of the software needed to implement the business 
requirements of the contact center. In addition, it has been very difficult to integrate the contact center with the 
corporate data systems, due to the lack of availability of common interfaces.

This complexity has typically made the implementation of IP telephony functionality a long and involved process, 
and the expertise required to install and maintain the system is expensive. 

Technology Use Case—IP-based Help Desk
Organizations need a simple method for their employees to contact their internal support departments, like 
Human Resources and Information Technology. Users expect timely responses to their questions and problems. 
However, it is easy for an issue to go unresolved, forgotten, or simply fall through the cracks if not handled 
promptly by an available resource. The information about the user and their particular issue should be collected 
in real-time so an expert in the functional area can help the caller as quickly as possible. Organizations need an 
easy way to manage their help desk from a central location without replicating costly components at their remote 
sites.

This design guide enables the following capabilities:

• Simplifies deployment and management through a centralized design, while saving on infrastructure 
components

• Routes calls over the internal IP network, avoiding the use of expensive dedicated PSTN trunks

• Establishes multiple queues for each department so that agents can be assigned to one or more 
available queues based on their skills as well as skill levels  

• Allows agents to accept calls regardless of their physical location in the company because the phones 
and application are IP-based

• Saves historical data in easy-to-read reports in order to help improve the day-to-day workings of the 
help desk

• Strategically defines the agent and supervisor desktop layouts to match the needs of the teams and their 
contact center activities

• Creates customized, detailed reports on key contact center metrics
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Design Overview 
Cisco Unified Contact Center Express (Unified CCX) is an IP-based help desk solution offered by Cisco Systems. 
It addresses the small to mid-size contact center market, ranging from a few agents up to 400 concurrent 
agents. It is tightly integrated with other Cisco Unified Communications platforms. Design and testing is 
performed on the suite of Cisco Unified Communications products as part of a complete solution. 

Cisco Unified CCX has the features of a large contact center packaged into a single- or dual-server deployment. 
The system scales up to 400 concurrent agents, 42 supervisors, 150 agent groups, and 150 skill groups. It 
includes email, chat, outbound calling, inbound calling, workforce optimization, and reporting. 

In a Cisco Business Edition 6000 (BE 6000) deployment, there is a limitation of 100 
agents only. The design and deployment discussed here otherwise apply for a full-
fledged Cisco Unified Call Manager deployment.

Tech Tip

Solution Details
The IP help desk solution includes the following components (see Figure 1):

• Cisco Unified CCX for contact center software

• Cisco Unified CM for agent and supervisor phones

• Network Time Protocol (NTP) server for logging consistency

• Domain Name System (DNS) for name-to-IP resolution

• Syslog server for logging events (optional)

Configuration of Cisco Unified CCX is easier than traditional systems because the components talk to each 
other over the internal IP network, which helps streamline the procedures. For example, when a phone number 
is created on Unified CCX to reach a help desk application, no additional configuration is needed in the Cisco 
Unified Communications Manager (Unified CM). The configuration is sent over the network to Unified CM and 
the directory number is created. Unified CM is automatically configured to pass calls for the directory number to 
Unified CCX for further processing.

When a call is placed to the help desk, it is first processed by Cisco Unified CM, which recognizes that the 
number is destined for the Cisco Unified CCX application server. Unified CCX receives the incoming call and 
identifies which application script is needed to handle the request based on the extension number that was 
dialed. The script plays prompts and collects digits as dictated by the steps in the script and, if necessary, uses 
the information from the caller to select an appropriate agent. If an assigned agent is not available, the call is 
put into an appropriate queue and a recorded message or music is streamed to the caller. As soon as an agent 
is available, Unified CCX instructs Unified CM to ring the agent’s phone. When the agent picks up, relative call 
context can be popped into the agent’s desktop application as the call is delivered to the answering agent. This 
ensures that the agent has the proper information in front of them to support the customer.
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Figure 1 - Help Desk using Cisco Unified CCX 
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Deployment Details
Cisco Unified CCX runs on the same Linux operating systems as several other Unified Communications platforms 
from Cisco. You install the operating system with the application by using the standard installation DVD or 
International Organization for Standardization (ISO) file. 

Preparing the Platform for Cisco Unified CCX

1. Configure platform connectivity to the LAN

2. Prepare the server for Cisco Unified CCXP
R

O
C

ES
S

For a quick and easy installation experience, it is essential to know up front what information you will need. For 
Cisco Unified CCX, make sure you have completed the following steps before you start:

• Download the Open Virtualization Archive (OVA) file from the Cisco website, here: 

http://software.cisco.com/download/release.html?mdfid=285000761&flowid=49042&softwareid=283733
053&release=2.5&relind=AVAILABLE&rellifecycle=&reltype=latest

• Determine if there is a patch for your version of Cisco Unified CCX by checking the Cisco website, here: 

http://software.cisco.com/download/release.html?mdfid=285000761&flowid=49042&softwareid=283733
053&release=2.5&relind=AVAILABLE&rellifecycle=&reltype=latest

Procedure 1 Configure platform connectivity to the LAN

The Cisco Unified Contact Center Express server can be connected to a Cisco Nexus switch in the data center 
or a Cisco Catalyst switch in the server room. In both cases, quality-of-service (QoS) policies are added to 
the ports to maintain voice quality during the setup and completion of calls. Please choose the option that is 
appropriate for your environment.

Option 1:  Connect Cisco Unified CCX to a Nexus 2248 Switch

Step 1: Log in to the Cisco Nexus switch with a user account that has the ability to make configuration changes. 

Step 2: If there is a previous configuration on the switch port where Cisco Unified CCX is connected, remove 
the individual commands by issuing a no in front of each one to bring the port back to its default state.

Step 3: Configure the port as an access port, and then apply the QoS policy.

Interface Ethernet107/1/18
 description Unified Contact Center Express

 switchport access vlan 148
 spanning-tree port type edge

 service-policy type qos input DC-FCOE+1P4Q_INTERFACE-DSCP-QOS

http://software.cisco.com/download/release.html?mdfid=285000761&flowid=49042&softwareid=283733053&release=2.5&relind=AVAILABLE&rellifecycle=&reltype=latest
http://software.cisco.com/download/release.html?mdfid=285000761&flowid=49042&softwareid=283733053&release=2.5&relind=AVAILABLE&rellifecycle=&reltype=latest
http://software.cisco.com/download/release.html?mdfid=285000761&flowid=49042&softwareid=283733053&release=2.5&relind=AVAILABLE&rellifecycle=&reltype=latest
http://software.cisco.com/download/release.html?mdfid=285000761&flowid=49042&softwareid=283733053&release=2.5&relind=AVAILABLE&rellifecycle=&reltype=latest
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When deploying a dual-homed Cisco Nexus 2248 Switch, you must apply this 
configuration to both Nexus 2248 devices.

Tech Tip

Option 2:  Connect Cisco Unified CCX to a Catalyst 3X50 Switch
To ensure that signaling traffic is prioritized appropriately, you must configure the Cisco Catalyst access switch 
port where Cisco Unified CCX is connected to trust the Differentiated Services Code Point (DSCP) markings. 
The easiest way to do this is to clear the interface of any previous configuration, and then apply the egress QoS 
macro that was defined in the access-switch platform configuration. For more information, see the Campus 
Wired LAN Technology Design Guide.

Step 1: Log in to the Cisco Catalyst switch with a user account that has the ability to make configuration 
changes. 

Step 2: Clear the interface’s configuration on the switch port where Cisco Unified CCX is connected.

default interface GigabitEthernet1/0/18

Step 3: Configure the port as an access port, and then apply the Egress QoS policy. 

interface GigabitEthernet1/0/18
 description Unified Contact Center Express

 switchport access vlan 148
 switchport host

 macro apply EgressQoS

Procedure 2 Prepare the server for Cisco Unified CCX

The following table describes the scaling options for Cisco Unified CCX.

Table 1 -  Cisco Unified CCX virtual machine scaling options

100 agents 300 agents 400 agents

Virtual CPUs 2 2 4

CPU speed 900 MHz 900 MHz 900 MHz

RAM 8 GB 8 GB 16 GB

Hard disk 146 GB (1) 146 GB (2) 146 GB (2)

VMware ESXi  4.1, 5.0, 5.1 4.1, 5.0, 5.1  4.1, 5.0, 5.1

OS support RHE Linux 5 (32-bit) RHE Linux 5 (32-bit) RHE Linux 5 (32-bit)

Total agents 100 or fewer 100 to 300 300 to 400

Complete the following steps to deploy an OVA file to define the virtual machine requirements. You use the Open 
Virtualization Format (OVF) support of VMware to import and deploy the OVA file.  

http://www.cisco.com/c/en/us/solutions/enterprise/design-zone-campus/
http://www.cisco.com/c/en/us/solutions/enterprise/design-zone-campus/
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Step 1: In the VMware vSphere client, choose File > Deploy OVF Template. 

Step 2: Click the Browse button next to the file or URL box, find the location of the OVA file that you 
downloaded from Cisco, and then click Next.

Step 3: Verify the information on the OVF Template Details page, and then click Next.

Step 4: Read the End User License Agreement, click Accept, and then click Next.

Step 5: Enter the following information in the Deploy OVF Template wizard, and then click Finish.

• On the Name and Location page, in the Name box, enter the virtual machine name CCX1, and then click 
Next.

• On the Deployment Configuration page, from the menu, choose the Configuration type, and then click 
Next.

• On the Storage page, choose the location to store the VM files, and then click Next.

• On the Disk Format page, choose Thick Provision Eager Zeroed, and then click Next.

• On the Ready to Complete page, verify the settings, and then click Finish. In the message window, click 
Close.

In the Cisco BE 6000 deployment, select the 100 agent profile in the OVA template to 
be deployed.

Reader Tip

 

The virtual machine is created. 

Step 6: Click the server name (In this example, CCX1), navigate to the Getting Started tab, and then choose Edit 
virtual machine settings.

Step 7: On the Hardware tab, click CD/DVD Drive 1, and then select the Connect at power on check box.
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Step 8: Select Datastore ISO File, click Browse, and then navigate to the location of the Cisco Unified CCX 
bootable installation file. After selecting the correct ISO image, click OK.

Step 9: On the Getting Started tab, choose Power on the virtual machine.

Step 10: Click the Console tab, and then watch the server boot.

The virtual machine is prepared for installation.

Installing Cisco Unified CCX

1. Install the Cisco Unified CCX platform

2. Set up application administrationP
R

O
C

ES
S

Make sure you have the following information:

• Time zone for the server

• Host name, IP address, network mask, and default gateway

• Domain Name System (DNS) server IP addresses

• Administrator ID and password

• Organization and unit

• Location, state, and country 

• Network Time Protocol (NTP) server IP addresses

• Security password

• Application username and password
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Complete the tasks listed below before you start the installation:

• In DNS, configure the Cisco Unified CCX host name: CCX1 

• Obtain license files from the Cisco licensing system. 

Procedure 1 Install the Cisco Unified CCX platform

After the ISO/DVD loads, continue the installation on the server console. 

Step 1: On the DVD Found page, perform a media check by selecting Yes.

Step 2: If the media check is successful, choose OK.

If the media check does not pass, contact Cisco Technical Assistance Center or your local representative to 
replace the media, and then repeat this step.  

Step 3: On the Product Deployment Selection page, verify the product is Cisco Unified Contact Center Express, 
and then choose OK.

Step 4: On the Proceed with Install page, verify that the version is correct, and then choose Yes.

Step 5: On the Platform Installation Wizard page, choose Proceed.

Step 6: If no upgrade patch exists for the version you are installing, on the Apply Patch page, choose No. 

If an upgrade patch does exist, on the Apply Patch page, choose Yes, and then follow the instructions to 
complete the process.

Step 7: On the Basic Install page, choose Continue.
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Step 8: On the Timezone Configuration page, select the correct time zone for the server location, and then 
choose OK.

Step 9: On the Auto Negotiation Configuration page, choose Continue.

Step 10: On the MTU Configuration page, choose No.

Step 11: On the Static Network Configuration page, enter the following information, and then choose OK.

• Host Name—CCX1

• IP Address—192.168.1.28

• IP Mask—255.255.255.0

• GW Address—192.168.1.1
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Step 12: On the DNS Client Configuration page, enter the following information, and then choose OK.

• Primary DNS—192.168.1.10

• Domain—cisco.local

Step 13: On the Administrator Login Configuration page, enter the following information, and then choose OK.  

• Administrator ID—Admin

• Password—[password]

• Confirm Password—[password] 
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Step 14: On the Certificate Information page, enter the information that will be used to generate security 
certificates, and then choose OK.   

• Organization—Cisco Systems, Inc.

• Unit—Unified Communications Group

• Location—San Jose

• State—California

• Country—United States

These fields must match the information submitted to Cisco or the licenses will not be 
valid.

Tech Tip

Step 15: On the First Node Configuration page, choose Yes.
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Step 16: On the Network Time Protocol Client Configuration page, enter the following information, and then 
choose OK.

• NTP server 1—192.168.1.10

Step 17: On the Security Configuration page, enter the password for server-to-server communication, and then 
choose OK. 

These passwords must match the information submitted to Cisco, or the licenses will 
not be valid.

Tech Tip

Step 18: On the SMTP Host Configuration page, choose No.

Step 19: On the Application User Configuration page, enter the following information, and then choose OK. 

• Application User Username—CCXAdmin

• Password—[password]

• Confirm Password—[password]

These values are used to initially access the Cisco Unified CCX Administration page 
and must match the license information submitted to Cisco. When specific users are 
given administrative rights during the application setup procedure, the initial username 
and password entered above will no longer work. 

Tech Tip

Step 20: On the Platform Configuration Confirmation page, choose OK.

The system continues with the rest of the installation process without user input. The system will reboot a few 
times during installation. The process can take 60 minutes or more, depending on your hardware. 

After the software has finished installing, the login prompt appears on the console. 
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Step 21: From the vSphere client, navigate to the virtual machine’s Getting Started tab, and then choose Edit 
virtual machine settings.

Step 22: On the Hardware tab, choose CD/DVD Drive 1. 

Step 23: Clear Connect at power on, and then click OK. 

Procedure 2 Set up application administration

After the software is installed, you use the web interface in order to complete the rest of the procedures. 

Step 1: With your web browser, access the IP address or hostname of the Cisco Unified CCX server and, in the 
center of the page, click Cisco Unified Contact Center Express. 

Step 2: If you receive a warning about the website’s security certificate, ignore it and continue to the page.

Step 3: Enter the name and password you entered on the Application User Configuration page in Step 19 of the 
“Install the Cisco Unified CCX platform” procedure, and then click Login. 

Step 4: On the Cisco Unified CCX Administrator Setup page, choose Fresh Install, and then click Next.

Step 5: On the Cisco Unified CM Configuration—Service Provider Configuration page, enter the following 
information, and then click Next.

• Unified CM server IP address— 192.168.1.16 (publisher)

• AXL Admin UserName—CUCMAdmin 

• Password—[password] (must match the password on Cisco Unified CM).  

Step 6: On the License Information page, click Browse, locate the Unified CCX license file received from Cisco, 
click Open, and then click Next.

Step 7: After the license validation is completed, click Next.
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Step 8: After all of the components are successfully activated, click Next. 

Step 9: On the Publisher Activation page, click Next.

Step 10: On the Cisco Unified CM Configuration page, in the AXL Service Provider Configuration section, in the 
Selected AXL Service Providers list, choose the Unified CM server 192.168.1.16(publisher), and then remove it 
from the list by clicking the right-facing arrow.

Step 11: Under Available AXL Service Providers, select the Unified CM servers 192.168.1.17(subscriber), and 
then move them to the Selected AXL Service Providers list by clicking the left-facing arrow. 

Step 12: In the Cluster Wide Parameters section, enter the following information: 

• User Name—CUCMAdmin

• Password—[password]
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Step 13: In the Unified CM Telephony Subsystem—Unified CM Telephony Provider Configuration section, in the 
Available CTI Managers list, choose the Unified CM servers 192.168.1.17(subscriber), and then move them to 
the Selected CTI Managers list by clicking the left-facing arrow.

Step 14: In the Cluster Wide Parameters section, enter the following information: 

• User Prefix—CCX_jtapi

• Password—[password]

• Confirm Password—[password] 

Step 15: In the RmCm Subsystem—RmCm Provider Configuration section, in the Available CTI Managers list, 
choose the Unified CM servers 192.168.1.17(subscriber), and then move them to the Selected CTI Managers 
list by clicking the left-facing arrow.

Step 16: In the Cluster Wide Parameters section, enter the following information, and then click Next.

• User Id—CCX_rmjtapi

• Password—[password]

• Confirm Password—[password]

Cisco Unified CCX sends the user information to the Cisco Unified CM server, and the application users are 
created automatically.

For historical reporting of the number of HR sessions, use the maximum number of supervisors or administrators 
who will be running Cisco Unified CCX reports at the same time. For the Recording Count, enter the maximum 
number of concurrent ad-hoc recording sessions. 
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The G.711 codec choice requires one of the following choices for calls that do not originate from the same region 
and location as the Cisco Unified CCX server:

• Transcoders must be configured in Cisco Unified CM and added to the media resource group list at the 
Cisco Unified CCX site in order to allow contact center calls to and from the remote sites.

• The regions must allow 64 kbps as the maximum audio bit rate between their site and the Cisco Unified 
CCX site for the contact center calls.

If one of these two options is not completed, contact center calls from remote sites will experience a fast-busy 
tone when calling the main pilot number for Cisco Unified CCX.

Step 17: On the System Parameters Configuration page, enter the following information, and then click Next:

• Number of HR sessions—4

• Recording Count—25

• Number of Outbound seats—100

• Codec—G.711

Step 18: On the Language Configuration page, enter the language that will be used for default Interactive Voice 
Response (IVR) prompts, the Cisco Agent Desktop, and the Cisco Supervisor Desktop, and then click Next.

Step 19: On the Desktop Client Configuration Tool message, click OK.
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Step 20: On the User Configuration page, select the Cisco Unified CM users who need administrative rights, 
move them to the Cisco Unified CCX Administrator list by clicking the left-facing arrow, and then click Finish.

The initial application administration setup is now complete. 
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Configuring the Help Desk

1. Create the call control group

2. Create skills

3. Assign skills to contact service queues

4. Associate a phone to an agent user ID

5. Associate user ID to a phone or profile

6. Assign skills to resources

7. Create the supervisors and teams

8. Create scripts and applications

9. Add a trigger

10. Associate Cisco Unified CCX application user

11. Create and upload the prompts

12. Verify Cisco Unified CCX Engine status

P
R
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S

After you configure the application administration for the first time, the next task is to configure the help desk to 
allow the system to begin taking calls from end users.

Procedure 1 Create the call control group

A call control group creates a group of computer telephony integration (CTI) ports on Cisco Unified CM that are 
used to send calls to Cisco Unified CCX for IVR treatment and queuing. The call stays on the CTI port until it is 
sent to an agent.  

Step 1: Access the IP address or hostname of the Cisco Unified CCX server by using your web browser and 
then, in the center of the page, click Cisco Unified Contact Center Express. 

The account created during the installation of the server will no longer work for 
administering the application.  

Tech Tip

Step 2: Enter the username and password of one of the users you assigned administrative rights in Step 20 of 
the previous procedure, and then click Login. 

Step 3: Navigate to Subsystems > Cisco Unified CM Telephony > Call Control Group, and then click Add New.  
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Step 4: Enter the following information, and then click Add.

• Description—Unified CM Telephony Group

• Number of CTI ports—4

• Media Termination Support—No

• Group Type—Inbound

• Device Name Prefix—CTIP

• Starting Directory Number—8009950

• Device Pool—DP_HQ1_1 (default for headquarters location)

• DN Calling Search Space—CSS_Base

• Location—Hub_None

• Partition—PAR_Base  

Leave the rest of the fields at their default settings.

Procedure 2 Create skills

Create skills for each different type of call you expect to receive in the call center. 

Step 1: Navigate to Subsystems > RmCm > Skills, and then click Add New.

Step 2: On the Skill Configuration page, enter IT, and then click Save.

Step 3: On the Skills search page, click Add New.

Step 4: On the Skill Configuration page, enter HR (For Human Resources), and then click Save.

Step 5: Create additional skills, by repeating Step 3 through Step 4.  

Procedure 3 Assign skills to contact service queues

Create Contact Service Queues (CSQ) for each skill entered in the previous procedure.

The CSQ names created here must exactly match the queue names referenced in the 
application scripts that are described later in this guide. The example script uses the 
CSQ names of IT and HR. Be sure to add these queues to the server. 

Tech Tip
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Step 1: Navigate to Subsystems > RmCm > Contact Service Queues, and then click Add New.

Step 2: On the first Contact Service Queue Configuration page, enter the following information, and then click 
Next:

• Contact Service Queue Name—IT

• Contact Service Queue Type—Voice

• Automatic Work—Disabled

• Wrapup Time—Disabled

• Resource Pool Selection Model—Resource Skills

• Service Level—5 (seconds)

• Service Level Percentage—70 

• Prompt—No Selection

Step 3: On the second Contact Service Queue Configuration page, enter the following information, and then 
click Add:

• Resource Selection Criteria—Longest Available

• Select Required Skills—IT 

• Minimum Competence—5  

 

Step 4: For each additional skill (such as HR), click Add New, and then repeat Step 2 through Step 3 using the 
appropriate information.
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Procedure 4 Associate a phone to an agent user ID

There are two ways to associate agents and supervisors with a phone. You can use extension mobility to allow 
agents to log in to a Cisco IP phone or you can associate an agent’s Cisco Unified CM user ID directly with a 
phone. Both options can be used for the same Cisco Unified CCX installation. Choose extension mobility if your 
agents move around from day to day or if you have more than one shift and the same phone will be used by 
multiple agents. Choose the phone association method if the agents work from the same phone every day.

Step 1: Use your web browser to access the IP address or hostname of the Cisco Unified CM publisher and 
then, in the center of the page, click Cisco Unified CM Administration.

Step 2: Enter the application administrator username and password for Cisco Unified CM, and then click Login.

Perform the next several steps only if you are planning to associate agents directly to a phone. If you will use 
extension mobility exclusively with your agents, you can skip to the next procedure. 

Step 3: Navigate to Device > Phone, click Find, and then click the name of the agent’s phone.

Step 4: On the Phone Configuration page, click line [1]. This adds the Cisco Unified CCX information for the 
specific line on the phone.  

Step 5: Scroll down to the bottom of the page, and then click Associate End Users. 

Step 6: On the Find and List Users page, click Find, and then choose the agent for this line by selecting the 
check box next to their name.

Step 7: Click Add Selected. You return to the previous page.

Step 8: Repeat Step 3 through Step 7 for each additional agent and supervisor phone, using each agent’s and 
supervisor’s specific information.

Procedure 5 Associate user ID to a phone or profile

In this procedure, you associate the agent and supervisor user ID to a phone or extension mobility profile. Please 
choose one or both of the following options:

• If you are associating agents with phones, follow the steps in Option 1, “Phone association.”

• If your agents will use extension mobility to log in to their phones, follow the steps in Option 2, 
“Extension mobility association.”



Deployment Details February 2014
22

Option 1:  Phone association

Step 1: Navigate to User Management > End User, and then click Find. 

Step 2: Select the agent or supervisor from the previous procedure, and then click the user ID. 

Step 3: On the End User Configuration page, scroll down to the Device Information section, and then click 
Device Association.

Step 4: On the User Device Association page, click Find. 

Step 5: Select the check box next to the agent’s phone, and then click Save Selected/Changes. 

Step 6: In the upper-right corner of the page, in the Related Links list, choose Back to User, and then click Go.

Step 7: On the End User Configuration page, scroll down to the Extension Mobility section, and then confirm that 
the Allow Control of Device from CTI check box is selected.  

Step 8: Scroll down to the Directory Number Associations section, set the IP Contact Center (IPCC) Extension to 
the phone’s directory number from the previous procedure, and then click Save.
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Step 9: For each additional agent or supervisor using phone association, repeat Step 1 through Step 8 using 
their specific information. 

Option 2:  Extension mobility association

Step 1: Navigate to User Management > End User, and then click Find. 

Step 2: Select the agent or supervisor, and then click the user ID. 

Step 3: On the End User Configuration page, scroll down to the Device Information section, select the agents 
profile from the Available Profiles: sudhekum_profile, and then click the Down-Arrow icon to move it into the 
CTI Controlled Device Profiles.

Step 4: Scroll down to the Extension Mobility section, and then confirm the Allow Control of Device from CTI 
check box is selected.

Step 5: Scroll down to the Directory Number Associations section, set the IPCC Extension to the agent’s 
extension mobility number, and then click Save.

Step 6: For each additional agent or supervisor using extension mobility association, repeat Step 1 through Step 
5, using their specific information. 
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Procedure 6 Assign skills to resources

Cisco Unified CM users associated with IPCC extensions show up automatically as resources in Cisco Unified 
CCX. Using the resource list on the Cisco Unified CCX Administration page, you assign skills to resources, 
making them available to answer calls in particular Contact Service Queues (CSQs).  

Step 1: Use your web browser to access the IP address or hostname of the Cisco Unified CCX server and then, 
in the center of the page, click Cisco Unified Contact Center Express. 

Step 2: Enter the name and password of a user with administrative rights to Cisco Unified CCX, and then click 
Login. 

Step 3: Navigate to Subsystems > RmCm > Resources. On the Resources search page, under the Resource 
Name, click a user.

Step 4: On the Resource Configuration page, in the Unassigned Skills list, choose the skill(s) that you want to 
assign, and then move the skill(s) to the Assigned Skills list by clicking the left-facing arrow. 

Step 5: Select the Competence Level for the resource, and then click Update.

 

Step 6: For each additional resource, repeat Step 3 through Step 5, using the appropriate information for each 
agent.

Procedure 7 Create the supervisors and teams

The first step in building a team is to create a supervisor. A supervisor has a full view of a team’s performance 
and can monitor the agents by using the Cisco Supervisor Desktop. 

Step 1: Navigate to Tools > User Management > Supervisor Capability View.
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Step 2: On the User Configuration page, in the Available Users list, choose the users you want to designate as 
supervisors, move them to the Cisco Unified CCX Supervisor list by clicking the left-facing arrow, and then click 
Update. 

 

Step 3: Navigate to Subsystems > RmCm > Teams, and click Add New.

Step 4: On the Team Configuration page, enter the following information, and then click Save.

• Team Name—IT

• Primary Supervisor—[Supervisor]

• Assigned Resources—[Agent or supervisor]

• Assigned CSQs—IT

Step 5: For each additional team, repeat Step 3 through Step 4, using the appropriate information.
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Procedure 8 Create scripts and applications

In this procedure, an externally created script is uploaded to the server to demonstrate how to upload your script 
and create your site-specific application. 

This guide uses the example script and prompts from a zip file that is included with the 
document. The script can be used as a template for your help desk application. The zip 
file can be downloaded from the following URL:  
http://www.cisco.com/go/cvd/collaboration/

Please use the example script as a template for your scripts.

Reader Tip

Step 1: Navigate to Applications > Script Management, select the script to upload, and then click Upload 
Scripts.

Step 2: Click Browse, find the location of the script (scripts have the file extension .aef), and then click Upload. 

Step 3: After the script is successfully uploaded, click Return to Script Management.

Step 4: Navigate to Applications > Application Management, and then click Add New.

Step 5: On the Add A New Application page, select Cisco Script Application, and then click Next.

Step 6: On the Cisco Script Application page, enter the following information, and then click Add.

• Name—Help Desk

• ID—[automatic setting] (do not change this value)

• Maximum Number of Sessions—4

• Script—SCRIPT[Helpdesk.aef]

• Description—Help desk for IT and HR

• Enabled—Yes

• Default Script—System Default

http://www.cisco.com/go/cvd/collaboration/
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Procedure 9 Add a trigger

The trigger for an application is the phone number the users will dial when they want to speak with someone in 
the help desk.  

Step 1: In the upper-left of the Cisco Script Application page, click Add New Trigger.

Step 2: In the Trigger Type list, choose Unified CM Telephony Trigger, and then click Next.

Step 3: On the Cisco Unified CM Telephony Trigger Configuration page, enter the following information:

• Directory Number—8009940 (CTI Route Point that will be automatically created in Cisco Unified CM to 
direct calls to this application)

• Language—English (United States) [en_US]

• Device Name—InternalHelp

• Description—Trigger for Internal Help Desk

• Call Control Group—Unified CM Telephony Group(1) 
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Step 4: Click Show More, enter the following information, and then click Add:

• Enabled—Yes

• Maximum Number of Sessions—Default

• Idle Timeout (in ms)—5000

• Override Media Termination—No

• Alerting Name ASCII—Help Desk Pilot

• Device Pool—DP_HQ1_1 (headquarters default)

• Location—Hub_None (headquarters default)

• Partition—PAR_Base (phone default)

• Voice Mail Profile—None

• Calling Search Space—CSS_Base

Leave the rest of the fields at their default settings.
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Procedure 10 Associate Cisco Unified CCX application user

The next set of steps associates the Cisco Unified CCX application user with the phones, extension mobility 
profiles, CTI Route Point, and CTI Ports in Cisco Unified CM. Please choose one or both of the following options:

• If you are associating agents and supervisors directly to phones, follow the steps in Option 1, “Phone 
association.”  

• If your agents and supervisors are using extension mobility on their phones, follow the steps in Option 2, 
“Extension mobility association.”

Step 1: From a new browser window, access the IP address or hostname of the Cisco Unified CM publisher and 
then, in the center of the page, click Cisco Unified CM Administration.

Step 2: Enter the administrator username and password for Cisco Unified CM, and then click Login.

Step 3: Navigate to User Management > Application User.  

Step 4: On the Application User search page, click Find, and then click CCX_rmjtapi.

Step 5: On the Application User Configuration page, in the Device Information section, the Available Devices list, 
choose the Unified CCX CTI ports and the Unified CCX CTI route point, and then click the down-facing arrow. 

Option 1:  Phone association

Step 1: On the Application User Configuration page, under Device Information, in the Available Devices list, 
choose the agent and supervisor phones, and then move them to the Controlled Devices list by clicking the 
down-facing arrow. 

 

Step 2: Click Save. 
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Option 2:  Extension mobility association

Step 1: On the Application User Configuration page, under Device Information, in the Available Profiles list, 
choose the agent and supervisor profiles, and then move them to the CTI Controlled Device Profiles list by 
clicking the down-facing arrow. 

Step 2: Click Save. 

Procedure 11 Create and upload the prompts

In this procedure, externally created prompts are uploaded to the server to demonstrate how to upload your 
prompts. 

This guide uses the example script and prompts from a zip file that is included with the 
document. The prompts can be used as examples for your help desk application. The 
zip file can be downloaded from the following URL:  
http://www.cisco.com/go/cvd/collaboration/

Please use the example prompts as templates for your recordings.

Reader Tip

Prompts are played to the callers when they are in the application. You must record the prompts as .wav files and 
save them in a location reachable by the PC accessing the Cisco Unified CCX Administration page.  

Step 1: Navigate to the Cisco Unified CCX Administration main page.

Step 2: Navigate to Applications > Prompt Management, and then click the en_US folder.

Step 3: After the folder opens, click Upload Prompts.

Step 4: From the Upload Prompt page, click Browse, locate the prompt WAV file, select it, and then click 
Upload.

http://www.cisco.com/go/cvd/collaboration/
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Step 5: For each of the prompts, repeat Step 4, and then click Return to Prompt Management.

Step 6: Navigate to Applications > Application Management, and then click the application that you created in 
Procedure 8, “Create scripts and applications.”  

Step 7: Change the default prompts by selecting the check box next to each one, clicking Show Prompts, and 
then choosing the appropriate file from the list of your own uploaded prompts. After they are all chosen, click 
Update.

Custom prompts must have the following WAV format when uploading them to the 
server.

Bit rate: 64 kbps

Audio sample size: 8 bit

Channels: 1 (mono)

Audio sample rate: 8 kHz

Audio format: CCITT u-Law 

Note that the new prompt names must match the variable values listed in the script 
application or they will not play.

Tech Tip

Procedure 12 Verify Cisco Unified CCX Engine status

Check the status of the Cisco Unified CCX engine in order to ensure the integration with Cisco Unified CM is 
working properly and is ready to receive calls.

Step 1: From the Navigation menu in the top right, choose Cisco Unified CCX Serviceability, and then click Go.

Step 2: Navigate to Tools > Control Center-Network Services, and then check the status of the Cisco Unified 
CCX Engine.

On the Cisco Unified CCX Engine line, the Status should read In Service; if this is the case, the configuration 
of the server is complete and you can skip ahead to Configuring the Cisco Finesse Application. If the Status is 
Partial Service, continue to the next step to attempt to fix the problem.
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Step 3:  From the Navigation menu in the top right, choose Cisco Unified CCX Administration, and then click 
Go.

Step 4: Navigate to Subsystems > Cisco Unified CM Telephony > Data Synchronization.

Step 5: Select Call Control Group(s), Trigger(s), and CM Telephony User(s), and then click Data Resync.

Step 6: Repeat Step 1 through Step 2 to recheck if Unified CCX Engine has come into service.

Configuring the Cisco Finesse Application

1. Enable the Finesse application on Cisco UCCX

2. Access the Finesse administration

3. Configure Reasons

4. Configure desktop layout

5. Create phonebooks

6. Configure team resources

7. Access the Finesse agent desktop

8. Change agent state from Not Ready to Ready after log in

9. Access the Cisco Finesse Supervisor desktop

10. Silently monitor and barge-in to existing agent call by supervisor
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Out-of-box, feature-rich Web 2.0 Finesse desktop is browser-based and offers ease of deployment and lower 
total cost of ownership (TCO). Open social technology offers flexibility of customized gadget insertion for other 
browser-based applications. The REST API of Finesse also makes it easy to develop customized applications and 
CRM integrations to meet business requirements. Cisco Unified CCX 10.0(1) provides inbound contact center call 
control functionality for agents, key supervisor functionality, and statistics for agent and supervisor for real-time 
updates. Core features of Cisco Finesse include the following: 

• Call Control/Agent State

• Cisco Unified CM Silent Monitoring

• HTTP & REST API workflows

• Login via username

• Phonebook

• Recording and playback via MediaSense

• Historical and real-time reports via Unified Intelligence Center
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Procedure 1 Enable the Finesse application on Cisco UCCX

Step 1:   Telnet to the Cisco UCCX server.

telnet 192.168.1.28

Step 2: Access the CLI interface by entering admin credentials. 

• User name: sudheer

• Password: [password]

Step 3: Activate Finesse application.

Utils UCCX Finesse Activate

Procedure 2 Access the Finesse administration 

Step 1:   Open a supported browser for instance Mozilla or Internet Explorer (Recommended).

Step 2:  Access the Cisco Finesse administration log in page by entering the following URL.

https://192.168.1.28:8445/cfadmin

Step 3: The login screen appears. Enter the following details.

• User name: Sudheer

• Password: [Password]

Procedure 3 Configure Reasons

Step 1: On the Cisco finesse administration home page, click the Reasons tab.

Step 2: In Manage Reason codes (Not Ready gadget), click New. A new reason code is created.

Step 3: Create reason codes for other states by repeating Step 1 through Step 2.

https://10.4.48.126:8445/cfadmin


Deployment Details February 2014
34

Procedure 4 Configure desktop layout

Step 1: On the Cisco Finesse home page, click the Manage Desktops tab. 

Step 2:  In the Finesse Layout XML gadget, specify the required desktop layout to be used by agents as shown 
below.

Procedure 5 Create phonebooks

Step 1: Click the Phonebooks tab. 

Step 2: In the Manage phonebooks gadget, create new phonebooks by clicking New. The phonebook can be 
assigned to all users or at team level via the Assign To list box.

Procedure 6 Configure team resources

Step 1: Click the Team Resources tab.

Step 2: In Manage Team Resources gadget, select the IT team for which you want to associate the resources 
from the list of teams available.
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Step 3: In Resources for IT, click the Desktop Layout tab, and then associate desktop layout to this team 
created above. Likewise, click other available tabs, to associate the Phonebooks, Reason Codes and workflows 
created in above steps. 

Procedure 7 Access the Finesse agent desktop

Step 1: Open a supported browser and enter the following URL.

http://192.168.1.28:8082

Step 2 Enter the following details at the log in screen:

• User name: Sudheer

• Password: [password]

• Extension: 8140007

Procedure 8 Change agent state from Not Ready to Ready after log in

Step 1: Under the agent name, click the down arrow, and then choose Ready for the state.

By the default, the agent desktop consists of the Home, My Statistics, and the Manage Call tabs.

• The Home tab includes the following gadgets by default:

 ◦ Agent CSQ Statistics report—This gadget typically updates the live data with the queue statistics.

 ◦ Agent Team Summary Report—This gadget displays the live status for the agents who are part of 
the same team.

http://10.4.48.126:8082
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• The My Statistics tab includes the following gadgets by default:

 ◦ Agent Statistics Report—This gadget displays detailed information for an agent such as the talk 
time, hold time, ready, not ready status, and after call work.

 ◦ Agent State Log Report—This gadget provides detailed information about the different states 
through which agents transform during the lifecycle. 

Procedure 9 Access the Cisco Finesse Supervisor desktop

Step 1:  Enter the following URL in a supported browser: 

http://192.168.1.28:8082

Step 2: Log in as a supervisor by entering the supervisor username, password, and extension. The Finesse 
supervisor desktop is displayed.

By default, the supervisor desktop consists of the Manage Team, Team Data, Queue 
Data, and Manage Call tabs. Each of these individual pages contains default gadgets 
that provide relevant statistical information using the CUIC. 

Reader Tip

Step 3: Click the Manage Team tab. 

Step 4: Choose the IT from the available team list to view IT Team’s Performance gadget capturing the agent’s 
status.

http://10.4.48.126:8082
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Step 5: Next, select an agent belonging to the IT team from the Team performance gadget to perform either a 
sígn-out, forced ready or silent recording on behalf of the agents.

Step 6:  Likewise click on other tabs to view them.

Procedure 10 Silently monitor and barge-in to existing agent call by supervisor

Step 1: In the Team Performance gadget on the supervisor desktop, click Start Monitoring. Now the supervisor 
can listen to the agent’s conversation.

The agent should be in Talking state for the Monitoring Agent button to be enabled. 
The supervisor should be in Not Ready state to start the Monitoring Agent.

Tech Tip

Step 2: Next, barge-in to an existing agent call, by clicking Barge-In in the call control area of the supervisor 
desktop.
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Customers can choose to have either Finesse agents or CAD agents. Mixing the two 
types of agents is not supported.

Tech Tip

Cisco Unified Intelligence Center (CUIC)

1. Start using Cisco Unified Intelligence Center
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Cisco Unified CCX users can access reports by using Cisco Unified Intelligence Center and Cisco Finesse. 
Unified Intelligence Center is a comprehensive, end-to-end reporting solution for Unified CCX. You can access 
Historical and Live Data reports.

With Unified Intelligence Center, you can complete the following tasks:

• Generate and view reports.

• Filter data in the reports by setting parameters.

• View help for a report.

• View the report in a new browser.

• Create and view dashboards.

• View permalinks for reports and dashboards, as well as copy this permalink URI and post it onto a 
webpage for public viewing of reports or dashboards without needing to log into CUIC or have a Finesse 
desktop.

• Configure thresholds for grid data cells.

Procedure 1 Start using Cisco Unified Intelligence Center

Step 1: Open a supported web browser.

Step 2: Access the CUIC by using one of the following methods:

• Open http://192.168.1.28, and then click Cisco Unified Contact Center Express Reporting.

or

• Open http://192.168.1.28:8081/cuic.

http://10.4.48.126
http://192.168.1.28:8081/cuic
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Log in by entering your Username and Password.

Configuring the Dashboard

1. Create  a dashboard

2. Add an item to the dashboardP
R
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A dashboard is mix of multiple items that you would like shown on a single web page. You can create multiple 
dashboards, and you can decide if each one is private to certain viewers, or if you want to allow the dashboards 
to be viewed by others via permission settings. 

The following items can be added to any dashboard, and then moved and resized within the dashboard to create 
the look you want to see within each dashboard:

• Existing reports

• Scheduled reports

• Web page URLs

• Sticky notes

• Custom Widgets
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Procedure 1 Create  a dashboard

To be able to create a dashboard, you must have the following option enabled for the user under the Security-
>UserList tab:

• Dashboard Designer  

Step 1: Move the dashboard drawer to the editing and viewing pallet on the right side of the CUIC display by 
clicking Dashboard drawer, right-click the dashboard folder, and then click Create Sub-category.

Step 2: In Create Dashboard window, enter the following detail and click OK.

• Name: Helpdesk_dashboard

Step 3: Assign Permission to the users, and then click OK. This example gives all permissions to All Users. 
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Step 4:  For each additional dashboard you want to create, repeat Step 1 through Step 3.

Procedure 2 Add an item to the dashboard

Step 1: Click Dashboards, and then select the dashboard you just created so you can add new items to it.

Step 2: Add a new item onto the dashboard by clicking Add. 

Step 3: In the Dashboard Item Settings pane, enter the following details and click OK.

• Title: IT-report

• Type: Report



Deployment Details February 2014
42

Step 4: In Dashboard Item Content, select the Team State Report to be generated.

Step 5: Select the resource(s) in this example IT for which the report needs to be generated, and then click Run. 

The Report widget is placed into the dashboard, as shown in the following.

Step 6: For each additional item, repeat Step 1 through Step 5
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Creating and Editing Reports

1. Creating sub-folder to store customized reports

2. Create and view permalinks

3. Generate and view reportsP
R
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Procedure 1 Creating sub-folder to store customized reports

To be able to create a folder, the user should be logged in as an App user.

Tech Tip

Step 1: In the left pane, click the Report drawer. The available folders are displayed. 

Step 2: Navigate to UCCX live data folder, and then right-click Create Sub-category. A sub-folder is created.
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Step 3: In the Create Sub-category pane, specify:

• Name: IT helpdesk data

• Permissions: Select all check boxes

To be able to create report, the user should be logged in as a user with report designer 
and report definition designer access privileges. 

Tech Tip

Step 4: Right-click the newly created folder, and then choose Create Report.



Deployment Details February 2014
45

Step 5: In the Create Report pane, enter the following details and click Save.

• Name: IT helpdesk team state report

• Description: IT team state stats

• Report Description: Team State Report Definition

Step 6: Right-click on the IT Helpdesk team state report created above, and then click on the Edit option to get 
to edit window.  

Step 7: Select Bypass filter check box in the edit window and Next click on the Edit Default Filter button.
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Step 8: On the Edit default filter page, from Choose collections list, and select IT and then save the filter.

Step 9: Go back to the Reports tab and then click the newly created report. The Teams agent state report is 
displayed.

Step 10: Create other report definitions by repeating Step 1 through Step 9.

Procedure 2 Create and view permalinks

Step 1: Navigate to the Reports tab, right-click the IT helpdesk team state report created in the previous 
procedure, and then choose Edit Views.
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Step 2: Select the IT helpdesk team state report to edit, and then click Links. A link to this report is generated 
that can be used to access the reports directly.

To restrict access to a permalink, uncheck the Enable Unauthenticated Access check 
box just above the HTML link.

Tech Tip

Procedure 3 Generate and view reports

Step 1: In the left pane, click the Reports drawer.

Step 2: Navigate to Stock Options->Agent->Agent CSQ Statistics. The filters for choosing report generation 
are displayed.

Step 3: From the Choose Collection list, choose the IT resource.

Step 4: Click Run to generate Report. 
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Step 5: If you want, you can use the Live Data Report Viewer, to do the following:

• View multiple grid views of the same report.

• Add or delete the column to the grid view by using the Gear icon.

• Choose if you would like the report to auto-refresh the live data. If you do not choose to auto-refresh, 
CUIC provides alerts about updates on the report.

• Decide whether or not to display only report items that have threshold events defined for the report 
items. When enabled, only data configured with threshold values are displayed.

• Display a report by opening it in a new browser.

• Display Help, which provides more information about the fields in the template or general help.

Step 6: If you want to generate or view reports in other report viewers, repeat Step 1 through Step 5.

For more information about using CUIC, see the Reporting user guide and the online 
help available in the CUIC.

Reader Tip
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Appendix A: Product List
Data Center or Server Room

Component Product Description Part Numbers Software

Call Control Cisco Business Edition 6000 with up to 1000 users BE6K-ST-BDL-K9 10.0

Contact Center Solution Cisco Unified Contact Center Express CCX-10-EHA-L-K9 10.0

Headquarters Voice
Functional Area Product Description Part Numbers Software

Headquarters Voice Router Cisco 3945 Voice Sec. Bundle, PVDM3-64, UC and SEC 
License PAK

C3945-VSEC/K9 15.2(4)M5 
securityk9 license 
ipbasek9 license 
uck9 license

Security Paper PAK for Cisco 3900 Series SL-39-SEC-K9

IP Base Paper PAK for Cisco 3900 series SL-39-IPB-K9

Unified Communications Paper PAK for Cisco 3900 Series SL-39-UC-K9

2 Port Channelized T1/E1 and ISDN PRI High Speed WAN 
Interface Card (data only)

HWIC-2CE1T1-PRI

2-Port 2nd Gen Multiflex Trunk Voice/WAN Int. Card-T1/E1 VWIC2-2MFT-T1/E1

Remote Site Voice
Functional Area Product Description Part Numbers Software

Remote Site Voice Routers Cisco 2921 Voice Sec. Bundle, PVDM3-32, UC and SEC 
License PAK

C2921-VSEC/K9 15.2(4)M5 
securityk9 license 
ipbasek9 license 
uck9 license

Security Paper PAK for Cisco 2900 Series SL-29-SEC-K9

IP Base Paper PAK for Cisco 2900 series SL-29-IPB-K9

Unified Communications Paper PAK for Cisco 2900 Series SL-29-UC-K9

2 Port Channelized T1/E1 and ISDN PRI High Speed WAN 
Interface Card (data only)

HWIC-2CE1T1-PRI

2-Port 2nd Gen Multiflex Trunk Voice/WAN Int. Card-T1/E1 VWIC2-2MFT-T1/E1

SRST For 50 phones FL-SRST-50 15.2(4)M5
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Endpoints
Functional Area Product Description Part Numbers Software

Phones Unified IP Phone 8900 Series CP-8961-C-K9 SIP8961.9-4-1-9

Unified IP Phone 7800 series CP-7821-K9

CP-7841-K9

CP-7841-K9

SIP78xx.10-1-1-9

Unified IP Phone 7975 CP-7975G SCCP75.9-3-1SR3-1S
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