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Safety Information
Important Information

Read these instructions carefully and look at the equipment to become familiar with the
device before trying to install, operate, service or maintain it. The following special
messages may appear throughout this bulletin or on the equipment to warn of potential
hazards or to call attention to information that clarifies or simplifies a procedure.

The addition of either symbol to a "Danger" or "Warning" safety label
indicates that an electrical hazard exists which will result in personal
injury if the instructions are not followed.
This is the safety alert symbol. It is used to alert you to potential personal
injury hazards. Obey all safety messages that follow this symbol to avoid
possible injury or death.

DANGER
DANGER indicates a hazardous situation which, if not avoided,will result in death or serious
injury.

WARNING
WARNING indicates a hazardous situation which, if not avoided, could result in death or
serious injury.

CAUTION
CAUTION indicates a hazardous situation which, if not avoided, could result inminor or
moderate injury.

NOTICE
NOTICE is used to address practices not related to physical injury.

Please Note
Electrical equipment should be installed, operated, serviced and maintained only by qualified
personnel. No responsibility is assumed by Siemens Industry for any consequences arising out of
the use of this material.

A qualified person is one who has skills and knowledge related to the construction, installation,
and operation of electrical equipment and has received safety training to recognize and avoid the
hazards involved.



Notices

DANGER

Hazardous voltages and high-speed moving parts in electrical devices communicating with
WinPM.Net can cause death, serious injury or property damage.

See Safety instruction contained herein. Restrict use to qualified personnel.

The use of unauthorized parts in the repair of the equipment or tampering by unqualified personnel will result in dangerous
conditions that can cause death, serious injury or property damage.

PLEASE READ
WinPM.Net can be configured to send commands to devices automatically. WinPM.Net can be used to manually send
commands to devices and to reconfigure the settings of devices.

IMPORTANT
The information contained herein is general in nature and not intended for specific application purposes. It does not relieve the
user of responsibility to use sound practices in application, installation, operation, and maintenance of the equipment purchased.
Siemens reserves the right to make changes at any time without notice or obligations. Should conflict arise between the general
information contained in this publication and the contents of drawings or supplementary material or both, the latter shall take
precedence.

QUALIFIED PERSONNEL
For the purposes of this manual and product labels, "qualified personnel" is one who is familiar with the installation, construction,
or operation of the equipment and the hazards involved. In addition, s/he has the following qualifications:

(a) is trained and authorized to energize, de-energize, clear, ground, and tag circuits and equipment in accordance with
established safety practices.

(b) is trained in the proper care and use of protective gear equipment such as rubber gloves, hard hat, safety glasses or face
shields, flash clothing, etc., in accordance with established safety procedures.

(c) is trained in rendering first aid.

SUMMARY
These instructions do not purport to cover all details or variations in equipment, nor to provide for every possible contingency to
be met in connection with installation, operation, or maintenance. Should further information be desired or should particular
problems arise which are not covered sufficiently for the purchaser’s purposes, the matter should be referred to the local
Siemens Industry, Inc. sales office. THE CONTENTS OF THIS INSTRUCTIONMANUAL SHALL NOT BECOME PART OF OR
MODIFY ANY PRIOR OR EXISTING AGREEMENT, COMMITMENT OR RELATIONSHIP. THE SALES CONTRACT
CONTAINS ALL OBLIGATIONS OF SIEMENS INDUSTRY, INC. THEWARRANTY CONTAINED IN THE CONTRACT
BETWEEN THE PARTIES IS THE SOLEWARRANTY OF SIEMENS INDUSTRY, INC.

ACCESS, ISGS, Isolated Multi-Drop, S7-I/O, SBwin, SAMMS-LV, SAMMS-MV, SEAbus, SIEServe, Static Trip III, Wisdom, and
WinPM.Net are trademarks, Sensitrip and Sentron are registered trademarks of Siemens Industry, Inc. SIEMENS is a registered
trademark of Siemens AG. Windows is a trademark of Microsoft Corporation. ION, Modbus andWebMeter are either trademarks
or registered trademarks of Schneider Electric in France, the USA and other countries. All other product names mentioned
herein are used for identification purposes only and may be the trademarks or registered trademarks of their respective
companies.
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Safety Precautions
During installation or use of this software, pay attention to all safety messages that occur in the
software and that are included in the documentation. The following safety messages apply to this
software in its entirety.

WARNING
UNINTENDED EQUIPMENT OPERATION
• Do not use the software or devices for critical control or protection applications where
human or equipment safety relies on the operation of the control action.

• Do not use the software to control time-critical functions.
• Do not use the software to control remote equipment without proper access control and
status feedback.

Failure to follow these instructions can result in death, serious injury, or equipment
damage.

WARNING
INACCURATE DATA RESULTS
• Do not incorrectly configure the software or the devices.
• Do not base your maintenance or service actions solely on messages and information
displayed by the software.

• Do not rely solely on software messages and reports to determine if the system is
functioning correctly or meeting all applicable standards and requirements.

• Consider the implications of unanticipated transmission delays or failures of
communications links.

Failure to follow these instructions can result in death, serious injury, equipment
damage, or permanent loss of data.

WARNING
POTENTIAL COMPROMISE OF SYSTEM AVAILABILITY, INTEGRITY, AND
CONFIDENTIALITY

Use cybersecurity best practices to help prevent unauthorized access to the software.

Failure to follow these instructions can result in death, serious injury, equipment
damage, or permanent loss of data.

Work with facility IT System Administrators to ensure that the system adheres to the site-specific
cybersecurity policies.

WinPM.Net 10.0 User Guide Safety Precautions
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Chapter 1: Introduction to WinPM.Net
WinPM.Net software is a power management solution for energy suppliers and consumers. It
allows you to manage energy information from metering and control devices installed in your
facility or other remote locations. The product offers control capabilities and comprehensive
power quality and reliability analysis to help you reduce energy-related costs.

The product supports multiple communications standards and protocols available on various
intelligent metering devices. You can also connect to existing power monitoring systems through
industry standard protocols such as Modbus and OPC.

Supported operating systems and SQL Server versions
See Operating Environment for information on supported Windows operating systems and
SQL Server versions and editions.

WinPM.Net software components
This section outlines the WinPM.Net software components.

Web Applications
Web applications are the end user facing components of the software. You use web applications
in your daily work with WinPM.Net. Web Applications has 3 main parts: Apps, Settings, and
Configuration Tools.

Apps
UseWeb apps to access power monitoring information. The following apps are included in the
Web Applications:

• Dashboards

• Diagrams

• Trends

• Alarms

• Reports

(SeeWeb Applications help for details.)

Settings
Use Settings to tailor the behavior and appearance of the software. The following Web Application
Settings are available:

• Alarm Views

• Authorized Hosts

• Diagrams Control Options

• Login Options

• Personal Preferences

• Report Theme

WinPM.Net 10.0 User Guide Chapter 1: Introduction to WinPM.Net
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• Security Options

• Session Timeout

• System Language

• System Theme

The Settings page also provides links to the following configuration tools:

• Software Alarms

• Device Manager

• Hierarchy Manager

• Log Viewer

• Notifications

• User Manager

(See the individual tool helps for details.)

Engineering applications
Engineering applications are the backend components that are used to configure and maintain
the monitoring devices, networks, databases and other elements of the power monitoring system.
It also includes the Vista application which is used to for real-time control and to build diagrams.
The following applications are included:

Management Console
Use Management Console to add and configure network components such as servers, sites
(communication links) and devices. Management Console also provides access to the following
system and database applications, and utilities (listed in menu sequence):

ThroughManagement Console > Tools

• Database Manager

• Event Watcher Manager 

• Reports Configuration

• Logical Device editors

• Deactivating alarms

ThroughManagement Console > Tools > System

• Diagnostics Viewer

• Device Type Editor

• Manual Data Editor

• Remote Modem Setup

• Virtual Processor setup

• Update OPC Server

• Upload Report Template



• PQDIF Exporter

• Time of Use Editor 

ThroughManagement Console > Tools > Web Tools

Management Console provides shortcuts to Web Applications configuration tools. SeeWeb
Applications for details.

Vista

Use Vista to reset counters and perform other control actions on monitoring devices. Vista also
displays real-time and historical information using graphical displays. You use Vista to create the
diagrams for the DiagramsWeb app.

Designer

Use Designer to perform a wide range of functions, from configuring setup registers of ACCESS
devices on your network to creating complex frameworks using a combination of ION modules
from hardware or software nodes.

OPC Server Assistant

The OPC Server Assistant is a utility that you use to expose IONmeasurements as OPC tags.
You open the utility from Designer. See OPC Server Support for further information.

WinPM.Net can be ordered with or without the optional OPC server license. You can also order
the OPC server license at a later date. If you purchased your OPC server license after you have
installed WinPM.Net, enable the OPC server functionality simply by entering your new product
key in Management Console (under Tools > License Manager).

Large system setup using Management Console

Use the Duplicate and Configure function to set up large systems efficiently. See Setting up large
systems for more information.

WinPM.Net Windows Services
For a list of WinPM.Net Windows Services see WinPM.Net Windows services

WinPM.Net databases
For information on the WinPM.Net databases, see WinPM.Net DatabasesWinPM.Net Databases.

Getting started
This section describes how to start, log on to, and exit most of the components of the WinPM.Net
product.

Starting a component of WinPM.Net
Use one of the following methods to start the main components Management Console, Vista, or
Web Applications of your product installation:

• Open the WinPM.Net folder on your desktop and double-click the icon of the program you
want to start.

WinPM.Net 10.0 User Guide Chapter 1: Introduction to WinPM.Net
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• Click Start > All Programs > Siemens > WinPM.Net and select the program you want to
start.

Logging into a component
Most WinPM.Net programs require you to log in before you can access them.

At the logon prompt, type your user name and password in the appropriate box, then clickOK.
Some actions are restricted to certain users or groups, depending on how their login permissions
were set up. For information on creating users and user groups, and on setting user access
levels, see the User Manager section in Web Applications Help.

NOTE: For security reasons, using View Only button to login to Vista no longer works and
displays an error message. Alternatively, it is recommended to login to Diagrams application
with Observer access level.

After you log on, the program interface appears.

Ending a session
There are two ways to end a session in a component:

• Log off if you want to end the current user session but keep the program running, or

• Exit if you want to close the program completely.

Some components offer both options; some only offer the Exit option.

Logging off

1. Select File > Logoff.

A message appears, prompting you to confirm your intention to log off.

2. Click Yes to log off or No to return to the program.

If you attempt to log off without saving your work, you are prompted to save your changes.
Click Yes to save your changes, No to discard them, or Cancel to return to the program.

After you log off, the component's Logon screen appears.

Exiting

1. Select File > Exit.

A message appears, prompting you to confirm your intention to exit the application.

2. Click Yes to exit or No to return to the program.

If you attempt to exit without saving your work, the program prompts you to save your
changes. Click Yes to save your changes, No to discard them, or Cancel to return to the
program.

Customizing and navigating interface displays
The following sections describe ways to customize and navigate display windows, dialogs, and
tables in components of WinPM.Net.



Navigating tree structures

Information is often displayed in a tree structure. Click “+” to expand items in the tree or “-” to
collapse them.

Selecting multiple items in tables, tree structures, diagrams and folder structures

To select adjacent items, select the first item, hold down the SHIFT key then click the last item.

To select non-adjacent items, hold down the CTRL key then click to select the items.

To select adjacent items in Vista or Designer diagrams, drag a selection box around the items. All
items in the box are selected.

Adjusting the display of a window or dialog
The following sections describe how to resize and hide or reveal panes.

Resizing panes

To resize panes in a window, point the mouse at the border where the two sections meet. When
the resize handle appears, drag to move the border.

Dock (Pin) or hide (Unpin) pane

Some component interfaces have panes that can be hidden (visible temporarily) or docked
(visible all the time).

To hide or dock a pane, click the Pin/Unpin button on the pane. When a pane is hidden, it is
minimized to a button at the edge of the workspace.

To temporarily show a hidden pane, hover the mouse over the button for that pane. Move the
mouse away to hide the pane again.

Grid table controls
Certain windows and utilities display information in “grid” tables. These tables have unique table
and information display commands.

Select columns/column selector
Some tables allow you to select which columns to include in the table.

1. In Management Console, hover over the column selector tab on the right side of the display
window. In other interfaces, click the “Select Columns” link.

2. Select the boxes for the columns you want to include in the table. Clear the boxes for the
columns you do not want to include in the table.

Adjust column width

To change the width of a column, point the mouse to the right edge of the column header. When
the resize handle (double-arrow pointer) appears, click and drag to adjust the width. To adjust the
width for best fit, point to the right edge of the column header, then double-click when the resize
handle appears.

WinPM.Net 10.0 User Guide Chapter 1: Introduction to WinPM.Net
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Best Fit
To adjust a column width to the best fit with the least amount of white space:

• For one column, right-click a column header and select Best Fit.

• For all columns, right-click the column title area and select Best Fit (all columns).

Arrange columns

To change the order of the columns, drag a column header to the left or right of its original
position.

Group by column

To group data according to the contents of a particular column, drag the column header to the
area above it (marked “Drag a column header here to group by that column”). To expand or
collapse the groups, click the “+” or “-” button. To expand or collapse all groups, right-click the
column header in the Group By Box area and select Full Expand or Full Collapse, respectively.

You can also group by multiple columns in a specific order, with sorting and filtering applied. To do
this drag each column to theGroup By Box area in the order that you want to group them.

To ungroup, drag the column header back to its original position (or right-click the column header
and select Ungroup).

To show or hide theGroup By Box area, right-click the column header and select or clearGroup
By Box.

Sorting data in a column

Click a column header to sort table rows according to data in that column. You can sort in
ascending or descending order (indicated by an up or down arrow, respectively). To cancel
sorting and return the column to its default state, right-click the column and select Clear Sorting.

Filtering data in a column

The following sections describe the available filtering options.

Using the Simple Column Filter

When the mouse is positioned over a column header, the Filter icon appears in the top right
corner of the header. Click it to select one of the listed filter conditions and apply it to the data in
that column. Select (Custom) to apply one or two logic conditions to filter the data. To cancel
filtering and return the column to its default state, right-click the column and select Clear Filter.

Using the Dynamic Column Filter

Some tables have a row between the column header and the table data. This is the dynamic filter
area.

To use the dynamic filter area, start typing the entry you want to filter on in the space above the
applicable column. You can use an asterisk (*) at the beginning of the filter as a wildcard. Once
you achieve the filter results you want, you can stop typing. For example, to filter out “DST” from
“disturbance” in System Log Events, you only need to type “di”.



Using the Filter Builder
The Filter Builder is an advanced data filtering tool. Use it to create filters with multiple conditions
across multiple columns. To use the Filter Builder:

1. Right-click a column header and select Filter Editor to open the Filter Builder dialog.

2. Specify the filter conditions.

The elements of the filter builder are: <Column Header> <Condition> <Value>

Click an element to display the options available, then select the option you want to use.

3. Select the <Column Header> and the <Condition> you want to apply. Type the <Value> to
test for.

4. To add another filter, click the “+” button on the top.

5. Select a logic to apply to this new filter (in relationship to the current filter).

6. Repeat step 3.

7. To remove a filter, click the delete (“x”) button beside it.

In the following example, the filter finds all devices in group name containing “Mfg” and whose
types begin with “ION”.

The rows returned are as follows:

WinPM.Net 10.0 User Guide Chapter 1: Introduction to WinPM.Net
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A
Select the checkbox to turn the filter on; clear it to turn the filter off.
Click the "X" to cancel and exit the filter mode.

B Click Edit Filter to configure the filter conditions



Chapter 2: Management Console
Use Management Console to add, remove or configure system components, such as metering
devices, in your WinPM.Net power management system. You can set up different types of sites
(communication links such as Ethernet or serial), and set up connection schedules for these sites.

In addition, the Management Console Toolsmenu provides access to device and system
configuration, maintenance and programming tools.

NOTE: Run Management Console as Administrator user. To do this, right-click the Management
Console program icon and select Run as administrator from the context menu. If you do not
run it as Administrator, then certain tools are not functional.

NOTICE
NETWORK INOPERABILITY

Do not make unauthorized changes in the network configuration.

Failure to follow these instructions can result in an unstable or unusable network.

The Management Console interface

WinPM.Net 10.0 User Guide Chapter 2: Management Console
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A
System Setup pane and
icons

B Sort indicator C Group By Box area D Filter indicator

E Column Selector F Pin/Unpin icon G Display window1 H Edit Filter button

I Current filter applied J Hover text K Show historical devices option

1 This area displays the contents of the selected System Setup icon

Window title

The window title displays the name of the software program and the current user.

System Setup pane

The icons in the System Setup pane represent categories of items you can add, remove, set up,
and view. Click an icon to go to the associated display window.

Display window

The Display window shows the contents of the item currently selected in the System Setup pane.

Refresh

To manually refresh Management Console and reload its contents, select View > Refresh (or
press F5).

Options

Select Tools > Options to open the Options dialog. Use this dialog to change display settings for
the System Log Events display window.

Highlighting

Highlighting controls how Error events are displayed in the System Log Events display window.
Select or clear the Enable Highlighting check box to turn highlighting on or off. Click Set Highlight
Color to change the highlight color for Critical or Error events in the System Log Events display
window.

Events

The Events section of the dialog lets you control how many records appear in the System Log
Events display window and how date and time are displayed.

Customizing the Management Console interface
You can customize what is displayed in the Management Console interface and the tables within
the display windows:

• Select which columns appear in tables.

• Filter, sort and group data in tables.

For instructions on using these features, see Customizing and navigating interface displays.

Display window shortcut menus

To access shortcut menus in the Display window, first click the icon of the System Setup item you
are interested in. Then right-click the display window area or on a network component to display
the shortcut menu. The menu items available vary depending on the network component



selected.

• New displays the options available for adding new network items.

• Duplicate and Configure lets you perform batch cloning of devices. When multiple devices
are selected, this right-click shortcut becomes Configure Selected Devices which lets you
perform setup functions such as batch renaming of devices.

• Delete removes the selected items.

• Connect and Disconnect lets you manually connect to or disconnect from the selected site.

NOTE: You cannot connect or disconnect an individual serial device in a site; you can only
connect or disconnect the site for that serial device.

• Connect Ethernet and Disconnect Ethernet let you manually connect to or disconnect from
the selected Ethernet device.

• Security accesses the Meter Security Settings dialog. This is used by the software to gain
access to security-enabled devices (for example, ION8600 or 9610); it is only available from
the shortcut menu for the Devices display pane.

• Configure <Network Component> opens the <Network Component> Configuration dialog
(where <network component> is the component selected). Use this dialog to make changes
to the properties for the selected network component.

For Devices only:

• Rename opens the Rename Device dialog. Use this to change the device Name.

• Change Group opens the Change Group dialog. Use this to change the device Group.

Management Console network components
This section describes the different components in Management Console: Servers, Sites,
Devices, Dial Out Modems, Connection Schedules, and System Log Events.

See Setting up your network in Management Console for information on adding these
components to your network.

NOTE: Do not use names such as CON, AUX, COM1, and LPT1 when naming sites and
devices. Consult Microsoft documentation regarding restrictions for naming files, paths, and
namespaces.

Servers

A server is a computer in the WinPM.Net system that runs administrative software to control
access to the network and its resources, such as metering devices.

Sites

A site is a group of devices in the system that share a common communications link. A site can be
a direct site, a modem site, an Ethernet gateway site, or an OPC site.

WinPM.Net 10.0 User Guide Chapter 2: Management Console

© 2021 Siemens Industry, Inc. All Rights Reserved. 11



Chapter 2: Management Console WinPM.Net 10.0 User Guide

12 © 2021 Siemens Industry, Inc. All Rights Reserved.

Direct site

In a direct site, serial communications occur between a computer and one or more meters. The
standards most commonly used on computers are RS-232 (for connecting one device) and RS-
485 (for connecting a loop of up to 32 devices). When connecting to more than one serial device,
use an RS-232 to RS-485 converter. Note that you should keep the number of devices on a daisy
chain to a minimum to reduce the delay in real-time updates.

Modem site

In a modem site, communications occur between a remote modem (at the Modem Site) and a
local modem (on the server).

NOTE: Remote sites that use radio modems or leased-line modems are configured as Direct
(Serial) Sites, not as Modem Sites.

Modem sites can include traditional hardware modems (those that are configured and controlled
by WinPM.Net or WinModems (Windows modems). If multiple modems are set up in the modem
site, WinPM.Net selects the first available modem to establish communications (this is referred to
as “modem pooling”).

Ethernet gateway site

An Ethernet gateway site (for example, EtherGate or Modbus gateway) consists of an RS-485
chain of devices that communicates with an Ethernet network via an Ethernet device. The
Ethernet device acts as a gateway that transfers data between an Ethernet network and the
devices connected to it via RS-485. The gateway device converts RS-232/RS-485
communications to and from Ethernet.

OPC site

An OPC site consists of an OPC client that communicates with OPC-compliant devices on the
network.

Devices

A device is a meter or other component that communicates and gathers data, and is installed on a
network.

Release notes and mapping spreadsheets for device drivers recently added to the product are
included in the product's installation location in ...\WinPM.Net\system\doc\Device
Support\. The release notes provide information about the firmware versions supported by the
device drivers, implementation details, images of Vista diagrams for the devices, and pertinent
safety messages. The device driver mapping spreadsheets contain details such as modbus
register addresses and corresponding ION register addresses (handles). Register mapping
information is also provided for any devices using PC logging.

Serial devices

Serial devices belong to direct sites, modem sites, or Ethernet gateway sites — they
communicate through a modem, RS-232, RS-485, or Ethernet-to-Serial gateway connection. You
must have the appropriate sites configured first before you can add serial devices.



Ethernet devices

Ethernet devices are those that are directly connected to the network via Ethernet. You can
manually connect or disconnect your Ethernet device through the Management Console.

Logical devices

Logical devices are a collection of measurements from physical and VIP devices grouped into
single sources for use in the system.

OPC devices

OPC devices represent physical devices to which the system is communicating through an OPC
interface.

Dial Out Modems

A dial-out modem is one that a server computer uses to communicate with a remote modem at a
modem site. The modem implemented can be a traditional hardware-based modem or it can be a
software-based modem that uses the computer’s processor to emulate a traditional hardware-
based modem.

When a modem site needs to establish communications, it selects a modem from the list of
modems configured in the modem site. You can add hardware modems or WinModems to the
modem list.

NOTE: A WinModem is a modem that is directly controlled by the computer’s operating system.

Connection schedules

Connection schedules are programmed routines for a server to regularly connect to and
disconnect from sites (and their associated devices) and Ethernet devices. See Configuring
connection schedules for more information.

System Log Events

System Log Events lists events for the network. You can select what time frame and components
you want to view events for. See System Log events for more information.

Setting up your network in Management Console

WARNING
INACCURATE DATA RESULTS
• Do not incorrectly configure the software or the devices.
• Do not base your maintenance or service actions solely on messages and information
displayed by the software.

• Do not rely solely on software messages and reports to determine if the system is
functioning correctly or meeting all applicable standards and requirements.

• Consider the implications of unanticipated transmission delays or failures of
communications links.

Failure to follow these instructions can result in death, serious injury, equipment
damage, or permanent loss of data.
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WARNING
UNINTENDED EQUIPMENT OPERATION
• Do not use the software to control time-critical functions.
• Do not use the software to control remote equipment without proper access control and
status feedback.

Failure to follow these instructions can result in death, serious injury, or equipment
damage.

NOTICE
NETWORK INOPERABILITY

Do not make unauthorized changes in the network configuration.

Failure to follow these instructions can result in an unstable or unusable network.

The Primary Server contains all the WinPM.Net programs and it controls the overall operation of
your energy management system. The primary server is displayed on the Server screen when
you first start Management Console.

To start building your system, add and configure your sites and devices.

Overview

Site and Device Naming restrictions

The following applies to Site, Device Group, and Device Name naming:

• Names cannot contain spaces or the following characters: \ / : * ? " < > { } . , ' & @ | % #

• The maximum length for a Group.Device name is 99 characters (+ 1 for the period
separation).

• Do not use names such as CON, AUX, COM1, and LPT1 for sites and devices.

• All characters must exist in the system's Windows code pages. For example. on an English
Windows operating system, certain non-English language characters are not supported.

Adding network components

For details on adding various components, see the following sections.

Follow the procedure below to add a new network component:

1. In the System Setup pane, select the icon for the type of item that you want to add ( Site,
Device, or Dial Out Modem).

2. Right-click the display window, select New, and then select the specific type of network
component from the shortcut menu to open the Configuration dialog.

The options differ depending on which system setup icon you selected.



3. Use the fields and drop-down menus to configure properties. Mandatory items are
highlighted in red. To configure advanced properties, right-click the dialog and select
Advanced Properties. For more shortcut menu options, see Configuration Dialog shortcut
menus, below.

4. ClickOK to add the component.

Configuration Dialog shortcut menus
Right-click the Configuration dialog to access the following shortcut menu options:

• Property Details: This opens a window that contains information on the selected property,
including minimum and maximum allowable values, if applicable.

• Advanced Properties: This exposes all the property fields that are hidden in the default
(basic) view. For further information about the Time synchronization option. see Time
synchronization for SIEMENS 9xxx series meters for further information.

• Reset All To Default: Resets all properties to their original values.

Adding a server
Click the Servers icon, right-click the display window and select New > Computer. Fill in the
mandatory Name field.

Adding devices

Setting Up devices for direct serial communications

To set up devices for RS-232 or RS-485 communications on a direct serial loop, first add a direct
site in Management Console and specify a serial communications port on the computer.

Step1: Adding a direct site
Click the Sites icon. Right-click the display window and select New > Direct Site. Fill in the Name
and Serial Port fields. Configure the other fields as you require.

Step 2: Adding a device to the direct site
Click the Devices icon. Right-click the display window and select New > Serial Device on Direct
Site. Fill in these fields:

• Group: Type a name for the group or select an existing group from the list.

• Name: Type the name you want to give the device.

• Device Type: Select the type of the device.

• Unit ID: Type the Unit ID of the device; the range is 1-9999 for SIEMENS 9xxx series devices
or 1-247 for Modbus RTU devices.

• Site: Select the direct site you previously set up.

• Time Zone: Select the timezone you want the device data to be displayed in, in the software.
This setting is only used for the display of timestamped data in the software. It does not affect
the configuration of the monitoring device itself.

Configure the other fields as you require.
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Setting up devices for Ethernet gateway communications

To set up devices for Ethernet gateway communications, first add and configure an Ethernet
gateway site. Ethernet gateways that can be used include those that are simple Ethernet-to-Serial
converters, or any gateway or data concentrator that provides ModbusTCP communications.

Step 1: Adding an Ethernet gateway site

Click the Sites icon. Right-click the display window and select New > Ethernet Gateway Site.

Complete the Name, IP Address or Host Name and TCP/IP Port fields. (The IP address can be
IPv4 or IPv6.) The TCP/IP Port identifies which communications port is used to connect to the
serial devices. The port you use depends on the type of Ethernet gateway you want to set up (use
7801 for an EtherGate gateway via COM1 or use port 502 for a Modbus gateway).

Configure the other fields as you require.

Step 2: Adding a Device to the Ethernet Gateway Site
Click the Devices icon. Right-click the display window and select New > Serial Device on
Ethernet Gateway Site. Fill in these fields:

• Group: Type a name for the group or select an existing group from the list.

• Name: Type the name you want to give the device.

• Device Type: Select the type of device.

• Unit ID: Type the Unit ID of the device; the range is 1-9999 for SIEMENS 9xxx series devices
or 1-247 for Modbus devices.

• Site: Select the Ethernet gateway site you previously set up.

• Time Zone: Select the timezone you want the device data to be displayed in, in the software.
This setting is only used for the display of timestamped data in the software. It does not affect
the configuration of the monitoring device itself.

Configure the other fields as you require.

Adding an Ethernet device
Ethernet devices are configured in WinPM.Net by providing fixed IP addresses (IPv4 or IPv6) and
ports, or based on device names. Device names must be used for devices with dynamic address
assignment, for example using the DHCP protocol. When device names are used, then a form of
name resolution mechanism is required on the network.

To add an Ethernet device, click the Devices icon. Right-click the display window and select
New > Ethernet Device. Fill in theGroup, Name, Device Type, IP Address or Host Name,
and Time Zone fields. (The IP address can be IPv4 or IPv6.) Configure the other fields as you
require.

NOTE: For the Time Zone field, select the timezone you want the device data to be displayed in,
in the software. This setting is only used for the display of timestamped data in the software. It
does not affect the configuration of the monitoring device itself.

Setting up devices for OPC communications

To set up devices for OPC communications, first add an OPC site.



Step 1: Adding an OPC site

Click the Sites icon. Right-click the display window and select New > OPC Site. Fill in the Name
and Address fields. Configure the other fields as you require.

Make sure you follow the correct syntax when typing in the address for the OPC site. Select the
Address field to see an example address in the Property Description section (near the bottom of
theOPC Site Configuration dialog).

Step 2: Adding a device to the OPC site

NOTE: At least one OPC Device Type needs to be preconfigured before an OPC Device can be
created in Management Console. Contact Technical Support for assistance.

Click the Devices icon. Right-click the display window and select New > OPC Device. Fill in the
Group, Name, Device Type, Site (select the OPC site you previously set up), and Time Zone.
Configure the other fields as you require.

NOTE: For the Time Zone field, select the timezone you want the device data to be displayed in,
in the software. This setting is only used for the display of timestamped data in the software. It
does not affect the configuration of the monitoring device itself.

Adding a modem
1. Click the Dial Out Modems icon, right-click the display window and select New, then select

either Serial Modem (hardware modem) orWinModem (Windows modem).

2. Fill in the values for the mandatory fields:

For Serial modem, select the Modem Type from the list. If your modem is not in this list,
select “Generic ION Modem - Other”. Select the Serial Port where your modem is
connected.

ForWinModems, select the Modem Name from the list.

Configure the other fields as you require.

3. ClickOK.

WinModem installation notes
Before you can use aWinModem, you must first install it on your computer (follow the instructions
that came with the WinModem product). After you restart the computer, set up the WinModem:

1. In Microsoft Windows, click Start > Settings > Control Panel, then double-click Phone
and Modem Options.

2. Click the Modems tab, select your WinModem, then click Properties.

3. Click the Advanced tab, then click Change Default Preference.

4. Set Port speed to match the baud rate that is used between the meter and the modem on
the remote end of the connection (both modems must be set to the same baud rate).

5. Set Flow Control to “None”.

6. ClickOK to save your changes.

NOTE: You may need to restart your computer for the settings to take effect.
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Editing a network component
1. Click the icon in the System Setup pane for the type of component you want to edit.

2. In the display window, right-click the network component you want to edit and select
Configure <Network Component> (with <Network Component> being the type of
component you want to edit).

You can rename devices or groups displayed in the Devices pane without selecting the
Configure option.

NOTE: If you rename a group or device, the data that is already stored in the database is
associated with the new group or device name. New data will be added to the database
using the new name.

3. Make the required changes. To display all configurable fields, right-click the Configuration
dialog and select Advanced Properties.

4. ClickOK when you are finished to save your changes.

Deleting a network component
1. Click the System Setup icon for the type of component you want to delete.

2. In the display window, right-click the network component you want to delete and select
Delete (or select the item and press the DELETE key).

3. Click Yes to confirm the deletion or No to cancel.

NOTE: When you delete a Site or a Server, all devices associated with it are also deleted.

Renaming devices and groups
You can change the display names of devices and groups without losing any of the real-time or
historical data associated with them.

In the Devices pane in Management Console:

• Group and Name are separate columns.

The Name column is always displayed.

TheGroup column is displayed by default, but you can use the Column Selector to
remove it from the display area. You can now drag and drop theGroup column to the
Group By Box area to show the devices organized within each group.

• Use the Data Availability column for inclusion in the display area.

Data Availability indicates All for devices that are active and have real-time and
historical data, and Historical only for devices that have been deleted and only provide
historical data. Historical devices are included in the devices displayed when you select
the Show historical devices checkbox.

• The Show historical devices option displays devices that have been deleted. Since the data
for these devices still exists in the system, they can be displayed when you select this option.



Renaming a device
Complete the following steps to change the display name of a device. The system (internal) name
is not affected by this name change.

1. Right-click the device name in the Devices pane of Management Console and select
Rename in the menu to open the Rename Device dialog.

2. Enter the new name for the device.

The appearance of the exclamation icon to the right of the field indicates that there are
instructions or errors associated with the device name. Hover over the icon to display the
text and take appropriate action.

3. ClickOK to rename the device.

Changing a group name
Change a group name as follows:

1. Right-click a single group name or select multiple group names (Ctrl + left mouse click) in the
Devices pane of Management Console and select Change Group in the menu to open the
Change Group dialog. (You can also select the devices and click the Change Group
option in the Editmenu.)

2. Enter a new group name or select a group name from the list of group names currently used
in the system.

The appearance of the exclamation icon to the right of the field indicates that there are
instructions or errors associated with the group name. Hover over the icon to display the text
and take appropriate action.

3. ClickOK to change the group name.

Considerations when renaming devices or groups
Note the following when you rename a device or a group:

• Complete any configuration tasks in progress, such as working in Designer, before changing
names.

• Restart any open components such as Vista, Designer, or Web Applications after the name or
group change has been completed to refresh the names that appear in them.

• Regenerate network diagrams in Vista to update the top-level grouping objects with the
changed Group name.

• Update OPC data mapping after device renaming by selecting the Update OPC Server
option in Management Console's Tools > Systemmenu. You can then update the OPC
clients with the new data.

• System (internal) names, not display names, continue to appear in System Log Events in
Management Console. You can view the system name of a device, in Device Manager, by
selecting Unique System ID in the Column Selector.
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Accessing meters with security
If you have a device in your network with security enabled, use Management Console to allow
WinPM.Net Windows Services to access the device. This is required for automatic upload of
historical data logs from the device.

To configure WinPM.Net Windows Services to the device:

1. Right-click the device that has security enabled and select Security to open theMeter
Security Settings dialog.

2. From the Software Access drop down list, select the option as per the following table:

Option Description

Standard Security

Select this option if standard security is configured on the
device.

NOTE: If standard security is not configured on the device,
refer to Changes in security settings of device for more
information.

User List
Select the user if advanced security is configured on the
device.

NOTE: You can configure the device security settings using Designer or ION Setup. See
Configuring Security module for more information.

3. ClickMatch Password and type the password in the Password field then re-type it in the
Confirm Password field.

4. Select the check box if you want to allow the software to send secure time synchronization
signals to the device. Clear the check box if you do not want to send secure time
synchronization signals to the device.

5. ClickOK.

Configuring connection schedules
You can schedule the times when the server connects to a site or Ethernet device.

Adding a connection schedule

Click the Connection Schedules icon, right-click the display window, then select New >
Connection Schedule to open the Scheduled Site Connection dialog.

The following sections describe the available tabs and how to configure them.

General Settings tab
On theGeneral Settings tab:

• Type the name of your connection schedule (for example “Daily Reading”) in the Name field.

• Type a description of the connection schedule, if required.

• Select Enabled if you want to enable the schedule.

• Select the date from which the schedule is valid.



Sites tab
On the Sites tab:

• Click the box beside the sites and devices to select those that you want to include in the
connection schedule. A check mark appears beside an item to indicate that it is included in
the connection schedule.

• Set your Site Connection Settings. To enter the minimum and maximum time to stay
connected, type the time in the fields or use the arrows to change the time.

• Set the Connection Priority. The higher the number, the greater the priority given to that
schedule if there are concurrent connection requests.

Schedule tab
On the Schedule tab:

• Set up the date schedule for the connection (the default is Daily). Schedule options vary
depending on the type of schedule selected.

Daily: Occurs every day.

Weekly: Occurs on the selected day at the specified frequency (in number of weeks) and
stays active for the specified duration. For example, if you set Frequency to 2, Day of
week to Sunday and Active Duration to 2, the connection occurs every second Sunday
and stays active for two days.

Monthly - Day of Week: Occurs at the specified frequency (in months), in the week and
on the day specified and for the specified duration. For example, if you set Frequency to
3, Day of Month to 2nd and Sunday, and Duration to 1, the connection occurs every third
month on the second Sunday and stays active for 1 day.

Monthly - Day of Month: Occurs at the specified frequency (in months), on the specified
date of the month, and for the duration specified. For example, if you set Frequency to 2,
Day of Month to 15th and Duration to 2, the connection occurs on the fifteenth day of
every second month and stays active for 2 days.

• Set up the time period for the connection to occur by setting a start and an end time. In the
Start Time and End Time fields, type the time or use the arrows to change the time.

If you configure a full-day (i.e., 24-hour) daily schedule, you need to allow enough time between
the end time and the start of the next connection to avoid connection problems. For example, to
add a 2-minute gap to a 24-hour schedule, set the Start Time to 0:00:00 and the EndTime to
23:58:00.

System Log events
System Log Events lists events for components in the system. This information comes from the
ION_SystemLog database.

TIP: For instructions on filtering and sorting columns and customizing the display, see
Customizing and navigating interface displays.
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Viewing System Log events
To view System Log Events:

1. Select System Log Events from the System Setup pane.

2. In the Show area select the checkboxes for the system components for which you want to
view events (i.e., servers, sites, devices).

If there are no events for a particular system component, that check box is unavailable.

3. Select the minimum priority level of events to be displayed from theMinimum Priority
Level dropdown list (see below for more information on priority levels).

4. ClickModify to change the date/time filter applied to the System Events Log display. See
System Log filter setup.

5. To view details of an event, double-click on the entry in the event log.

Priority

Priority classifies what type of event has occurred. The value corresponds to the severity of the
event: the higher the number, the more severe the event.

The priority is contained in the ION_SystemLog database as a number. In the System Events Log
display, the priority levels are displayed as text strings. The priority numbers are mapped to the
text strings as follows:

Diagnostic 0 - 5
Information 6 - 20
Warning 21 - 63
Error 64 - 191
Critical 192 - 255

By default, the Cutoff setup register of Log Inserter’s System Log Controller module is set to 192.
This means that system events with a priority less than 192 are not transferred to the ION_Data
database and therefore cannot be viewed in Alarms. If you want to view lower priority events in
Alarms, use the above priority mapping as a guide to set the Cutoff setup register to a lower value
(using Designer).

System Log filter setup
The System Log Filter Setup dialog lets you change the date and time filter applied to the System
Events Log display.

1. ClickModify to display the System Log Filter Setup dialog.

2. Select the time range by which you want to filter from the dropdown list. To set up a custom
filter, select Custom Date Range then use the dropdown lists and arrows in the Select a
Date Range dialog to specify the start and end of the range.

3. ClickOK.

Setting up large systems
To perform batch network setup of devices, create the first device in Management Console (see
Adding network components) using a logical naming scheme. After you create this first device,
you can then use it to create multiple duplicate devices and configure their properties.



The Duplicate and Configure interface

NOTE: The Duplicate and Configure function always operates on all devices visible in the table.
When table rows are filtered in the Duplicate and Configure tool, changes done using the
configuration editors on the top pane of the window affect only the devices that are visible in the
Table Editing area. If you want to apply the changes to all devices, clear the filter first before
making the changes.

NOTE: The Duplicate and Configure function cannot be used with logical devices. See Creating
multiple logical devices for information about creating more than one logical device.

The Duplicate and Configure area

The Duplicate and Configure area has different sections depending on the type of device you are
duplicating.

Ethernet devices have the following sections:

• Configure Names: Use this section to create the duplicates.

• Configure TCP/IP Addresses: Use this section to create a sequence of IP addresses to
assign to the duplicates after they have been created.

• Configure TCP/IP Ports: The port number used in the original device is automatically
assigned to all the duplicates. If required, use this section to select a different port number for
all the displayed devices in the Table Editing area (changes made in this area are applied to
all devices, including the original).

• Configure Unit IDs: This section is disabled by default, since unit IDs do not apply to typical
Ethernet devices. (To enable this section, you must first set up the Table Editing area so that
the “Unit ID” column is visible).

Serial devices have the following sections:

• Configure Names: Use this section to create the duplicates.

• Configure Unit IDs: Use this section to create a sequence of unit IDs to assign to the
duplicates after they have been created.

• Configure Serial Sites: The serial site used in the original device is automatically assigned
to all the duplicates. If required, use this section to select a different serial site for all the
displayed devices in the Table Editing area (changes made in this area are applied to all
devices, including the original).

OPC devices have the following sections:

• Configure Names: Use this section to create the duplicates.

• Configure OPC Address: Use this section to create a sequence of addresses to assign to
the duplicates after they have been created.

• Configure OPC Sites: The OPC site used in the original device is automatically assigned to
all the duplicates. If required, use this section to select a different OPC site for all the
displayed devices in the Table Editing area (changes made in this area are applied to all
devices, including the original).
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The Table Editing area

When making configuration changes in the Duplicate and Configure interface, these changes are
applied only to the rows that are visible in the Table Editing area.

See Customizing and navigating interface displays for instructions on filtering and sorting data in
the table.

NOTE: To discard your changes since the last saved state, click Revert. You can also press
CTRL+Z to undo the last action. To redo the last action, press SHIFT+CTRL+Z. You can only
undo your last action (one undo).

Creating multiple copies of a device
This section describes how to duplicate and configure devices.

Step 1: Configuring the first device

1. Add the first device using your logical naming scheme.

For example, you can use a scheme like “FL1_PNL1A.CCT01” to name a device that is
installed on the “1st Floor” of the building, “electrical panel 1A”, and “Circuit breaker #1”.
Type “FL1_PNL1A” as the group name and “CCT01” as the device name when you
configure the first device.

2. Right-click the device you want to duplicate and select Duplicate and Configure. The
Duplicate and Configure interface appears.

Step 2: Configuring names
In the Configure Names area, the device name is displayed. Each letter and number is selectable.
A group of numbers is treated as a single entity. For example, in the name “MY8600” the entities
you can select are “M”, “Y” and “8600”. Leading zeroes are also supported, so you can set
sequences such as “01, 02, 03” or “001, 002, 003”.

1. Select a letter or number in the device name. The Start box displays the selected
number/letter, which is the start value. Use the up or down arrow in the spin box to change
the start value, or simply type it in the box.

2. Click the up or down arrow on the End box edit the range, or type the end value in the box.
To clear the range and start over, click Remove Parameters.

3. For letters, select Upper Case or Lower Case, depending on whether you require upper
case or lower case letters.



4. Set exceptions for individual values or a range of values, if required. Exceptions reduce the
number of names created (i.e., total generated names minus the exceptions). See Setting
exceptions to generated sequences.

Once you have finished configuring names, you can duplicate the device. See Step 3: Duplicating
the device, below, for more information.

Example

For example, if you select the first “1” from the example naming scheme and set the End spin box
to “2”, two names are generated (the original, plus one duplicate). If you select a letter and set its
Start value to “A” and the End value to “C”, three names are generated (the original, plus two
duplicates).

The total number of generated names is the product of the first range multiplied by the next, and
so on until the last range, as indicated in the following graphic.

A
The total generated names are the
product:
[2 X 3 X 10] = 60

Setting exceptions to generated sequences
The Exceptions option applies to the Configure Names and Configure TCP/IP Addresses
sections only.

1. To set exceptions to the range of generated values, click Edit (this button is unavailable until
you change the name or IP value).
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A List of current exceptions

2. Use the Add number or Add character (as applicable) spin box to set a value to exclude
from the range you have specified, then click Add. Repeat to set additional values to
exclude. To set a range of values to exclude, select Add number range or Add character
range, then use the Start and End spin boxes to set the range to exclude.

Click Add. Repeat to set additional ranges of values to exclude.

NOTE: You cannot add the same number or letter to the list of exceptions more than once.
If the Add button is disabled, check that the numbers or letters are not already included in
the exceptions list near the top of the window.

3. Use the Remove number or Remove character spin box to remove the exception that was
set for a given value (i.e., put it back in as an acceptable value). Use the Remove number
range or Remove character range spin boxes to remove the exception that was set for a
range of values. Click Remove.

Step 3: Duplicating the device

Once you have finished configuring names, you are ready to duplicate the device. Click
Duplicate. The duplicated devices appear in the Table Editing area of the window.

The first device in the list is the original device. The remaining devices are the duplicates.
Asterisks next to the device names indicate pending changes that have not yet been saved.

Click Apply to save your changes and continue editing devices, clickOK to save your changes
and return to Management Console, or click Revert to undo unsaved changes.

In Management Console, duplicated devices are always disabled when they are added.

Step 4: Configuring duplicated devices

See the following section, Configuring multiple devices, for instructions on configuring other
properties for multiple devices.



Configuring multiple devices
After you have duplicated the devices, you can select and configure any or all of them.

1. If you have closed the Duplicate and Configure interface, select the devices you want to
configure from the Devices display window in Management Console. Right-click and select
Configure Selected Devices (this option is only available if multiple devices are selected).

The Configure Selected Devices interface appears. This interface has the same layout and
controls as the Duplicate and Configure interface; see The Duplicate and Configure
interface for information.

NOTE: Devices affected by a configuration change (that has not been saved) are identified
by an asterisk in the first column of the Table Editing area.

2. Scroll to the right in the Duplicate and Configure area to view the Configure TCP/IP
Addresses, Unit IDs, Ports and Sites sections of the interface (depending on the type of
device being configured). If the number of items in this area does not match the number of
items in the |Table Editing area, a message in red text appears in the area. If the numbers
match, the message text is black. Configure these parameters as described in Configuring
addresses, ports, unit IDs and sites then click Configure at the bottom of the applicable
interface section.

NOTE: Configuration changes only affect the devices that are currently displayed in the
Table Editing area. Use the column sorting and filtering features, described in Customizing
and navigating interface displays, to control which devices are displayed in the table. If you
want to apply the changes to all devices, clear any filtering before making the changes.

3. Click Apply to save your changes and continue working or clickOK to save your changes
and return to Management Console.

NOTE: If you changed the name of one or more devices, a message displays with a list of
devices that will be renamed. If data for those devices already exist in the ION_Data
database and you still proceed with the renaming, then the existing data associated with
the old device name is lost (“orphaned”).

Click Continue to proceed or Cancel to go back and edit the device configuration.

4. When you have finished, clickOK to save your changes and return to Management Console
or click Cancel to discard your changes.

If you click Cancel, a message prompts you if there are pending (unsaved) changes when
you click Cancel. Click Yes to discard the changes and return to Management Console, or
No to return to the configuration window and continue editing.

If inappropriate values (such as a device that is renamed with the same name as another
existing device) are encountered, a message displays with error details. You cannot save
the configuration changes until you have corrected the errors.

Configuring addresses, ports, unit IDs and sites

The following sections describe how to configure addresses, ports, and unit IDs.

WinPM.Net 10.0 User Guide Chapter 2: Management Console

© 2021 Siemens Industry, Inc. All Rights Reserved. 27



Chapter 2: Management Console WinPM.Net 10.0 User Guide

28 © 2021 Siemens Industry, Inc. All Rights Reserved.

Configuring TCP/IP addresses

1. Select the section of the IP address that you want to configure. The Start box displays the
selected number/letter, which is the start value. Use the up or down arrow in the spin box to
change the start value, or simply type it in the box.

2. Click the up or down arrow on the End box edit the range, or type the end value in the box.
To clear the range and start over, click Remove Parameters.

3. Set exceptions for individual values or a range of values, if required. Exceptions reduce the
number of addresses created (i.e., total generated addresses minus the exceptions). See
Setting exceptions to generated sequences.

4. Click Configure at the bottom of the Configure TCP/IP Addresses section.

Configuring unit IDs
The following instructions apply to serial devices (and Ethernet devices that require a unit ID).

1. Use the up or down arrow in the Start spin box to change the start value, or simply type it in
the box.

2. Click the up or down arrow on the End box edit the range, or type the end value in the box.

3. Click Configure at the bottom of the Configure Unit IDs section.

NOTE: To edit the unit ID of an Ethernet device, you must first add the Unit ID column to
the table in the Table Editing area.

Configuring sites

1. From the dropdown list, select the site you want to use for the selected serial or OPC
devices.

2. Click Configure at the bottom of the Configure Sites section.

Configuring ports

1. From the dropdown list, select the port you want to use for the selected Ethernet devices.

2. Click Configure at the bottom of the Configure Ports section.

Editing duplicated device information
The following sections describe how to quickly edit the properties of duplicated devices in the
table editing area.

Copying device information from a spreadsheet

Sometimes device names do not follow any particular naming pattern. In this case, you can use
the copy/paste function to apply configuration changes directly to the Table Editing area.

First, you need to add a new device in Management Console, then create as many duplicates of
the device as the quantity of items you are pasting.

If you have a Microsoft Excel spreadsheet that contains a list of these devices to add to
Management Console, you can use the Configure Names area to create duplicates of that device
type, then use the Table Editing area to copy and paste the device properties from the Excel
spreadsheet.



Example: Copy and paste 20 Ethernet devices from excel

1. Confirm that the names in the Excel spreadsheet conform to the naming convention
“[Group].[DeviceName]”.

2. Add the first device and set up its properties in Management Console. You can assign it a
simple device name such as “A.B1” since it will be overwritten when the values are copied
and pasted from Excel. Set the Enabled property to No so that Management Console does
not attempt to connect to the device.

3. ClickOK to add the device.

4. Right-click the device and select Duplicate and Configure.

5. Select the “1” in the Configure Names box, then use the End spin box to set the value to 20.

6. In the Hide/Show Columns area, clear the check box of all non-editable columns to hide
those that contain grayed out values. Also hide the columns you do not want to paste over or
those that are not included in the Excel spreadsheet.

7. On the Excel spreadsheet, arrange the columns so they match the order of the columns on
the Table Editing area. Hide all columns on the Excel spreadsheet except those
corresponding to columns on the Table Editing area.

8. Select the cells in Excel and copy them (CTRL+C).

9. On the Table Editing area, click on the first cell under the Name column to select it, then
paste the contents of the clipboard (CTRL+V).

10. Click Apply to save your changes or clickOK save your changes and return to Management
Console.

Using Find and Replace to edit device information
Use the Find and Replace feature to modify matching characters in the device names or in any
other editable columns on the device table. The Find and Replace feature does not work on read-
only columns.

1. Right-click the device table and select Find and Replace (or press CTRL+H).

2. Type the characters you want to search for in the Find box. Do not use wildcard characters
(“*”). Note that the search is case-sensitive.

3. Find in column lists all available columns. Select the column you want to search in.

4. In the Replace box, type the characters you want to use to replace the characters in the
Find box. If you want to delete characters from a column value, leave the Replace box
blank.

5. Click Preview to list the search results in the table. The Replace with column displays the
new name or value resulting from the Find and Replace operation.

6. Use the check box in the Select column to select the rows for which you want to change
values. Click Select All to select all the items or Clear Selected to clear all.

7. Click Apply to save your changes or Cancel to discard your changes

8. ClickOK to save your changes and close the dialog.
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Management Console tools are additional programs that help you manage and monitor your
WinPM.Net network.

(Software) Alarm Configuration
The Alarm Configuration application allows you to configure software alarms for multiple sources
and measurements. Each alarm configuration is represented as an Alarm Rule. The rule includes
a threshold value, pickup and dropout delays, an update rate, and the alarm priority.

Starting Alarm Configuration
Open the Alarm Configuration application, either from Tools > Web Toolsmenu in Management
Console, or SETTINGS > Configuration Tools in the Web Applications component.

See Alarm Configuration Help, available from the Alarm Configuration application, for information
about creating, configuring, and enabling alarm rules.

Database Manager and database maintenance
Database maintenance

WinPM.Net uses databases to store information such as system configuration, data logs, and
system event log messages. These databases must be maintained to preserve performance,
manage disk space use, and guard against data loss in case of database failure.

NOTICE
LOSS OF DATA
• Back up the database at regular intervals.
• Back up the database before upgrading or migrating the system.
• Back up the database before trimming it.
• Back up the database before making manual database edits.
• Verify correct database behavior after making database or system changes.

Failure to follow these instructions can result in permanent loss of data.

The following table shows the WinPM.Net databases and the recommended database
maintenance tasks for each:

Database Type of Data Maintenance Tasks*

ApplicationModules
Web Applications related configuration data
and system event log entries.

Backup, Maintenance,
Trim

ION_Data
Historical power system data such as
interval data logs, waveforms and alarms.

Archive, Backup,
Maintenance,
Size Notification**
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Database Type of Data Maintenance Tasks*

ION_Network
Device network and other system
configuration data

Backup, Maintenance

ION_SystemLog
Non-Web Applications related system event
log entries.

Maintenance, Trim

* See Database maintenance task definitions for basic task definitions.
** Size Notification is only used for systems with SQL Server Express, which has a maximum
database size limit of 10 GB.

In Standalone WinPM.Net systems, the database maintenance tasks are pre-configured and
scheduled to run automatically by default. For Distributed Database WinPM.Net systems, you
need to configure the tasks and set up the schedules manually.

NOTE: It is best to automate the maintenance tasks, but you can run themmanually on demand
using Database Manager and Microsoft SQL Server Management Studio.

The following table shows the default database maintenance task schedules for Standalone
WinPM.Net systems:

Database Task Enabled Trigger Time

ApplicationModules Backup Yes Daily at 01:30

ApplicationModules Maintenance Yes Daily at 03:30

ApplicationModules Trim Yes Daily at 02:30

ION_Data Archive* No** Annually, on Jan 3 at 01:00

ION_Data Backup Yes Weekly, Fridays at 00:00

ION_Data Maintenance Yes Daily at 02:00

ION_Data Size Notification*** Yes Daily at 03:00

ION_Network Backup Yes Daily at 01:00

ION_Network Maintenance Yes Daily at 07:30

ION_SystemLog Maintenance Yes Daily at 07:05

ION_SystemLog Trim Yes Daily at 04:00

* TheWinPM.Net archive task does not trim the database, it only copies data to the archive.
** You need to edit the Windows user account settings before enabling the archive task. See the
Note on the ION_Data archive task for more details.
*** Size Notification is only used for systems with SQL Server Express, which has a maximum
database size limit of 10 GB.

For more information on the default task settings see Default maintenance task settings.

Managing database maintenance tasks for Standalone WinPM.Net systems

In Standalone systems, the database maintenance tasks are pre-configured and scheduled to run
automatically by default. The scheduling and execution of the tasks is done with Task Scheduler
in Windows. The database interaction specific steps of the tasks are defined as Windows



PowerShell scripts.

Note on the ION_Data archive task:

NOTE: The archive task for the ION_Data database is disabled by default. The Windows user
account that is used to run this task must have a sysadmin server role in the SQL Server
database server. The Windows user account that is used by default, IONMaintenance, does not
have a sysadmin server role. To enable and run the scheduled archive task successfully, you
need to add the sysadmin role to IONMaintenance, or change the user account that is used to
run this task to an account with sysadmin role. See Database maintenance account
requirements for more information on account requirements.

To edit the task schedule settings (enable or disable tasks, set trigger times):

NOTE: The database maintenance tasks in Task Scheduler are configured to run using the
IONMaintenanceWindows user account. To save any changes to the task settings in Task
Scheduler, you need to enter the password for the IONMaintenance account. See Using
IONMaintenance for database maintenance tasks for information on where to find the password.

1. On the WinPM.Net application server, open Task Scheduler in Windows.

2. In the Task Scheduler Library, open the Siemens Industry >WinPM.Net folder to see the
configured database maintenance tasks.

3. Edit the tasks as required:

a. To enable or disable a task, select it and use the Actions pane in Task Scheduler.

b. To edit task settings, double-click a task and make the desired changes in the Job
Properties dialog box.

4. (Optional) Select Enable All Tasks History in the Actions pane in Task Scheduler. This
turns on event recording for the scheduled tasks, which is useful for auditing and
troubleshooting.

5. Close Task Scheduler.

To edit the task script settings (change backup and archive location, set the data to keep on trim,
size notification threshold):

1. On the WinPM.Net application server, open the
...\WinPM.Net\config\cfg\DbScheduledTasks\Support\Configuration.ps1

script file in a text editor.

2. Change the values of the variables in the script file for the settings you want to change. The
following settings can be customized:

NOTE: Follow the instructions in the script file on formatting and syntax.
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Setting Variable Default Value Comments

Backup folder
location $locationForBackupFiles

...\
WinPM.Net
\Database\Backup

Sets the folder to which the database
backups are saved. The backup script will
create the following subfolders in this
location:
...\Data for ION_Data
...\Network for ION_Network
...\SystemLog for ION_SystemLog
...\Applications for ApplicationModules
NOTE: IONMaintenance needs Read and
Write permissions on this folder.

Archive folder
location $locationForArchiveDBFiles

...\
WinPM.Net
\Database\Archive

Sets the folder to which the database
archives are saved.
NOTE: IONMaintenance needs Read and
Write permissions on this folder.

Data to keep when
trimming $diagnosticsDaysToKeep 30 Sets how many days' worth of data is left

in the database after trimming.

Database size
(max)

$maximumDatabaseSizeIn
Gigabytes 9

Sets the maximum database size. This
value is used by the size notification task
to assess what percentage of database
space has been used.
The maximum size for a SQL Express
database is 10GB. The maximum size in
the script is set to 9GB to allow for a 1GB
warning buffer before the database stops
logging data.

Database size
notification limit

$databaseSizeNotification
ThresholdPercentage 85 Sets the threshold for when a database

size notification will be issued.

3. Save the script file changes and close the text editor.

Database Manager
Use Database Manager to manually perform operations on the WinPM.Net databases.

NOTICE
LOSS OF DATA
• Back up the database at regular intervals.
• Back up the database before upgrading or migrating the system.
• Back up the database before trimming it.
• Back up the database before making manual database edits.
• Verify correct database behavior after making database or system changes.

Failure to follow these instructions can result in permanent loss of data.

NOTE: Database Manager does not include manual database operations on the Application
Modules database (ApplicationModules). In a disaster recovery situation or when directed by
Technical Support, the Application Modules database can be restored by using the Restore
database function in the SQL Server Management Studio. See Restoring a database for further
information about this operation. WinPM.Net databases can be restored using the same
process.

For information on database maintenance tasks in WinPM.Net, see Database maintenance.



Prerequisites

The following user prerequisites need to be met to work with Database Manager and database
functions through SQL Server Management Studio:

• For Database Manager: Since Windows authentication is used to access the SQL Server
databases, the user needs to be a member of the sysadmin SQL Server role, which is set in
SQL Server Management Studio.

• For most database functions available in SQL Server Management Studio: The user needs to
be a member of the sysadmin SQL Server role.

NOTE: If the Windows user that you used to log into the system is not a member of the sysadmin
role, and you want to run Database Manager, you can do so without logging out by completing
the following steps:

1. Navigate to the system\bin folder in the product's install location.

2. Locate DatabaseManager.exe.

3. Click the EXE file name to highlight it, then press Shift+Right-click to open the menu.

4. Click Run as different user to open the Windows Security dialog.

5. In the User name field, type a user name that has the sysadmin role, then type the
password for that user.

6. ClickOK to open Database Manager.

Database Manager interface
To access Database Manager, start Management Console then click Tools > Database
Manager.

Note that the Windows user running Database Manager needs to be a member of the sysadmin
SQL Server role.

Expand the items in the navigation tree to display the Databases for each instance.

Note that scheduled jobs are available only in Windows Task Scheduler. For further information,
see Database maintenance.
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A
SQL Server
Instance

B Databases C
Options
menu

D
Show
Archives

SQL Server instance

The default SQL Server instance that the product uses for its databases is
COMPUTERNAME\INSTANCE, where COMPUTERNAME is the name of the server, and INSTANCE is
the SQL Server instance used with the product.

Databases

The Databases section lets you view information about the databases or perform manual actions
on the databases.

For information on the manual actions you can perform, see Manual actions.

Viewing Database Properties
To view the properties of a particular database, right-click that database and select Properties.
The properties are:

• Size: The current size of the database.

• Primary File Location: The file path for the primary database (.mdf) file.

• Transaction Log Location: The file path for the transaction log (.ldf) file.

• Creation Date: The date and time when the database was created.

• Last Backup Date: The date when the last backup was performed.

• Disk Space Available: The amount of free space available on the disk where the database
resides.



• Server Version: The type and version of the SQL Server instance that is hosting the
database.

Show archives

Select this check box (lower left-hand corner) if you want the list under Databases to include all
archived databases along with the live databases. After Show Archives is selected, you can
upgrade archived databases or view the properties of the archived databases.

Clear the Show Archives check box to hide the archived databases from view. This also
prevents the database actions from being performed on database archives.

Manual actions
The following sections provide information on the manual actions that you can use to manage
your databases.

To perform an action manually, do one of the following:

• Right-click Databases and select the action from the menu, or

• Right-click the specific database and select the action you want to perform from the pop-up
menu.

When you right-click Databases and select an action, a dialog specific to that action opens. The
databases listed in the dialog are those to which the action applies.

When you right-click a specific database, only the actions that apply to that database appear in
the menu and the database is selected by default in the dialog for the action.

Archive
The Archive action creates an archive of the selected database.

Before proceeding, ensure that you have write access to the archive directory location.

1. Right-click Databases or ION_Data and select Archive to open the Database Archive
dialog. If necessary, select the database that you want to archive.

2. Select the directory where the archive will be saved.

For standalone environments:

a. In Save archive to, click the browse button to select the directory where the archive
will be saved.

...\WinPM.Net\Database\Archives\Data is the default directory for the saved
archive, but you can specify another local directory.

b. (Optional) Specify a different local directory.

NOTE: You can only save an archive to a directory on the local machine, not to a
location on the network.

c. (Optional) Edit the default archive filename to follow your naming conventions.

NOTE: The database name is restricted to characters A-Z, a-z, 0-9, and _
(underscore).
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For distributed environments:

a. In Save archive to, enter an existing directory path on the server and a valid filename
for the archive.

For example: C:\Archives\ION_Data_January.mdf. The path – in the example
C:\Archives – must exist on the Database Server.

NOTE: The database name is restricted to characters A-Z, a-z, 0-9, and _
(underscore).

3. Select the data types that you want to archive.

4. Specify the date range of the data that you want to archive. For Start, select The beginning
of the database or select Date and enter a date and time. Enter a date and time for End
Date.

5. Under Trim after archive select whether or not you want to remove archived data from the
database.

You need to select The beginning of the database for the start date range for trimming the
live database, otherwise the Trim after archive option is disabled.

6. ClickOK.

The Progress field displays the current progress of the archive process. If a manual archive does
not succeed, a message appears and the Database Archive dialog remains open with theOK
button grayed out — examine the Progress field to discover where the process did not succeed.
If the archive is successful, the dialog closes automatically.

Export Registry Setting
The Export Registry Setting action exports settings to a registry (.reg) file. This is useful if you
need to set up client computers in a system where the primary server’s database settings (server
instance name and database name) are customized. After you export the settings to the registry
(.reg) file, you can import that registry file on the client computer.

1. Right-click Databases and select Export Registry Setting to open the Database Registry
Key Export dialog.

2. Type the path and filename for the file or click the browse button to specify the location
for the saved the database registry key.

The directory ...\WinPM.Net\config\cfg\ is the default save location for the exported
database registry key.

3. ClickOK.

New ION_Data Database
The New ION_Data Database action creates a new, blank version of the ION_Data database.

1. Right-click Databases and select New ION_Data Database to open the New Historical
Database dialog.

2. Type a name for your new database.



NOTE: Do not name it “ION_Data” as this is the default name for the existing ION
database. Database names are restricted to characters A-Z, a-z, 0-9, and _ (underscore).

3. Click the browse button to specify a location for the database.

4. ClickOK.

Trim

The Trim action removes data from a database.

NOTICE
LOSS OF DATA
• Back up the database at regular intervals.
• Back up the database before upgrading or migrating the system.
• Back up the database before trimming it.
• Back up the database before making manual database edits.
• Verify correct database behavior after making database or system changes.

Failure to follow these instructions can result in permanent loss of data.

1. Right-click Databases, ION_Data or ION_SystemLog and select Trim to open the Trim
Database dialog.

2. Select the database you want to trim from the Database to trim list.

3. Under Trim Range, specify the date range of data you want to trim (for the ION_Data
database) or set the maximum data age in days (for the ION_SystemLog database).

4. For the ION_Data database, select the data types you want to trim (Data Records,
Waveforms, Events) in the Data Types section. You can select any combination of data
types to trim.

5. ClickOK. A message appears to notify you that the selected data will be removed. Click Yes
to continue or No to cancel.

Upgrade Database

The Upgrade Databases action upgrades the selected database to the latest database schema.

1. Right-click Databases and select Upgrade Databases to open the ION Database
Upgrade dialog.

The WinPM.Net installer automatically upgrades your databases with the new database
schemas when you install WinPM.Net on an existing server. If you install the latest version
of the product on a different server so that you can manually copy older database files to the
new computer, you can run this action on the older databases (that is, on the ION_Data,
ION_SystemLog, and ION_Network databases, and archives) to upgrade them with the new
schema.

2. Select the database in the list that you want to upgrade and clickOK.
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Restoring a database

You can restore a database from a backup by logging in to SQL Server Management Studio as a
user with syadmin access authority for the Restore Database function. (Database backups are
specified as a scheduled job in Windows Task Scheduler. See Database maintenance for more
information.)

Restoring the latest database
Complete the following to restore a database from the latest backup:

1. Stop all WinPM.Net services.

2. Open SQL Server Management Studio, enter your password if required and click
Connect to access your SQL Server.

3. In theObject Explorer pane on the left, expand Databases, right-click the database you
want to restore and click Tasks > Restore > Database to open the Restore Database
dialog.

4. Under Source, select Database and click the database you want to restore in the dropdown
list if it is not already selected.

5. Under Backup sets to restore, select the checkbox in the Restore column for the
database you want to restore.

6. ClickOptions in the Select a page pane on the left.

7. On theOptions page:

Under Restore options, selectOverwrite the existing database (WITH REPLACE).

For Recovery state, select RESTORE WITH RECOVERY from the dropdown list.

RESTORE WITH RECOVERY is described as Leave the database ready to use by
rolling back uncommitted transactions. Additional Transaction logs cannot be
restored.

8. ClickOK to begin the restore operation.

A message indicates that the database has been restored successfully. If the restore
operation is not successful, the database reverts to its original state.

NOTE: After you restore the database, you need to assign its ownership to the ION user as
follows:

a. In SQL Server Management Studio, right-click the restored database and click
Properties in the menu to open the Database Properties dialog.

b. Click Files under Select a page.

c. Click the button on the right of theOwner field to open the Select Database Owner
dialog.

d. Type ION in the field labeled Enter the object names to select and click Check
Names to adjust the format of your entry to [ION].

e. ClickOK to update the owner of the database.



f. ClickOK to close the Database Properties dialog.

9. Restart all WinPM.Net services.

Restoring a specific database
Complete the following to restore a specific database:

1. Repeat steps 1 through 3 from Restoring the latest database above.

2. Under Source, select Device and click Browse to open the Select backup devices dialog.

3. Select File in Backup media type list if it is not already specified and then click Add to open
the Locate Backup File dialog.

4. Navigate to and select the backup file you want to restore and clickOK.

5. Verify that the file referenced in the Specify Backup dialog is the one you selected and click
OK to return to the Restore Database dialog.

6. Under Select the backup sets to restore, select the checkbox in the Restore column for
the database you are restoring.

7. ClickOptions in the Select a page pane on the left.

8. On theOptions page:

Under Restore options, selectOverwrite the existing database (WITH REPLACE).

Under Recovery state, select RESTORE WITH RECOVERY from the dropdown list.

RESTORE WITH RECOVERY is described as Leave the database ready to use by
rolling back uncommitted transactions. Additional Transaction logs cannot be
restored.

9. ClickOK to begin the restore operation.

A message indicates that the database has been restored successfully. If the restore
operation is not successful, the database reverts to its original state.

NOTE: After you restore the database, you need to assign its ownership to the ION user as
follows:

a. In SQL Server Management Studio, right-click the restored database and click
Properties in the menu to open the Database Properties dialog.

b. Click Files under Select a page.

c. Click the button on the right of theOwner field to open the Select Database Owner
dialog.

d. Type ION in the field labeled Enter the object names to select and click Check
Names.

The format of your entry changes to [ION].

e. ClickOK to update the owner of the database.

f. ClickOK to close the Database Properties dialog.

10. Restart all WinPM.Net services.
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Accessing the ION Database with 3rd-party applications
The following example uses Microsoft Excel 2007 to retrieve data from the ION_Data database.

NOTE: The database uses Universal Coordinated Time (UTC) time. When you import data into
Excel, the Clock module’s Time Zone Offset register for the meter is applied.

1. To create a database query in Excel, click Data > From Other Sources > From Microsoft
Query.

2. To create a new data source, select <New Data Source> from the list and clickOK.

3. Type the name you want to give the data source. Once you type a name, the list of drivers
for the database type becomes available. Select <SQL Server> from the list. Click Connect.

4. Choose your server from the list. Provide your LoginID and Password and clickOK. Select a
default table for your data source (optional). ClickOK to continue.

5. Select the source name you created and clickOK.

6. After you have selected the data you want to view, theQuery Wizard opens. Use this to
filter and sort the data.

7. Follow the steps in theQuery Wizard to add data to the spreadsheet.

Deactivating alarms
Active alarms can continue to appear in the Alarms viewer if, for example, an alarm dropout has
not been configured, or a device has been removed from the network after an alarm was issued.
In such cases you can use the Deactivate Alarms utility to remove these permanently active
alarms from the Alarms viewer.

WARNING
INACCURATE DATA RESULTS
• Do not incorrectly configure the software or the devices.
• Do not base your maintenance or service actions solely on messages and information
displayed by the software.

• Do not rely solely on software messages and reports to determine if the system is
functioning correctly or meeting all applicable standards and requirements.

• Consider the implications of unanticipated transmission delays or failures of
communications links.

Failure to follow these instructions can result in death, serious injury, equipment
damage, or permanent loss of data.

To use the Deactivate Alarms utility:

1. OpenManagement Console and select Tools > Deactivate Alarms to open the dialog.

2. Select a date for the Show Active Alarms older than field if you want to change the default
date.



3. Click Load Active Alarms to display a list of the active alarms that are older than the date
specified.

4. Use the Select column to select the alarms that you want to set to an inactive state. You can
also click Select All to select all of the alarms displayed in the grid. Use Select None to clear
the selection of any alarms listed.

5. Click Set Selected Alarms to Inactive.

The Active column displays N for all alarms set to the inactive state.

6. Click Done to close the Deactivate Alarms dialog and then close Management Console.

When you log in toManagement Console again and open the Deactivate Alarms dialog,
the number of alarms shown in the Alarms Displayed field matches the number in the
Alarms Displayed field in the All Active Alarms view in the Alarms application. (The
Alarms application is available in the Web Applications component.)

Device Type Editor
NOTE: The Device Type Editor replaces the Modbus Device Importer (MDI) tool that was
available in older versions of the software.

Use Device Type Editor to create device drivers for Modbus and OPC devices, in WinPM.Net, for
which pre-configured drivers or downloadable add-on drivers do not exist . You can also edit
existing Modbus and OPC device drivers with Device Type Editor.

Device drivers are called Device Types in WinPM.Net.

NOTE: Before creating a new device type with the Device Type Editor, check if it is available as a
pre-configured device type or as a downloadable add-on.

NOTE: The device types you can create with the Device Type Editor are limited to reading
numeric and Boolean data from the device, and writing simple 16-bit values to the device. These
device types cannot access complex data such as historical logs, event logs, or waveform
captures.

NOTE: Drivers created with the Device Type Editor require mid-range (M) type device licenses.
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WARNING
INACCURATE DATA RESULTS
• Do not incorrectly configure the software or the devices.
• Do not base your maintenance or service actions solely on messages and information
displayed by the software.

• Do not rely solely on software messages and reports to determine if the system is
functioning correctly or meeting all applicable standards and requirements.

• Consider the implications of unanticipated transmission delays or failures of
communications links.

Failure to follow these instructions can result in death, serious injury, equipment
damage, or permanent loss of data.

WARNING
UNINTENDED EQUIPMENT OPERATION
• Do not use the software to control time-critical functions.
• Do not use the software to control remote equipment without proper access control and
status feedback.

Failure to follow these instructions can result in death, serious injury, or equipment
damage.

Creating a Modbus Device Type
AModbus device type translates between the register based data structure on the Modbus device
and the ION based data structure in WinPM.Net.

When you create the device type with the Device Type Editor, you first define the Modbus
registers that you want to access on the device, and then you map these registers to ION
managers, modules, and registers. You can enter the Modbus register information manually in the
Device Type Editor user interface, or use Microsoft Excel to define the register list and then copy
and paste it into the Device Type Editor. The mapping of Modbus to ION registers is done by
dragging Modbus registers onto ION registers, or the reverse, using the mouse pointer.

Prerequisites

To create a device type for a device, you need to know the details of its Modbus register map. At a
minimum, you need the Modbus addresses, data formats, and possible scaling values for the
measurements you want to access on the device. You can get this information from the device
documentation or the device manufacturer.

NOTE: Before creating a new device type with the Device Type Editor, check if it is available as a
pre-configured device type or as a downloadable add-on.



References

See the following references for information on how to use the Device Type Editor or information
related to Modbus register definitions:

• Device Type Editor User Interface

• Configuring Logging and Calculation User Interface

• Modbus Data Formats

• Modbus Register Properties

• Measurement Tree

To create a Modbus device type:

1. In Device Type Editor, click File > New > Modbus Device Type to open a NewMapping
template.

2. Enter the Modbus register information into the Modbus Map table in the right display pane, in
one of two ways:

Add each Modbus register manually in the Device Type Editor, using the available
editing controls (right-click to open the context menu).

Use Microsoft Excel to define the register list, copy it, and paste it into the Modbus Map
table.

NOTE: The register list columns in the Excel sheet must match the column content and
positions in the Device Type Editor Modbus Map table. Confirm that the format entries
match one of the supported Modbus Data Formats and that there are no spelling
mistakes, such as added space characters or different capitalization.

3. Map each Modbus register in the Modbus Map to a measurement in the Measurement Tree
in the left pane. To see the measurements in the tree, expand the managers and modules,
for example Current > Phase Current > Current A,B,C, ... . Map the registers in one of two
ways:

Using the mouse, drag the measurement you want to map in the Measurement Tree
onto the corresponding measurement in the Modbus Map.

Using the mouse, drag the Modbus register you want to map in the Modbus Map onto
the corresponding measurement in the Measurement Tree.

NOTE: If you cannot find a suitable measurement in the Measurement Tree, add a new
manager, module, and register to represent this measurement. To do this, right-click any of
the existing managers in the Measurement Tree and choose the appropriate menu
options.

4. Configure the device type name and template name.

a. In the Measurement Tree, click Factory Information > Factory 1 > FAC1 Device
Type to open the String Register Details dialog for this register. In String Register
Details, enter a device type name in the Value box. This name will be visible in the
Management Console when you select a device type for a new device. Choose a name
that identifies the device, but does not match any of the existing device types.
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Example: For a device called "PM123", you could use a device type name of "DTE_
PM123". The device type name does not have to include DTE, but it is a good practice to
choose a string that identifies this device type as a DTE type.

b. In the Measurement Tree, click Factory Information > Factory 1 > FAC1 Template to
open the String Register Details dialog for this register. In String Register Details, enter
a template name in the Value box. This name is used to match your new device type
with a default Vista diagram, if you choose to create such a diagram. The template name
should include the device type name followed by a version number that represents the
version of your new device type.

Example: For a device type called "DTE_PM123", you could use a template name of
"DTE_PM123_V1.0.0".

5. (Optional) Click Tools > Clean Measurement Tree to remove any Measurement Tree
elements that have not been mapped to Modbus registers. This makes it easier to find the
relevant measurements in the Measurement Tree in Vista or OPC clients for example.

6. Click File > Save, to save the new device type.

Related topics
• Creating a Modbus Device Type

• Editing a Modbus Device Type

• Adding Software Logging to a Modbus Device Type

• Installing a Device Type on the System

Editing a Modbus Device Type
You can use the Device Type Editor to modify existing Modbus device types. This includes your
own, as well as factory types, which means pre-configured and downloadable add-on device
types. The factory device types have been designed and tested for compatibility with the devices
and the WinPM.Net software. If you see a need to modify a factory device type, save the modified
type under a new name that does not match any of the factory device type names. This ensures
that you can identify this type as custom and it prevents it from being overwritten during a system
upgrade.

References

See the following references for information on how to use the Device Type Editor or information
related to Modbus register definitions:

• Device Type Editor User Interface

• Configuring Logging and Calculation User Interface

• Modbus Data Formats

• Modbus Register Properties

• Measurement Tree

To edit a Modbus device type:



1. In Device Type Editor, click File > Open, find and select the device type you want to edit,
and clickOpen.

2. Modify the Modbus Map registers, the Measurement Tree mappings, or the software logging
to meet your needs.

See Creating a Modbus Device Type for details on how to perform these tasks.

3. Click File > Save, to save the modified device type under the same name. Click File > Save
As, to save the modified device type under a new name.

Related topics
• Creating a Modbus Device Type

• Editing a Modbus Device Type

• Adding Software Logging to a Modbus Device Type

• Installing a Device Type on the System

Adding Software Logging to a Modbus Device Type
The Modbus device types you create with the Device Type Editor are limited to reading numeric
and Boolean data from the device. These device types cannot access complex data such as
historical logs, event logs, or waveform captures. However, it is possible to automatically log the
measured values in WinPM.Net after they are read from the device. In addition to logging the
measured values, WinPM.Net can also calculate and log average, low, and high values for these
measurements.

NOTE: The data logs are timestamped with the date and time at which the software logs the
value, not the date and time the measurement was taken on the device. Device communications
and system delays determine the time delay between when the measurement is taken by the
device and when it is logged by the software.

To add software logging:

1. In Device Type Editor, open the Modbus device type for which you want to add logging.

2. Click Tools > Configure Software Logging to open the Configure Logging and Calculation
dialog.

3. In Configure Logging and Calculation, select the measurements you want to log and
calculate, and set the logging intervals.

NOTE: Only numeric output registers can be calculated and logged. All other types of
registers (for example, enumerated) do not appear on the Configure Logging and
Calculation screen.

See Configuring Logging and Calculation User Interface for information on the controls and
options available in the user interface.

4. ClickOK to save the changes.
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Related topics
• Creating a Modbus Device Type

• Editing a Modbus Device Type

• Adding Software Logging to a Modbus Device Type

• Installing a Device Type on the System

Creating an OPC Device Type
An OPC device type translates between the tag based data structure on the OPC server and the
ION based data structure in WinPM.Net.

When you create the device type with the Device Type Editor, you first define the OPC tags that
you want to access on the server, and then you map these tags to ION managers, modules, and
registers. You can enter the OPC tag information manually in the Device Type Editor user
interface, or use Microsoft Excel to define the tag list and then copy and paste it into the Device
Type Editor. The mapping of OPC tags to ION registers is done by dragging tags onto ION
registers, or the reverse, using the mouse pointer.

NOTE: The software logging of values is not available for OPC device types.

Prerequisites

To create a device type for an OPC server, you need to know the details of its tag list. You can get
this information from the OPC server documentation or the OPC server vendor. You can also get
the tag list by browsing the OPC server with an OPC client such as the OPC Test Client we ship
with WinPM.Net. You can find the OPC Test Client, OpcTestClient.exe, in
...\WinPM.Net\system\bin\

References

See the following references for information on how to use the Device Type Editor or information
related to OPC tag definitions:

• Device Type Editor User Interface

• Measurement Tree

• OPC Tags

To create an OPC device type:

1. In Device Type Editor, click File > New > OPC Device Type to open a NewMapping
template.

2. Enter the OPC tag information into the OPCMap table in the right display pane, in one of two
ways:

Add each tag manually in the Device Type Editor, using the available editing controls.

Use Microsoft Excel to define the tag list, copy it, and paste it into the OPCMap table.

NOTE: The tag list columns in the Excel sheet must match the column content and
positions in the Device Type Editor OPCMap table. .



NOTE: When entering a tag, only specify the tag name, with a leading period (.), do not
include the OPC server or device name. For example, for the tag
Opcda://Server/OpcDa.1.Channel_1.Powers.Real_Power enter
.Powers.Real_Power as the tag name in the OPCMap.

3. Map each OPC tag in the OPCMap to a measurement in the Measurement Tree in the left
pane. To see the measurements in the tree, expand the managers and modules, for
example Current > Phase Current > Current A,B,C, ... . Map the tags in one of two ways:

Using the mouse, drag the measurement you want to map in the Measurement Tree
onto the corresponding tag in the OPCMap.

Using the mouse, drag the OPC tag you want to map in the Modbus OPCMap onto the
corresponding measurement in the Measurement Tree.

NOTE: If you cannot find a suitable measurement in the Measurement Tree, add a new
manager, module, and register to represent this measurement. To do this, right-click any of
the existing managers in the Measurement Tree and choose the appropriate menu
options.

4. Configure the device type name and template name.

a. In the Measurement Tree, click Factory Information > Factory 1 > FAC1 Device
Type to open the String Register Details dialog for this register. In String Register
Details, enter a device type name in the Value box. This name will be visible in the
Management Console when you select a device type for a new device. Choose a name
that identifies the OPC server, but does not match any of the existing device types.

Example: Use "OPC_ABC" as the device type name, where ABC identifies the server.

b. In the Measurement Tree, click Factory Information > Factory 1 > FAC1 Template to
open the String Register Details dialog for this register. In Edit String Register, enter a
template name in the Value box. This name is used to match your new device type with
a default Vista diagram, if you choose to create such a diagram. The template name
should include the device type name followed by a version number that represents the
version of your new device type.

Example: For a device type called "OPC_ABC", you could use a template name of
"OPC_ABC_V1.0.0".

5. (Optional) Click Tools > Clean Measurement Tree to remove any Measurement Tree
elements that have not been mapped to OPC tags. This makes it easier to find the relevant
measurements in the Measurement Tree in Vista or an OPC client for example.

6. Click File > Save, to save the new device type.

Related topics
• Creating an OPC Device Type

• Editing an OPC Device Type

• Installing a Device Type on the System
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Editing an OPC Device Type
You can use the Device Type Editor to modify existing OPC device types.

References

See the following references for information on how to use the Device Type Editor or information
related to OPC tag definitions:

• Device Type Editor User Interface

• Measurement Tree

• OPC Tags

To edit an OPC device type:

1. In Device Type Editor, click File > Open, find and select the device type you want to edit,
and clickOpen.

2. Modify the OPC tags or the Measurement Tree mappings to meet your needs.

See Creating an OPC Device Type for details on how to perform these tasks.

3. Click File > Save, to save the modified device type under the same name. Click File > Save
As, to save the modified device type under a new name.

Related topics
• Creating an OPC Device Type

• Editing an OPC Device Type

• Installing a Device Type on the System

Installing a Device Type on the System
Before a device type can be used by WinPM.Net to communicate with a device, it must be
installed on the system. Follow the steps below to install a new device type or a modified device
type.

To install a new or modified device type:

1. In Device Type Editor, click Tools > Install Device Type, to open the Device Type Installer.

2. In Device Type Installer, specify the device type you want to install.

(Optional) Specify a diagram and icon to be used for this device type in the Vista and
Diagrams applications if you want to use the default diagram feature.

(Optional) Specify a measurement extension file for exposing the device measurements
through the OPC server, if desired.

3. Check the Device Type Name and Template. If you need to make changes, exit the Device
Type Installer, open the device type for editing in the Device Type Editor and correct the
names, then run the installer again.

4. Select the Protocol for your device type,Modbus orOPC.

(Optional) Select Ethernet Support if the device has Ethernet communication capabilities.

5. Click Install Device Type, to install the device type on the system.



Related topics
• Creating a Modbus Device Type

• Editing a Modbus Device Type

• Adding Software Logging to a Modbus Device Type

• Creating an OPC Device Type

• Editing an OPC Device Type

• Installing a Device Type on the System

Diagnostics Viewer
Diagnostics Viewer is a tool you can use to troubleshoot network communications problems and
related network errors.

Starting Diagnostics Viewer
1. Start Management Console and log in.

2. Click Tools > System > Diagnostics Viewer.

TIP: For instructions on using filtering, sorting, column selection, and pin/unpin to customize the
Diagnostics Viewer display, see Customizing and navigating interface displays.

Navigation pane
Diagnostics information is grouped as follows:

• Service Diagnostics: Contains diagnostics information for certain services (WinPM.Net
Network Router Service, WinPM.Net Site Service andWinPM.Net Log Inserter Service).

• Communication Diagnostics: Contains diagnostics information for the sites, hardware
devices, and software nodes.

Select an item in the navigation pane to display its diagnostics information.

If you add a new device to the system while Diagnostics Viewer is open, you can refresh the tree
view to display the new device by collapsing then expanding the root node of the tree.

Diagnostics Information pane

The diagnostics information pane displays detailed data about the state of your power monitoring
system and devices.

Service Diagnostics
Service Diagnostics records communication problems and similar events occurring with the
product's software components.

Communication Server diagnostics
Information about the communications server is arranged in these tabs:

• Console Messages lists all WinPM.Net Network Router Service andWinPM.Net Site
Service console messages for the current session.
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TIP: The blank area below the Description column header is a dynamic filter field. Type the
wildcard character (*) in front of the text you want to search (for example, to display only
messages prefixed with WARNING, type *warning). The diagnostics information pane
automatically displays only those records that match the text you typed in the box.

• Connection Status displays the current status of the software components connected to
Network Router.

• Tree States displays the ION tree status of all nodes (hardware devices and software nodes).

Log Inserter diagnostics

The Log Inserter diagnostics information pane is split into two sections. The top section (Select
Nodes pane) contains the available nodes, while the bottom section contains the node details.

Select nodes to display

In the Select Nodes pane, select the check box beside a node to display its diagnostics
information. Clear the check box to hide that node’s diagnostics information.

TIP: If there are many nodes and you want to display only a few of them, right-click the Select
Nodes area then click Clear All. Select only the nodes you want to display. To display all the
nodes again, right-click the Select Nodes area and click Select All.

Node details
The node details are organized in these tabs:

• Node Information provides diagnostics associated with the communication status of each
selected node. If the Log Inserter is not configured to gather data from a given node, it does
not appear in the list in the Node column. If the Log Inserter is configured to automatically
gather information for a node, but that node has not yet been processed, it does not initially
appear in the list. Once information becomes available, the node appears (if it has been
selected).

• Node Performance provides per-node performance summary information.

• Log Performance provides performance information on a per log basis.

The following table summarizes the columns on the Node Information tab:

Column Description

Node The name of the device, VIP, or Log Inserter.

DeviceType
The device type of the associated node that is returned by the device
itself. The Log Inserter uses this to detect device swap outs.

SerialNumber
The serial number of the device that is returned by the device. The
Log Inserter uses this to detect device swap outs.

Configured Polling
Interval (s)

The requested polling interval in effect. It can be configured either
from the log upload control or from the customWindows Registry
value. All of the nodes for which polling is disabled are identified with
Polling Disabled in this column.



Column Description

Average Update Interval
(s)

A weighted average time between polled results for the device. The
most recent interval accounts for 20% of the value, and the previous
average accounts for the remainder. If the value deviates from the
average by more than 30s, then the old average is discarded and the
current interval is used. By default, the expected value for devices
that support logs is the Configured Polling Interval (s) value. The
expected value for devices that do not support logs is 60 seconds.
If the Log Inserter is selected but it is not configured to collect data
from its System Log Controller, it appears in the diagnostics and
shows 300s for Average Update Interval. Initially this value is n/a.

Time Since Update (s)
The time in seconds since the last communication with the node. This
time includes polling updates, record uploads, and configuration
loads.
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Column Description

CommStatus

Can be one of the following values:

• alive – The node is communicating.

• late – If a response to a polling program is not received within 3
minutes, the Log Inserter sends a ping. If the ping does not
respond in 10 minutes, the communication status is set to late
and another ping is sent. The system continues pinging every 10
minutes until a response is received.

• expired – If a ping returns before the response for any
preceding request, the original request was lost. The request is
abandoned and the communication status is set to expired. A
request can be lost if a destination Site Server or VIP is shut
down. The state changes from expired when the device
responds to a request.

• timeout – A request to the device timed out. The device is not
communicating.

• site not connected – The site is currently not connected.

• cannot send – An unrecoverable error. The Log Inserter cannot
send a program to the communications subsystem. The Log
Inserter shuts down if Network Router is not running. Restart the
system.

• invalid password – The password entered for this device in
Management Console is invalid.

• password changed – The password for this device has been
changed. Update the password for the device in Management
Console.

• site not responding – The connection is unexpectedly
broken during communication with the device.

• device disabled – The device or its site is not enabled. Note
that Log Inserter automatically removes this node from this list if
the node had been detected by automatic means.

• does not exist – The device is not registered in the system. In
auto-mode, the device eventually disappears from the list unless
it is referenced remotely by a VIP.

• pending – No responses have been processed.

• nack'd – The request was not acknowledged. This could mean
that the Site Server hosting the device is not running.

• validating – Treemon reported that the device is not
responding. A signal is sent to Treemon to validate the state. This
state clears once Treemon (via Validator) establishes



Column Description

communications with the device.

Comments

Under steady-state conditions, this is blank. While the Log Inserter
attempts to upload configuration information, this can contain a string
value indicating that the Tree is in use by another client.
This indicates that the Log Inserter cannot process the device until the
aforementioned client releases it. If the client is ION Designer, it is not
released until the node is closed in Designer or Designer is closed. If
the client's name ends with -not-clean, the node is currently being
evaluated by Treemon/Validator.

AggregateSetupCount
The aggregate setup count of the device. The Log Inserter uses this
to detect configuration changes.

RequestedIONs

The number of ION registers, modules, and/or managers that have
been requested from the tree. The Log Inserter needs to upload
configuration information to determine which logs need to be
processed, which labels should be used for measurement mapping
and source resolution, and which labels to use for event cause and
effects.
The Log Inserter retrieves the currently cached tree from Treemon,
populating as needed by communicating directly with the device. The
tree is locked for the duration of this process, and this prevents
Designer from opening the tree.
If the value is:

• none – No configuration information is currently required. This is
typical in a steady-state condition.

• cache – Only the currently cached configuration is required. This
is typically seen at startup.

• A number – The Log Inserter needs specific information and that
number of ION objects has been explicitly requested.
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Column Description

RequestStatus

The status of the tree requests can include one of the following
values:

• ready – The Log Inserter does not require any configuration
information.

• requesting – The Log Inserter requires configuration
information and is in the process of gathering it. The value in
Request Update Time indicates how long it has been
processing this request.

• retrying – A previous tree request was not successful. (See the
Comments column for the reason.) The request is retried, as
shown by the value in Request Update Time. The amount of
wait time before retrying a request depends on the nature of the
unsuccessful tree request:

Tree in use by another node – 10 seconds.

Tree dirty – 10 seconds.

Not responding – 60 seconds.

Tree request timed out after 10 minutes – 5 minutes.

Comm error – 10 seconds.

Other errors – 5 minutes.

• blocked – The Log Inserter requires configuration information
but all available resources are in use. By default, the Log Inserter
can simultaneously request only up to 2 trees per site and 6 trees
in total. The Request Update Time value indicates how long the
request has been pending.

• processing – The Log Inserter has received the requested ION
objects and is processing them. The Request Update Time
value indicates how long this request has been processed,
including the time during the "requesting" state.

• abandoned – This is the same as the retrying status but the
request of some of the configuration information was not
successful following the successful receipt of some information.
The Log Inserter recovers when it retries the request.

Request Update Time
(s)

The time varies depending on the status of the tree requests
described for RequestStatus.

pID
The program ID of the program used to poll the current position
counters. The Log Inserter now performs its own polling, and as a
result, the entry in this column is not used for diagnostic purposes.

The following table summarizes the columns on the Node Performance tab:



Column Description

Node The name of the device, VIP, or Log Inserter.

Responding

Indicates whether or not the node is responding. For a VIP, this
includes all external nodes connected, directly or indirectly, to the
input of a Recorder. The responding state is used to determine
whether or not the download of the log is caught up.

All Logs Polling
Disabled

Indicates if log upload is disabled for all recorders on the device. A
Yes in the column indicates that log upload is disabled.

TotalLogs

The total number of Data Recorders, Waveform Recorders, Event
Log Controllers, and System Log Controllers that the Log Inserter is
configured to collect data from a given node. Note that when
automatically detecting these modules, this number may change as
the Log Inserter gathers configuration information.

PendingRecords
The total number of records that the Log Inserter has requested from
the node but has not yet received.

OutstandingRecords
The total number of records not yet uploaded based on the last read
position counter on the device and the position of the last uploaded
record, taking into account the maximum depth of each log.

ProcessedRecords
The number of records that have been inserted into the database.
Note that a record typically corresponds to a number of DataLog
entries. The term "record" refers to records at the device level.

Generated Rec. per sec
An estimate of the number of new records being generated per
second.

Retrieved Rec. per sec An estimate of the number of records being uploaded per second.

Avg Retrieval Time (s)
The average round-trip time in seconds taken to retrieve a record
from a device.

Avg Processing Time
(s)

The average time in seconds necessary to insert a record into the
database.

RestoredLogs
The total number of logs that the Log Inserter is configured to gather
information for.

ManagedLogs
The total number from the value in RestoredLogs that is being
monitored by an enabled Log Acquisition Module (LAM).

ConfiguredLogs
The total number from the value in RestoredLogs that are Recorders
and have source inputs or are Event Log Controllers or System Log
Controllers.

ConfirmedLogs
The total number from the value in RestoredLogs for which the
current configuration is known.

NumCaughtUp
The total number from the value in RestoredLogs for which the node
is responding and there are no records outstanding or pending.

The following table summarizes the columns on the Log Performance tab:
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Column Description

Node The name of the device, VIP, or Log Inserter in question.

LogHandle The handle of the Log Register or Event Log Register for this Node.

Responding

Indicates whether or not the node is responding. For a VIP, this
includes all external nodes connected, directly or indirectly, to the
input of a Recorder. This state is used to determine whether or not it is
caught up.

Polling Disabled
Indicates which individual recorders are excluded from polling
requests. A Yes in the column indicates which recorders are
excluded.

PendingRecords

The total number of records that the Log Inserter has requested from
the node but has not yet received. This number includes event
records that have been uploaded but are cached internally pending
configuration information necessary to complete the processing of the
cause and/or effect ION objects.

OutstandingRecords
The total number of records not yet uploaded based on the last read
position counter on the device and the position of the last uploaded
record, taking into account the maximum depth of each log.

ProcessedRecords
The number of records that have been inserted into the database.
Note that a record typically corresponds to a number of DataLog
entries. In this context, "record" refers to records at the device level.

Generated Rec. per sec
An estimate of the number of new records being generated per
second.

Retrieved Rec. per sec An estimate of the number of records being uploaded per second.

Avg Retrieval Time (s)
The average round-trip time in seconds taken to retrieve a record
from a device.

Avg Processing Time
(s)

The average time in seconds necessary to insert a record into the
database.

Restored
This is always yes. If the log is not "restored", it does not appear in the
list.

Managed A Log Acquisition Module (LAM) is enabled that is monitoring this log.

Configured
The log is a Recorder that has source inputs or it is an Event Log
Controller or a System Log Controller.

Confirmed

The latest configuration for the log has been uploaded. For a VIP
Recorder that references external devices, directly or indirectly, the
configuration information includes information from the external
device.

CaughtUp
The node is communicating, the current configuration is known, and
there are no outstanding or pending records. For a VIP, any device on
which the log depends for information must also be responding.



Alarm Service

Alarm Service provides the status of alarms that you configure and enable in the Software Alarms
application.

The information is organized in a grid. The column labels indicate the type of information
provided, such as Rule Name, Alarm Name, Alarm Status, and so on. See the Software Alarms
Help (accessible from the Software Alarms application) for further information about configuring
alarms for multiple sources and measurements.

Log Pipeline Service

The Log Pipeline Service diagnostics provides information on the Log Subsystem Data Pipeline. It
shows a variety of statistics on log collection and insertion performance.

Log Inserter writes log data into a message queue instead of writing it to SQL Server directly.
Another process (the Log Subsystem Router Service) reads the messages from the queue and
writes the data to SQL Server.

Previously, the Log Inserter would wait for database writes to complete before processing the
next piece of data. This effectively limited the rate of data insertion to something that SQL Server
could handle. Writing to MSMQ is much faster: MSMQ can store messages in the queue faster
than Log Inserter can retrieve them from the devices. However the performance of SQL Server
has not changed, which means that data can accumulate in the queue faster than it can be
inserted into the database. Allowing the message queues to become full (they have a limited
storage capacity) results in failure modes that are difficult to handle automatically. To avoid this
scenario we monitor the size of the inbound data message queue and prevent writes when it
contains more than a set number of bytes. If the message queue reaches a specified capacity,
then no future messages will be accepted from LogInserter and the write thread is "put on hold"
until the message queue has dropped below a specified capacity. This ensures that LogInserter
never considers data written that may be missed in the message queue due to over capacity.

The following table summarizes the columns on the Pipeline Status tab:

Column Description

Name
Identifies the message queue (Primary or Secondary) and the type of
data being tracked.

Duration
Total time that the diagnostics have been counted. In practice this
value will be identical for all rows.

Message Count
Number of messages that have been processed from this queue
since the service was started.

Messages Per Minute Number of messages that have been processed in the last minute.

Messages Per Minute
Average

Average of the messages per minute over the last hour (60 samples).

Messages Per Minute
Max

Maximum number of messages per minute over the last hour (60
samples).

Messages Per Second Number of messages that have been processed in the last second.
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Column Description

Messages Per Second
Average

Average of the messages per second over the last minute (60
samples).

Messages Per Second
Max

Maximum number of messages per second over the last minute (60
samples).

Processing Time
Milliseconds Average

Average time taken to process each message (milliseconds).

Processing Time
Milliseconds Max

Maximummessage processing time (milliseconds).

Time Since Last Elapsed time since a message was last processed.

Start Time Utc Time in UTC at which the service was started.

The following table summarizes the columns on theMessage Queues tab:

Column Description

Identity Identity of the message queue.

Queue Type Data or Control

Message Count Number of messages currently in the queue.

Message Kilobytes Size of messages currently in the queue (kilobytes).

Maximum Kilobytes

Maximum size allowed for the queue.  Note that a value of
4294967295.00 (4GB) is the maximum amount of data that the entire
MSMQ service can support.  This effectively indicates that no queue-
specific limit has been defined.

TheMessage Queues tab allows you to inspect messages flowing through the pipeline. Enabling
message capture increases the load on the pipeline so this should not be left activated
indefinitely.

The controls on the top select which messages are written to the table. This filtering only occurs
as the messages arrive at the tab; once a message is displayed in the table it will not be removed
when the Message Type or Source Filtering fields are changed. Rows already in the table may be
filtered by the fields below the header.

The viewer buffers messages as they arrive to avoid locking up the receiving thread. If the buffer
fills (which indicates that messages are arriving faster than the viewer can process them) a
message indicating how many messages were missed will be written to the table.

Communications Diagnostics
Communications Diagnostics provides diagnostics information for sites and devices connected to
the workstation.



Site overview
Diagnostics information for the sites are contained in these tabs:

• Device Summary displays communications statistics for each site.

• NetUser Status displays the number of ION programs currently in the ION Network Router
Service queue (awaiting processing) and the total number of ION programs already
processed.

NOTE: Requests and responses transmitted between the software components are referred to
as “ION programs”.

Site/Device Diagnostics
Diagnostics information for sites and devices are summarized in these tabs:

• Communication Status displays error rates and connection statistics for the selected site or
device. The following information is available from the Communications Status tab:

Column Description

Node The device (or software node) name.

Requests
The number of communications requests transmitted to the
meter.

Responses The number of successful responses received.

Request Ratio
The number of requests sent to the device to fulfil the last client
request. The value is always 1 for ION devices but it varies for
Modbus devices.

Total Errors The total number of communication errors.

Total Err Rate (%) The ratio of Total Errors to Requests.

Sliding Err Rate (%)
The error rate in the last 100 requests. This can indicate a trend in
communications performance.

Time Util (%)
The percentage of the communication channel utilized (serial line
or Ethernet) on the site.

Avg Resp Time (s) Average time in seconds for the meter to respond.

Last Resp Time (s) The last response time, in seconds.

Timeouts
The number of timeouts. A timeout occurs when no data is
received in response to a request.

Bad CRC
The number of bad packets received, that is, those that do not
pass the error-detection checksum.

Incompl. Frm
The number of incomplete packets received, that is, those that
did not have all the expected bytes.

Broken Conn. Number of times the connection was lost to the meters on a site.

Bad Frames The number of received packets that had an internal error.
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Column Description

HWErrors
Number of errors reported by the computer’s communication
hardware.

Misc Errors
Number of other errors that do not fit any of the above
descriptions.

• Site Status displays site statistics such as connection status and totals.

• Polling Status displays the number of programs currently in the WinPM.Net Site Service
queue (awaiting processing) and the total number of programs already processed.

Communication Status vs. Site Status

This section explains the difference between the statistics provided on the Communication
Status tab and those on the Site Status tab.

“Total Errors” in the Communication Status tab is an WinPM.Net Site Service derived statistic,
while “Bad Responses” in the Site Status tab is a client derived statistic.

To explain this difference, consider a situation where a direct site is experiencing timeouts.
Communications with the device is attempted according to two parameters: Connect Attempts
(an advanced site property) andMaximum Attempts Multiple (an advanced device property).
Multiplying the values of these two properties determines the number of attempts made to re-
establish communications with the device.

For instance, if Connect Attempts is set to 1 andMaximum Attempts Multiple is set to 3, the
device will go offline after 3 attempts (that is, 1 x 3).

The “Total Errors” statistic increases by one every timeWinPM.Net Site Service detects a
timeout. However, the “Bad Responses” statistic only increments every time a response is sent
back to a client.

Using the previous example, consider the case where four timeouts occurred and the device went
offline. In this case, “Total Errors” increases by four, while “Bad Responses” only increases by
one. If only two timeouts occurred, “Total Errors” would increase by two, while “Bad Responses”
would not change.

The following information is available from the Site Status tab.

Column Description

Node The device (or software node) name.

Status The device communication status.

Current Attempt
The current number of repeated attempts to communicate with the
device.

Max Attempts
The maximum number of attempts before flagging the device as
offline (Timed-out).

Offline Count The total number of times the device went offline.

Bad Responses The total number of errors sent back to the clients, such as to Vista.



Column Description

Last Response The time when the last response was received.

Last Attempt The last time that a request was sent to the device.

RT Data Reqs
The total number of requests to the device sent by the Real Time Data
Service.

TreeMon Reqs
The total number of requests to the device sent by the TreeMon
service.

VISTA Reqs
The total number of one shot requests to the device sent by a Vista
client (control, label requests...).

LogInserter Reqs
The total number of requests to the device sent by the LogInserter
service.

IONSERVICE Reqs
The total number of requests to the device sent by ION real-time
services.

Note that the last five columns on the Site Status tab are dynamic. That is, the columns are only
shown when requests were sent to the device from aWinPM.Net service or client.

Additional commands
The following sections describe additional display options and shortcut menus available in
Diagnostics Viewer.

Diagnostic Details

In the tabs on the diagnostics information pane, double-click a row to display its Diagnostic
Details screen. This displays the diagnostic information for the selected item only.

Use the Previous and Next buttons to view the details of other rows in that tab of the diagnostics
information pane.

To copy information to the clipboard, select the rows you want to copy, then press CTRL+C.

Diagnostics Information pane shortcut menu options

Right-click the diagnostics information pane to display a shortcut menu. The following table lists
all the commands available (though not all panes in Diagnostics Viewer provide all the commands
listed):

Right-click Option Description

Update Refreshes the information in the diagnostic table.

Reset
Resets the information in the diagnostic table (not available in the
Communications Server Diagnostics display).

Copy All Copies all selected information to the clipboard.
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Right-click Option Description

Auto Scroll

Enabled by default, this option is only available in the Console Messages
tab of the Communications Server Diagnostics display. This option
automatically scrolls and selects the latest console message. Clear this
option to disable scrolling (that is., select and view an older console
message without jumping to the latest one when Diagnostics Viewer
refreshes).

Options
Displays theOptions dialog where you can change the diagnostics
refresh rate. Note that changing the refresh rate frequency can affect the
product's performance.

Event Watcher Manager
The Event Watcher Manager defines events for the “On Event” selection in report subscriptions.
(For more information about report subscriptions, see Creating report subscriptions in the online
help for Reports in the Web Applications component.)

The Event Watcher Manager interface consists of two tabs:

• Event Watchers: An event watcher links a device or group of devices to the conditions
defined in a template.

• Templates: A template defines the conditions that make up an event.

TIP: For instructions on using filtering, sorting, and column selection to customize the Event
Watcher Manager interface, see Customizing and navigating interface displays.

Opening Event Watcher Manager

Open Management Console and select Tools > Event Watcher.

Symbols used in the Updated column

The following symbols are used in the Updated column to display the status of information in a
row:

* Information in the row has been modified since it was last saved.
! Information in the row is inaccurate or incomplete.
+ The row is new since the user or group information was last saved.

Creating a template
Before adding an event watcher, you must have a template that defines the conditions to be
watched. You can use one of the default templates or create your own. Use the Templates tab to
define and edit templates.

Event Watcher Manager comes with default templates that can be modified for specific devices.
Test any changes to the default template to ensure that events are available for selection for
report subscriptions. In cases where a device is not supported by the default templates, you can
create custom templates to define what you need.



To define a custom template:

1. Click New in the top right corner of the tab. A new row appears in the main table for the new
template.

2. Type a name for the template. Type a description for the template if desired.

3. Use the Template Conditions section to set the conditions to be watched. See Using the
Template Conditions section, below.

4. Click Apply to save your changes, clickOK to save your changes and exit Event Watcher
Manager, or click the Event Watchers tab to set up an event watcher.

Using the Template Conditions section
Use this section of the interface to configure the condition the template watches for.

1. Add a condition:

To add a condition from the event log, click Select from Event Log to open the Select
Event Log Lines dialog. To select an event, click on the boxes at the left of the table to
select a check box. Click on the check box again to clear the check mark. ClickOK to
return to the Templates tab.

To add a condition without selecting from the event log, click New. A new row appears in
the table for the new condition.

NOTE: It is recommended that you use Select From Event Log to add conditions. This
helps ensure that the syntax is correct. If the syntax is not correct, the event watcher will
not work. Conditions only appear in the Select Event Log Lines dialog after they have
occurred in the system.

2. Select the parameters you want to include in the condition by selecting or clearing the check
boxes below the Template Conditions table. The available parameters are: Priority, Cause,
Cause Value, Effect, Effect Value. You must include at least one parameter. If you select
multiple parameters, the event watcher only activates when all parameters are met.

The Logic of the Template Conditions

The conditions within a row of the Template Conditions table must all be true for the condition to
be met. For example, if you have a row with a Priority of greater than 220 and an Effect Value of
Disturbance, both of these must be met for the condition to be true. If you have multiple rows in
the table, the condition is met if any of the rows are true. For example, if you have a row with
Priority greater than 220 and a row with an Effect Value of Disturbance, the condition is met if
either of these are true.

Deleting and reverting

To delete a template condition, select the condition from the Template Condition table and click
the Delete button in the Edit <Template> section. To delete a template, select the template from
the main table and click the Delete button in the top right corner of the tab.

To undo changes, click Revert.
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Adding an event watcher
To add an event watcher, you need a template. You can use one of the default templates or define
your own (see Creating a template). Use the Event Watchers tab to define and edit event
watchers.

1. Click New to add a new event watcher. A new row appears in the main table for the new
event. Use the Event Watcher Editing Area to define the event watcher.

2. Type a name for the event watcher.

3. Select the template you want to use from the Template dropdown list.

4. Type a description of the event watcher if desired.

5. From the Devices table, select the devices you want to include in the event watcher. Click
the check boxes to the left side of the devices to select or clear a device.

NOTE: Checking Select All will include any Query Server, Log Inserter or Virtual
Processor instances in the system. It also includes any devices or software nodes added in
the future.

6. Click Apply to save your changes, clickOK to save your changes and exit Event Watcher
Manager, or click the Templates tab to edit the templates.

Deleting and reverting

To delete an event watcher, select the event watcher from the table and click Delete.

To undo changes, click Revert.

Hierarchy Manager
Depending on the number of devices you are currently monitoring, organizing the data coming
from those devices can be a difficult task. The Hierarchy Manager feature allows you to organize
the devices in WinPM.Net by defining their relationships and displaying them in an easy to
understand way. Once these relationships have been created, energy data can be grouped and
summarized, and used by other components of WinPM.Net.

Starting Hierarchy Manager
To use Hierarchy Manager:

1. Open Management Console.

2. Enter an operator-level or supervisor-level access username and password and clickOK.

3. Click Tools > Web Tools > Hierarchy Manager to open the Hierarchy Manager Login
dialog.

4. Enter an operator-level or supervisor-level access username and password and clickOK.

Hierarchy Manager opens using the default hierarchy template.

The hierarchy creation process is dependent on the current template. See the Hierarchy Manager
online help for information regarding this feature. Click the Help link in the top right corner of
Hierarchy Manager to access the information.



License Manager
For additional device or client user support (for example, for Vista clients) in your system, or to
add OPC options, order the appropriate license from Siemens Industry.

When you receive your new license, use License Manager to upgrade the number of supported
devices and client users in your system:

1. Log in to Management Console.

2. Click Tools > License Manager to open the License Manager dialog.

The current product key number, number of devices in the system, and maximum number of
devices supported are listed in the System Info section.

3. Type the new product key in the Product Key field.

4. ClickOK.

The System Info section lists the updated support information from the newly activated product
key. If the new key supports additional features or options, these are made available immediately,
without restarting Management Console.

Logical Device editors
The logical device functionality allows you to assign logical names to output registers on physical
devices, and associate the generic inputs with standard measurements, including WAGES
measurements.

Before you can create a logical device, the physical device that it references must be created. You
can create one or more logical devices from a single physical device, or you can also create a
single logical device from several physical devices.

After you create a logical device, you can view its real-time data in the following components:

• Vista.

• The Diagrams application in the Web Applications component.

CAUTION
INACCURATE DATA RESULTS
• Do not incorrectly configure the software or the devices.
• Do not base your maintenance or service actions solely on messages and information
displayed by the software.

• Do not rely solely on software messages and reports to determine if the system is
functioning correctly or meeting all applicable standards and requirements.

Failure to follow these instructions can result in injury or equipment damage.

Each logical device has a logical device type associated with it. Each logical device type is
defined with a collection of output measurements. The measurements defined by the device type
become the output measurements for instances of that device type, that is, for the logical devices.
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You use the Logical Device Type Editor to create logical device types. See Using the Logical
Device Type Editor for information about viewing, creating, editing, and deleting logical device
types.

The Logical Device Editor in Management Console allows you to configure specific logical
devices by mapping input registers to output measurements that are defined in the associated
device type. See Using the Logical Device Editor for information about creating, configuring,
editing, and deleting logical devices.

Open the Logical Device editor applications from the Toolsmenu in the Management Console.

NOTE: Access to this application or function is controlled by user privileges. See Default User
Access Level Privileges in Web Applications help, and Customizing Access Level
Privileges in User Manager help for details.

Using the Logical Device Type Editor
Use the Logical Device Type Editor to define a collection of output measurements for each logical
device type. Logical device types created with this editor are available for selection in the Logical
Device Editor, where you map input registers to output measurements.

Open the Logical Device Type Editor

1. Start Management Console and log in using an account with supervisor-level access.

2. Select Tools > Logical Device > Logical Device Type Editor.

The top portion of the editor contains a logical device type display grid listing the logical device
types that have been defined. The bottom portion is an edit area where you can modify existing
device types and their measurements, or create new ones.



A Display grid area B Edit area - Summary tab C Edit area - Measurement tab

The display grid area
TheModified column displays one of the following characters indicating a change of status of an
entry:

+ (plus) - a new entry.

* (asterisk) - an existing entry has been modified.

! (exclamation mark) - the entry is incomplete or in error.

The Type Name column contains the names for the defined device types. Type names must be
unique.
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The System Measurements and Custom Measurements columns show the number of
measurements that have been defined for each device type.

The edit area

When a device type is selected in the display grid, the current information for that device type is
displayed in the edit area. The edit area has a Summary tab and aMeasurement tab.

The Summary tab contains the following:

• A Type Name field showing the name of the device type that is selected in the display grid at
the top.

• In theMeasurements area, expand System and Custom to view the measurements defined
for these respective categories. You can expand each list to show all of the measurements
that have been defined for the selected device type.

• A Notes input field that you can use to describe the device type.

TheMeasurement tab contains the following:

• Options that indicate whether to display the measurements with descriptive names or
engineering names.

• An Available Measurements dropdown list that contains category names for the
measurements, such as Air, Current, and Voltage. When you select one of these categories,
only those measurements associated with the selected category appear in the grid.

The default All in the list displays all of the categories and their respective measurements in
the grid.

• An available measurements grid listing the measurements available for selection when you
define a device type. Measurements that are grayed out indicate that they have been added
to the selected device type. Clicking New opens a dialog for defining a new, custom
measurement. An X in the Custom column identifies the entry as a custom measurement.
The Edit and Delete links give you the option to modify or delete custom measurements only.

NOTE: It is recommended that you add a new custommeasurement only if an existing
measurement does not suffice. Factory-defined System Measurements contain
considerable information about their type and usage, which is then used throughout the
system to provide intelligent assistance in Dashboard controls and Report selections. Since
custom measurements do not have this information, their usage may not provide the
expected results.

• AMeasurements For grid that lists the measurements that comprise the device type that is
selected in the display grid area. Use the >> button to add a measurement that you selected
in the list of available measurements to theMeasurements For list for the device type.
Measurements that you select for a device type are grayed out to indicate that they have been
assigned to the device type. Use the << button to remove a selected measurement from the
Measurements For grid. Measurements that are removed are no longer grayed out in the list
of available measurements and they are available for selection.



Note that if you attempt to delete a custommeasurement that has been mapped to any logical
device, a message indicates that the measurement cannot be deleted. You need to unmap
the custommeasurement from the logical devices before you can delete it.

In all grids:

• Each of the columns can be sorted in ascending or descending order when you click on the
column heading.

• When you place your cursor on a column heading, a filter icon appears on the right side of the
heading area. Click this icon to open a list of items that are available for filtering. Click the item
that you want to use as the filter. When you do this, the filter condition displays on the left side
of the status area at the bottom of the grid. Click the X icon in the status area to turn off the
filter.

• The blank area immediately below a column heading is an entry field for filtering on an entry
you type in that area. For example, to filter on a specific name, enter a name under the Name
column to automatically filter the entries in the grid.

• You can drag and drop the grid column headers to rearrange the order of the columns in the
grid.

Creating a new logical device type
Complete the following steps to create a new logical device type:

1. Click New on the top right of the editor.

This clears the Type Name field and resets System measurements and Custom
measurements to 0 (zero) on the Summary tab.

All is selected by default in the Available Measurements list on theMeasurements tab.

2. Enter a device type name in the Type Name field.

The name appears in the logical device type display grid and an ! (exclamation) appears in
theModified column to indicate that the device type entry is incomplete.

3. Click theMeasurements tab to go to the list of measurements that are available for
selection.

4. Locate and click an available measurement that you want to associate with the device type,
then click >> to add it to theMeasurements For list. Repeat this step for each measurement
that you want to associate with the device type.

5. To delete a device type, click the device type in the display grid and click Delete on the top
right of the editor.

Note that Delete is disabled if any logical devices are associated with the logical device
type.

Custom measurements

The following sections describe how to create, modify, or delete custom measurements. Because
factory-defined SystemMeasurements contain considerable information about their type and
usage, custom measurements should only be created in exceptional circumstances, and only with
an understanding of the expected results from their usage.
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CAUTION
INACCURATE DATA RESULTS
• Do not incorrectly configure the software or the devices.
• Do not base your maintenance or service actions solely on messages and information
displayed by the software.

• Do not rely solely on software messages and reports to determine if the system is
functioning correctly or meeting all applicable standards and requirements.

Failure to follow these instructions can result in injury or equipment damage.

Creating a new custom measurement
Complete the following steps to create a new, custom measurement:

1. Click New beside the Available Measurements dropdown list to open the New
Measurement dialog. (You can also edit a new custommeasurement by clicking Edit and
modifying the entries.)

2. Enter a descriptive name and an engineering name for the new measurement in the
respective fields. For example, Voltage A-B Low is the descriptive name, and Vll ab

low is the engineering name.

3. Select the unit of measure from the Units list or add a custom unit of measure by typing it in
the Units field.

Note that the combination of the descriptive name, the engineering name, and the unit of
measure must be unique for each custom measurement.

4. Select a type of information to be measured from theQuantity list.

5. ClickOK to add the measurement.

The new measurement is added as an available measurement in the grid and an X in the
Custom column indicates that it is a custom measurement.

You need to select All or Custom in the Available Measurements list to see the custom
measurement in the grid.

Modifying or deleting a custom measurement
Complete the following steps to modify a custom measurement. Note that you cannot modify or
delete system measurements.

1. Go to theMeasurements tab of the Logical Device Type Editor.

2. Select the custommeasurement that you want to modify or delete.

Custommeasurements that have been associated with a logical device type can be edited
but not deleted. Selecting Delete results in a message indicating that the custom
measurement cannot be deleted because it is mapped either to a logical device type or to a
logical device that is logging data.

3. To modify the custom measurement, click Edit to open the Edit Measurement dialog,
update the entries or selections in the dialog, and clickOK to apply to changes.



4. To delete a custom measurement, click Delete.

A message confirms the deletion.

Note that if you attempt to delete a custommeasurement that is associated with any logical
devices, a message indicates that the measurement cannot be deleted.

Using the Logical Device Editor
Use the Logical Device Editor to map measurements from physical devices to measurements
provided by the logical device type that is associated with a logical device.

To open the Logical Device Editor:

1. Start Management Console and log in using an account with supervisor-level access.

2. Click the Devices icon, then right-click the Display window and select New > Logical
Device.

The devices defined in Management Console are listed in the Input Devices area of the
Logical Device Editor.

The top portion of the editor consists of a header area that contains instructions, selection lists,
and input fields. The bottom portion is the mapping area that allows you to map the input registers
of a physical device to a list of measurements provided by the associated device type.

A Header area B Mapping area

The header area

The instructions indicate the steps required to create a logical device.
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TheGroup field is a combination input field and dropdown list. You can either enter a name for
the group or select a group from the list.

The Name field identifies the name of the logical device that you are defining. Enter the name of
the logical device in the field.

The Logical Device Type dropdown list contains the names of logical device types that are
available for selection.

The mapping area

The Input Devices grid lists the devices that are in your system. When you select a device, its
output registers are listed in the Input Device Registers area.

The Register Mapping grid is populated with a list of the output measurements that are defined
for the logical device type that you select in the Logical Device Type dropdown list. They are
listed under a generic Device Name label pending their mapping to the logical device name that
you specified. Drag an entry from the Input Device Registers list to an output measurement in
the Register Mapping grid to map the two values.

Defining a logical device

1. Select a logical device type from the Logical Device Type dropdown list.

The output measurements defined for the selected logical device type are listed in the
Output Measurement column in the Register Mapping area.

2. Either select an existing group name from theGroup dropdown list, or enter a group name
in the field.

3. Enter a name for the new logical device in the Name field.

4. Select one of the input devices from the Input Devices area of the editor.

The registers for the selected input device appear in the Input Device Registers area. Note
that if you choose to display the registers for the input device in an ION tree format, delays in
displaying the registers can occur for devices with a large volume of registers.

5. Map an input device register to an output measurement by dragging it to the output
measurement listed in the Register Mapping area of the editor.

The input device registers appear in bold font when they are mapped to an output
measurement.

6. ClickOK to save the logical device configuration in Management Console.

Any unmapped measurements are displayed in red.

7. To edit a logical device that is in the Device panel of Management Console, double-click the
device name, or right-click the device name and select Configure Device to open the
Logical Device Editor, or click the device then select Edit > Configure Device.

Note that:

If you choose to edit the configuration of the logical device, delays can occur in
displaying the registers for devices with a large volume of configured registers.



Duplicate and Configure in Management Console's Editmenu cannot be used with
logical devices. See Creating multiple logical devices for information about creating
more than one logical device.

Considerations regarding logical devices and historical data

When a logical device is configured, historical data for an output register (that is, an output
measurement) on the physical device is automatically routed to the corresponding output
measurement on the logical device.

When a logical device is configured, historical data is logged to the logical device and not the
related physical device.

If multiple logical devices include the same input measurement from the same physical device,
historical data from that input measurement is routed to the logical device that was configured
last.

Deleting a physical device that is mapped to a logical device

If a physical device that is mapped to a logical device is deleted, the mapping of input
measurements for the logical device can no longer be resolved. A message dialog opens to
indicate the result of the delete action and asks whether you want to continue with the deletion.

If you right-click the logical device in Management Console and select Configure Device to open
the Logical Device Editor after you have deleted the physical device, a message indicates that the
physical device has been deleted. The Register Mapping grid for the logical device shows the
deleted physical device/ION handle in the Input Register column.

If you re-create the physical device, the input measurement mapping for the logical device is
automatically restored.

Renaming a physical device that is mapped to a logical device

If a physical device that is mapped to a logical device is renamed, a message dialog opens to
indicate the result of the rename action and asks whether you want to continue with renaming.

If you right-click the logical device in Management Console and select Configure Device to open
the Logical Device Editor after you have renamed the physical device, the Register Mapping grid
for the logical device shows the renamed physical device in the Device Name column.

Deleting a site which has a physical device mapped to a logical device

If a site with a physical device mapped to a logical device is deleted, the physical device is also
deleted and the mapping of input measurements for the logical device can no longer be resolved.

If you right-click the logical device in Management Console and select Configure Device to open
the Logical Device Editor after you have deleted the site, a message indicates that the physical
device has been deleted. The Register Mapping grid for the logical device shows the deleted
physical device/ION handle in the Input Register column.

Creating multiple logical devices
You can create multiple logical devices by:

• Exporting a logical device configuration to a comma-separated values (CSV) file.

• Modifying the CSV file to add multiple logical device configurations based on the original
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logical device configuration.

• Importing the CSV file in Management Console to add the logical devices to the system.

Export a logical device configuration

Complete the following steps to export one or more logical device configurations to a CSV file.

1. Use the Logical Device Editor to create at least one logical device in the Devices area of
Management Console.

2. Select one or more logical devices, right-click and select Export to open the Export Status
dialog.

Note that if you choose to export the registers for the logical device, delays in the export
process can occur for logical devices with a large volume of configured registers.

3. Click the browse button on the right of the Selected File field to open the Save As dialog.

4. Navigate to the location where you want to save the file and enter a name for the file in the
File name field.

Text files (*.csv) is pre-selected in the Save as type field.

5. Click Save to return to the Export Status dialog.

The Selected File field is populated with the location and file name that you specified.

6. Click Export.

The Status column in the grid area of the dialog indicates Exported for a completed export
operation. If the export operation is not successful, for example if the input registers cannot
be retrieved for the logical device being exported, it is indicated in the Status column. Click
the link to open the log file to view additional information.

Configuration information for all of the selected logical devices is exported to the CSV file.

Create multiple entries in the CSV file
Use Microsoft Excel or a similar spreadsheet editor to open the CSV file. The column headings in
the spreadsheet are labeled as follows:

• Logical device name

• Logical device type

• Physical device name

• Physical device type

• Input register

• Output measurement

• Handle - this column heading is required but the entries are not required unless there are
duplicate labels, that is, input registers with the same name but with a different ION handle. In
this case the ION handle is required. You can view the ION handles by exporting the input
measurements from the Logical Device Type Editor.

NOTE: The column headings remain in English for localized versions of the product. This is
required for CSV file-processing purposes.



To create multiple entries for the logical device configuration, use the copy and paste function in
Excel. It is recommended that only users with supervisor-level access create multiple entries.

1. Select the rows that you want to duplicate and press Ctrl+C to copy them.

2. Place the cursor in the left-most cell of the first blank row and press Ctrl+V to paste copies of
the selected rows.

3. Continue the paste operation for as many logical device configurations that you want to
create.

4. After completing the paste operation, be sure that you use unique device names to avoid
duplicates.

You can also export all of the register names of a physical device as well as all of the
measurement names of a logical device type. This gives you the ability to use these additional
CSV files to copy and paste additional register names and measurement names into the CSV file
you are using to create the multiple logical devices.

To export all of the register names of a physical device:

1. Open the Logical Device Editor and select a physical device.

2. Right-click anywhere in the register list in the Input Device Registers area to open a menu
and select Export Device Input Registers.

3. Enter a name for the file and clickOK.

To export all of the measurement names of a logical device type:

1. Open Management Console and select Tools > System > Logical Device Type Editor.

2. Select a logical device type in the logical device types area of the editor.

3. Click theMeasurements tab.

4. Right-click anywhere in the grid underMeasurements For and select Export
Measurements.

5. Enter a name for the file and clickOK.

Import multiple logical device configurations
Complete the following steps to import the CSV file with the multiple logical device configurations.
It is recommended that only users with supervisor-level access import logical device
configurations.

1. Open Management Console and select Tools > Import Logical Device in the Devices
panel of Management Console to open the Logical Device Import Form window.

Logical Device Import Form is available only when you are in the Devices panel of
Management Console,

2. Use the Browse button to navigate to and select the CSV file to import.

3. SelectOverwrite Existing Devices if you want overwrite logical devices with the same
name that were previously created.

Logical devices with the same name can occur as a result of a previous import operation.
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4. Click Import to add the multiple logical devices to the Devices area of Management
Console.

The system performs a validation of the configuration data during the import operation. If an
error occurs during the import operation:

The Status column in the grid area indicates Failed for any logical device that is not
imported. Click Failed to view details about the cause of the unsuccessful import.

Logical devices are created for all correct entries in the CSV file. Logical device entries
that are incorrect are not created in Management Console.

Manual Data Editor
Use Manual Data Editor to edit logged measurement data or to manually enter measurement data
into the WinPM.Net database. With this tool, you can adjust incorrect data, outliers, roll overs,
jitter, and other unexpected or unwanted data records. You can fill data gaps or enter manually
collected data, such as clipboard readings from mechanical meters. The Manual Data Editor also
has the ability to create new, custommeasurements in WinPM.Net.

NOTE: Manual Data Editor can only be used to edit trend data logs. It cannot be used to edit
waveform logs or event logs.

NOTICE
LOSS OF DATA

Back up the database before making manual database edits.

Failure to follow these instructions can result in permanent loss of data.

Editing existing logged measurement data
Edit existing data logs to adjust incorrect data, outliers, roll overs, jitter, and other unexpected or
unwanted data. You can also fill in missing data and insert missing data records.

To edit existing logged measurement data:

1. In Manual Data Editor, click Load New Data to open the Load Data dialog box.

NOTE: Load Data opens automatically when you start Manual Data Editor.

2. In Load Data:

Select the Source for which you want to edit the logged data.

Select the Measurement for which you want to edit the logged data.

Click Add Data to Selection to add the source/measurement to the list of items to be
opened in the data editor.

3. (Optional) Repeat step 2 to add additional sources and measurements to the selection list.

4. In Load Data, select the Time Range for the logged data you want to open in the data editor.



5. (Optional) In Load Data, set the following data editor options:

Timezone - Set the timezone for the display of the configurable timestamp in the data
editor. The data editor shows two timestamps for each data record, one timestamp in
UTC and one in a configurable timezone.

Timestamp Format - Set the format for the timestamp display in the data editor.

Number Format - Set the number of decimals that are displayed for the logged data in
the data editor.

Is Interval Data - Select the check box to enable this property. Set the expected logging
interval for the data.

This setting ensures that there is a data row in the editor for every expected log entry. If
there is no data record for an expected entry in the database, then the Manual Data
Editor inserts a timestamped row with a <no data> data values in the editor. This makes
it easier to identify missing records and correct them.

NOTE: The data editor shows all logged records in the selected time range, regardless
of the Interval Data settings. No records are hidden or filtered out.

6. Click Load Data to open the source/measurement data in the data editor.

7. (Optional) In the data editor, click Load New Data to change which data is loaded, the time
range, or the editor options.

8. (Optional) In the data editor, click View Issue Report to see which data issues were
identified with the loaded data by Manual Data Editor.

9. (Optional) In the data editor, use Locate Issues to find and step through the data issues
identified by Manual Data Editor. The data editor uses different color highlights to mark data
issues.

10. Locate data records that you want to edit and use any of the following tools or methods to
edit the data:

Click a data record and edit the data value.

Insert Timestamp - Insert a new data record with a timestamp that you specify. The
timestamp must be in the time range of the data that is loaded into the editor. The new
record has <no data> data values.

NOTE: A historical data log timestamp marks the end of the logging interval. For
example, a data log with a 15 minute logging interval and timestamp of 17:00
represents data for the time interval of 16:45 - 17:00.

Smart Gap Fill - Automatically fill missing data values in a selected time range, or the
entire time range of the loaded data set. You can choose between different interpolation
algorithms to fill the missing data. See Smart Gap Fill UI for more details.

Delete a data record or data value. These options are available in the right-click context
menu.

Set a data value to <null>. This option is available in the right-click context menu.
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Copy one or more data values and paste them into an external editor, such as Microsoft
Excel, for bulk editing. Paste the modified data values back into Manual Data Editor. The
copy and paste options are available in the right-click context menu.

NOTE: Only select the data values for copy/paste, not the timestamps.

TIP: Modified data values are shown in bold font in the Manual Data Editor.

11. (Optional) In the data editor, use Locate Changes to find and step through the edited data
records.

12. (Optional) Revert edited data values back to their original value. This option is available in
the right-click context menu. Use Undo all Changes to revert all edits in the loaded data
set.

13. Click Apply Changes to write the data log changes to the database.

NOTE: The Apply Changes command permanently writes the data log changes to the
database. There is no undo option for this command. See Reverting previous data edits for
more information.

14. (Optional) Click View Log to see a historical audit log of all the data log changes.

15. Close Manual Data Editor.

For information on how to use the Manual Data Editor , see:

• Editing existing logged measurement data

• Adding manually collected measurement data

• Viewing previous change details

• Reverting previous data edits

• Creating new measurements

For reference information see:

• Manual Data Editor user interface

Adding manually collected measurement data
Manually add data logs to the database that were collected from data sources that do not have a
communication link with the software.

To add manually collected measurement data:

1. In Manual Data Editor, click Load New Data to open the Load Data dialog box.

NOTE: Load Data opens automatically when you start Manual Data Editor.



2. In Load Data:

Select the Source for which you want to add data.

Select the Measurement for which you want to add data. If the measurement does not
exist, click Create new Measurement to create a new measurement.

NOTE: Check the list of available measurements to see if one exists for your
application before creating a new measurement.

Click Add Data to Selection to add the source/measurement to the list of items to be
opened in the editor.

3. (Optional) Repeat step 2 to add additional sources and measurements to the selection list.

4. In Load Data, select the Time Range for the data you want to add in the data editor.

5. (Optional) In Load Data, set the following data editor options:

Timezone - Set the timezone for the display of the configurable timestamp in the data
editor. The data editor shows two timestamps for each data record, one timestamp in
UTC and one in a configurable timezone.

Timestamp Format - Set the format for the timestamp display in the data editor.

Number Format - Set the number of decimals that are displayed for the logged data in
the data editor.

Is Interval Data - Select the check box to enable this property. Set the expected logging
interval for the data. This setting ensures that there is a data row in the editor for every
expected log entry.

6. Click Load Data to open the source/measurement data entry fields in the data editor.

7. (Optional) In the data editor, click Load New Data to change which data is loaded, the time
range, or the editor options.

8. In the data editor enter the measurement data using any of the following tools or methods:

Click a data record and edit the data value.

Insert Timestamp - Insert a new data record with a timestamp that you specify. The
timestamp must be in the time range of the data that is loaded into the editor. The new
record has <no data> data values.

NOTE: A historical data log timestamp marks the end of the logging interval. For
example, a data log with a 15 minute logging interval and timestamp of 17:00
represents data for the time interval of 16:45 - 17:00. That means that the last data log
for a day has a timestamp of midnight (or 12 AM) of the following day. For example, the
last data log timestamp for January 31 has a timestamp of February 1, 00:00 hrs (or 12
AM).

Smart Gap Fill - Automatically fill missing data values in a selected time range, or the
entire time range of the loaded data set. You can choose between different interpolation
algorithms to fill the missing data. See Smart Gap Fill UI for more details.
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Delete a data record or data value. These options are available in the right-click context
menu.

Set a data value to <null>. This option is available in the right-click context menu.

Copy one or more data values and paste them into an external editor, such as Microsoft
Excel, for bulk editing. Paste the modified data values back into Manual Data Editor. The
copy and paste options are available in the right-click context menu.

NOTE: Only select the data values for copy/paste, not the timestamps.

TIP: Modified data values are shown in bold font in the Manual Data Editor.

9. Click Apply Changes to write the new data log entries to the database.

NOTE: The Apply Changes command permanently writes the data log changes to the
database. There is no undo option for this command. See Reverting previous data edits for
more information.

10. (Optional) Click View Log to see a historical audit log of all the data log changes.

11. Close Manual Data Editor.

For information on how to use the Manual Data Editor , see:

• Editing existing logged measurement data

• Adding manually collected measurement data

• Viewing previous change details

• Reverting previous data edits

• Creating new measurements

For reference information see:

• Manual Data Editor user interface

Viewing previous change details
Manual Data Editor maintains an audit log which records all changes to logged data made by the
tool. The log is filtered by source/measurement.

To view previous change details:

1. In Manual Data Editor, click Load New Data to open the Load Data dialog box.

NOTE: Load Data opens automatically when you start Manual Data Editor.

2. In Load Data:

Select the Source for which you want to see the audit log.

Select the Measurement for which you want to see the audit log.

Click Add Data to Selection to add the source/measurement to the list of items to be
opened in the data editor.



3. (Optional) Repeat step 2 to add additional sources and measurements to the selection list.

4. Click Load Data to open the source/measurement data entry fields in the data editor.

NOTE: Ignore the settings for Time Range andOptions, they have no influence on the
display of the audit log.

5. (Optional) In the data editor, click Load New Data to change which data is loaded, the time
range, or the editor options.

6. Click View Log to open the audit log for these sources/measurements.

7. View the audit log.

8. Close Manual Data Editor.

For information on how to use the Manual Data Editor , see:

• Editing existing logged measurement data

• Adding manually collected measurement data

• Viewing previous change details

• Reverting previous data edits

• Creating new measurements

For reference information see:

• Manual Data Editor user interface

Reverting previous data edits
It is not possible to directly and automatically revert previous data edits with Manual Data Editor.
However, you can use the information available in the audit log to manually revert previous edits.

To revert previous data edits:

1. In Manual Data Editor, click Load New Data to open the Load Data dialog box.

NOTE: Load Data opens automatically when you start Manual Data Editor.

2. In Load Data:

Select the Source for which you want to revert previous edits.

Select the Measurement for which you want to revert previous edits.

Click Add Data to Selection to add the source/measurement to the list of items to be
opened in the data editor.

3. (Optional) Repeat step 2 to add additional sources and measurements to the selection list.

4. In Load Data, select the Time Range for the logged data you want to open in the data editor.

5. (Optional) In Load Data, set the following editor options:

Timezone - Set the timezone for the display of the configurable timestamp in the data
editor. The data editor shows two timestamps for each data record, one timestamp in
UTC and one in a configurable timezone.
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Timestamp Format - Set the format for the timestamp display in the data editor.

Number Format - Set the number of decimals that are displayed for the logged data in
the data editor.

Is Interval Data - Select the check box to enable this property. Set the expected logging
interval for the data.

This setting ensures that there is a data row in the editor for every expected log entry. If
there is no data record for an expected entry in the database, then the Manual Data
Editor inserts a timestamped row with a null value in the editor. This makes it easier to
identify missing records and correct them.

NOTE: The data editor shows all logged records in the selected time range, regardless
of the Interval Data settings. No records are hidden or filtered out.

6. Click Load Data to open the source/measurement data in the data editor.

7. (Optional) Click Load New Data to change which data is loaded, the time range, or the
editor options.

8. Click View Log to open the audit log for these sources/measurements.

9. Find the log entries that you want to revert. Using the information provided in theOriginal
Value and New Value columns, identify the values you want the logs to be reset to.

TIP: You can copy the values from the audit log and paste them into the data editor or an
external editor such as Microsoft Excel.

10. Close the Audit Log.

11. In the data editor, locate data records that you want to edit and use any of the following tools
or methods to reset the data:

Click a data record and edit the data value.

Insert Timestamp - Insert a new data record with a timestamp that you specify. The
timestamp must be in the time range of the data that is loaded into the editor. The new
record has <no data> data values.

NOTE: A historical data log timestamp marks the end of the logging interval. For
example, a data log with a 15 minute logging interval and timestamp of 17:00
represents data for the time interval of 16:45 - 17:00.

Delete a data record or data value. These options are available in the right-click context
menu.

Set a data value to <null>. This option is available in the right-click context menu.

Paste the data values from the audit log into the data records. The copy and paste
options are available in the right-click context menu.

NOTE: Only select the data values for copy/paste, not the timestamps.

TIP: Modified data values are shown in bold font in the Manual Data Editor.



12. (Optional) In the data editor, use Locate Changes to find and step through the edited data
records.

13. (Optional) Revert edited data values back to their original value. This option is available in
the right-click context menu. Use Undo all Changes to revert all edits in the loaded data
set.

14. Click Apply Changes to write the data log changes to the database.

15. Close Manual Data Editor.

For information on how to use the Manual Data Editor , see:

• Editing existing logged measurement data

• Adding manually collected measurement data

• Viewing previous change details

• Reverting previous data edits

• Creating new measurements

For reference information see:

• Manual Data Editor user interface

Creating new measurements
You can use Manual Data Editor to create new, custommeasurements in WinPM.Net. These
measurements are available anywhere in the software.

To create a new measurement:

1. In Manual Data Editor, click Load New Data to open the Load Data dialog box.

NOTE: Load Data opens automatically when you start Manual Data Editor.

2. In Load Data, click Create new Measurement to open the Create new Measurement dialog
box.

NOTE: Check the list of available measurements to see if one exists for your application
before creating a new measurement.

3. In Create new Measurement, enter the relevant information for the new measurement.

4. Click Create to add the new measurement to the system.

5. (Optional) Repeat steps 2-4 to add additional measurements.

6. Close Manual Data Editor.

For information on how to use the Manual Data Editor , see:

• Editing existing logged measurement data

• Adding manually collected measurement data

• Viewing previous change details
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• Reverting previous data edits

• Creating new measurements

For reference information see:

• Manual Data Editor user interface

PQDIF Exporter
PQDIF (Power Quality Data Interchange Format) is a non-proprietary means of exchanging
power quality data between different metering devices and software.

Developed under the guidelines of IEEE P1159.3, PQDIF provides a common ground where
different vendors can export to or import from, using a data format consistent with the defined
PQDIF standard.

WinPM.Net supports PQDIF through the “PQDIF Exporter” add-on. PQDIF Exporter takes data
from the WinPM.Net SQL Server database, converts it to PQDIF, and stores this formatted file for
viewing with any of the various programs that can display PQDIF data. The PQDIF Exporter
allows you to set regularly scheduled exports of WinPM.Net data to PQDIF, as well as perform
these exports manually.

This guide provides basic configuration and operation instructions for the PQDIF Exporter. It is
assumed that the user already has knowledge of PQDIF. For details on viewing the PQDIF data,
refer to the documentation that came with your PQDIF viewer. For detailed information on the
PQDIF specification, visit the IEEE website.

Configuring the PQDIF Exporter
FromManagement Console, select Tools > System > PQDIF Exporter.

When you run PQDIF Exporter for the first time, the PQDIF Exporter Configuration dialog opens
with the options to perform the initial configuration steps. To edit these settings at any time, select
Options > Configure PQDIF Exporter. You can also edit the PT/CT Scaling used for the
sources by the PQDIF Exporter; selectOptions > PT/CT Scaling.



Database options

The Database Options dialog allows you to make changes to the database connection settings
(SQL Server Instance, User Name, and Password). Type your changes in the appropriate fields.

NOTE: Under most conditions, you do not need to change the factory settings.

Click Test These Settings to test your database connection. A prompt displays to indicate
whether or not connection to the database was successful.

Output folder

ClickOutput Folder to change the folder where PQDIF Exporter stores its output files. Type the
folder path or click Browse to navigate and select the folder (or to create a new folder).

Message logging options

ClickMessage Logging Options to change the settings for message logging and email
notification. The options available to configure are Log File, System Log, and E-mail Notification.

Log File options

Click Log File Options to specify the location for the log file and the logging level option.

Location

To change the folder location for the log file, type the folder path in the Location field or click
Browse to navigate and select the folder.
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Logging Level

Logging Level lists the different options for logging depth. Select the level you want from the
dropdown list:

• Disabled: No messages are stored in the log file.

• Normal: Warning and error messages are stored in the log file.

• Detailed: Warnings, errors, and information are stored in the log file.

• Diagnostic: Warnings, errors, information, and diagnostic messages are stored in the log file.

NOTE: The “Diagnostic” log file option uses a huge amount of system resources. Select this
option only if absolutely necessary.

System Log options

Click System Log Options to specify whether or not messages are stored in the WinPM.Net
system log.

Select from the following options:

• Disabled: No messages are stored in the system log.

• Normal: Warning and error messages are stored in the system log.

Email options

Click E-mail Options to set up email notification from PQDIF Exporter.

SMTP Server to set for E-mail messages

Type the name of the SMTP server PQDIF Exporter uses to send the email.

From E-mail Address to use for PQDIF Exporter

Type the address you want to appear in the “From” field in the email message.



E-mail Recipients

Click Add to enter email address recipients for the PQDIF Exporter messages. To delete an email
address from the list, select it then click Remove.

Logging Level

The Logging Level box lists the different options for the amount of information sent in the email
message. If you change this setting, it affects the setting for all email recipients.

• Disabled: No email sent.

• Normal: Email warning and error messages.

When you have finished setting up the email options, click Test These Settings to test the email
connection.

If email settings are configured properly, a test message is sent to your inbox.

Exporter service options

Click Exporter Service Options to specify how often the PQDIF Exporter service restarts from
an idle state to check the database for data to export.

Use the up and down arrows and dropdown list to set the frequency.

NOTE: Setting the Exporter Service Frequency Settings to seconds uses a huge amount of
system resources. Select this option only if absolutely necessary.

PT/CT scaling

For a network where the PT/CT ratios on the meters are not set to the actual ratio values (for
example, if the ratios are set to 1:1 for revenue metering purposes), the PQDIF Exporter service
can scale the values to the correct primary measurements when it exports data.

To set the PT/CT scaling for the PQDIF Exporter:

1. ClickOptions > PT/CT Scaling to open the PT/CT Scaling dialog displaying the current
PT/CT scaling for the sources in your network.

2. Select a source(s) and click Edit PT/CT Scaling for Selected Sources to open the Edit
PT/CT Ratios dialog.

3. Enter the multiplier required to convert secondary values to primary values (for example,
enter 1000 for a 5000:5 CT). ClickOK.

4. Click Save to save your changes.

PQDIF Exporter main window
This is the main user interface for setting up schedules for PQDIF Exporter jobs or for setting up
and running the jobs manually.

FromManagement Console, click Tools > System > PQDIF Exporter.

WinPM.Net 10.0 User Guide Chapter 3: Management Console tools

© 2021 Siemens Industry, Inc. All Rights Reserved. 88



Chapter 3: Management Console tools WinPM.Net 10.0 User Guide

89 © 2021 Siemens Industry, Inc. All Rights Reserved.

A Main menu items B Status of Exporter

Menu items

All the PQDIF Exporter commands are available from the main menu. Some of these commands
are also available when you right-click on the interface background or on a job.

Starting/stopping the exporter service
To start the PQDIF Exporter service:

• SelectOptions > Start Exporter Service, or

• Right-click the status bar and select Start Service.

To stop the service:

• SelectOptions > Stop Exporter Service, or

• Right-click the status bar and select Stop Service.

PQDIF Exporter jobs
The Jobsmenu contains commands which allow you to set up PQDIF Exporter jobs that run
automatically, according to the schedule you specify. You can also set up manual jobs to collect
data for a specific date range from the SQL Server database for conversion to PQDIF.

PQDIF data templates
PQDIF data templates are the mapping files that convert WinPM.Net data to PQDIF. PQDIF
Exporter extracts recorded data for the following default templates:

• Flicker: Short-term and long-term flicker disturbance data on the voltage inputs.

• Sag/Swell: Sag/swell disturbance data for the voltage inputs, including minimum, maximum
and average values.

• Sag/Swell Waveforms: Waveform data for voltage sag/swell.

• Steady-state: Steady-state (RMS) data for trending.

• Steady-state Waveforms: Waveform data for steady-state data.



NOTE: For the Steady-state Waveforms template, you must program the meter to use a
Periodic Timer module to perform periodic waveform recording of the voltage and current
channel inputs. The time interval you specify must be a multiple of 15 minutes.

• Transient Waveforms: Transient disturbance data for voltage inputs.

In addition to the default templates, custom templates can be also be developed— contact
Technical Support if you require customized data templates for your application.

Scheduled export jobs

You can set up PQDIF Exporter to run at a specific time every day, or you can specify a different
time interval (for example, every 12 hours or every 7 days). You can create and store multiple
scheduled jobs for the PQDIF Exporter.

Creating a Scheduled Export Job

1. Click Jobs > New Job > Scheduled Export to open the Scheduled Export dialog.

2. Type a short but descriptive name in the Job Name field. Use the Job Description field to
give more details about the job.

3. Select the sources for your scheduled data export. Click the box beside each source to
select or deselect it.

Click All Sources to select all available devices that log the type of data specified by the
data templates. When this logged data is detected for a new device, that device is
automatically added to all scheduled PQDIF Exporter jobs that have All Sources selected.

4. Select the Data Templates you want to use when the PQDIF Exporter runs. Click the box
beside each template to select or deselect it.

Click All Templates to select all available data templates for the selected devices. When a
new data template is added, that template is automatically added to all scheduled PQDIF
Exporter jobs that have All Templates selected.
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5. Use the Export Time section to specify how frequently the PQDIF Exporter should run, as
well as its start/cut-off time. When a scheduled PQDIF Exporter job runs for the first time (at
the specified start time), it collects historical data to create PQDIF files so that the time
period for that export is consistent (“caught up”) with the time periods of all subsequent
scheduled PQDIF exports.

Example 1: If you saved the scheduled job (1) at 4:25 PM, with the Exporter scheduled
to run daily at midnight, the first PQDIF file is generated at midnight (2) the same day,
and includes data spanning from the previous midnight. PQDIF Exporter runs again next
midnight (3), and includes data spanning the first scheduled export (2).

Example 2: If you set a scheduled job to run PQDIF Exporter every 8 hours, starting at
3:00 AM, then the first PQDIF file is generated at 3:00 AM, and will include data
spanning 8 hours previous to that time (that is, 7:00 PM). The next export starts 8 hours
later, at 11:00 AM, then at 7:00 PM, then at 3:00 AM and so on.

Example 3: To run PQDIF Exporter once a week at 6:00 AM, change Export Time to
“Export every 7 Day(s) at 6:00 AM”. In this example, the PQDIF file contains a full
week’s worth of PQDIF data

6. Click Add Job.

NOTE: Exporter Service must be started in order to run scheduled PQDIF Exporter jobs. See
PQDIF Exporter main window.

Manual export jobs

Amanual export job enables you to run the PQDIF Exporter immediately. You can create a
different manual job for each source and/or template, or for specific groups of sources and/or
templates.



Creating a manual export job

1. Click Jobs > New Job > Manual Export to open theManual Data Export dialog.

2. Type a short but descriptive name in the Job Name field. Use the Job Description field to
give more details about the job.

3. Select the sources for your data export. Click the box beside each source to select or
deselect it.

To select all available devices, select the All Sources box.

4. Select the Data Templates you want to use. Click the box beside each template to select or
deselect it.

To select all available templates, select the All Templates box.

5. Use the Export Range From and To boxes to specify the date range of historical data that
the PQDIF Exporter will use. The default time format is local time. If you want to use
Coordinated Universal Time format, select UTC.

6. Use the File Splitting options to specify how PQDIF Exporter exports the data. The default
method is to export the data to a single PQDIF file. You can change this so the data is split
into different PQDIF files — for example, if you want to split the data so each PQDIF file
contains 12 hours worth of data, set the File Splitting to “Export into separate files for each
12 Hour(s) of data”.

7. Click Export Now to run and save this manual PQDIF Exporter job, or click Add Job to
save without running it.
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Running manual jobs

After you enter the manual PQDIF Exporter jobs, you can select and run them:

1. On the PQDIF Exporter interface, select the manual job(s) you want to run.

2. Right-click and select Export Selected Manual Job(s). A command window displays to
indicate the progress of the export. Press the RETURN (ENTER) key when prompted to
return to the PQDIF Exporter interface.

NOTE: To run all manual jobs, click Jobs > Export All Manual Jobs.

Editing the PQDIF Exporter jobs
To make changes to a scheduled or manual job:

1. To edit a job, open the Export Configuration dialog in one of the following ways:

Double-click the job.

Select the job, then click Jobs > Edit Selected Job, or

Right-click the job and select Edit Selected Job.

2. Make your changes and click Save.

Duplicating PQDIF Exporter jobs
If you are creating jobs that have very similar attributes (for example, jobs that use the same set of
devices, templates and/or time schedules), you can set up the first job, duplicate it, then simply
edit the copy.

1. Select the job(s) you want to duplicate, then click Jobs > Duplicate Selected Jobs (or
right-click the job and select Duplicate Selected Jobs).

2. Double-click the copy of the job you want to edit, make your changes, then click Save.

Enabling/disabling the PQDIF Exporter jobs
To enable or disable the scheduled or manual jobs:

1. Select the job(s) you want to enable or disable.

2. To enable the jobs, click Jobs > Enable Selected Jobs. To disable them, click Jobs >
Disable Selected Jobs. You can also right-click the jobs and select Enable Selected Jobs
or Disable Selected Jobs to enable or disable the jobs.

Adjusting the column widths

To change the width of a column, hover the mouse over border of the column headings— the
mouse pointer changes into a double-arrow pointer — click and drag to adjust the column width.

Sorting the PQDIF Exporter job list

Click the title of a column to sort the data according to that column heading. An arrow appears in
the title of the column. Click the title again to toggle the sorting—ascending or descending order.



Deleting PQDIF Exporter jobs
To permanently remove PQDIF Exporter jobs from the list:

1. Select the jobs you want to delete, then:

Click Jobs > Delete,

Press the Delete key on your keyboard, or

Right-click and select Delete Selected Jobs.

2. Click Yes when prompted.

NOTE: You can also disable a job instead of deleting it (that is, Enable = “No”). This way, the job
can be enabled at a later date if required.

Closing the PQDIF Exporter window
To close and exit the PQDIF Exporter window, click the “X” at the top right corner, or click File >
Exit.

If the Exporter Service is stopped when you try to exit, PQDIF Exporter prompts you to start the
service in order to process scheduled jobs. Click Yes to start the Exporter Service.

Remote Modem Setup
Use Remote Modem Setup to preconfigure dialup modems that will be connected to meters at
remote locations. Hardware-based and software-based (WinModems) modems are supported.

Remote Modem Setup provides access to a database that contains configuration data for a
variety of modems you can pick from. Remote Modem Setup also provides direct access to your
modem so you can customize settings and troubleshoot its operation.

Preliminary Setup

Follow the instructions in your modem’s documentation to set up and connect the modem to one
of your computer’s serial ports. Select a port that the WinPM.Net Communications Server is not
using.

Using Remote Modem Setup
1. Start Management Console.

2. Click Tools > System > Remote Modem Setup to open the Remote Modem Setup
dialog.

3. Set the Port to the serial communications port that the computer uses to communicate with
(and set up) the modem. Set the Baud Rate to match the modem’s baud rate.

NOTE: To reduce possible communication issues, set the computer, modems and meters
to the same baud rate.

4. Set the following properties for the remote modem:

Select the type of modem from the Type box.

Set the Site Baud Rate.
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To set the modem to answer after a specified number of rings, select Auto Answer,
then type the appropriate number in the Number of Rings box.

To save the modem configuration data in the modem’s onboard memory, select Store
Profile. This feature allows the modem to revert to the saved settings after a power
outage. Clear Store Profile to disable this feature.

To turn on the modem’s internal speaker, select Speaker On, then select a setting from
the Volume list. Clear Speaker On to disable this feature.

5. Click Send to save the settings to the modem.

If there are DIP switch settings required for the modem that is being configured, a message
displays with instructions on which switches to turn on or off. Set the DIP switches on the
modem as instructed.

The modem is now ready to be used at the remote power monitoring site.

Reports Configuration
Before you can use Reports, you need to specify the database to use for reporting, and you need
to configure the delivery options for report subscriptions. These settings are defined in
Management Console.

To set the prerequisites:

1. Open Management Console and select Tools > Reports Configuration to open the dialog.

2. Click the Reports tab to configure general reporting options:

From the dropdown list in the ReportsDatabase section, select the database on which
to run reports. Only those databases and database archives compatible with Reports
are listed.

(Optional) Use the slider in the Report Timeout section to set the time (in seconds)
after which Reports stops trying to complete a report generation task.

3. Click the Subscriptions tab to configure the settings for report subscriptions:

SMTP Server: Enter the IP address of your SMTP server, or the fully-qualified network
server name from which the report subscriptions are emailed.

Port: Type the port address used by your SMTP server.

Use SSL: Select this option to encrypt your user credentials.

Username: If required by your SMTP server, enter the Windows user name used to
configure the SMTP server settings.

Password: If required by your SMTP server, enter the password associated with the
Windows user name.

“From” Display Name: (Optional) Type the name that you want to appear in the “From”
field of an emailed report.

“From” Email Address: Type the email address that you want to appear in the “From”
field of the emailed report.

4. ClickOK to save your changes.



Setting Reports prerequisites
Before you can use Reports, you need to specify the database to use for reporting, and you need
to configure the delivery options for report subscriptions. These settings are defined in
Management Console.

To set the prerequisites:

1. Open Management Console and select Tools > Reports Configuration to open the dialog.

2. Click the Reports tab to configure general reporting options:

From the dropdown list in the Reports Database section, select the database on which
to run reports. Only those databases and database archives compatible with Reports
are listed.

(Optional) Use the slider in the Report Timeout section to set the time (in seconds)
after which Reports stops trying to complete a report generation task.

3. Click the Subscriptions tab to configure the settings for report subscriptions:

SMTP Server: Enter the IP address of your SMTP server, or the fully-qualified network
server name from which the report subscriptions are emailed.

Port: Type the port address used by your SMTP server.

Use SSL: Select this option to encrypt your user credentials.

Username: If required by your SMTP server, enter the Windows user name used to
configure the SMTP server settings.

Password: If required by your SMTP server, enter the password associated with the
Windows user name.

“From” Display Name: (Optional) Type the name that you want to appear in the “From”
field of an emailed report.

“From” Email Address: Type the email address that you want to appear in the “From”
field of the emailed report.

4. ClickOK to save your changes.

Software Logging
Use Software Logging to add or edit software-based data logging for Modbus device types. This is
intended for device types that do not have onboard data logging capabilities. You can also add
software logging to a device type with onboard data logging to log additional measurements that
are not logged by the device.

RECOMMENDATION: Use onboard data logging when possible. The data log timestamps for
onboard data logs are more accurate than the timestamps for software data logging. Onboard
data logging is also more reliable than software data logging since it does not depend on a
network connection to the device.
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The Software Logging link in Management Console opens the same Configure Logging and
Calculation dialog that is available through the Device Type Editor. For more information on
adding software logging see the Device Type Editor Help > Adding Software Logging to a Modbus
Device Type.

Time of Use Editor
Time of Use (TOU) schedules created with the Time of Use Editor are designed to be used with
the Reports application. When you use a TOU schedule in a report, the report data is presented
according to the time periods you defined in the schedule. See Report definitions in the online
help for Reports in the Web Applications component for information on the Energy Cost Report.

A typical TOU has On Peak, Off Peak and Shoulder periods. Since rate schedules vary not only
by day and week, but also by season, the TOU schedules can be set up to match your precise
needs.

Opening the Time of Use Editor

To access the Time of Use Editor, open Management Console and select Tools > System >
Time of Use Editor.

Use the navigation pane on the left to navigate through the schedules. Right-click a schedule or
sub-schedule to access menu items. Select an item to display associated tabs in the tab display
pane on the right.

Overview: Creating a TOU schedule
To create a TOU schedule, you need to:

1. Add a schedule. See Adding or editing a schedule.

2. Add a sub-schedule, if you need more than one sub-schedule. See Adding or editing a sub-
schedule.

3. Add a season, if you need more than one. See Configuring seasons.

4. Configure special days (such as holidays) to include in your TOU schedule. See Adding
special days.

5. Add day groups, if you need groups other than the default day groups. See Configuring Day
groups.

6. Add TOU names, if you need names other than the default names. See Defining TOU
names.

7. Assign TOU periods to TOU names. See Defining TOU periods.

To view a sample schedule, right-click the navigation pane and select Import Schedule. Select
SampleSchedule.tou from the ...\WinPM.Net\system\etc folder and clickOpen.

Adding or editing a schedule
This section describes how to add a blank schedule, and import or copy an existing schedule.



Adding a blank schedule

1. Select File > New Schedule to open the Add a Schedule dialog.

2. Type a name and description for the schedule. Click the arrow beside the effective date to
bring up a calendar where you can select the effective date of the schedule.

3. ClickOK. That schedule name appears in the list in the navigation pane.

Copying an existing schedule

1. In the navigation pane, right-click the schedule that you want to copy.

2. Select Save as New Schedule to open the Save as New Schedule dialog.

3. Enter a name and description for the new schedule.

4. ClickOK. The new schedule appears in the navigation pane with the attributes of the copied
schedule.

Importing a schedule

1. Place the schedule that you want to import into a folder that can be accessed from the
computer.

2. In the navigation pane, right-click an empty area of the navigation pane then select Import
Schedule to open theOpen dialog.

3. Navigate to the folder where you placed the schedule. Select the schedule and clickOpen.

The schedule is imported with the extension “_imported”. For example, a schedule named
“ScheduleA” becomes “ScheduleA_imported”.

Exporting a schedule
To export a schedule to use in another TOU installation:

1. Right-click the schedule you want to export in the navigation pane. Click Export to open the
Save As dialog.

2. Select the folder where you want to save the schedule.

3. Enter a schedule name in the File name box.

4. Click Save.

The schedule is saved with the extension “.tou”. For example, “ScheduleB” becomes
“ScheduleB.tou”.

Editing an existing schedule
To edit a schedule name or description:

1. From the navigation pane, right-click a schedule name then click Edit Schedule to open the
Edit a Schedule dialog.

2. Change the schedule name or description.

To change the effective date, you must make the change to the sub-schedule(s). See
Editing a sub-schedule effective date.

3. ClickOK.
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Deleting a schedule

To delete a schedule, right-click the schedule name in the navigation pane then select Delete
Schedule. This deletes the entire schedule, including any sub-schedules.

Adding or editing a sub-schedule
When you add the basic schedule, it contains one sub-schedule, with the effective date (start
date) you entered for the schedule. To add additional sub-schedules with alternate effective
dates, follow the instructions in the following sections.

Expand a schedule to display its sub-schedule(s). Sub-schedules are listed in order of their
effective dates.

TIP: If you want to have more than one sub-schedule with the same seasons, day groups, TOU
periods, etc., configure the first sub-schedule then right-click it and select Save as New
SubSchedule.

Adding a blank sub-schedule

1. Right-click the schedule name and select New SubSchedule to open the New
SubSchedule dialog.

2. Click the arrow beside the effective date to open a calendar where you can choose an
effective date for the new sub-schedule.

3. ClickOK.

The sub-schedule displays in the navigation pane. Continue configuring the sub-schedule
by adding seasons and day groups.

To add a new sub-schedule that has the same settings as an existing sub-schedule, see Copying
an existing sub-schedule, below.

Copying an existing sub-schedule

1. Right-click the sub-schedule that you want to copy and select Save as New SubSchedule
to open the New SubSchedule dialog.

2. Click the arrow beside the effective date to open a calendar where you can choose an
effective date for the new sub-schedule.

3. ClickOK. The new sub-schedule displays in the navigation pane with the same attributes
(other than effective date) of the sub-schedule you copied.

Editing a sub-schedule effective date

1. Right-click the sub-schedule for which you want to change the effective date, then select
Edit Effective Date to open the Edit SubSchedule Effective Date dialog.

2. Click the arrow beside the effective date to open a calendar where you can choose an
effective date for the new sub-schedule.

3. ClickOK.



Deleting a sub-schedule

To delete a sub-schedule, right-click the sub-schedule name in the navigation pane and select
Delete. This also deletes all seasons in that sub-schedule (and any day groups, special days,
etc., that they contain).

Configuring seasons
Use seasons to create timeframes for presenting data in reports. A newly created schedule has a
single season, called All Year. Expand a sub-schedule to view its seasons.

If you only need one season (All Year), you can skip the steps below and go to configuring special
days.

Configuring seasons
Use the Define a Season tab to set up or edit the time spans for each season.

NOTE: A date can only belong to one season; you cannot overlap dates in one season with
dates in another.

1. From the navigation pane, select the sub-schedule to which the season belongs.

2. In the tab display pane, select the Define a Season tab.

After you add a sub-schedule, the tab displays only one season (All Year) that covers the
entire year. The season is listed at the top of the tab, and the calendar that shows the days
and months that belong to that season is full. To make room to add other seasons, you must
edit the All Year season.

3. Select All Year from the Define a Season tab and click Edit to open the Edit a Season
dialog.

4. In the Season Name field, type the name of one of the seasons you want to define (for
example, Summer).

5. Set the Start Date and End Date for the season. You can specify fixed start and end dates
(For example, 12/31) or relative start and end dates (for example, the last Saturday of
October).

Fixed Date: Click on the month or day portion of the date then either type the new date or
use the up and down arrows beside the date to edit it.

Relative Date: Select the day and month from the dropdown lists.

For the end date, select the Time of Day the season ends (Start of Day or End of Day). If you
select Start of Day, the season ends at 12:00:00 AM on the selected day; if you select End of
Day, the season ends at 12:00:00 AM on the next day so there are no gaps in the schedule.

NOTE: If you use relative dates, you can configure a schedule that may become invalid in
future years. Be careful when you configure the schedule that there will be no missing or
overlapping days in the schedule in future years. For example, rather than scheduling one
season to end on the 1st Sunday in June and the next to start on the 1st Monday in June, it
is better to schedule the first season to end at Start of Day on the 1st Sunday in June and
the next season to start on the 1st Sunday in June.

WinPM.Net 10.0 User Guide Chapter 3: Management Console tools

© 2021 Siemens Industry, Inc. All Rights Reserved. 100



Chapter 3: Management Console tools WinPM.Net 10.0 User Guide

101 © 2021 Siemens Industry, Inc. All Rights Reserved.

6. If this is a split season (where there is a gap between two parts of the season), select the
Split Season check box and add a second sets of dates. For example, winter is typically a
split season because it occurs in the first and last months of the year.

7. ClickOK.

The calendar on the Define a Season tab now shows one season with the rest of the year
unassigned.

8. Click Add to create additional seasons. Repeat steps 4 to 6 to name the season and define
the start and end dates.

NOTE: Do not leave any dates unassigned: unassigned dates are not calculated in the reports.

Editing a season

1. On the Define a Season tab, select the season you want to edit then click Edit to open the
Edit a Season dialog.

2. Make the changes you require then clickOK.

Deleting a season

To delete a season, select the season in the Define a Season tab then click Delete. This also
deletes the day groups and TOU periods configured for that season.

Adding special days
After you define a sub-schedule, you need to set up holidays and other special days. You can
define holidays that occur on the same date every year or at some other regular interval (such as
the third Thursday in November). You can also define special days, such as inventory days, that
might occur regularly and require special treatment in reports.

Use the Define Special Days tab to set up holidays and other special days.

1. In the navigation pane, select the sub-schedule for which you want to define special days.

2. In the tab display pane, select the Define Special Days tab.

3. Click Add to open the Add a Special Day dialog.

4. Type a name for the special day in the Name field.

5. Select the frequency of the day:

One time only: Enter the date for a single day that does not repeat in future years; for
example, a special day for your organization that does not repeat every year.

Repeat yearly: Enter the date; for example, a holiday that occurs on the same date
every year.

Repeat on: Complete the fields in the Repeat On section to define how the day repeats
and in which months it occurs. Select whether it occurs on a particular date of the
selected month(s) (Day) or a relative day (i.e., Last Saturday) in the selected month(s).

6. Repeat steps 3 to 5 to add additional special days.

7. ClickOK to save your changes and return to the Define Special Days tab.

See Configuring Day groups for instructions on how to apply special days to a sub-schedule.



Deleting a special day

To delete a special day, select the special day in the Define a Special Day tab then click Delete.

Configuring Day groups
Day groups define how days of the week are divided into groups.

Day groups can include:

• days of the week

• special days, such as holidays or other specially designated days (such as inventory days)

Default settings are weekdays (Monday to Friday) and weekends (Saturday and Sunday) but you
can add additional groups. There can be a maximum of 47 day groups in any season.

Make sure that all days have been accounted for since unaccounted time is not included in any
reports.

Adding a Day group
Before you add a day group, make sure that you have defined seasons and special days for the
sub-schedule.

1. In the navigation pane, select the season for which you want to define day groups. The
Define DayGroups tab appears in the tab display pane.

2. Click Add to open the Add a DayGroup dialog.

If the Add button is unavailable, there are no free days to add to a day group. A day can only
belong to one day group. To add another day group, you must first remove days from an
existing day group.

3. Type a name for the day group.

4. Select one of the following options:

Day of week: Select the check box(es) for the day(s) you want to include. A day can
belong to only one day group; if a day is unavailable, it already belongs to an existing
group. If all days are unavailable, you can only include special days in this group unless
you remove days from another day group.

Special Day(s) Only: Select the special day in the Include Special Days list then click to
select or clear the day. Days with a check mark beside them are included in the day
group. You can only include a special day in one day group.

5. ClickOK. The name is added to the day group list.

Editing a Day group

1. On the Define DayGroups tab, select the day group you want to change, then click Edit to
open the Edit a DayGroup dialog.

2. Make the changes you require then clickOK.
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Deleting a Day group

To delete a day group, select the day group in the Define DayGroups tab then click Delete.
When you delete a day group, you also delete the TOU periods configured for that day group. If
you add a day group again, you will need to reconfigure the TOU periods.

Configuring TOU names and TOU periods
When you run reports, the reports calculate and display data according to the information you
enter in the Define TOU Periods and Define TOU Names tabs.

NOTE: You need to define TOU names and periods for each schedule that you create. Be sure
to apply a TOU name to every square on the calendar. Unaccounted time causes your reports to
display inaccurate information.

Defining TOU names

A TOU name is a designation that is used to differentiate billing rates. Three TOU Names are
already defined: On Peak, Off Peak and Partial Peak. You can edit or delete these names, or add
new names.

To define TOU names:

1. In the navigation pane, select the day group for which you want to define TOU names then
select the Define TOU Names tab.

2. Click Add to open the Add a TOU Name dialog.

3. Type the TOU name you want to add then clickOK. The TOU name is added to the list of
TOU names.

Editing an existing TOU name

1. Select the TOU Name in the list on the Define TOU Names tab and click Edit to open the
Edit a TOU Name dialog.

2. Type the new name in the TOU name field.

3. ClickOK.

Deleting a TOU name

Select the TOU name in the list on the Define TOU Names tab and click Delete.

NOTE: If you delete a TOU name, the TOU periods assigned to the name are replaced with
“Unaccounted”. Deleting a TOU name in a particular schedule affects all sub-schedules in that
schedule.

Defining TOU periods

A TOU period is the time span within the 24-hour period to which you apply a TOU name (such as
8:00 a.m. to 5:00 p.m. for On Peak). You must have TOU names defined before you can
associate TOU periods with those names.

Two TOU names are already defined: On Peak and Off Peak. You can edit or delete these
names, or add new names.



Adding TOU periods
Select a day groups to set up the TOU time periods (on-peak, off-peak, etc.) for that group.

1. In the navigation pane, select the day group for which you want to define a TOU period then
select the Define TOU Periods tab.

2. Click Add to open the Add a Time Period dialog.

3. In the Start Time field, type the time that the period begins, or select the hours and minutes
and use the up and down arrows to set the start time.

4. In the Stop Time field, type the time that the period begins, or select the hours and minutes
and use the up and down arrows to set the stop time.

5. From the Time of Use Name dropdown list, select the TOU name to associate with the time
period.

6. ClickOK.

To add a split time period (i.e., a time period that spans from 19:00 to 6:00), you must add two
separate time periods and associate them with the same time of use name.

If you want to expand a time period into time that already belongs to another period, you must first
edit the other time period to clear the time.

Continue adding time periods until the 24 hour period is filled. Unaccounted time blocks cause
your reports to display inaccurate information.

Editing TOU periods

1. Highlight the period you want to edit and click Edit to open the Edit a Time Period dialog.

2. Make the required changes then clickOK.

Deleting TOU periods

To delete a period, highlight the period and click Delete.

Update OPC Server
Use this function to initialize or update the OPCmeasurement mappings in the system. This
function is part of the OPC server capabilities of WinPM.Net. For information on how to map ION
registers to OPC, see OPCmeasurement support. For information on how to map Modbus
registers to OPC, see Device Type Editor Help.

Upload Report Template
Use Upload Report Template to upload reports that are not available by default in the software.
You can upload single report template or multiple report templates. The multiple report templates
together are called as Report Pack.

NOTE: Information on how to create custom Report Templates is not provided in this help.
Contact your local Siemens Industry representative for information on custom Report
Templates.
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For information on how to use the Upload Report Template, see:

• Uploading Single Report Template

• Uploading Multiple Report Template (Report Pack)

Uploading Single Report Template
You can upload single report template to use it along with other report templates.

To upload single report template:

1. In Upload Report Template, select Report Template(.rdl).

2. Click Select File to navigate to the location of the .rdl file.

3. Select the file and clickOpen.

4. Click Upload.

The uploaded report is in ...\ WinPM.Net\web\ReportDepot\ION Reports\ION Single Reports

NOTE: After you uploaded the Report Template, you can access it, together with the default
templates, in the Report Library.

For information on how to use the Upload Report Template, see:

• Uploading Single Report Template

• Uploading Multiple Report Template (Report Pack)

Uploading Multiple Report Template (Report Pack)
You can upload multiple report template (Report Pack) at a time as a .zip file to use it along with
other report templates.

To upload multiple report template (Report Pack):

1. In Upload Report Template, select Report Pack(.zip).

NOTE: Make sure that multiple report templates are zipped as a single .zip file.

2. Click Select File to navigate to the location of the .zip file.

3. Select the file and clickOpen.

4. Click Upload.

A progress bar displays the upload status.

The uploaded report are unzipped and is in ...\ WinPM.Net\web\ReportDepot\ION
Reports\ION Report Packs

NOTE: After you uploaded the Report Template, you can access it, together with the default
templates, in the Report Library.

For information on how to use the Upload Report Template, see:

• Uploading Single Report Template

• Uploading Multiple Report Template (Report Pack)



User Manager
User Manager is a Web-based application that you use to configure users and user groups.
WinPM.Net does not provide any pre-configured user accounts or user groups. One supervisor
account is created with a user defined password during the installation of the software. Create
user accounts and groups to meet your needs. User Manager also gives information about the
Web Application user licenses for the system.

Open the User Manager application from the Configuration Tools section on the Settings page in
the Web Applications banner. You can also open User Manager from the Toolsmenu in the
Management Console.

See the User Manager online help for information on how to use this application.

Virtual Processor setup
TIP: You can open Virtual Processor Setup in Management Console from the Tools > System
> ION Virtual Processor Setup link.

The Virtual Processor (VIP) is the WinPM.Net service (WinPM.Net Virtual Processor Service) that
provides coordinated data collection and aggregation, control, and mathematical analysis of
power monitoring system data from groups of metering or similar intelligent devices. Use Virtual
Processor Setup to configure a Modbus Slave port when using the VIP as a Modbus Slave device
for exporting data to an external, 3rd-party Modbus Master. . Virtual Processor Setup can also be
used to improve the performance of the WinPM.Net Virtual Processor Service by modifying its
global operating parameters.

See Virtual Processor service (VIP) for application examples using the Virtual Processor.

Configuring the Modbus Slave port
You can configure the VIP to act as a Modbus Slave device to an external Modbus Master. The
Modbus Master can read data from the VIP through the VIP Modbus Slave modules. See the ION
Reference for information on how to configure Modbus Slave modules.

For the Modbus Master to be able to access the VIP, you need to configure a Modbus Slave Port.
A Modbus Slave Port can be a serial port, for example COM1, COM2, and so on, or a Modbus
TCP port.

To add a Modbus Slave Port:

1. Open Management Console and log on with a supervisor level user account.

2. Select Tools > System > ION Virtual Processor Setup. This opens the ION Virtual
Processor Setup dialog box.

3. In ION Virtual Processor Setup, find the VIP for which you want to add a slave port. Double-
clickModbus Network for this VIP. This opens the Network view.

4. Double-click Slave Ports. This shows any configured slave ports for this VIP. If no slave
ports are configured, the list will be empty.

5. Click Add Port. This opens the VIP Setup Modbus Port/Site dialog box.

6. In VIP Setup Modbus Port/Site, select the Port you want to use. ClickOK.
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7. Double-click the newly added slave port and then double-click Settings. This opens the port
settings.

8. Edit the port settings if required. For more information on port settings, see VIP Modbus
Slave port settings

9. Click Save, then click Exit.

NOTE: You must restart the VIP for the changes to take effect.

Done

Modifying the Global Parameters
Typically, you do not need to change the default Virtual Processor’sGlobal Parameters.
However, the settings in the following table can be modified to improve system performance. To
view and select the settings, expand Global Parameters.

Global
Parameter

Value Range Description Notes

Module Update
Period

50 to 1000 ms

The interval at which
ION modules inside
the Virtual Processor
are updated.

Frequent module updates
contribute to the workstation's
processor load. By increasing
the Module Update Period, you
reduce the number of times a
module executes in a given time
period.

Configuration
Saver Period

10 to 600
seconds

The interval at which
the Virtual Processor
writes its configuration
data to the
workstation's hard
disk.

Increasing the Configuration
Saver Period significantly
reduces the processor load if
you have a large Virtual
Processor configuration file.

Client Polling
Period

500 to 300000
ms

The interval at which
the Virtual Processor
gets information from
other nodes in the
network (for example,
another Virtual
Processor or a
device).

You can increase the period for
less time sensitive Virtual
Processor applications and
reduce the period for more time
sensitive applications.

Server Polling
Period

200 to 1440000
ms

The interval at which
the Virtual Processor
responds to requests
for information from
client nodes such as
Vista or the Log
Inserter.

Reducing this value increases
the rate at which these
responses are sent; however,
this can also increase network
traffic.
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Chapter 4: Vista
Vista is the WinPM.Net component that displays and controls your power monitoring system.

WARNING
INACCURATE DATA RESULTS
• Do not incorrectly configure the software or the devices.
• Do not base your maintenance or service actions solely on messages and information
displayed by the software.

• Do not rely solely on software messages and reports to determine if the system is
functioning correctly or meeting all applicable standards and requirements.

• Consider the implications of unanticipated transmission delays or failures of
communications links.

Failure to follow these instructions can result in death, serious injury, equipment
damage, or permanent loss of data.

WARNING
UNINTENDED EQUIPMENT OPERATION
• Do not use the software to control time-critical functions.
• Do not use the software to control remote equipment without proper access control and
status feedback.

Failure to follow these instructions can result in death, serious injury, or equipment
damage.

For information on starting and logging on to Vista or ending your Vista session, see Getting
started.

The Vista interface
The Vista interface consists of a main screen with a title bar, a menu bar, a toolbar, a workspace,
a status bar and (in Edit mode) a toolbox.

For information on opening or generating a Vista diagram, see Generating, opening and closing a
user diagram.

The following image illustrates the Vista interface with a user diagram showing real-time values.
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A Menu Bar B Toolbar C Workspace

D Click a tab to display its data E
Click to return to the Network
Diagram view

F Status Bar

G
Click this grouping object to open another
window containing more data

H Toolbox I
Receive/Transmit Status
indicators

Toolbar

The toolbar offers quick access to the commands that are used most frequently. Each command
on the toolbar is also available from the menus.

A Open G Cut

B Save H Copy

C Zoom I Paste

D Fit to window J Layout

E
Restore to
100%

K Up One Level

F
Plot Selected
Data

L Help

Zoom

Select View > Zoom In or click the Zoom button to change the mouse pointer to a crosshair. Use
this pointer to drag an outline around the area you want to enlarge.



Restore to 100%

Select View > Restore to 100% or click the Restore to 100% button to return to the normal view.

Fit to Window

Select View > Fit to Window or click the Fit to Window button to force the user diagram to fit in
the current window.

Up One Level

Select File > Up One Level or click the Up One Level button to return to the previously displayed
window. Note that this also closes the current window. If you want to be prompted when you reach
the top level of a diagram, make sureOptions > Browse closes active window is selected.

Workspace

The main area in the center of the Vista screen is the workspace. The workspace is used to
display information such as user diagrams and data and event viewers.

Status Bar
The status bar displays:

• The status line, which describes any active processes and provides a brief description of the
currently selected command or toolbar button.

• The current time on the workstation.

• A progress indicator bar.

• Two communication status lights.

Toolbox

In Edit mode, the toolbox also appears on the screen. You can add objects to the user diagram
using the toolbox. See Creating and customizing a user diagram for more information on the
toolbox and Edit mode.

Other display features

Vistaoffers several display features to assist you when viewing a user diagram. Some of these are
accessible through the toolbar and menu options (see Toolbar). Those only accessible through
menu options are:

Browse closes active window

SelectOptions > Browse closes active window to have each window that you open replace
the previous one. This option is selected by default. Without this option selected, any previously
opened windows remain open.

Arrange All

SelectWindow > Arrange All to tile all open windows in the workspace.
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Display mode and Edit mode
There are two display modes in Vista, which affect how you navigate a user diagram. Whether or
not the toolbox is shown indicates the mode you are in: if the toolbox is open, you are in edit
mode; if it is closed, you are in display mode.

• Displaymode allows you to monitor your system, view system data, and control some
aspects of your system. In Display mode, single-click objects to view the information they
contain or perform their associated action.

• Editmode allows you to configure the appearance and function of user diagrams and
diagram objects. In Edit mode, double-click objects to view the information they contain or
perform their associated action. Right-click the objects to view configuration options. See
Creating and customizing a user diagram and Customizing a diagram object for more
information.

When instructed to click a diagram object, either single-click or double-click, depending on the
mode you are in.

Vista user diagrams
This section explains how to use Vista user diagrams to view real-time and logged data from your
power monitoring system. The information that you obtain from your WinPM.Net network is
represented graphically in a user diagram.

WARNING
INACCURATE DATA RESULTS
• Do not incorrectly configure the software or the devices.
• Do not base your maintenance or service actions solely on messages and information
displayed by the software.

• Do not rely solely on software messages and reports to determine if the system is
functioning correctly or meeting all applicable standards and requirements.

• Consider the implications of unanticipated transmission delays or failures of
communications links.

Failure to follow these instructions can result in death, serious injury, equipment
damage, or permanent loss of data.

What is a user diagram?
A user diagram is a configurable display that consists of two main elements:

• Diagram objects are configurable graphic icons that display your system information. Each
diagram object displays a single piece of information from somewhere in your power
monitoring network. In some cases, diagram objects are stored within grouping windows.

• Grouping object: In some cases, a user diagram stores related information within a grouping
object. Click on a grouping object to open a grouping window and display its contents.

NOTE: To configure a grouping object to open a grouping window, see Specifying an action
for numeric, status, or grouping objects.



• Grouping windows are a type of folder or “sub-window” that contain diagram objects. Vista
uses grouping windows to logically organize diagram objects within a user diagram. When
closed, a grouping window is usually represented by a grouping object icon.

TIP: It is better to use grouping objects to open other user diagrams rather than to open grouping
windows. Large numbers of grouping windows in a user diagram can slow the performance of
Vista.

You can create as many user diagrams as you want and edit each one to suit your needs. You
can share user diagrams with multiple users over your network, and users can view them
simultaneously and share the same information. For more information on creating user diagrams,
see Creating and customizing a user diagram.

Default user diagrams

Vista provides a set of pre-configured user diagrams that you can use to display data. These
default diagrams provide a standard set of options that you can use to access your device's most
commonly required functions.

The default diagram displays real-time data. It includes a simple power system illustration that
displays the various real-time parameters measured by the device.

Generating, opening and closing a user diagram

A user diagram is identified by its “.dgm” extension. You can generate, open, and close user
diagrams as needed.

Generating a network diagram

The network diagram displays your entire power monitoring system by linking to individual default
user diagrams that display data from each device in your system. When you generate a network
diagram, Vista automatically locates all devices in your system and displays them. This diagram is
saved with the default name “network.dgm”.

1. Select File > Generate Network Diagram.

The network diagram appears in the workspace containing icons that represent groups of
devices on your system.

2. Click on one of the grouping objects to open a window and display the node icons contained
within.

3. Click a node icon to display the user diagram for the associated device.

4. Save the network diagram.

NOTE: Regenerating a network diagram and saving it overwrites the previously saved
(network.dgm) file.

Opening a user diagram
To open a user diagram:

1. Select File > Open.

2. Navigate to the user diagram you want to open and select it from theOpen Diagram dialog.

3. ClickOpen to open the selected user diagram.
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Specifying the user diagram that opens for a given user
To set a specific Vista workspace and set of diagrams to open every time a given user logs on:

1. Log on to Vista using the particular user’s logon credentials.

2. Organize Vista to appear as you want it to appear on startup.

3. Click Save, then close Vista.

4. Use Windows Explorer to navigate to the ...\WinPM.Net\config\cfg\ud folder.

5. Locate the .wsu file for the user you are setting up (i.e., <username>.wsu). Right-click and
select Properties.

6. Select the Read-only attribute, then clickOK.

NOTE: Applying the Read-only attribute prevents the workspace information from being
modified, so Vista opens the same way for a given user every time. The user can still modify and
save user diagrams (if allowed by their access level).

Closing a User Diagram
To close a user diagram:

• Select File > Close to close the current diagram.

• Select File > Close All to close all diagrams.

Navigating a user diagram

After you open a user diagram, you can use it to interact with your power monitoring system. Each
user diagram displays system information through diagram objects, which you can use to monitor
and control various aspects of your system.

Monitoring your system in Vista
Use Vista user diagrams to display real-time and logged data, monitor events and alarms, and
control a variety of system functions.

WARNING
UNINTENDED EQUIPMENT OPERATION
• Do not use the software to control time-critical functions.
• Do not use the software to control remote equipment without proper access control and
status feedback.

Failure to follow these instructions can result in death, serious injury, or equipment
damage.

How data is displayed

Information in your user diagram is displayed using diagram objects. Each diagram object
communicates a single piece of information from somewhere in your power monitoring network;
for example, a single numeric object displays numeric data from a single source.



There are seven types of diagram objects: grouping, text, numeric, status, data log viewer, event
log viewer, and control. Each type of object performs a specific type of function.

In most cases, you can identify an object's function by a caption, a label, or both (the text object
does not use a caption or a label).

• By default, the caption is usually located below the diagram object and identifies the node to
which the diagram object is connected. The caption can be modified to display a custom
description. See Caption options for more information.

• When a label is used, it is usually displayed to one side of the diagram object. By default, the
label identifies the register (on the node) to which the diagram object is connected. The label
can be modified to display a custom label name. See Text options for more information.

TIP: To toggle between default labels and custom labels, select or clearOptions > Show
Default Labels. You can identify the type of diagram object by pointing to it with the mouse. The
object type appears on the status line.

Identifying stale data

Real-time data that has not been refreshed is referred to as stale data. Vista detects stale data as
it occurs and identifies it with a colored border. By default, Vista identifies data as stale after 60
seconds. Position the mouse pointer over an object to display a ToolTip that explains why the
data has become stale.

The stale data settings are user-configurable on a per-diagram basis, and can be customized by
anyone with the necessary access level.

Changing the Stale Data settings
To change the amount of time (in seconds) that Vista uses to identify stale data:

1. Ensure that the Toolbox is open (Options > Show Toolbox), right-click the background of
the diagram and click Properties.

2. Click the Updates tab and change the settings in the Stale Data section.

3. ClickOK.

Changing the flag settings for Stale Data
To change the flag color:

1. ClickOptions > Flag Colors.

2. Click the Edit button for the flag color you want to change, select the new color and clickOK.

Identifying errors in communication

Vistadetects errors (such as disabled devices, security access restrictions, or configuration
errors) and identifies these with a colored border around an object (orange, by default). The
border color can be customized (see the previous section, Changing the flag settings for Stale
Data). Position the mouse pointer over an object that Vista is indicating has an error to display a
ToolTip that explains the error.

Increasing the timeout period of a Vista query

When Vista queries the ION_Data database, the query can timeout if the database is large.
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To increase the timeout period of a Vista query, a new entry to the registry of ION_SERVER
needs to be created, and the Query Server connect timeout period needs to be increased.

NOTICE
IRREVERSIBLE OPERATING SYSTEM DAMAGE OR DATA CORRUPTION

Before making any changes, back up your Windows Registry in a network folder or other
remote location.

Failure to follow these instructions can result in irreparable damage to the operating
system of the computer and all existing data.

NOTE: Registry edits must be performed only by qualified and experienced personnel.

Increase the Vista query timeout

1. Select Start > Run and type regedit in the Run window to open the registry.

2. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Siemens Industry\WinPM.Net\x.x,
where x.x is the version number.

If the component is run on a 64-bit operating system, navigate to:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Siemens Industry\WinPM.Net\x.x

3. Right-click an empty area in the pane on the right and select New > DWORD Value.

4. Name the new DWORD VistaQueryTimeout_s.

5. Right-click VistaQueryTimeout_s and selectModify.

6. Enter a value for the timeout period.

The timeout period is 60 (for 60 seconds) by default. You can increase the value to 120
initially. If timeouts still occur, modify the value to 180.

7. Select File > Exit to exit the registry editor.

NOTE: If your system installation includes Client machines running Vista, you need to update
the registry for each one.

Increase the Query Server timeout

1. Open the WinPM.Net folder and double-click the Designer icon to start Designer.

2. Select File > Open > QUERYSERVER.host_name (where host_name is your workstation
name) to open the Query Server node.

3. Double-click theQuery Modules grouping object, then right-click the query module to open
its setup dialog.

4. Select the Connection String setup register and clickModify.

5. Change Connect_Timeout from the default 60 to 120 (or 180 if necessary).

6. Save your change and restart the Query Server Service.



Viewing real-time data
Vista uses numeric objects and status objects to display real-time data. Numeric objects display
real-time numeric values and status objects display real-time Boolean (ON/OFF) information.

Viewing data with numeric objects
Vista uses numeric objects to display real-time numeric data from your power monitoring system.
Numeric objects can display many types of data, such as line voltage or current, power or energy
levels, harmonics, or demand parameters.

Depending on their configuration, numeric objects can display data in different formats:
alphanumeric, dial, horizontal or vertical bar, or scrolling graph.

See Customizing the display of a numeric object for more information on configuring numeric
objects.

Using flags on a numeric object

In some cases, a numeric object may use flags to indicate the low and high limits of the displayed
parameter.

When used on a dial display, flags appear as colored areas on the dial. When used on other types
of numeric objects, flags change the object's background color to indicate that a Low, Low Low,
High, or High High limit is currently exceeded. To view or change the default colors, select
Options > Flag Colors.

The following image depicts a Low Limit of 140, a Low Low Limit of 60, a High Limit of 260, and a
High High Limit of 340. The portion of the dial between 140 and 260 is transparent in Vista (the
background color fills that portion of the dial), and is white in the Web-based Diagrams
application.

TIP: If you need only Low Low and High High limits, set the Low limit equal to the Low Low limit
and the High limit equal to the High High limit.

Flag colors are stored in the workspace file on a per-user basis. They are configurable and can be
customized by anyone who has the necessary access level. See Display options for more
information on configuring flags.
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Viewing data with status objects
Vista uses status objects to display Boolean (ON/OFF) conditions in your system. A status object
may display the status of a digital output (such as a relay), a digital input (status input), or a
setpoint in your system.

The default status object appears as an indicator light that changes color to indicate various
conditions. Gray indicates the status object is not linked or not receiving data.

Like most diagram objects, status objects can be modified by any user with an appropriate access
level. Depending on how a status object has been configured, its appearance and function can
differ significantly from the default settings.

You can specify that it appear as an alphanumeric display or you can select custom images
representing different conditions, for example for ON, OFF, and Unconnected. See Customizing
the display of a status object for more information.

NOTE: In some cases, the active state of a status object may have been changed (inverted) so
that an active state appears as inactive and vice versa. See Customizing a diagram object for
more information.

Viewing logged data
Data and events recorded by the devices in your system are regularly transferred by the Log
Inserter from each device to the database. Vista uses the WinPM.Net Query Service to transfer
this information from the database to your workstation. Vista provides two ways to view logged
data and events: the Data Log Viewer and the Event Log Viewer.

• The Data Log Viewer displays data logs from all devices represented in the active user
diagram. You can use the Data Log Viewer to display waveform and trend data in tabular
format. You can also select a range of logs from the viewer and display the data graphically in
the log view plotter.

• The Event Log Viewer typically displays events and alarms from each device represented in
the active user diagram. The Event Log Viewer is used primarily to monitor low-priority events
and alarms associated with the active user diagram. Each Event Log Viewer is associated
with a single user diagram.

Using a Data Log Viewer
Use a Data Log Viewer to view system data stored in the database. Data Log Viewers display
historical trend data (from data recorders) and waveform data (from waveform recorders).

You can select any data displayed in a Data Log Viewer and plot it as a graph or copy it to another
application (for example, Microsoft Excel) where you can perform advanced calculations or
include it in a report.

See Using the Query options for information on log viewer configuration.

Displaying a Data Log Viewer

Click on a Data Log Viewer object in your user diagram. The Data Log Viewer appears.

Each Data Log Viewer displays data as a table of columns and rows. Each labeled column
contains a single type of data and each numbered row represents a single data record.



Plotting a range of data from the Data Log Viewer

You can plot data from a Data Log Viewer in the Log View Plotter.

1. Highlight the cells containing the data that you want to plot. The range of data can be
selected in one of three ways:

To graph trends for all parameters over a particular time span, select a group of rows.

To graph the trend for a specific parameter using all available records, select the entire
column.

To graph multiple parameters over a specific time span, click on the first cell in the
desired range then drag to highlight the last cell of the range.

2. Select Edit > Plot Selected Data or click .

The Log View Plotter window appears, displaying a graphical representation of the selected
data. See Plotting logged data for more information.

TIP: To quickly plot a single waveform, double-click on its waveform symbol in the Data Log
Viewer.

Copying a selection to another application

1. Highlight the cells containing the data that you want to copy.

2. Select Edit > Copy or click . This copies the selection to the Windows Clipboard.

3. Switch to another application and paste the selection.

Using the Event Log Viewer
Events and alarms that occur in your system are recorded by the meter and transferred via Log
Inserter to the database.

Vista. Use the Event Log Viewer to view event records. The Event Log Viewer displays events
and alarms from the device(s) represented in the active user diagram. Use it to monitor low-
priority events and alarms associated with the active user diagram. The Event Log Viewer is
associated with a single user diagram, so alarms only update when the user diagram is open.

See Using the Query options for information on log viewer configuration.

Displaying an Event Log Viewer

Click an Event Log Viewer object in your user diagram to open the Event Log Viewer.

The Event Log Viewer displays logged events in a table of columns and rows. Each labeled
column contains a single category or event description and each numbered row represents a
single event record.

Typically, Event Log Viewers display the following information:

• Timestamp: This indicates the event’s date and time.

• Priority: This determines the relative significance of the event. Each type of event has a
numeric value assigned to it that represents its relative priority level.
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• Cause: This is the label and value describing the cause of the event. For example, if the label
is “Setpoint #1” and the value is “Active,” then the event was caused by setpoint #1 changing
to an active state.

• Effect: This is the label and value describing the effect of the event. For example, if label is
“Relay #1” and the value is “Forced On,” then the effect of the event was to force relay #1 on.

• Ack Time: This is the date and time that an alarm was acknowledged.

NOTE: Because Event Log Viewers are associated with a single user diagram, they only update
when the user diagram is open. All Event Log Viewers need to be re-opened if a diagram is
closed or the software is shut down.

Acknowledging alarms
Every type of event has a prioritized value that identifies its relative significance on a scale of 0
(zero) to 255. By default, Vista identifies any event with a priority of 128 (default) or greater as an
alarm.

The event record is highlighted in red, and identified under the Ack Time column as "ALARM".
The Cause column lists the source of the alarm and the Effect column describes the event.

By default, Vista plays a "beep" to annunciate an event with a priority range of 128-191, and a
beep combined with a flashing display to annunciate an event with a priority range of 192-255. To
customize these options, see Alarming options.

When you acknowledge an alarm, Vista records the time the alarm was acknowledged (in the Ack
Time column) and your user ID (in the User Name column).

The alarm acknowledgement function is also available in the Alarms application in the Web
Applications component. See the online help for the Alarms application for information about
acknowledging alarms.

NOTE: In some cases, your access level may not be sufficient to acknowledge an alarm; for
example, a critical alarm may require Supervisor access. This is a user-configurable option. See
Alarming options for more information.

Acknowledging an alarm

1. Open an Event Log Viewer, then do one of the following:

To acknowledge a single alarm, click the word ALARM in the Ack Time column or
highlight the row containing the alarm.

To acknowledge all alarms to date, click the Ack Time column heading.

A confirmation box appears, asking if you want to acknowledge the selected alarms.

2. Select Yes to acknowledge the alarms or No to cancel.

If you acknowledge the alarm but do not have a sufficient access level, the alarm remains
unacknowledged and the message "Insufficient Authorization" appears in the status line.



NOTE: When an alarm has been acknowledged in the Web-based Alarms application, and you
view the entry in the Event Log Viewer, the Ack Time and User Name columns are populated
with the appropriate acknowledgement entries for the ON value. However, these columns
remain blank for the related OFF value even though the alarm has been acknowledged.

Silencing alarms

If you are not ready or able to acknowledge an alarm, you can silence it until it can be
acknowledged by selectingOptions > Silence Outstanding Alarms.

NOTE: Acknowledging an alarm does not change the operating condition that caused the alarm.
You must ensure that the cause is corrected to remove the alarm condition.

Viewing user diagram of devices with security
You can view the user diagram of devices with security settings enabled in Vista.

To view user diagram in Vista for devices with standard security enabled,

1. Select File > Generate Network Diagram.

The network diagram appears in the workspace containing icons that represent groups of
devices on your system.

2. Click on one of the grouping objects to open a window and display the node icons contained
within.

3. Click a node icon to display the user diagram for the associated device.

NOTE: To perform any control object function, enter the device password. The user name is set
to default. Refer for Controlling system functions more information. If user name is prompted
when performing any control object function, then refer to Changes in security settings of device
for more information.

To view user diagram in Vista for devices with advanced security enabled,

1. Select File > Generate Network Diagram.

The network diagram appears in the workspace containing icons that represent groups of
devices on your system.

2. Click on one of the grouping objects to open a window and display the node icons contained
within.

3. Click a node icon to display the user diagram for the associated device.

4. Enter the user name and password of the device.

NOTE: All control object functions can be performed without entering credentials.

WinPM.Net 10.0 User Guide Chapter 4: Vista

© 2021 Siemens Industry, Inc. All Rights Reserved. 121



Chapter 4: Vista WinPM.Net 10.0 User Guide

122 © 2021 Siemens Industry, Inc. All Rights Reserved.

Controlling system functions
You can use control objects to send commands from Vista to a node.

WARNING
UNINTENDED EQUIPMENT OPERATION
• Do not use the software to control time-critical functions.
• Do not use the software to control remote equipment without proper access control and
status feedback.

Failure to follow these instructions can result in death, serious injury, or equipment
damage.

Each control object in your user diagram is configured to perform a single function. When you
click a control object, it performs the specified function. For example, you could click a control
object to clear an energy accumulator, toggle a relay, reset a counter, or adjust the value of an
analog output device.

The default appearance of a control object depends on the function it has been configured to
perform:

Boolean Pulse Numeric

Regardless of their appearance, all control objects are used the same way—to use a control
object, click it.

NOTE: For information on configuring the message, appearance and access level of control
objects, see Customizing the action for a control object and Customizing the display of a control
object.

When you click on a control object, one of the following happens, depending on how the control
object is configured:

• Vista performs the specified action immediately.

• Vista displays a confirmation message. Click Yes to proceed or No to cancel the operation.

• Vista requests a password. Type the logon password then clickOK to proceed.

Depending on the function, a dialog prompting for the meter password may also open. If so, type
the meter password then clickOK to proceed.

NOTE: There can be a time delay until Vista displays a new control value or state after it has
been written to the device.

Plotting logged data
This section describes how to use and customize the Log View Plotter to view logged data in a
graphical representation. Use the Log View Plotter to graphically show trends in numeric data,
display logged waveforms, display phasor diagrams, and perform harmonics analysis on



waveform data. You can also plot Sag/Swell voltage disturbances and compare them to industry
standard voltage tolerance curves (such as the CBEMA/ITIC curve).

TIP: You can copy information displayed by Vista Log Viewers to the Windows Clipboard and
paste it into other Windows applications.

Plotting logged data

1. Select data from a data log viewer:

To graph trends for all parameters over a particular time span, select a group of rows.

To graph a trend for a specific parameter using all available records, select an entire
column.

To graph multiple parameters over a specific time span, select the first cell in the desired
range and drag to highlight to the last cell of the range.

2. Select Edit > Plot Selected Data or click .

Vistaplots the data and displays it in the Log View Plotter window.

The Log View Plotter interface
The Log View Plotter is a Vista window that graphically displays selected data.

The default display is the Plot Display tab. Depending on the type of data selected, the Log View
Plotter may also offer a Harmonics Analysis tab and a Phasor Diagram tab.

In all cases, the Log View Plotter offers additional information in two floating boxes: the Legend
and the Calculations window.

The Legend

Each line or bar in the graph is represented by a pattern of the same color in the legend.

TIP: Click on the curve sample in the legend to select its equivalent in the graph.

Displaying the Legend

1. Right-click the background of the Log View Plotter window.

2. SelectGraph Options in the menu to open theGraph Options dialog.

3. Select the Show legend check box then clickOK.

The Calculations window

The Log View Plotter calculates several values for every line or bar in the graph. You can view the
results of these calculations in the Calculations window.

The Calculations window updates automatically, displaying a range of calculated values based on
the currently selected parameter. By default, all values displayed in the Calculations window are
calculated from the first parameter. To view the calculations for a different parameter, select the
line or bar you want.

For example, to view the calculations for a curve on the Plot Display tab, click on the curve line in
the graph or on its line pattern in the legend. When you click a different tab, the Calculations
window displays the values relevant to that tab.
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Displaying the Calculations Window

1. Right-click the background of the Log View Plotter window.

2. SelectGraph Options from the menu to open theGraph Options dialog.

3. Select the Show calculations check box then clickOK.

Changing graph options
When using the Log View Plotter, you can adjust the graph options to change the title of a graph
or the way data is displayed.

1. Right-click the graph background then select Graph Options. TheGraph Options box
appears.

Type a name for the graph in the Title box. This name appears in the title bar of the Log
View Plotter window. The default is Log View Plotter.

Select or clear the Show legend and Show calculations check boxes to show or hide
the legend and Calculations window.

Select the Align triggers check box to align the trigger times of all waveforms in the
graph. (When multiple waveforms are plotted, their trigger times may not always be
correlated.)

Select Separate curves vertically to display each curve separately.

NOTE: See Calculating Harmonics using more than one cycle for more information on the
System Frequency and # of cycles for harmonics options.

2. ClickOK to save your changes.

Displaying curve data in a table
After you plot data in the Log View Plotter, you can select a curve and display its data points in a
table. This option is only available on the Plot Display and Harmonic Analysis tabs.

1. Right-click the curve line in the Plot Display or Harmonic Analysis tab and select Data
from the menu.

Plot Display tab: The data points are displayed. The X column lists the x-axis
coordinates and the Y column lists the y-axis coordinates. The first column (#) assigns a
number to each set of points.

Harmonic Analysis tab: A window appears listing each harmonic number and the
magnitude of each harmonic for each parameter. The first column numbers the rows.
The X column lists the harmonics number and the Y1, Y2, Y3, etc., columns list the
harmonic values for each bar in the harmonics histogram. Rows where the X value is not
an integer (i.e., .5, 1.5, 2.25) contain sub-harmonic values.

2. Click Format to change the number of significant digits displayed in the X and Y columns or
to change the width of these columns.

Width defines the number of characters the column can display.

Precision defines the number of significant digits displayed.



3. Click Copy to copy columns to the clipboard. This allows you paste a copy of the data into
another application, such as a spreadsheet program or a text file.

NOTE: The Log View Plotter can only display one data table at a time. If you want to display
tabular data for another curve (from the same graph or a different one), you must first close any
open data window.

Viewing the Plot Display tab
The Plot Display tab depicts the specified parameters as curves against a graph.

Each parameter is plotted in a different color. The legend identifies the color of each curve in the
selection and what it represents. Click on a curve to select it or right-click it to display additional
options. The timestamp at the top of the tab identifies the first point in the selected curve.

The vertical axis (y-axis) represents the specified range; the horizontal axis (x-axis) represents
time. Vista automatically adjusts the scale of the y-axis and x-axis to accommodate the largest
parameter(s) in the selection. Right-click either axis to change the scale of its properties; right-
click the axis numbers to change their format.

The time unit indicator in the lower right corner identifies the time scale of the x-axis (for example,
“h” indicates an hourly scale). Possible time scale units include months, days, hours, minutes, and
seconds.

Zooming in on the Plot Display tab

To zoom in on the Plot Display tab, click on the Zoom button then drag a selection box

around the area you want to view. To view the entire plot, click the Restore to 100% button .

Calculations window parameters for the Plot Display tab

The Calculations window updates automatically, displaying the following values for the currently
selected curve:

Value Label Description

Cursor 1 The timestamp and the y-value of the selected curve at Cursor 1.

Cursor 2 The timestamp and the y-value of the selected curve at Cursor 2.

Delta C
The time difference between Cursor 1 and Cursor 2, and the
difference between the y-values at Cursor 1 and at Cursor 2.

Min
The minimum value of the selected curve between the two
cursors.

Max
The maximum value of the selected curve between the two
cursors.

dpeak
The maximum peak-to-peak value of the selected curve between
the two cursors (Max-Min).

Avg1 The average value of the selected curve between the two cursors.

RMS1
The root-mean-square value of the selected curve between the
two cursors.
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Value Label Description

Int(H)1
The integration of the selected curve between the two cursors with
respect to time in hours (for example, if the curve is in kW, the
information is displayed in kWh.)

1 The last three values (Avg, RMS, INT(H)) on the Calculations window are only available on plots
where the x-axis represents time. They are not offered on other types of plots (for example,
CBEMA plots).

Both numeric data and waveform data can be plotted in the same graph. On waveform plots, the
trigger time is represented by a red vertical line.

Using the cursor lines

There are vertical cursor lines at either end of the curves in the Log View Plotter. These cursor
lines define the start and end points used by the Calculations window. By default, Cursor 1 is
located on the leftmost point of the selected curve and Cursor 2 on the rightmost point.

To define a new start point, drag Cursor 1 along the curve to the new start point. Repeat this
procedure with Cursor 2 to define a new end point. You can also use the arrow keys to move the
active cursor left or right. The active cursor is identified by a small box that appears where the
cursor line meets the curve. Use the TAB key to switch the active cursor between Cursor 1 and
Cursor 2.

As the cursor line moves from point to point along the curve, the information in the Calculations
window is updated. You cannot drag Cursor 1 past Cursor 2 or vice versa.

De-indexing parameters and specifying Y-offsets

If you are plotting multiple parameters with different magnitudes, the lower magnitude values may
be difficult to see in the default graph. Vista allows you to index any parameter to a different axis
that can be scaled and offset independently from the other axes.

The new axis automatically assumes a scale appropriate for the selected parameter. In this way,
you can plot parameters of different magnitudes on the same graph (such as voltage and current).

De-indexing a parameter or offsetting a parameter on the Y-axis

1. Right-click the graph background to display the menu. In the last section of the menu,
highlight the curve you want to change.

The curve's sub-menu appears. (You can also access the sub-menu directly by right-clicking
on the parameter curve or on its curve sample in the legend.)

2. SelectOptions from the sub-menu to open the Curve Option dialog.

3. Choose one of the four axis options for the selected parameter. The axis is indicated by the
location of the tick marks.



Specify a Y-offset if required. This shifts the selected parameter up the y-axis (or down for a
negative number) by the amount you specify.

4. ClickOK. A new axis appears with a default title and a scale appropriate for the selected
parameter.

The scale of the default axis can also be adjusted to accommodate the remaining curves. A
parameter has an asterisk after it in the legend if it has been offset.

Repeat these steps for each parameter that you want to de-index from the default axis. You can
assign more than one parameter to an axis and the scale adjusts accordingly to incorporate each
new parameter. For example, if you have plotted three voltage parameters and three current
parameters, you can select the current curves and assign each of them to another common axis,
leaving the three voltage curves to share the default axis.

Displaying Power Factor data

If you have plotted power factor data (from historical logs) in the Log View Plotter, you can
improve the display to avoid discontinuity by setting the vertical axis to Power Factor Display (-
100,+100).

Setting any vertical axis for Power Factor display

1. Right-click the vertical axis or right-click the graph background and select the axis after you
have plotted the power factor data.

2. Select Power Factor Display from the menu. A check mark appears beside the option to
indicate that it is selected.

You can plot other non-power factor data on the same graph; however, you should not plot the
new data on the same axis as the power factor data. De-index the new data on a separate axis as
described in De-indexing a parameter or offsetting a parameter on the Y-axis.

Viewing the Harmonics Analysis tab
If any of the parameters you have plotted is a waveform, you can display a histogram of the
signal's harmonic content by selecting the Harmonics tab on the Log View Plotter window. The
resulting histogram shows the harmonics for all waveforms in the plot.

NOTE: The cycle used is the first full cycle to the right of Cursor 1on the Plot Display tab.

The total harmonic distortion (THD), K-factor and Crest factor values for this waveform are
displayed in the Calculations window.

To view the calculations for another parameter, click on it in the graph or on its curve sample in the
legend. The Calculations window updates automatically. The currently selected parameter is
indicated above the calculations.
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Calculating Harmonics using more than one cycle
By default, the harmonics are calculated using one cycle. You can increase the number of cycles
by any power of two cycles (i.e., 2, 4, 8, 16, 32 or 64) up to the maximum number of cycles
available for the waveform.

1. Right-click the background of the graph area then selectGraph Options to open theGraph
Options dialog.

2. Select the number of cycles over which harmonics calculations are to be performed from the
“# of cycles for harmonics” list.

3. Select the appropriate frequency in the “System Frequency” box, if the waveform you are
analyzing came from a system with a frequency other than 50Hz or 60Hz. (For example, if
the waveform was captured from a 400 Hz system using a 3710 ACM, specify “400Hz” in
this box.)

NOTE: The Harmonics Analysis tab is only available for waveform records. Vista does not
perform a harmonics analysis for trend data or for waveforms with less than eight samples per
cycle. You cannot display the harmonics of more than 16 parameters at a time.

Viewing the Phasor Diagram tab
If you have plotted waveforms for all three voltages and/or currents of your system, you can view
this information as a phasor diagram. The phasor diagram graphically displays the three phases
(voltages and/or currents), showing their relative magnitudes and angles.

You can use a phasor diagram to evaluate important aspects of your power system such as
voltage balance, per-phase loading, and type of load (or generator operating mode). A phasor
diagram also provides a way to identify PT or CT wiring problems.

NOTE: The timestamp at the top of the Phasor Diagram tab is based on the time of Cursor 1 on
the Plot Display tab.

To display a phasor diagram, select the Phasor Diagram tab from the Log View Plotter window.

The Phasor Diagram and calculations are derived from a one-cycle window starting at Cursor 1
on the Plot Display tab. The magnitude and angle of the selected phase is displayed in the
Calculations window.

NOTE: The Log View Plotter conforms to the convention where all phasors are plotted with
respect to V1 (always at 0°) and rotate in a positive counter-clockwise direction. On a balanced
power system, all three phases should appear 120 degrees apart.

To edit a phasor displayed on a phasor diagram, right-click a parameter in the legend to display a
menu where you can change the phasor's color or delete the phasor from the diagram.

Symmetrical components

The Log View Plotter calculates the symmetrical components of your power system— the
positive, negative, and zero sequences relative to the first phase— for the cycle selected. If you
have plotted waveforms for three voltages and/or currents, you can access their symmetrical
component calculations. To produce correct symmetrical components, the waveforms must have
been plotted in the correct order (for example, V1, V2, V3— not V1, V3, V2).



The analysis of an unbalanced system, such as determining the effects of a system fault, is made
simpler by using symmetrical components. Symmetrical components are a mathematical tool that
allows any system of three unbalanced phasors to be represented by three balanced phasor
systems. The total current or voltage in any phase wire is expressed as the sum of three
balanced, three-phase components.

Positive Sequence Components (1) - these consist of three phasors that are equal in magnitude
and displaced from each other by 120º and have the same phase sequence as the original
phasors.

Negative Sequence Components (2) - these consist of three phasors that are equal in magnitude
and displaced from each other by 120º and have the phase sequence opposite to that of the
original phasors.

Zero Sequence Components (0) - these consist of three phasors that are equal in magnitude and
with zero phase displacement from each other.

If the original phasors of voltages are Va, Vb, and Vc, then the symmetrical components would be
as follows:

• Va = Va1 + Va2 + Va0

• Vb = Vb1 + Vb2 + Vb0

• Vc = Vc1 + Vc2 + Vc0

The symmetrical components function, as implemented inside some ACCESSmeters, is useful
for steady state analysis (unbalance), since the parameters are updated every second. However,
when determining the symmetrical components during a fault, per-cycle analysis is required. For
this application, you do not need real-time updates from the meter, because you are only
interested in the relatively short time before, during, and after a system fault. This information is
contained in the waveforms recorded when triggered by a disturbance.

Viewing symmetrical components

1. From a waveform Data Log Viewer (such as Waveforms/Sequence of Events), select all
three phases of a fault (voltage or current).

2. Select Edit > Plot Selected Data.

3. Drag the Cursor and move it to the location of the fault.

4. Click on the Phasor Diagram tab to view the Symmetrical Components in the Calculations
window.

Plotting waveforms from devices with high sampling rates
Waveforms from devices with high sampling rates can be quite large. These large waveforms are
split into a series of smaller waveforms when displayed in the data log. To plot all the sections of
the waveform in Vista, you must select all the rows that relate to the waveform before you click the
Plot button. All the rows related to the one waveform have the same timestamp.

When the waveform is displayed, you may need to zoom in to view the area of the waveform you
are interested in. To zoom in, drag a selection box around the area you are interested in.
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Adding parameters to a Log View Plotter
After you have created a graph and the Log View Plotter window is visible, you can add additional
parameters to the graph by copying and pasting them into the graph. These parameters can be
copied from the same data log viewer, a different data log viewer, or from a different Windows
application such as Microsoft Excel. The x and y-axes are automatically re-scaled to
accommodate the new parameters.

When adding waveforms to the log view plotter, you can correlate all of their trigger times. See
Overlaying curves in the Log View Plotter for more information.

Adding data from a Data Log Viewer

You can add additional parameters from any data log viewer configured to provide compatible
time-based data. Any added parameter is plotted using the same x-axis used by the existing
curves. To avoid confusion ensure that the column you selected for your x-axis in the data log
viewer (from which you are adding data) contains the same parameter (typically a timestamp) as
the original data log viewer.

Adding additional parameters from a Data Log Viewer

1. Select the range of cells you want to plot. Ensure that it contains the same type of
information (timestamps) as the data already being plotted.

2. Select Edit > Copy.

3. Click on the title bar of the existing Log View Plotter window then select Edit > Paste. The
parameters you selected are added to the graph.

If you want to plot waveforms on the same graph as historical data, the historical data should
originate from high-speed data recorders and span a short time range, typically a few waveform
cycles (<1 second).

Adding events from an Event Log Viewer

You can add events to a waveform or trend plot. This is useful for comparing abnormalities of the
waveform or trend shape with any corresponding events that happened in the same time period.

1. Select the row(s) you want to add in the Event Log Viewer.

2. Select Edit > Copy.

3. Click on the title bar of the existing Log View Plotter window then select Edit > Paste. The
copied event records are added to the graph.

Each event is represented in the Log View Plotter as a diamond symbol. A diamond symbol is
added to the legend and diamond symbols appear at the appropriate areas along the top of the
diagram.

Point to a diamond symbol to display a description of the event in the status bar at the bottom of
the screen.

Adding data from a spreadsheet or text file

You can select data from a spreadsheet or text file and paste it into an existing graph. This is
useful if you want to compare trends from different times, waveforms showing different system
events, and other analysis applications.



Ensure that the first column of data in the spreadsheet or text file is the same type as the first
column in the data log viewer from which the log plot originated. In particular, for timestamps,
make sure the entire timestamp is contained in a single column and that it uses the same date and
time format as defined in the Windows Control Panel. If the date portion of the timestamp is in one
column and the time is in another, or if the format is different in any way, the data cannot be
pasted into the Log View Plotter.

When you paste data into a graph, from both spreadsheets and text files, the Log View Plotter
interprets the first row of data in the selection as a heading. The first row in your selection is used
to label the parameter in the legend. So, if the first row is not already used for column headings,
insert a row and type in the label you want to appear in the Log View Plotter.

To copy data from a text file, the text file must be formatted correctly. Each column in the text file
must be separated by a tab and there must be a hard return at the end of each row.

Adding data to a graph from a spreadsheet or text file

1. Open the spreadsheet or text file.

2. Copy the range of values you want to plot, including the first column and the first row.
Include other columns in your selection, if required.

3. Click on the title bar of the Log View Plotter window then select Edit > Paste.

The parameters you copied and pasted are added to the graph. The axis scales are
adjusted automatically to include the new data.

You can define a trigger for waveform records containing timestamps when you copy records
from other applications. Simply add an exclamation mark to the end of the timestamp to indicate
that it is the trigger time. For example, the exclamation mark at the end of
22/05/2015@02:00:41.035 PM! indicates that the trigger occurred at this time.

Customizing the Log View Plotter display
Many display attributes for each curve can be adjusted. In most cases, if you right-click an area of
the graph, either a menu or a dialog opens with configuration options. Unless otherwise noted, the
options you specify for the Log View Plotter window are saved and restored every time you plot
data from the original data log viewer. If you plot data from a different data log viewer, its graph
has its own optional settings.

Customizing an axis

After you have plotted data in the Log View Plotter, use the following instructions customize the
axis or gridlines, change an axis label’s format or add an axis title, or change the font or color used
on all axes. You can also change the scale of an axis.

Configuring an axis

1. Right-click the graph background to display the menu. Highlight the axis from the menu to
reveal the sub-menu. You can also right-click the axis to access the sub-menu directly.

2. Select Axis Properties from the sub-menu to open a dialog with the following options.
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Range: Make changes in the From and To boxes to adjust the axis range.

Ticks: Make changes in theMajor every and Sub-divided by boxes to adjust the
frequency of major and minor ticks respectively.

Grid: Select or clear theMajor andMinor check boxes to turn graph gridlines on or off.
Click the Style buttons to change to the line style or width of major and minor gridlines.

Logarithmic scale: Select this check box to enable the logarithmic scale option.

Line: Click this button to display the Line Parameters dialog and change the line style
or the width of the axis.

3. ClickOK to save your changes.

NOTE: The axis range and the frequency of the major ticks are not stored in the diagram but are
recalculated for every new plot.

Changing the color of an axis or the gridlines

1. Right-click the graph background to display the menu. Highlight the axis from the menu to
reveal the sub-menu. You can also right-click the axis to access the sub-menu directly.

2. Select Axis Color,Major Grid Color, orMinor Grid Color from the sub-menu to open the
Color dialog.

3. Select the color you want or click Define Custom Colors for more options.

4. ClickOK to save your changes.

The axis or the major or minor gridlines change to the color you selected.

Changing the format of the axis labels or adding an axis title

1. Right-click the graph background to display the menu. Highlight the axis from the menu to
reveal the sub-menu. You can also right-click the axis labels to access the sub-menu
directly.

2. Select Axis Labels from the sub-menu to open the Axis Labels dialog.

3. Select the format in which you want the axis labels to appear.

Decimal is used by default (for example, .01, .02, .03) but if the labels are too large or too
small, select Scientific (1.0 x 10-2, 2.0 x 10-2, 3.0 x 10-2...) or Engineering (1m, 2m, 3m...).

4. Determine the axis title: select None to have no axis title or Text to enter your own title.

For time-based plots, the default x-axis title is “s” if the timestamps of the data spans a
number of seconds, “mn” for minutes, “h” for hours, “d” for days, “m” for months. (This
applies to the Plot Display tab only.)

For non time-based plots (CBEMA or harmonics), you can change the title. Select Text and
type the title in the edit box. The title must be nine characters or less.

5. ClickOK to save your changes.

NOTE: If the first column of the source data includes a space or @ sign, the Log View Plotter
assumes time on the horizontal axis and automatically determines the units based on timestamp
information. The axis title is updated whenever the window is updated.



Changing the font used on all axes

1. Right-click anywhere in the graph background and selectGraph Font to open the Font
dialog.

2. Specify the font, style, size, effects and color options that you want to use for the axes
labels.

3. ClickOK to save your changes.

Customizing curve style

When displaying multiple parameters, Vista distinguishes between parameters using color. Each
parameter is listed in the graph legend accompanied by a sample of its associated curve. The
color of a curve can be changed after you have plotted data in the Log View Plotter.

If color is not enough to distinguish one curve from another—for example, if you plan to print the
graph on a black and white printer—you can change the curve style after you have plotted data in
the Log View Plotter.

By default:

• Each curve is shown by a thin line that connects each point of data. You can customize the
style of each curve independently and show or hide the coordinates of each data point.

• Harmonics are displayed in a bar graph. You can distinguish between parameters by
customizing the display style of each parameter. Display options include bar type, hatching,
width and color.

Use the following instructions to customize curve styles, bar styles, and curve colors.

Changing the style of a curve on the Plot Display tab

1. Right-click the graph background to display the menu. Highlight the curve from the menu to
reveal the sub-menu. You can also right-click the parameter curve in the diagram or its entry
in the legend to access the sub-menu directly.

2. Select Curve Properties from the sub-menu to open the Curve Style dialog.

Select the type of curve you want from the Type list. Vista offers seven curve types: a
simple line, a line with symbols, a scatter plot of markers, horizontal or vertical bars, or
3-D horizontal or vertical bars.

Select Spline (available for Line or Line + Symbol types) if you want the line that
connects each point to be a smooth curve. If you leave it cleared, each pair of points is
connected by a straight line.

Select Fill Area (available for Line type) to fill the area under the curve with the line
color. Clear the check box to leave the area under the curve transparent.

TheMarker section is available for Line + Symbol and Scattered types of lines. Specify
the shape, size, and style of the marker used for the points. The Style options apply only
to geometric shapes (for example, circles, boxes, diamonds, etc.).

For any line type, click Line to change the width and the style (for example, solid, dotted,
dashed, etc.) of the line. For bar graph types, a dialog opens where you can specify the
hatching pattern and the width of the bars.

3. ClickOK to save your changes.
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Changing the bar style for the Harmonics Analysis tab

1. Right-click the bar (or on its curve sample in the legend) and select Curve Properties to
open the Bar Graph Configuration dialog.

2. Select the type of bar to use from the Type list. This selection is applied to all bars in the
graph. Three bar styles are available:

Group Bars: Shows bars side-by-side

Deep Bars: Shows bars one behind the other

Stacked Bars: Shows bars stacked one on top of the other vertically

3. Select a hatching style for the selected bar from the Hatching list. This selection is applied to
the currently selected bar only.

4. Set how wide you want each bar to be in the Width text box. The specified width is applied to
all bars in the graph. The default depends upon the number of parameters.

5. ClickOK to save your changes.

Changing the color of a curve

1. Right-click the graph background to display the menu. Highlight the curve from the menu to
reveal the sub-menu. You can also right-click the curve in the diagram or its entry in the
legend to access the sub-menu directly.

2. Select Curve Color from the sub-menu to open the Color dialog.

3. Select the color you want or click Define Custom Colors for more options.

4. ClickOK. The curve changes to the color you selected.

Customizing graph and legend options

After you have plotted data in the Log View Plotter, you can change the color of the graphing area
(and the legend) and define a font for the legend.

Changing the color of the graphing area

1. Right-click anywhere in the graph background and select Background Color to open the
Color dialog.

2. Select the color you want or click Define Custom Colors for more options.

3. ClickOK. The graphing area changes to the specified color.

Changing the font used in the legend

1. Right-click the background of the legend to open the Font dialog.

2. Specify the font, style, size, effects, and color options that you want to use for the legend
text.

3. ClickOK to save your changes.



Removing graph parameters
After you have plotted data in the Log View Plotter, you can remove a parameter from the graph.

1. Right-click the graph background to display the menu. Highlight the curve you want to
remove from the menu to reveal the sub-menu. You can also right-click the curve in the
diagram or its entry in the legend to access the sub-menu directly by right-clicking on the
curve.

2. Select Delete Curve from the sub-menu. The curve is deleted without further prompting.

Overlaying curves in the Log View Plotter
After you plot data in the Log View Plotter, you can overlay a curve onto your graph to help
analyze sag/swell data. This applies to devices that measure disturbances in voltage and store
the magnitude and duration of these disturbances. When these values are inserted into the ION_
Data database, they provide a series of coordinates that can be plotted on a voltage tolerance
curve. A voltage tolerance curve is often used to categorize the severity of a voltage disturbance.

NOTE: Most Vista queries are plotted against timestamps (with the timestamp as the x-axis);
however, any query that uses the ION Sag/Swell module must be plotted against duration.
When plotting sag/swell data, select Duration as the X-parameter of the Log View Plotter.

Vista provides common curves or voltage tolerance envelopes that can be used as overlays in the
Log View Plotter:

• CBEMA/ITIC: These curves (for CBEMA, described by the IEEE standard 446-1987, and for
ITIC, described by the IEEE 1100-1999 standard) define an upper and a lower bound on the
types of disturbances that electrical equipment is likely to tolerate. It plots disturbance
magnitude against disturbance duration and indicates at what points a voltage disturbance is
likely to disrupt or damage equipment. Points near or outside the voltage tolerance envelope
indicate events that could interrupt or damage electrical equipment.

• SEMI F47-0200: This specification defines the voltage sag tolerance capability required for
semiconductor processing equipment, though it is now used by other industries. According to
the specification, equipment must tolerate sags to 50% of nominal voltage for up to 200
milliseconds, sags to 70% of nominal voltage for up to 0.5 seconds, and sags to 80% of
nominal voltage for up to 1 second. Points above the voltage tolerance curve indicate
disturbances that exceed these specifications.

Overlaying curves on plotted data

To overlay one of the provided curves, you need a data log viewer that contains the magnitude
and duration values for the sag/swell disturbances. The Duration column must be set as the X-
parameter for the Log View Plotter—it appears in blue in the data log viewer table (See X-
parameter for Log View Plotter for more information on setting the X-parameter for Data Log
Viewers). The Magnitude values can be in any one of the other columns.

1. In the Data Log Viewer, select a range of cells to be plotted.

2. Select Edit > Plot Selected Data. The Log View Plotter window appears with Duration as
the x-axis and Magnitude as the y-axis.
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3. Right-click the graph and selectOverlay Curve from the menu to open theOverlay Curve
dialog.

4. Select the text file containing the curve data that you want to overlay (from the
...\WinPM.Net\config\lvp directory).

5. ClickOpen. The selected curve appears in the graph.

You can review each point in your data and see where it falls in relation to the curve.

NOTE: This process automatically changes your x-axis scale to logarithmic.

Creating and customizing a user diagram
The following sections describe:

• How to customize an existing user diagram by customizing the appearance and function of a
diagram object or diagram window.

• How to create a new user diagram.

• The various types of diagram objects and how to use each type to add function to your user
diagram.

NOTE: You must have the appropriate security clearance to edit or create a user diagram. To
determine if you can edit a diagram, selectOptions > Show Toolbox. If you can select this
option, then you can edit a diagram. Consult your network administrator if you need to change
your access privileges.

NOTE: Any changes you make to a default diagram affect all other devices using the same
diagram.

Creating a new user diagram

To create a new user diagram, login to Vista and select File > New. A new (blank) user diagram
appears. You can only create a new user diagram if you have supervisor-level access.

To automatically generate a network diagram based on devices added using Management
Console, see Generating a network diagram.

Saving a user diagram
To save changes you made to a user diagram:

1. Select File > Save to save a new or existing user diagram, or File > Save As to open the
Save New Diagram dialog.

2. Type a name for the diagram in the File name field and click Save.

By default, Vista points to the root of the \ud directory when you attempt to save a new diagram. If
required, you can create a new folder within that directory to store your customized diagrams,
rather than storing them in the \ud folder.

NOTE: This \ud directory should be located on a networked drive where it can provide multiple
users with access to saved user diagrams.



NOTE: You should notify users of the Diagrams application in the Web Applications component
of the location of the new custom network diagram if they want to use it instead of the
automatically generated diagram. Users of the Diagrams application need to update the registry
settings on their computer to specify the location of the new custom network diagram. See
"Custom network diagram setup" in the Diagrams section of the Web Applications online help.

Editing a user diagram
To edit a user diagram, the Diagram Objects toolbox must be displayed. To open the toolbox,
selectOptions > Show Toolbox. If the Show Toolbox option is grayed out, your user account
does not have sufficient access; contact your system administrator.

The Enable Undo option
The Enable Undo option enables or disables the undo feature in Vista. With this option active, you
are allowed to undo or “step backward” up to three times. This feature is enabled by default. If you
disable the undo feature, you lose the ability to undo any previous changes. You cannot enable
the feature and undo changes made prior to enabling the feature. A check mark appears beside
Enable Undo in the Options menu when this option is selected.

NOTE: The Show Toolbox option must be selected for the Enable Undo option to become
active — it remains unselectable otherwise.

Adding a diagram object to a user diagram
You can add a new diagram object to a user diagram by dragging it from the Diagram Objects
toolbox.

Types of diagram objects

Diagram objects provide the interface to ION registers in your network. Each diagram object
performs a single function. For example, a single numeric object placed in a user diagram
displays numeric data from a single source. There are seven types of diagram objects available
on the Diagram Objects toolbox:

Grouping Object:
Group a number of related objects within a separate grouping window. Click on a
grouping object to open the grouping window and display its contents.

Text Box:

Display independent headings, titles, and comments in a user diagram.

Numeric Object:

Display real-time numeric values such as Volts, Amps or kW.

Status Object:
Display Boolean data (On/Off, Yes/No, 1/0, etc.) or device-dependent conditions to
indicate the status of a digital output (relay), digital input (status input) or setpoint. The
image can be customized and it can be configured to use animation.

Data Log Viewer:
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Display data logs stored in the ION_Data database (including archives from previous
versions of the product), show waveform data (waveform capture, waveform recorder)
and trends (data recorders) using tables, and provide data for plotting.

Event Log Viewer:
Display event logs stored in the ION_Data database (including archives from previous
versions of the product), show event records from devices and other components, and
display alarms.

Control Object:
Send commands to a device on your network (for example, clear an energy accumulator,
toggle a relay, reset a counter, or adjust the value of an analog output device).

To add a function to a user diagram, choose the type of diagram object you want, drag it into the
user diagram then link it to the appropriate register in a node. The following sections explain how
to add and link a diagram object.

See Monitoring your system in Vista for more information on the function and basic use of each
type of diagram object.

Adding a diagram object to a user diagram

1. SelectOptions > Show Toolbox if the toolbox is not displayed. The toolbox appears in the
workspace.

2. Click on the diagram object you want and drag it from the toolbox to the diagram.

In most cases, the object appears in the window as the icon from the toolbox. However,
there are two exceptions:

A text box appears in the window as a rectangular box that displays the default
message: “Your text goes here.”

A numeric object appears in the window as a rectangular box with a colon (:). This
indicates that the object is not yet linked to a node.

The object is now ready to be linked to a real-time or logged data source. See Linking a
diagram object to a data source for details on linking an object to a source.

NOTE: When a diagram object is placed in a window, it automatically uses the same node as the
window. If you want to change this source, either relink each diagram object or change the
default window link before placing the objects.

Cutting, copying, and pasting a diagram object
Use the Cut, Copy and Paste commands on the Edit menu to make a copy of a diagram object
and paste it into another window or user diagram.

You can paste the copy as many times as you like to create multiple versions of an object. Each
copy retains all of the attributes and linkage information of the original.



Cutting or copying a diagram object

1. Select the object(s).

2. Do one of the following:

To remove the original, select Edit > Cut then click Yes to confirm the deletion or No to
cancel.

To retain the original, select Edit > Copy. The selection is copied to the WinPM.Net
clipboard.

NOTE: The WinPM.Net clipboard is a temporary storage area that holds any information cut or
copied from Vista. It should not be confused with the Microsoft Windows Clipboard.

After the object is copied to the clipboard, you can paste it into the active window.

Pasting a diagram object

1. Select the window you want to paste to.

2. Select Edit > Paste. The object appears in the active window.

Copying a group of diagram objects to a framework
A Vista framework is a template that you can use to record the layout of a group of diagram
objects.

When you select Edit > Copy to framework, Vista saves the selection (including the type and
location of each diagram object) as a file. You can then use the Paste from framework command
to copy the group layout to another diagram or grouping window. This is useful for replicating a
single configuration on multiple workstations. You can store a saved framework with its own
filename and retrieve it anytime.

Copying a group of diagram objects to a framework

1. Select the group of objects you want to copy.

2. Select Edit > Copy to framework to open the Copy to framework dialog.

3. Type a name for the framework in the File name box then click Save. The framework file
extension (.fwu) is added automatically.

The selection is saved as a framework.

After you save a group of objects as a framework, you can paste it to another window.

Pasting a group of diagram objects from a framework

1. Select the window you want to paste to.

2. Select Edit > Paste from framework to open the Paste from framework dialog.

3. Navigate to the framework you want to paste and clickOpen. The framework selection
appears in the active window.

Adjusting diagram object layout and size
This section describes how to move, align and resize diagram objects.
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Moving diagram objects
You can move a single diagram object or a group of diagram objects within a single window or
from one window to another.

1. Select the object(s) you want to move.

2. Drag the selected object(s) to the new location.

You can also use the arrow keys on the keyboard to move the selected diagram object(s) one
space at a time.

When diagram objects overlap, use the Send to Back command to place one object beneath the
others. Select the object then select Edit > Send to Back (or press CTRL+K).

Resizing a single diagram object
You can adjust the size of a diagram object to make it larger or smaller or you can stretch it
horizontally or vertically to change its shape.

1. Click on the diagram object to select it.

2. Do one of the following:

To make the object larger or smaller, drag a corner handle.

To stretch the object horizontally or vertically, drag a middle handle.

Resizing a diagram objects to a standard size
The Size tab in the Layout dialog lets you automatically resize a diagram object or group of
diagram objects to a set of standard dimensions.

1. Select the diagram objects you want to resize.

2. Select Edit > Layout or click to open the Layout dialog.

3. Select the Size tab.

4. Edit the horizontal and vertical dimensions of the object(s) as required.

Select No change to make no changes to that dimension.

Select Shrink to smallest orGrow to largest to adjust the width and/or height to
match that of the smallest or largest object in the selected group.

Select Pixels to enter the exact width or height in pixels.

You can also combine horizontal and vertical options on a single selection. For example, if
you select Shrink to Smallest in the Horizontal section and 30 pixels in the Vertical section,
the entire selection is resized to the width of the shortest object and the specified height of
30 pixels.

5. ClickOK to save your changes.



Aligning diagram objects relative to each other
The Align tab of the Layout dialog lets you specify the horizontal and vertical arrangement of the
selected objects.

1. Select the diagram objects that you want to align.

2. Select Edit > Layout or click to open the Layout dialog.

3. Select the Align tab to specify the horizontal and vertical alignment of the object(s).

The options in the Horizontal and Vertical areas determine the criteria by which you can
align diagram objects. For example, if you select Left sides under Horizontal and Space
evenly under Vertical, Vista aligns all objects in the selection by their left sides (using the
leftmost object for reference) and distributes them evenly along a vertical axis.

4. Select the options you want then clickOK.

Aligning diagram objects on a grid

TheGrid tab of the Layout dialog lets you activate and configure an invisible grid. Objects placed
onto the grid snap to the nearest gridline to help align and space them evenly.

To activate or deactivate the grid:

1. Select Edit > Layout or click to open the Layout dialog.

2. Select theGrid tab.

3. Select one of the following options:

No grid turns the grid off.

Grid size in pixels activates the grid. Type a number in the “Grid size in pixels” box to
specify the size of the grid (distance between grid lines).

4. ClickOK to save your changes.

Customizing a diagram object
After you have placed and linked a diagram object, you can customize it. Right-click a diagram
object in edit mode to display the configuration options available for that object type.

Customizing a diagram object

1. Right-click the diagram object to open the <Object> Configuration dialog (where <Object>
is the type of diagram object selected).

2. Select the appropriate tab and make your changes. Repeat this step for the other tabs until
you have made all your desired changes.

3. ClickOK to save your changes to the diagram object.

The options available vary depending on the tab and the object selected. See the sections below
for details on the options available for different tabs and objects.

The Preview pane

Use the Preview pane to view how your proposed changes will appear in the diagram.
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For some tabs, you access dialog boxes by right-clicking on the image in the Preview pane (for
example, the Display tab of a numeric object). More information is given in the relevant sections
that follow.

Available configuration options

The following table lists the various configuration options available for each type of diagram
object.

Available Option
Tabs

Diagram Objects

Grouping
Object

Text Box
Object

Numeric
Object

Status
Object

Data Log
Viewer

Event Log
Viewer

Control
Object

Caption x x x x x x

Text x x x x

Edit Text x

Link (or Node)1 x x x x

Query Server2 x x x x x x

Display x x x x

Action x x x x

Box x x

Annunciation x

Query3 x x

Alarming x
1 Node is the tab available with Grouping Objects.
2Query Server is only available on Grouping, Numeric,Status, and Control objects when the Action is set to something other
than none.
3 See Querying the database for information on configuring this option.

Caption options
To view caption options, right-click the object then select the Caption tab.

Use the Caption tab to add custom, user-defined text to a diagram object. The Caption tab is
available for the following diagram objects: Grouping, Numeric, Status, Data Log Viewer, Event
Log Viewer, and Control.

The Caption tab contains three sections: Caption, Font, and Position.

The Caption section determines whether a diagram object displays a textual comment along with
the diagram object’s icon. This section has three options:

• Select None to display no caption.

• Select Use default to display the default Vista caption (i.e., the device name or data source).

• Select Use custom to display the text that you type into the field provided.



The Font section allows you to change the font used in a caption. This section has two options:

• Select Inherit from parent window to use the default font.

• Select Custom to specify a custom font. Click Font to open the Font dialog and change the
font, size, style or color.

The Position section has two options:

• Select Top to place the caption above the diagram object.

• Select Bottom to place the caption below the diagram object.

Text options
Some diagram objects have a text label integrated into the display. To edit the appearance of this
label, use the options offered on the Text tab. The Text tab is available for the following diagram
objects: Numeric, Status, Control, and Text.

NOTE: You can edit the text displayed in a text label. For a numeric, status or control object, use
the Label section of the Link tab. For a text box object, use the Edit Text tab.

To view the Text options, right-click the object then select the Text tab. The Text tab has two
sections: Font and Position.

The Font section has two options:

• Select Inherit from parent window to use the default font

• Select Custom to specify a custom font. Click Font to display the Font dialog and change the
font, size, style or color.

The Position section has three options— Left, Center and Right— to define the alignment of
the text in relation to the diagram object. Use the Preview area located beside the Text tab to view
your proposed changes.

Edit Text options
To view the Edit Text options, right-click the object then select the Edit Text tab.

Use the Edit Text tab to specify a text message for the text box. The Edit Text tab is available on
the text box object only.

The Edit Text tab has two options:

• Use default displays the window link information (i.e., the node).

• Use custom displays your custom text message.

If you select custom, use the text box to enter your text. The text box supports multiple lines of
text. If your message appears incomplete or truncated after you enter text and clickOK, you can
adjust the dimensions of the text box object. To resize a text box, select it then drag its handles.

The font used in the text box is based on the default setting specified for the active window. Use
the Text tab to specify a different font or position for the text box. Use the Box tab to specify a
border style or change the background color.
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Link options
To view the link options, right-click the object then select the Link tab.

Use the Link tab to link a diagram object to a real-time source, and to specify a new text label. The
Link tab is available for the following diagram objects: Numeric, Status, and Control.

NOTE: To set a real-time source for a grouping object, use the Node tab.

The Link tab contains two sections: Link and Label.

Use the Link section to specify a real-time source for the diagram object. See Linking a numeric,
status or control object for more information.

Use the Label section to change the object's text label. The Label section has three options:

• Select None to display no label.

• Select Use node label to display the node's register label. This is the default.

• Select Custom to display the label that you type into the text field provided. The custom
labels you create are stored in the user diagram and are only available to users of your
diagram.

TIP: If you have specified custom labels in your diagram, or custom labels have been applied to
an ACCESSmeter at the device level, you can display the default labels at any time by selecting
Show Default Labels from theOptionsmenu. This displays the default label of the data source
instead of the label assigned in the device or in the user diagram.

Query Server options
Use the Query Server tab to connect a diagram object to a Query Server. The Query Server tab is
available on the Data Log Viewer and Event Log Viewer objects. See Linking a Data Log Viewer
or Event Log Viewer for more information.

The Query Server tab is also available on grouping objects and any object configured to open a
grouping window or user diagram. In this case, use the Query Server tab to specify a default
Query Server for the associated grouping window or user diagram. See Query Server: setting a
default Query Server for a window for more information.

Display options
Use the Display tab to customize the appearance of a diagram object. The Display tab is
available for the following diagram objects: Numeric, Status, Control, and Grouping.

The Display tab offers a unique set of options for each type of diagram object. To view the display
options, right-click the diagram object then select the Display tab.

Customizing the display of a numeric object

Numeric objects display real-time data in your user diagram. The default numeric object appears
as a rectangular alphanumeric display with a single decimal place of resolution and no unit
symbol. You can customize the display to change any of these default elements.



NOTE: Vistasupports a maximum of 59 non-alphanumeric numeric objects within a single
window. To change the way numbers are displayed (thousands separator and decimal point),
use the Regional Settings option of the Windows Control Panel. You can also use this option to
customize the time and date styles. (The year/month/day format can be modified, and the clock
can be changed from am/pm to 24 hour.)

Setting Display style
The Display style box lets you select a new style from the list of available choices. The following
styles are available:

• Alphanumeric: Default style. General-use text display.

• Partial Dial: General use voltage, current, harmonic distortion, etc.

• Full Dial: power factor, bi-directional power flow, etc.

• Horizontal Bar: General use.

• Vertical Bar: General use.

• Scrolling Graph display: General use. Displays recent readings on a scrolling graph.

• Arc Meter Display: General use voltage, current, harmonic distortion, etc.

• Timestamped display: Displays the value, and the date and time the value was measured by
the device. Useful for min./max. values.

• Timestamp Only: Same as timestamped, but does not display a value. Can be used as a
clock.

• PC Timestamped Display: Displays the value, and the date and time the value was received
by Vista.

Setting Units and Resolution

Use the Units box to type the unit name for the measured value (for example, “Volts” or “Amps”).
This name is displayed on the numeric object.

In certain cases, the value is scaled. For example, if the unit name begins with K, M, or G (for
example, kV or MVolts), the displayed value is adjusted accordingly. However, if the unit contains
certain letters (i.e., kW or kVA), the scaling factor is reduced by 1,000 (for example, if the unit
begins with K, the value is not scaled and M is scaled by 1,000). The reason for this is that most
devices provide these values already scaled.

Use the Resolution box to specify the number of decimal places to be displayed for a numeric
object. The default value is 1, but this can be increased to take advantage of any extra resolution
available from the data source.

NOTE: Specifying higher resolution does not result in higher accuracy than the specified
accuracy of the device.
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Setting the Font options
Use the Ticks Labels Font section to define font options (such as style, size, and color) for the
numeric object. This section has two options:

• Select Inherit from parent window to use the default style.

• Select Custom to specify a custom style, then click Font to open the Font dialog and make
your changes.

Setting Flags

Use the Flags button to display the Normal Operating Range dialog. Use this dialog to set a Low
Low Limit, Low Limit, High Limit, and High High Limit, and define a normal operating range to be
displayed on the numeric object. After flags have been set, you can use them to quickly determine
whether a reading is within the normal range you defined.

The effect of setting these limits depends on the display style you have specified. For example, on
the Partial Dial, Full Dial, and Arc Meter displays, flags appear as colored ranges on the dial. On
other types of numeric objects, the flag function changes the object's background color whenever
a limit is exceeded.

To view or change the default colors, selectOptions > Flag Colors.

NOTE: The flags used in Vista are not linked to setpoints in ACCESSmeters. Setpoint activity is
automatically logged by the Log Inserter. Setpoint status can be monitored using a status object
and/or data log viewer.

Other display options for Vertical or Horizontal Bar graphs
In the Preview section of a vertical or horizontal bar graph Display tab:

• Right-click the axis labels to display the Axis Labels dialog. Select the Format (Decimal,
Scientific, or Engineering) and determine the Axis Title (none or custom text).

• Right-click the axis tick marks to display the Vertical or Horizontal Axis dialog. Configure the
Range, Ticks and Grid style. Select Logarithmic scale to enable the logarithmic scale option.

Other display options for Partial Dial, Full Dial and Arc Meter displays
To configure meter parameters on partial dial, full dial or arc meter displays, right-click anywhere
in the Preview section of the Display tab.

Set the Range, Arc Position, Ticks, and dial Position. For full and partial dial displays, set the label
position to inside or outside. Click Line Attributes to set the style and width of the dial.

Other display options for Scrolling graphs
In the Preview section of the Display tab:

• Right-click the vertical or horizontal axis tick marks to open the Vertical and Time Axis dialogs.
Set the Range and Ticks, and (for the vertical axis) Grids Style.

• Right-click the vertical axis labels to display the Axis Labels dialog. Select the Format
(Decimal, Scientific, or Engineering) and determine the Axis Title (none or custom text).

• Right-click the graph background to display the Scrolling Graph dialog where you can set the
Sample Interval and Relative Reset.



The sample interval determines the resolution of the X-axis in seconds. It should be set
between one tenth and one hundredth of the X-axis range; for example, when extending the
range to one hour (3600 seconds), the sample interval should be set to approximately 60
seconds.

The relative reset is a percentage that determines the amount the scrolling graph shifts back
upon filling the plotting area. (For example, a relative reset of 0.5 shifts back 50%; a relative
reset of 0.99 scrolls the most smoothly.)

Customizing the display of a status object

Status objects display the status of Boolean “on/off” conditions in one of three ways: an indicator
light, an alphanumeric field, or a custom image.

To view the display options of a status object, right-click the object then select the Display tab.

NOTE: To invert the default color scheme, select “Invert active state” from the Annunciation tab.

The Display tab has three options:

• Select Default image to display the default indicator light image, which changes color to
indicate various conditions: by default, green indicates an OFF condition, red indicates an ON
condition and gray indicates a status object that is not connected or is not receiving
information. Device dependent multi conditions (HighHigh, High, Normal, Low, and LowLow)
also use colors to indicate the various conditions.

• Select Custom images to use custom images for each condition. Custom images can show
animation, customized buttons, and so on.

For each item selected under Condition (ON, OFF, and Unconnected), click Browse to
locate and select the image you want to associate with the condition. To hide the status object
in a given state, leave the image field blank.

Currently, the custom image option supports the following graphic file formats: BMP,
animated GIF, transparent GIF and PNG, WMF (Windows Metafile), EMF, JPG, AVI (without
audio and uncompressed or compressed using RLE8 compression).

NOTE: GIF, JPG, and PNG images need to be in \config\diagrams under the product's
installation location or they will not be shown in the Web-based Diagrams application.

You can use three different files to represent the three display states (ON, OFF, and
Unconnected) of a status object. Each of these files can also be of a different type (for
example, BMP, GIF, and JPG), however you cannot mix AVI and animated GIF images within
a status object.

• Select Alphanumeric to display the Boolean state or multi-condition state labels stored in the
device and choose custom colors to visually indicate the corresponding states.

For example, suppose “Running” has been stored in a meter as the label for the Boolean
register that stores the ON condition of a motor relay and “Stopped” for the OFF condition.
You can show this register label together with the status label using the alphanumeric display
style. You can override the meter labels on the Link tab.

ClickON Color andOFF Color to specify the colors associated with each condition.
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You can also have multi conditions if you link the status object to an enumerated register
instead of a boolean. You can do this for BCPM devices.

Customizing the display of a grouping object

The grouping object can be displayed as the default image, a custom image, or no image. You
can customize the display to change any of these default elements.

To view the display options of a grouping object, right-click the object then select the Display tab.

The Display tab has three options:

• Select Default image to use the default image for a grouping object that appears in the
toolbox.

• Select Custom image to display a custom image. Enter the filename of the image you want
to use or click Browse to locate and select an image. The filename should include the file's
extension (.bmp, .jpg, .png, .gif, .emf, .wmf, or .avi).

• Select None to hide the grouping object. With no image specified, the grouping object is
transparent unless you select it (displaying the handles). If you move the mouse over a
transparent object, the status line displays the size and object type (for example,
“30x30:Grouping Object” in the status line means the hidden object is a grouping object and
its size is 30 pixels by 30 pixels).

Hiding a grouping object is especially effective when using a custom background image; you
can integrate your transparent grouping objects into the image by placing them at the
appropriate points on the drawing. Users can display site-specific information by double-
clicking on the appropriate spot in the background. See Image: Displaying a background
image for information on using a custom background.

Customizing the display of a control object
A control object appears differently depending on the type of register to which it is linked. This
same criteria also determines the display options available.

To view the display options of a control object, right-click the object then select the Display tab.

The options available depend on the type of control object.

External Numeric

A control object that is linked to an External Numeric module appears as an alphanumeric display
box. The Display tab has the following sections: Border and Background Color.

In the Border section, select Hide to show no border or select Show to display a border. If you
select Show, you can specify the width in pixels and click Color to choose a color for the border.

In the Background Color section, select Transparent for no background or select Custom then
click Color to define a color for the background.

External Pulse



A control object that is linked to an External Pulse module appears as a button icon, by default.
The Display tab has three options: Default image, Custom image and None.

Select Default image to display the button icon. Select Custom image and click Browse to select
a different image. Select None to show no image (the control object is hidden but still functions).

External Boolean

A control object that is linked to an External Boolean module appears as a switch icon, by default.
The Display tab has two options: Default image or Custom images.

Select Default image to display the switch icon. Select Custom images then click Browse to
define custom images for ON, OFF and Unconnected. To hide the control object for a given state,
leave the appropriate box blank. Currently, the custom image option supports the following
graphic file formats: BMP, JPG, PNG, GIF, EMF, WMF (Windows Metafile), and AVI (without
audio and uncompressed or compressed using RLE8 compression).

Note that you cannot mix AVI and animated GIF images within a control object.

Action options
To view the action options, right-click the diagram object then select the Action tab.

Use the Action tab to specify the response of a diagram object when it is clicked (in Display mode)
or double-clicked (in Edit mode).

The Action tab is available for the following diagram objects: Numeric, Status, Grouping, and
Control objects. Depending on the type of diagram object, the Action tab displays one of two sets
of options:

• Specify an action for a numeric, status, or grouping object

• Customize the action for a control object

Specifying an action for numeric, status, or grouping objects

NOTE: If you change the action for a grouping object that is already associated with a grouping
window, the existing window (and any objects within it) is deleted. Vista displays a message
before performing this action.

When you right-click a numeric, status, or grouping object, the Action tab displays the available
options:

• Select None if you do not want the object to support an action. This is the default for numeric,
status, and grouping objects.

• SelectOpen Grouping Window to open a grouping window when the object is clicked. You
can use this grouping window to display additional information. For example, if a numeric
object displays a total value (such as total kW), you can display specific information (such as
kW readings for each phase) in an associated grouping window.

WinPM.Net 10.0 User Guide Chapter 4: Vista

© 2021 Siemens Industry, Inc. All Rights Reserved. 149



Chapter 4: Vista WinPM.Net 10.0 User Guide

150 © 2021 Siemens Industry, Inc. All Rights Reserved.

• TheOpen Diagram for Meter Template option is used by default each time a network
diagram is generated. Each meter icon in the network diagram is set to open the default
diagrams that match that meter's configuration.

• SelectOpen User Diagram to open a user diagram when the object is clicked. Type the full
path and filename into the field provided or click Browse to locate the diagram you want.
Using this action, you can choose a diagram object that displays a representative reading
from an independent diagram and use it to open the other diagram when clicked.

• SelectOpen File to open a file when the object is clicked. Type the full path and filename into
the field provided or click Browse to locate the file you want. The file can be a third-party
program or some other document; if a document is specified, then the program associated
with the file extension is launched and the specified document is loaded into the application.

• SelectOpen Web Page to open a specified webpage in your default web browser when the
object is clicked. Type the entire address into the field provided.

NOTE: When you select any action other than None, the Query Server tab is added to the top of
the object configuration box. You can use this tab to specify a source of logged data for the new
user diagram or grouping window. If you enter only the filename into the field provided (and do
not specify a directory), Vista defaults to
...\WinPM.Net\config\diagrams\ud.

Customizing the action for a control object

To view the action options of a control object, right-click the control object and select the Action
tab.

WARNING
UNINTENDED EQUIPMENT OPERATION
• Do not use the software to control time-critical functions.
• Do not use the software to control remote equipment without proper access control and
status feedback.

Failure to follow these instructions can result in death, serious injury, or equipment
damage.

The Action tab offers three options that you can use to define how the control object responds
when clicked:

• Select No confirmation to have no confirmation message displayed.

• SelectMessage box confirmation to display a message box when the object is clicked. The
message box requires the user to click eitherOK or Cancel.

• Select Password confirmation to request the user’s logon password when an object is
clicked.

The Level to operate list allows you to specify the access level required to perform the action.



Box options
To view the Box options, right-click the object then select the Box tab.

Use the Box tab to add a border or background color to a diagram object. The Box tab is available
for the following diagram objects: Numeric, Text Box, and any status object that has been
configured as an alphanumeric display

The Box tab has two sections:

• Border lets you adjust a border’s width and color as well as whether or not it is displayed.
Select Hide to remove the border or Show to display it. If you select Show, click Color to
define a border color and type a number in theWidth in pixels field to change the line
thickness.

• Background Color lets you set the background color of an object. Select Transparent to
use the background color of the parent window or select Custom and click Color to select
another color.

NOTE: A Numeric Object uses the diagram background color in Vista when set to
Transparent, which makes it look transparent. In Diagrams (web application), this same
Numeric Object is displayed as truly transparent. Text Box Objects are truly transparent in
Vista and Diagrams when set to Transparent.

Annunciation options
To view the annunciation options, right-click the Status Object to open the Status Object
Configuration dialog, then select the Annunciation tab.

Use the Annunciation tab to specify how users are notified of a change of status. The
Annunciation tab is available only on the Status Object.

NOTE: The Annunciation feature requires that the Status Object’s diagram is displayed; if the
display is closed or minimized, then the annunciation feature does not work.

The Annunciation tab has three options that set the action that Vista performs when a status
object becomes active:

• Select Command line to automatically launch another application in the event of a change in
status. Type the program's executable (.exe) command into the field provided or click
Browse to locate the appropriate file.

• SelectMessage box to specify an annunciation message. Type your message into the field
provided. The first line of text appears as the title of the message box.

• Select Invert active state to change the way the status object reacts to an active state. When
this option is selected, the status object treats an active state as inactive and vice-versa. This
is useful, for example, in cases when you want to be notified if a function (such as a cooling
fan) switches off.

NOTE: If you select the Invert active state check box, this also inverts the default colors of the
status object.
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Alarming options
Every type of event that occurs in a WinPM.Net network has a prioritized value that identifies its
relative significance on a scale of zero to 255. By default, Vista identifies any event with a priority
of 128 or greater as an alarm.

To view the Alarming options, right-click the Event Log Viewer then select the Alarming tab.

Use the Alarming tab to create or delete a priority range, specify the security level required to
acknowledge an alarm, or customize the way Vista annunciates an alarm.

The Alarming tab has three main sections:

• Priority ranges lists the currently configured alarm ranges. When you select a range in the
Priority ranges section (for example “Range 192-255”), the other sections (Level to
Acknowledge and Annunciation) display the current settings for that range. You can proceed
to modify any of these settings for the specified range. (Your changes affect only the currently
selected priority range.)

Click New to add a new priority range. In the Priority dialog box, type a number representing
the lower limit of the new range then clickOK. The upper limit of the new range is
automatically defined by the lower limit of the existing range. For example, if you have an
existing range of 128-191, you can type 100 then clickOK and the range 100-127 appears.
To delete an existing range, select it and click Delete.

• The Level to acknowledge list specifies the access level required to acknowledge alarms in
the selected range.

• Annunciation lets you customize the way Vista annunciates an alarm:

Select Beep to play a beeping sound.

Select Flash to have a flashing display.

Select Command line to have Vista to automatically launch another application in the
event of an alarm. Type the program's executable (.exe) command into the field provided
or click Browse to locate the appropriate file. This option can be used to automatically
alert other users of specific events through paging systems, fax transmissions, or any
other command line capable application.

Select Message box to display an annunciation message. When you select this option,
type your message into the field provided. The first line of text appears as the title of the
message box and the remaining text appears as the content of the message box.

By default, Vista uses a beeping sound to annunciate an event with a priority between 128-191
and a beeping sound combined with a flashing display to annunciate an event with a priority
between 192-255.

NOTE: If your computer is equipped with a sound card, you can replace the default alarm sound
with a custom sound. Save the sound file you want to use as “alarm.wav” and store it in the
...\WinPM.Net\system\etc directory.



Linking a diagram object to a data source
After placing an object in your user diagram, you need to link the object to a data source. Some
types of diagram objects require a real-time data source and others require a logged data source:

• Numeric, status, and control objects require a real-time data source. You can link these
diagram objects to a device.

• Event Log Viewers and Data Log Viewers require a logged data source. You can link these
diagram objects to any log in your system.

Linking a numeric, status or control object

This section describes how to link a numeric, status, or control object to a node. Numeric, status,
and control objects display real-time data. After you have placed one of these objects into a user
diagram, you should link it to a real-time data source. An object cannot receive or display
information until it is linked.

Specifying a real-time link to a node

1. Right-click the diagram object you want to link to open the Configuration dialog.

2. Select the Link tab.

The Link tab contains two sections: Link and Label. Use the Label section to define a label
for the diagram object (see Link options for information on the Label section) and use the
Link section to choose a real-time source.

3. Select one of the following:

Inherit from parent window: The selected diagram object defaults to the same node
used by the parent window (the window in which the object resides). You must specify a
real-time register within the node, but the node itself is pre-selected.

Custom: Allows you to select a new node. Select ION to choose a different device than
that used by the parent window.

4. Click Edit Link to open the Create Link dialog.

5. Specify a node, manager, module and output register:

a. Double-click the node in the Nodes box that contains the data source you want. If you
chose Inherit from parent window in step 3, the node is preselected.

b. Double-click the manager you want (for example, Power Meter modules) from the
Managers box.

c. Double-click the module you want from the Modules box (for example, Power Meter).

d. Double-click the output register you want from the Output Registers box (for example,Vll
avg).

6. ClickOK in the Create Link dialog to save your changes.

The Create Link dialog closes and the new link information is displayed along the lower
edge of the Configuration dialog.

7. ClickOK on the Configuration dialog to save your new configuration.
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Linking a Data Log Viewer or Event Log Viewer

The Event Log Viewer and Data Log Viewer display logged data. After you have placed an Event
Log Viewer or Data Log Viewer object into a user diagram, you need to link it to the WinPM.Net
Query Service.

Linking a diagram object to the WinPM.Net Query Service

1. Right-click the Event or Data Log Viewer object you want to link.

2. Select theQuery Server tab in the Configuration dialog.

TheQuery Server tab has two options:

Select Inherit from parent window to have the selected diagram object default to the
same Query Server used by the parent window (the window in which the object resides).
If you select this option, clickOK to exit, skip the following steps, and continue with
Querying the database.

Select Custom Query Server and click Edit Link to open a dialog where you can select
a new Query Server link.

3. Select Custom Query Server and click Edit Link to open the Create Link dialog.

Use this dialog to specify the Query Server, Query Manager, Query module, and Query
register.

Double-click the Query Server that you want from the Nodes box.

Double-click Query Modules from the Managers box.

Double-click the Query module that you want from the Modules box.

Double-click the Query Register that you want from the Output Registers box.

4. ClickOK the Create Link dialog to save your changes.

The name of the selected WinPM.Net Query Service is displayed as the Group Name on the
Query Server tab of the Configuration dialog.

5. ClickOK on the Configuration dialog to accept your new configuration.

After you have linked a diagram object to a log server, you need to define a query to specify the
type(s) of logged data that you want the object to display. See Querying the database for more
information.

NOTE: If the Query Server has multiple Query modules that are accessing multiple databases,
you need to select the Query module that is connected to the database that contains the data of
interest.

Querying the database
The Data Log Viewer and the Event Log Viewer query the database, extract logged data, and
display that data in Vista.

A query is a set of instructions that the log viewer uses to request particular data from the
database. Each log viewer has its own individual query. Editing this query information changes
what data the query retrieves and the way a log viewer displays that data.



Right-click the data or event log viewer object and select the Query tab to view the query options
or access the Query Wizard. Use the query options to define the way a viewer displays data and
the Query Wizard to edit the actual query.

NOTE: Anytime you place and link a new Data Log Viewer or Event Log Viewer, you need to
specify a query for it. You can specify a query using the Query Wizard.

Using the Query options
To define the way a log viewer displays information, configure its query options.

To view the query options for an Event Log Viewer or Data Log Viewer, right-click the viewer
object to open the Configuration dialog. Select theQuery tab.

The upper section of theQuery tab offers two buttons:

• Edit Query starts the Query Wizard, a user-friendly interface that helps you edit the query.

• Edit SQL accesses the SQL statement via Windows Notepad so you can edit the query
directly using SQL, if preferred.

NOTE: If you edit a query directly (i.e., by editing the SQL statement), your changes may not
be accessible to the Query Wizard. This is not a problem unless you intend to use the Query
Wizard as well.

TheOptions section of the Query tab offers the following options:

• Records uploaded at a time: This option specifies the number of records Vista uploads into
active memory (RAM) when you first open a Data or Event Log Viewer. The maximum value
is 9999. As you scroll down the list of records, Vista uploads additional records as needed.
You may want to change this default value if, for example, you want to select a large number
of records for plotting, without scrolling down repeatedly.

• Update automatically: This option is disabled (cleared) by default. The Data or Event Log
Viewer does not display any new records; rather, the Log Viewer initially uploads the specified
number of records (for example 100) and does not update again unless it is closed (and its
query results deleted) then reopened.

With this option selected, the Log Viewer continually receives and displays new records up
to a maximum of 1000 records; the Log Viewer checks for new records every 20 seconds.
However, the updates can consume a noticeable amount of CPU power, especially if
several Log Viewers remain open simultaneously or if Log Viewers are uploading
waveform data.

• Delete query on close: This option is enabled (selected) by default. The Log Viewer clears
its temporary records from active memory (RAM) upon closing so that every time a Log
Viewer is opened, the database is queried again and all available records are displayed. (This
option does not affect any original records stored in the database.)

If this option is disabled, Vista caches the record set returned to the Log Viewer, meaning that
if the Log Viewer is closed then reopened, the table is populated from memory and not from
the database. Any new records inserted into the database during the time the Log Viewer was
initially open do not appear.
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NOTE: Since it is recommended that Update automatically remain disabled in all but the
most compelling circumstances, it is important that the Delete query on close option
remains enabled.

• Use parent node: With this option selected, the log viewer uses the same node linkage as
the parent window. The node is also pre-selected in the Query Wizard - you should not select
this option if you intend to query more than one node.

X-parameter for Log View Plotter
For a Data Log Viewer, the X-parameter for Log View Plotter section is offered at the bottom of the
Query tab. Use this section to specify a column to be used on the X-axis of the Log View Plotter.
This section offers two options:

• Timestamp is selected as the X-parameter by default. In some cases, you may need to
specify a different X-parameter. For example, when you are plotting disturbances, you need
to plot your data against the Duration column.

• Use column # lets you specify a new x-parameter. In the field provided, type the column
number that you want to use as the X-parameter (for example, 3). When you clickOK on the
Data Log Viewer Configuration box, the specified column changes to blue.

NOTE: In the Data Log Viewer, the column specified for the X-parameter is colored blue for easy
identification.

Using the Query Wizard
The Query Wizard helps you edit an existing query or create a new query for a Data Log Viewer or
Event Log Viewer.

1. Right-click the log viewer that you want to configure.

2. Select theQuery tab in the Configuration box.

3. Click Edit Query to open the Query Wizard.

The Query Wizard consists of four steps designed to guide you through the process of
editing a query. These steps are described in more detail in the following sections.

Selecting the node(s) to query.

Specifying logs within the specified node(s).

Specifying columns and specifying filters.

Choosing a sort order.

Depending on the type of query (new or existing), you may not need to perform all four
steps. When you start the Query Wizard, it automatically opens on the appropriate step in
the process.

4. Use the four buttons at the bottom of the Query Wizard to move through or exit the Query
Wizard:

Use the Back and Next buttons to navigate through the wizard.

Click Cancel to quit the Query Wizard and discard your changes.



Click Finish to quit the Query Wizard and save your changes.

5. When finished, clickOK to save your changes and close the viewer configuration box.

The following example describes each step in the process of creating a typical query: configuring
a Data Log Viewer to display waveforms for three phases (V1, V2, V3).

Step 1: Selecting the nodes

The Available list displays the available nodes (device or software) and the Selected list displays
the currently selected nodes.

Select a node (or nodes) for your query. If a node has already been specified or you select Use
Parent Node on the Query tab, the Query Wizard proceeds directly to Step 2: Specifying logs.

1. Click Edit Query on theQuery tab of the Log Viewer Configuration dialog to start the Query
Wizard.

2. Highlight the name of the node that you want from the Available list and click Add. The node
appears in the Selected list. Repeat this procedure to add additional nodes for this query, if
required.

If you want to remove a node from the Selected list, highlight the node and click Remove.
The node disappears from the Selected list.

3. Click Next to continue.

NOTE: If you want to view or edit a node's SQL statement directly, highlight the node in the
Selected list and click the SQL button. The Windows Notepad displays the SQL statement for
the specified node.

Step 2: Specifying logs

Specify one or more data logs to query. If a valid query has already been specified, the Query
Wizard proceeds directly to Step 3: Specifying columns.

1. The Available list displays the logs available on the specified node. The Selected list
displays the currently selected logs.

2. Highlight the name of the log(s) that you want from the Available list and click Add. The log
(s) appears in the Selected list.

NOTE: Check for additional tabs. If you selected more than one node in step 1, this box
requires you to specify logs for each node. Each tab is labeled “Node 1,” “Node 2,” etc. and
is identified at the top of each tab. Select “Advanced log view” to access any logs whose
configuration has changed over time. This check box enables access to old configurations
of snapshot logs.

3. Click Next to continue.

Step 3: Specifying columns and filters

Use the Select the columns to appear in the Log Viewer section to add or remove a column
from your log viewer and the Filter section to establish a range for your query and to screen out
unwanted data.
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If you selected multiple logs in step 2, this box contains a tab for each log. Specify the column and
filter information for each tab.

Specifying columns to appear in the Log Viewer

The Available list displays the available columns and the Selected list displays the currently
selected columns. The Selected list displays the columns in the same order (left to right) that they
will appear in the log viewer (top to bottom).

To specify the columns to appear in the Log Viewer:

1. Highlight the name of the column(s) you want then click Add. The column(s) appears in the
Selected list.

Select the asterisk (*) at the top of the Available list to select all available columns.
For example, if you want to select some basic columns for the first waveform log you
chose in the last step, you could highlight timestamp, node, and V1 in the Available list.

NOTE: The * column option shows all inputs connected to a recorder for Data Log Viewers.
For example, use the * option if you are using a framework and the configuration of the
data log is different for several meters. The * option is not available if more than one table is
selected, as in the example.

2. Repeat this procedure for each column that you want (and for each tab).

3. Adjust the order of the items in the Selected column—highlight the column name you want to
move in the Selected (in order) list then click the up or down arrows to move it. The
columns are listed from top to bottom in the order they will appear from left to right.

For example, if you want the Timestamp column to be the first (leftmost) column in your log
viewer, highlight “timestamp” in the Selected (in order) section then click the up arrow to
move it to the top of the list.

After you have selected the columns you want, proceed to specify filter settings.

Specifying a filter

Use the Filter section to construct one or more filter statements for your log viewer. Filters are
useful for restricting the scope of your query or specifying a priority range for alarms.

To edit an existing filter statement, double-click on it.

For example, if you want to instruct the log viewer to display data for the past month (excluding
today), you could use the following procedure:

1. In the first dropdown list on the left, select “timestamp”.

2. In the second dropdown list to the right, select “BETWEEN”.

3. In the third dropdown list to the right, select “last_month_to_date()”.

4. In the fourth dropdown list (on the right), select “today_12AM()”.

5. Click Insert.
The following filter definition appears in the area below the filter controls:
“timestamp” BETWEEN last_month_to_date() and today_12AM()



If you wanted to instruct an Event Log Viewer to display only unacknowledged alarms, create a
filter that only displays alarms that have no acknowledgement time (ack-time).

1. In the first box, select “ack-time”

2. In the second box, select “IS NULL”

3. Click Insert.
The following filter appears in the box below the filter controls:
“ack_time” IS NULL

As you construct a filter statement, each field offers options based on your selection in the
previous field(s). For example, if you select “priority” in the first field, the third field becomes a text
field where you can type a numeric value; if you select “timestamp” in the first field, the third field
displays time-based options (i.e., now, today 12AM, yesterday, etc.).

The following table lists the time-related functions:

Function Description

now_() The current time.

today_12AM() Today at 00:00:00.

yesterday() Yesterday at 00:00:00.

last_week() Seven days ago at 00:00:00.

this_month() The first day of this month at 00:00:00.

last_month_to_date() The same date of the month one calendar month ago at 00:00:00.

last_month() The first day of the last calendar month at 00:00:00.

last_quarter_to_date() The first day of the month three calendar months ago at 00:00:00.

Note that time-related functions only return one record. To return all of the records for the time
period, you also need to specify < today_12AM(). For example, specifying a filter of
=yesterday() returns only one record, but a filter specifying >=yesterday() AND <today_

12AM() returns all of yesterday's records.

The second field offers a standard set of operators.

Operator-specific data

If you select an operator that requires additional information, Vista displays a dialog where you
can specify the required data.
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For example, if you select the “node” column in the first field then select the “IN” operator from the
second field, a dialog opens requesting that you specify the node you want to use.

If you specify any column other than “node” then select “IN”, a box appears requesting numeric
values.

After you have specified a filter, click Next to continue.

Step 4: Choosing a sort order
Specify a sort order. The sort order is the order in which records appear in the viewer.

1. Highlight the name of the column to sort by in the Available Columns list then click Add. The
column appears in the Sort Order list.

Available Columns displays the columns you chose in step 3.

2. Double-click on the column in the Sort Order list to select either an ascending or descending
sort order.

The Sort Order list displays the column(s) that dictate the order in which the records are
sorted.

3. Click Finish to save your changes and quit the Query Wizard.

4. ClickOK in the Configuration box to save your changes.

Customizing a diagram window
You can customize the appearance and configuration of any window within a user diagram. You
can customize a window's font or background color, or configure window properties such as
background image, real-time and logged data links, double-click action, and stale data settings.

In many cases, Vista uses the properties specified for the parent window as the default settings
for any diagram objects or grouping windows contained within. By modifying a setting in the
parent window, you automatically modify the same property on all objects inside the window that
share this setting. (For example, any object with an option set to Inherit from parent window
shares this information.) This can be useful when adding multiple diagram objects that are all
linked to the same source.

To access any of these options, right-click anywhere in the background of the user diagram or
window that you want to customize.

NOTE: Right-clicking in the background of a window displays a menu of available options;
however, right-clicking on any object in the window while in Edit mode (including transparent
objects such as text boxes or grouping windows) displays the configuration options for that
object.

Default font
The font you select becomes the default setting for all captions and text labels within the window.

Changing the default font

1. Right-click the background of a user diagram and select Default Font to open the Font
dialog.



2. Set the default font, style, size, effects, color, and format that you want.

3. ClickOK to save your changes.

Background color
The default background color is gray. However, you can display any solid color as a background
for any window in your user diagram.

Changing the background color

1. Right-click the background of a user diagram and select Background Color to open the
Color dialog.

2. Select the color that you want or click Define Custom Colors for more options.

3. ClickOK to save your changes.

Configuring window properties
To view the Window Properties Configuration options, right-click the background of any window in
your user diagram and select Properties.

The Window Properties Configuration dialog opens with five option tabs: Image,Query Server,
Node, Action and Updates.

Image: Displaying a background image

To view the image options, select the Image tab on theWindow Properties Configuration
dialog. Use the Image tab to specify a background image for the active diagram or grouping
window.

The Image tab has two options:

• Select None if you do not want to display a background image, or if you prefer to display a
single color.

• Select Custom image to display a background image. Enter the path and filename of the
image you want to display. Vista supports images saved in the following formats: .bmp, .jpeg,
.png, .gif, .emf, and .wmf.

You can create your own background image using a scanned photograph or a drawing created
within a standard graphics program. Some ideas include:

• An engineering drawing of your installation depicting the power distribution system and the
location of critical elements.

• A single line diagram illustrating the power distribution network or the individual components
of your facility.

• An aerial photograph of your facility depicting the approximate location of your monitoring
equipment.

• A satellite image or geographical map depicting your transmission and distribution network.

The following illustration depicts a sample Vista background with hidden diagram objects (here
the object is visible by the handles because it is selected in Edit mode):
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You can integrate your diagram objects into the image by placing them at the appropriate points
on the drawing. Users then display site-specific information by clicking on the appropriate spot in
the background.

Specifying a custom background image

1. Right-click the background of the window you want to customize and select Properties to
open theWindow Properties Configuration dialog.

2. Select the Image tab.

3. Select Custom image and click Browse.

4. Select the image file you want to use and clickOpen.

5. ClickOK to set this image as the background.

Query Server: setting a default Query Server for a window

Use the Query Server tab to specify a logged data source for any window in a user diagram. The
Query Server that you select provides the default source of logged data for all Event Log Viewers,
Data Log Viewers and Grouping Objects within the window.

Setting a default Query Server for a window

1. Right-click the background of the window and select Properties.

2. Click the Query Server tab in the Window Properties Configuration box.

3. Select either Inherit from parent icon or Custom Query Server.

Select Inherit from parent icon for the active window to default to the same Query
Server used by the parent icon. (The parent icon is the diagram object that you clicked to
open this window.)

Select Custom Query Server then click Edit Link to open a dialog where you can select
a new Query Server link.

When you click the Edit Link button, the Create Link dialog opens.



Use the Create Link dialog to specify a query:

1. Double-click the Query Server that you want from the Nodes box.

2. Double-click Query Modules from the Managers box.

3. Double-click the Query that you want from the Modules box.

4. Double-click the query register that you want from the Output Registers box.

5. ClickOK to save your changes.

The name of the selected Query Server and register are displayed as the Group Name on the
Query Server tab of the Window Properties Configuration dialog.

Node: Setting the default node for a window

Use the Node tab to specify a real-time source for any window (or grouping object) in a user
diagram. The node that you select provides the default source of real-time data for all numeric,
status, and control objects within the window. It also is the parent node for any Data Log Viewer or
Event Log Viewer objects placed in the window.

Setting a default node for a window

1. Right-click anywhere in the background of the window and select Properties from the pop-
up menu to open theWindow Properties Configuration dialog.

2. Select the Node tab.

3. Do one of the following:

Select Inherit from parent icon to use the same node as the parent icon (the diagram
object you double-clicked to open the window).

Select Custom to select a different node. Select ION and click Select to display the
Select Node dialog. Select a default real-time source for the window from the nodes
available.

4. ClickOK to save your changes.

Action: Specifying an action for a window

You can specify an action for Vista to perform upon opening or closing a particular window. For
example, if you want Vista to automatically engage a modem tool (such as the Connection
Manager) every time you open a certain grouping window, you can specify the tool as an action.

Specifying an Open or Close action

1. Right-click the background of the user diagram or grouping window and select Properties to
open theWindow Properties Configuration dialog.

2. On the Action tab, select Command line on open or Command line on close.

3. Click Browse to open the Browse dialog, locate the program you want, select the .exe file,
and clickOpen.

The specified file and path name appears in the box below the selected option.

4. ClickOK to save your changes.

NOTE: To remove an action, clear the check box beside the option.
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Updates: Setting the time interval

Data that is not updated is considered stale data. Vista detects stale data as it occurs and
identifies it with a colored border around the diagram object (the default color is yellow).

On the Updates tab, you can specify the interval of time Vista uses to detect stale data. The
Updates tab has two sections:

• Update Period allows you to specify how often data in that window is refreshed.

• Stale Data allows you to specify whether data is highlighted and how old data must be to be
considered “stale”.

NOTE: The Update Period and Stale Data settings also apply to Diagrams.

Changing the Update and Stale Data settings

1. Right-click the background of the window and select Properties to open theWindow
Properties Configuration dialog.

2. Select the Update tab.

3. Enter a numeric value in seconds in the Update data period or Stale data timeout fields to
set the intervals.

4. Select or clear the Highlight stale data check box to enable or disable checking for stale
data.

5. ClickOK to save your changes.

To change the color of the stale data border, close the Window Properties Configuration dialog,
then selectOptions > Flag Colors to open the Flag Colors dialog. Click Edit beside “Stale Flag
Color” to open a dialog where you can select a different color.



Chapter 5: Designer
Use Designer to configure nodes on your network that are based on ION Architecture. The node
can be a software component or a hardware device.

NOTE: Only nodes based on ION Architecture can be configured using Designer.

Designer’s graphical user interface helps visualize a node's configuration. You can link ION
modules together to customize a node for your particular application. You can also cut, copy and
paste functionality within a single node or between different nodes.

WARNING
UNINTENDED EQUIPMENT OPERATION

Do not use a controlled output for any safety critical application due to possible unexpected
changes of state during power cycles, power outages, configuration changes, or firmware
upgrades.

Failure to follow these instructions can result in death or serious injury.

Only personnel with a thorough understanding of ION architecture and the system in which the
meters and software are installed can configure ION modules and registers.

For more information on ION Architecture, ION modules or ION registers, see the ION Reference.

Getting started with Designer
Designer is a programming tool intended for advanced users only. Familiarity with ION
architecture is essential, as Designer is based on ION architecture.

The functions used in traditional power monitoring are treated as discrete modular objects that
can be interconnected and customized. These objects, known as IONmodules, are the basic
building blocks that comprise a node.

Designer is used to make any changes to the operation of an ION-compliant node. ACCESS
devices, the Virtual Processor and Log Inserter are all configured using Designer.

For those already familiar with Designer, see Designer shortcuts for a list of the most commonly
used commands.

Starting, logging into and exiting Designer
To start Designer, use one of the methods outlined in Starting a component of WinPM.Net or open
Management Console and select Tools > System > Designer.

For instructions on logging in to or exiting Designer, see Logging into a component and Ending a
session, respectively.
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Node diagrams and the Designer interface
This section describes the components of the Designer interface and of node diagrams.

A Menu bar B Toolbar C

Workspace
with open
node
diagram

D
Core module (indicated by
double border)

E Toolbox F Status line G
Grouping
object

H Shortcut icon

I Module link J Module icon K Time display L Progress indicator

M Communication status lights

The Designer interface
The Designer interface consists of a main screen with a title bar, a menu bar, a toolbar, a
workspace, and a status bar. When in Edit mode, the ION Modules toolbox is also displayed.

Title bar

The title bar displays the name of the program, the user name, and the name of the active node
diagram.

Menu bar

Below the title bar is the menu bar. Click on a menu name to display a list of available commands.



Toolbar

The Toolbar offers quick access to the commands used most frequently. Each command offered
on the toolbar is also available from the menu bar.

A Open E Cut

B Save F Copy

C Reset G Paste

D Create a link H Help

When you point at a toolbar button, a description of it appears in the status bar at the bottom of the
screen and on a small ToolTip beside the button.

Workspace

The main area in the center of the screen is the workspace, where you view and edit node
diagrams.

Status bar
The status bar displays status information. The components, from left to right, are:

• Status line: Describes any active processes and provides brief descriptions of the currently
selected command or toolbar button. For example, when you move the pointer over a toolbar
button or click on a menu name, a brief description of the item appears in the status line.

• Time display: Displays the current time on the workstation.

• Progress indicator: Depicts the progress on an action being performed.

• Communication status lights: Indicate if Designer is currently receiving and transmitting
data on the WinPM.Net network.

The node diagram
A node diagram is a graphical representation of an ION-compliant node. The node diagram
displays the actual configuration of the node. Module icons represent the ION modules in the
node, while lines drawn between these module icons show links between the IONmodules.

In some cases, groups of modules are organized inside grouping windows. When closed, a
grouping window appears as a grouping object (an icon that looks like a folder). Click a group
object to open the grouping window that contains the module icons.

Using a node diagram

The node is graphically displayed as a node diagram in Designer. The node diagram contains a
number of ION modules, which represent the node's current configuration. You can change the
configuration of the node simply by editing its node diagram. For example, when you delete a
module from a node diagram, the module is removed from both the diagram and the node. You
can add, configure, link and delete modules on the node by making the corresponding changes to
the module icons in the node diagram. A module’s setup registers can be accessed and changed
through the module icon.
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Use Designer to configure hardware nodes (for example, ACCESSmeters) or software nodes (for
example, Virtual Processor or Log Inserter).

NOTICE
LOSS OF DATA

Do not leave hardware or software nodes open in Designer, as this stops log downloads from
the device.

Failure to follow these instructions can result in permanent loss of data.

Default node diagrams in Designer

When a meter is opened in Designer, the default diagrams for the appropriate meter and default
template are loaded automatically.

Opening a node diagram

1. Select File > Open to open the Select Node dialog.

2. Select the node you want to open then clickOK.

When you select a node from the list, Designer communicates with the specified node and
opens the applicable node diagram.

NOTICE
UNINTENDED DEVICE OPERATION

Do not open a node diagram if the node is currently being configured from its front panel.

Failure to follow these instructions can result in unplanned configuration changes.

When Designer loads a node diagram, it compares the diagram with the configuration of the node.
If there are any discrepancies between the diagram and the node, Designer updates the diagram
to match the node:

• If a diagram depicts a module that does not exist on the node, Designer deletes the module
icon from the diagram.

• If a node contains a module that is not depicted in the diagram, Designer adds the module
icon to the diagram.

• If the links between modules differ from node to diagram, Designer adjusts the diagram to
match the node.

A node diagram typically does not differ from the node's true configuration unless the node's
configuration was changed through other means (for example, with a remote display unit.)



Saving a node diagram
Saving a node diagram serves two purposes: it saves your changes to the diagram, and applies
your changes to the node.

• To save the active node diagram, select File > Send & Save.

• To save all open node diagrams, select File > Send & Save All.

Closing a node diagram
To close the node diagram(s):

• Select File > Close to close the active diagram, or

• Select File > Close All to close all open diagrams and windows.

If you attempt to close a diagram without saving your changes, Designer displays a message with
a list of the modules affected.

You can then do one of the following:

• ClickOK to return to the diagram and save your work before closing the diagram.

• Click Close Anyway to discard any unsaved changes and close the diagram.

NOTE: If you reopen a diagram containing unsaved changes, Designer may list the unsaved
changes as offline modules.

Display mode versus Edit mode
There are two display modes in Designer, which affect how you navigate a node diagram.
Whether or not the toolbox is shown indicates the mode you are in: if the toolbox is open, you are
in edit mode; if it is closed, you are in display mode.

Displaymode allows you to view the node diagram without making changes. To prevent
accidentally moving or deleting modules or links, use Display mode when navigating node
diagrams. In Display mode, single-click grouping objects to open associated grouping windows.

Editmode allows you to configure the node and the appearance of the node diagram. In Edit
mode, double-click grouping objects to open associated grouping windows. Right-click objects
or icons to view configuration options.

For more information on the Toolbox, see Using the IONmodules toolbox.

Designer shortcuts
Designer provides several shortcuts to assist in programming the nodes.

A Input

B Output
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The following table lists the different mouse and keyboard combinations you can perform on a
module’s input or output symbols, and their corresponding functions:

Action Result

Left-click input
The list of inputs appears - you can select an input and link it to
another module's output register

SHIFT + left-click input
The list of inputs appears with the current input values displayed in
square brackets

Right-click input
The Delete Links dialog appears - you can break links from this
dialog.

SHIFT + right-click input
The Delete Links dialog appears, showing inputs and current input
values in square brackets

Left-click output The list of output registers appears

SHIFT + left-click output
The list of output registers appears with the current register value
displayed in square brackets

CTRL + left-click output
The list of setup registers appears - these setup registers can be
linked to inputs on other modules

SHIFT + CTRL + left-click
output

The list of setup registers appears with the current register settings
displayed in square brackets

Right-click output
The list of output register owners appears - you can break links
from this dialog

CTRL + right-click output
The list of setup register owners appears - you can break links
from this dialog

NOTE: To create a shortcut to an IONmodule, see Creating a shortcut to an IONmodule.

Designer icons
In each node diagram, Designer uses icons to represent the configuration of the node. There are
two basic types of icons: module icons and grouping icons.

Module icons represent ION modules located on the node. Grouping icons represent a group of
module icons.

NOTE: A module icon with a symbol in the lower corner is a shortcut.



Module icons
All module icons share four common elements: a label, a graphic, an input symbol and an output
symbol.

A Label C Graphic

B Input Symbol D Output Symbol

• The label displays the name of the module.

• The graphic shows a picture to distinguish one type of module from another.

• The input and output symbols provide access to the module's input and output registers.
Click the left symbol to display a list of inputs; click the right symbol to display a list of output
registers. See Linking ION modules for more information.

Module icons with a double border represent core modules; module icons with a single border
represent standard modules. For more information on core and standard modules, see Core
modules and standard modules.

Grouping icons and grouping windows

Grouping icons represent grouping windows. Click a grouping icon (left) to open its associated
grouping window (right).

A grouping window acts as a folder or sub-window where you can store icons that you want to
keep together. For example, you can use grouping windows to group module icons by
application—a single grouping window may contain all module icons required for demand or
advanced setup routines.

You can use a grouping window much like a standard window. You can create, rename or delete
a grouping window; you can move a grouping window within a diagram, and you can move a
module into or out of a grouping window.

When you finish editing the grouping window, close it to minimize the window to its corresponding
grouping icon in the node diagram.
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Opening a grouping window

Click on the grouping icon.

Closing a grouping window

Click the Close button .

Moving icons into a grouping window
To move an icon (or group of icons) to or from an open grouping window, select it and drag it to
the new location.

1. Click on a grouping icon to open the grouping window.

Drag the grouping window by the title bar and position it so that you can see the icon(s) that
you want to move.

2. Select the icon(s) you want to move and drag the selection into the grouping window.

When you move a linked module icon into a grouping window, the module remains linked but any
lines that represent links to modules outside the window disappear.

Creating a new grouping window

To create a new grouping window, drag the grouping object from the toolbox onto the node
diagram.

The IONmodules toolbox is a collection of ION modules and generic tools that you can add to a
node diagram. If the ION modules toolbox is not displayed, selectOptions > Show Toolbox. See
Using the IONmodules toolbox for more information.

When you point to an object in the toolbox, the name of the object is displayed on a ToolTip. You
can use ToolTips to identify the grouping object in the toolbox.

Renaming a grouping window
When you create a new grouping window, the default name is that of the node diagram. To
change the name of a grouping window, rename the grouping icon:

1. Right-click the grouping icon to open theGrouping Object Configuration dialog.

2. Select Use Custom from the Caption section and type the new name into the text box.

3. ClickOK.

Changing the font of a grouping window
To change the font, font style and size of a caption:

1. Right-click the grouping icon to open theGrouping Object Configuration dialog.

2. In the Font section, do one of the following:

To use the font of the parent window, select Inherit from parent window.

To use a different font, select Custom, then click Font to open the Font dialog. Select
the font options you want then clickOK to continue.

3. ClickOK.



Changing the position of the caption
To change the location of the caption:

1. Right-click the grouping icon to open theGrouping Object Configuration dialog.

2. Select either Top or Bottom in the Position section to specify a caption position above or
below the grouping icon.

3. ClickOK.

Deleting a grouping window

NOTE: When you delete a grouping window, any modules inside are deleted as well. Designer
displays a message before deleting modules. See Deleting or cutting an IONmodule for more
information on deleting modules.

1. Select the grouping icon of the window you want to delete.

2. Press the Delete key. If the grouping window contains modules, Designer displays a list of
modules that will be deleted.

Displaying default or custom icon labels

Module icons can display two types of labels: Default (left) and Custom (right).

• Default labels: All modules have a default label. The default label identifies the module by
type and, if applicable, by number. It appears in node diagrams, user diagrams and event logs
unless a custom label is available.

• Custom labels: Custom labels are available only if they have been preconfigured by a user.
A custom label usually identifies a module by its function or purpose. Custom labels are useful
for describing modules, setup registers, output registers, and Boolean ON/OFF conditions.
For information on adding custom labels, see Customizing a module label.

Displaying default labels or custom labels
SelectOptions > Show Default Labels to toggle the option on or off.

• When Show Default Labels is selected, default labels are displayed.

• When Show Default Labels is not selected, custom labels are displayed.

This is a global setting that applies to all node diagrams.

Moving icons in a node diagram

You can move module and grouping icons anywhere in a node diagram. This is useful for
organizing your diagram (for example, by function or type) so that you can easily find a particular
module or visualize the workings of your node's configuration. You can move a single icon or
group of icons within a single node diagram, or into an open grouping window.

NOTE: Moving the icons in a node diagram does not affect the function of the modules or the
node in any way.

WinPM.Net 10.0 User Guide Chapter 5: Designer

© 2021 Siemens Industry, Inc. All Rights Reserved. 173



Chapter 5: Designer WinPM.Net 10.0 User Guide

174 © 2021 Siemens Industry, Inc. All Rights Reserved.

Moving icons

1. Select the icon(s) you want to move.

When a grouping icon is selected, all icons within its grouping window are automatically
selected as well.

2. Drag the selected icon(s) to the new location.

NOTE: When selecting a group of icons, you can only choose icons from within the active
window.

Arranging icons in a node diagram

You can use the Align and Grid options in the Layout dialog to adjust the spacing and layout of the
module and grouping icons in your node diagram. Use the Align option to specify the horizontal
and vertical arrangement of the selected icons and the Grid option to activate and configure
invisible guidelines.

NOTE: Arranging the icons in a node diagram does not affect the function of the modules or the
node in any way.

Changing the order of layered or stacked icons

If an icon appears on top of another icon that you want to bring to the front, select the icon that is
sitting on top, then click CTRL+K (or click Edit > Send to Back).

Aligning icons

The Align tab in the Layout dialog allows you to specify the horizontal and vertical alignment of
selected objects.

To align objects:

1. Select the icons that you want to align.

2. Select Edit > Layout to open the Layout dialog.

3. Select the Align tab and set the horizontal and vertical alignment of the icons.

The options in each area determine the criteria by which you can align icons. For example, if
you select Left sides under Horizontal and Space evenly under Vertical, Designer aligns
all objects in the selection by their left sides (using the leftmost object for reference) and
distributes them evenly along a vertical axis.

4. ClickOK.

Using the grid

TheGrid tab in the Layout dialog activates and configures an invisible grid. Icons placed onto the
grid snap to the nearest gridline to help align and space them evenly.

To activate or deactivate the grid:

1. Select Edit > Layout to open the Layout dialog.

2. Select theGrid tab.



3. Select one of the following options:

No Grid turns the grid off.

Grid size in pixels activates the grid. Type a number in the Grid size in pixels box to
specify the size of the grid (distance between grid lines).

4. ClickOK to save your changes.

Designer windows
To create links between several node diagrams or grouping windows, you need to position the
open windows so you can see all the modules involved. Use the Window menu to organize open
windows in the workspace.

Arranging windows in your workspace
To arrange windows, do one of the following:

• To locate an open window and move it to the foreground, select the Window menu and select
the window name from the list of open windows.

• To arrange all open windows in the workspace, selectWindow > Arrange All.

Changing a window’s background color
By default, the background color of all windows in a node diagram is light gray. To select a new
background color for a window:

1. Right-click the background of the window and select Background Color to open the Color
dialog.

2. Select the color you want or click Define Custom Colors for more options.

3. ClickOK.

When choosing a background color, consider how the color affects the visibility of icons and links.
Links, highlights and shadow effects used to depict the various states of an IONmodule may not
appear against certain background colors. For this reason, you should avoid using certain colors
for your background, particularly white, dark gray and black.

Changing a window’s default font
You can specify a default font to be used for all module icons, grouping icons and text boxes in a
window.

1. Right-click the background of the window and select Default Font to open the Font dialog.

2. Specify a new default font, size and style.

3. ClickOK.

Fonts can also be specified individually for grouping windows and text boxes. See Changing the
font of a grouping window and Changing the font of a Text Box for more information.

ION module overview
After you have opened a node diagram, you can view the node’s configuration or edit it by working
with its ION modules. As described earlier, each module performs a specific function. Using
Designer, you can add, remove or link modules together to customize the function of the node.

WinPM.Net 10.0 User Guide Chapter 5: Designer

© 2021 Siemens Industry, Inc. All Rights Reserved. 175



Chapter 5: Designer WinPM.Net 10.0 User Guide

176 © 2021 Siemens Industry, Inc. All Rights Reserved.

This section explains how to add and remove IONmodules from your node diagram. It describes
the basic types of modules, and explains how you can organize your node diagram by grouping
modules together, arranging them, and labeling them.

For more information on IONmodules and architecture, refer to the ION Reference.

Working with ION modules

The following sections outline some considerations to remember when working with ION
modules.

Output and setup registers

A register is a type of memory bank that stores a module's linking and configuration information.
Each module uses two types of registers: output registers and setup registers.

Module status: online and offline

The terms “online” and “offline” describe whether a module is currently active or not. A module is
described as online when it is functioning normally (monitoring its input and updating its output
registers). An offline module is inactive.

Anytime you send and save changes to a node, Designer temporarily takes the affected modules
offline and programs them with your changes. After they have been programmed, the modules
are then placed back online.

Normally, this is a routine procedure. However, certain circumstances may cause a module to
remain offline. For example, if the node lacks sufficient processing power to operate the module,
the module remains offline.

You can easily identify any offline modules: all offline modules are highlighted with a red outline.
In addition, whenever you open a node diagram, Designer displays a list of all offline modules in
the node.

NOTE: If you have offline modules in your node, you may be able to put them back online by
selecting File > Send & Save.

Module status: programmed vs. pending

The terms “programmed” (left) and “pending” (right) refer to whether or not a module's
representation in the node diagrammatches the node itself.

Programmed: A programmed module is one that is the same both in the node diagram and in the
node. The links, labels and setup register values in the node diagram exactly match those on the
node. When you first open a node diagram, all the modules appear programmed since they are
read directly from the node itself and then displayed in the node diagram.

Pending: A pending module is one where changes have been made to the module in the node
diagram and not yet sent to the node, so the node diagram does not match the node. The borders
of pending module icons appear as a dashed line.



If you change a module in the node diagram (for example, re-link it or edit its setup registers), it
does not match the node until you select File > Send & Save. Until it is saved, the edited module
is depicted as pending to indicate that it does not match the configuration on the node. When you
send and save your changes to the node, the module becomes programmed.

Core modules and standard modules

There are two basic types of ION modules: core (left) and standard (right).

Core modules are required IONmodules that are fundamental to the operation of the node. You
cannot add or delete core modules and, in some cases, you cannot configure them. Core module
icons are identified by a double border around the edge. The Power Meter module is an example
of a core module.

Standard modules are reusable ION modules. Generally, most modules in a node are standard
modules. You can add or delete standard modules as required. Standard modules icons are
identified by a single border. The Setpoint module is an example of a standard module.

Persistent modules

Similar to core modules in that they cannot be added or deleted, persistent modules are standard
modules that have been converted to core modules. These modules are created at the factory,
and can never be removed from the meter frameworks. Persistent modules are represented by
icons with single borders.

An example of a persistent module is External Pulse module #1 on the ION8600 meter. This
module pulses when the Demand Reset switch is pressed on the meter.

Using ION modules
You can change the function of a node by editing the appropriate module(s) in the node diagram
and linking modules together.

This section describes how to locate an existing module, how to add a new module, and how to
delete a module. It also explains how to create a shortcut to a module and how to view the
contents of a module in text format.

After you have located or added the module you want, you can configure it using the procedure
described in Linking ION modules.

Using the ION modules toolbox

The IONModules toolbox is a collection of ION modules and generic tools that you can add to a
node diagram. To display the IONModules toolbox, selectOptions > Show Toolbox.
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The type and quantity of modules offered on the toolbox varies depending on the type of node you
are configuring; however, the generic tools (the grouping and text objects) are available for all
nodes.

NOTE: To identify a module in the toolbox, point to it with the mouse—the module type is
displayed as a ToolTip and on the status line at the bottom of the screen.

To add a module to your node diagram (and to the node itself), drag its icon from the toolbox into
the diagram window.

Opening the ION modules toolbox

To open the toolbox, selectOptions > Show Toolbox.

Closing the ION Modules Toolbox

Click the Close button or clearOptions > Show Toolbox.

Locating an existing ION module

Before you can edit a module, you must first locate it in the node diagram. To find a module in a
node diagram, you can use the module tray feature of the toolbox.

Locating an existing module from the Module Tray

1. To display the module tray, right-click the toolbox icon for the type of module you want to
locate. The module tray appears beside the toolbox.



The module tray displays links to all modules of that type that are currently in use on the
node—for example, in the image above, there are 22 Setpoint modules in use by the node.
To identify a link in the tray, point to it—the module's label is displayed on the status line at
the bottom of the screen.

2. To locate a particular module, click its link in the module tray. Designer locates the module
and displays it in the center of the workspace. If the module is located inside a grouping
window, Designer opens the window to display the module.

TIP: To close the module tray, click on any module icon in the toolbox.

Adding a new ION module
Most nodes are pre-programmed at the factory to provide the most commonly required functions.
However, if the factory default configuration is not appropriate for your application, you can add a
new module.

Adding a module on a node

Drag the icon of the module you want to add from the toolbox onto the node diagram.

As you drag the icon, the cursor changes shape to indicate you are placing an object.

Designer adds the module and places a pending module icon into the diagram. You can then link
and configure the module.

See Linking ION modules for more information on programming modules.

Deleting or cutting an ION module
To remove a standard module from a node, delete its icon from the node diagram. By removing
unnecessary modules from the node, you can free up resources for use elsewhere.
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NOTICE
UNINTENDED DEVICE OPERATION

Do not delete any IONmodules without knowing which modules are dependent on it.

Failure to follow these instructions can result in the unintended operation of the
remaining modules.

NOTE: Each time a module is deleted, all of its output registers, setup registers and input links
are deleted as well. Removing this information from the node affects the operation of any
modules that depend on it. For this reason, you should be aware of all dependent modules (also
known as owners) before you delete anything.

Checking for dependent modules

When two linked modules are located in the same window, Designer depicts the link as a line that
runs from the output register of one module to the input of another. You can easily identify the
dependent module (or owner) by the line running to its input. However, if one of the linked
modules is located in a different window, the connection is not visible. A more effective way to
locate a module's owners is to view the owners of its registers.

Viewing the owners of a module's setup and output registers
You can view a register's owners to quickly identify all dependent modules on the node. You can
determine what purpose the modules serve, and then decide whether to delete them or not.

1. Do one of the following to open theOwners dialog:

To view the owners of a module’s output registers, right-click the output symbol.

To view the owners of a module’s setup registers, hold the CTRL key and then right-click
the output symbol.

The dialog lists all of the module's registers and any dependent modules on the node
(dependent modules on other nodes are not displayed).

2. Click a register in the Registers list to display the owners of that register in the Owners list on
the right. Owner information includes the module name or label and its relevant input.

3. If necessary, delete the link between a register and one of its owners. Select the owner from
the Owners list and click Unlink. (See Deleting links for more information on deleting
module links.)

4. When you have finished viewing the register owners, clickOK.

Viewing owners on other nodes

Displaying a module's register owners is an effective way to locate dependent modules on the
selected node but it does not show any dependent modules located on another node.

If you remove a module with a dependent module on another node, the dependent module's
inputs are not reset. It continues to look for the deleted output register.



If you are not sure whether a module has dependents on other nodes, check with the person who
programmed them to ensure you do not disrupt the operation of any modules on that node. If you
still want to remove the module, you may want to directly delete the link on the other node first. In
this way the module is not inadvertently linked to the next module to occupy the location of the
deleted module.

Deleting or cutting an ION module
After you have determined that you can remove an IONmodule without disrupting other functions,
there are two ways to remove it: delete and discard the module or cut the module to paste it in
another location.

In either case, Designer immediately removes the icon from the node diagram and deletes the
module from the node. The difference is, when you delete a module, it is discarded; when you cut
a module, it can be restored (by selecting Edit > Paste).

NOTE: You do not have to select Send & Save Changes to delete a module. Designer
immediately removes the module from both the diagram and the node.

Removing an ION module from the node

1. Select the icon(s) of the module(s) you want to remove.

2. Do one of the following:

To cut the module(s) to paste it in another location, select Edit > Cut.

To discard the module(s), press the Delete key.

NOTICE
UNINTENDED DEVICE OPERATION

Do not delete any IONmodules without knowing which modules are dependent on it.

Failure to follow these instructions can result in the unintended operation of the
remaining modules.

NOTE: If a module has a dependent module on another node, Designer does NOT alert
you of the dependency when you delete it. Before you delete a module, ensure that you are
aware of all links to modules on other nodes.

Designer displays a summary of the proposed changes.

The summary lists all selected modules, and identifies those in the selection that will be
deleted (including those with dependents on that node) and those that will not. Select a
module in this list to display any additional information available in the field at the bottom of
the dialog.

3. ClickOK to remove the selected modules (or Cancel to abort the procedure).

Designer removes the module icon from the node diagram and deletes the module from the
node itself.
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NOTE: If you delete a shortcut icon, the original module is not affected. However, when you
delete the original module, all shortcuts to that module are also deleted.

Viewing a node or module as text
You can use the View Diagram Text command to display as text the complete contents of one or
more modules or of an entire node. Use this option to view the specified information on your
screen so you can sort it, perform analysis, create a detailed record of your node’s configuration,
or print a copy for your records.

1. Select the module(s) that you want to display.

TIP: To select all modules in the node, left-click on the background of the main node
window, being careful not to click on a module icon, then select Edit > Select All.

2. SelectOptions > View Diagram Text to open the Text View screen. The text of any
modules that are offline appears in red.

• The Text View screen offers several ways to view, sort and find information:

• In the View dropdown list, select one of two view modes:

Use Archive to display information useful for archiving the node's configuration.

Use Diagnostic to display diagnostic information on the selected module(s).

• In the Sort by dropdown list, select the criteria by which you want to sort the data:

Archive View Diagnostic View Sorts by

Default Default Module label

Module Class Module Class Type of module

Module Name Module Name Default label

Module State
Displays offline modules first followed by online modules.
Sorts alphabetically within each group.

Module Update
Period

Displays event driven modules first, then inactive (not
updating) modules, followed by high-speed (one cycle
updates) modules, and finally high-accuracy (one
second updates) modules. Sorts alphabetically within
each group.

• In the Find text field, type a text string and click Find to find that text string in the data.

To reset the text view after you have made a configuration change, click Refresh. If you want to
print a copy of the text view information, click Print. When you are finished viewing the text view
information, click Close.

Creating a shortcut to an ION module
To save time switching between modules in different windows, create a shortcut icon in one
window that represents the original module in the other window.

A shortcut icon is identified by a symbol in the lower left corner of a module icon.



Creating a Shortcut Icon

Hold down SHIFT+CTRL then drag the module icon(s) to the window where you want to place the
shortcut(s).

After you have created a shortcut icon, you can use it in the same way you use the original module
icon. Both icons support the same features. However, if you delete the shortcut icon, the original
module icon is not deleted; whereas if you delete the module icon, it deletes all shortcuts to that
module.

NOTE: You cannot create more than one shortcut icon per window for a single module.

Adding a text box to a node diagram
You can place a text box anywhere in a node diagram, and move it or resize it as necessary. You
can use a text box to describe any process or function in your system; for example, you can label
individual components of your system or display a block of descriptive text or instructions.

Adding a Text Box

1. Drag a Text Box object ( ) from the toolbox onto the node diagram.

A text box opens in the diagram with the default message: “Your text goes here.”

2. Right-click the text box to replace the default text with your own text. The Text Box
Configuration dialog opens.

Select the Edit Text tab, then do one of the following:

To display the name of the node in the text box, select Use Default.

3. To display your own message, select Use Custom and type your text into the field provided.

4. ClickOK. The text box displays your specified text.

Resizing a Text Box
To resize a text box:

1. Select the text box.

2. Do one of the following:

To make the object larger or smaller, drag a corner handle.

To stretch the object horizontally or vertically, drag a middle handle.

Changing the font of a Text Box
The font, size and style of the text used in the text box is based on the default setting specified for
the active window. If you want to use a different font, you can specify a new font for the text box:

1. Right-click the text box to open the Text Box Configuration dialog.

2. Select the Text tab.

3. In the Font section, do one of the following.

To use the font specified for the parent window, select Inherit from parent window.

To use a different font, select Custom, then click Font to open the Font dialog. Specify
a font, style, and size. ClickOK to continue.
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4. ClickOK.

Changing the position of the Text
To change the position of the text in the text box:

1. Right-click the text box to open the Text Box Configuration dialog.

2. Select the Text tab.

3. In the Position section, select Left, Center, or Right.

4. ClickOK.

Adding a border or background color to a Text Box
To add a border to a text box or change its background color:

1. Right-click the text box to open the Text Box Configuration dialog.

2. Select the Box tab.

3. Do one or more of the following:

To add a border, select Show in the Border section and click Color to select a border
color.

To set the width of the border, type a border width in the “Width in pixels” field in the
Border section.

To add a background color, select Custom in the Background Color section and click
Color to select a background color.

4. ClickOK.

Linking ION modules
Linking ION modules together is the foundation of programming ION-compliant nodes in
WinPM.Net. Although an IONmodule can perform a function in isolation, the strength and
flexibility of the ION architecture comes from the ability to interconnect modules to build more
sophisticated functions.

Choosing which ION modules to link

The first step in linking modules is to decide which modules you want to use. When choosing a
module to link, you have two choices: you can add and link a new module or you can re-link an
existing module.

In some cases, you may not want to add a new module. For example, if all the modules of a
particular type are already used, you need to re-link one of them to perform the new function. Most
devices are preconfigured at the factory to provide common measurements and calculations. If
any of these factory defaults are unnecessary in your application, you can unlink the modules
involved and reuse them.

Plan ahead before you add new modules. Unlinked modules are wasted resources.

You may find a linked module that you can use to add a new link, in order to augment the function
it is performing. For example, if you have a Setpoint module that triggers a waveform recording,
then later decide to use this trigger to reset a counter, you can link that Counter module to the
same Setpoint that controls the Waveform Recorder module.



Linking ION modules graphically
Linking modules graphically means pointing and clicking a module’s input, then clicking another
module’s output register to link it (note that both input and output register classes must be
compatible). You can use this method to link to modules on the same node or to create links
across nodes.

You can use the autolinking feature to speed up the process of linking ION modules. Typically,
linking ION modules involves connecting the output register of one module to the input of another.
In many cases, only one of the module's inputs have the same register class as the selected
output register.

If autolinking is enabled, Designer automatically selects the appropriate input and establishes the
link. If necessary, it overwrites an existing link. This relieves you from having to manually select
the input; however, you cannot see what input you are linking to.

By default, autolinking is disabled. You should only use autolinking if you are thoroughly familiar
with all the inputs and output registers of the modules you are working with so that you do not
inadvertently create undesirable links.

Enabling autolinking

To enable autolinking, selectOptions > Enable Autolinking. A check mark beside the option
indicates it is selected.

Disabling autolinking

To disable autolinking, clearOptions > Enable Autolinking.

Linking ION modules on the same node
If the selected node is a meter such as the 9610, the process of configuring the node primarily
involves creating links between modules on that node.

NOTE: To cancel a link-in-progress, click anywhere in the background of the window or press
the ESC key.

Linking modules using the point and click method

1. To list a module's output registers, click the output symbol on the right side of the module
icon. To list the module's setup registers, hold the CTRL key while clicking the output
symbol.

Either a menu opens or, if the module has many registers, a dialog opens listing the
available registers.

2. Select the register you want to link:

In the menu, click the register you want to select.

In the dialog, double-click the register (or click it then click Select).

3. Move the cursor towards the module you want to link to. The cursor changes and a dotted
line follows it across the node diagram. This indicates you are in the process of creating a
link and it shows where the connecting line will appear in the node diagram.
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If you link to a module that is in a different window than the original module (either in a
different node diagram or grouping window) the dotted line disappears but the cursor still
indicates that a link is in progress.

If the module you want is obscured by another window, click on the title bar of the window
containing the module. This brings the window to the foreground without canceling the link.
(If you click on the background of the window, the link is cancelled.)

4. Click the input symbol of the module that you want to link to display the module's inputs.
Either a menu opens or, if the module has many registers, a dialog opens listing the
module's inputs.

If the input is already linked, the label of the register it is linked to is displayed beside the
input. If you select the input, the existing link is overwritten.

The inputs that are of a different class than the selected output register are grayed out to
indicate you cannot select them.

5. Select the input you want to link to:

In the menu, click the register you want to select.

In the dialog, double-click the register (or click it then click Select).

6. Select File > Send & Save to save your changes to the node.

The procedure described above can also be performed in reverse order. You can select a
module's input first and then link it to another module's output register.

Linking modules with variable number of inputs

Some modules, such as AND/ORmodules, Data Recorder modules, and Log Acquisition
modules have a variable number of inputs. In these cases, when you click on the input symbol,
the menu offers one instance of the variable input as well as any fixed inputs the module may
have. When linking to one of these modules, you can select the NEW Source item to add a new
link or you can select an existing link and overwrite it.

If the two modules are in the same window, the line remains on the screen to show the link
between the modules—when you save this change to the node, the line changes from a dotted
line to a thin black line to indicate that the link is now programmed on the node.

Linking ION modules across different nodes
If the selected node is a software node, such as the Virtual Processor or Log Inserter, many of the
links you create are to modules on other nodes. When you create links across different nodes, it is
important to keep track of these links and note what modules are dependent on others. This helps
you determine what will happen if you ever want to delete a module that is linked to a module on
another node.

NOTE: You cannot link modules on one device to another. For example, you cannot create a link
between a module on an 9410 to a module on a different 9410 or to a module on another meter.

1. Open the node diagrams that contain the modules you want to link.

2. Position the diagrams within the workspace so you can see the two modules you want to
link.



3. In the first node diagram, click on the output symbol of the module icon. A menu or dialog
opens listing the module's output registers.

4. In the list of output registers, click the register you want. (In the case of the dialog, click a
register and then click Select.)

5. Drag the cursor from the first node diagram to the module you want to link to in the second
node diagram. The dotted line ceases to follow the cursor if it crosses the window boundary
but the cursor changes to indicate a link is in progress.

6. Click on the input symbol of the module icon in the second node diagram. A menu or dialog
opens listing the module's inputs. Those that are of a different class than the selected output
register are grayed out to indicate you cannot select them.

7. Click the input you want, or in the case of the dialog, click the input then click Select.
Designer does not graphically represent links between modules on different nodes so you
will not see a line connecting the modules.

8. Select File > Send & Save to save your changes to the node.

This procedure can also be performed in reverse order. You can select a module's input first and
then link it to another module's output register.

NOTE: If the input is already linked, the label of the register it is linked to is displayed beside the
input. If you select this input, the existing link is overwritten.

A note about performance

While creating links, you may notice that the circle at the end of the arrow cursor is sometimes

black ( ).

This indicates that Designer is in the process of retrieving information about a module. You can
still click on the inputs or outputs of other modules, but Designer aborts the original request. To
minimize the amount of communications between Designer and the connected nodes, avoid
unnecessary clicking on the input and output symbols.

If you click on several items in a row, you only see the menu for the last item you click; however,
Designer initiates many requests for information, which may impact its performance.

Linking ION modules using the ION tree
In some cases, you may want to use the ION tree to select the register for linking. The ION tree is
a hierarchical listing of every node, manager, module, and register in the WinPM.Net network. It
allows you to select a register on a node without opening the node diagram. Generally, you use
the ION tree to create links across nodes.

The ION tree is also the only way to select registers from devices that are not ION-compliant (and
use translators to make data available) such as PAC series meters. For example, if you are
programming a Virtual Processor node and you want to sum data from several PAC3200s, you
must access the PAC3200 register via the ION tree.

Using the ION tree is faster than opening a node diagram. It is useful if you want to link to a
register on a node whose diagram has not yet been opened. It is also useful if you want to link to a
register, but you are not acquainted with the configuration of the node in which it resides. You can
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go straight to the register without having to navigate through an unfamiliar node diagram. Also,
since a diagram can only be accessed by one user at a time, you can use the ION tree to link to a
register on another node where the diagram is already open.

Linking modules using the ION tree

1. Click the input symbol of the module icon. A list of the module's inputs is displayed.

2. In the list of inputs, select the input you want to link.

3. Click the button in the toolbar. (To link a module's setup register, hold the CTRL key
while clicking this button.)

The Create Link dialog opens, providing access to the ION tree.

4. Specify a node, manager, module and output register: Double-click the node you want in the
Nodes box. All managers within the selected node appear in the Managers box. You can
then double-click the manager you want, and repeat this procedure for the modules and
registers.

5. ClickOK. The module whose inputs changed appears grayed-out to indicate it is now
pending. If both modules are in the same window of the same node diagram, a line appears
to represent the link.

6. Select File > Send & Save. The new link is established and the module appears
programmed.

The procedure described above can also be performed in the reverse order. You can click the

button first, select an output register, and then click the input symbol of a module icon to
select one of its inputs.

Deleting links
If you want to disassemble a group of linked modules and use them for another function, you can
delete the links between the modules rather than deleting the modules. Designer provides several
ways to delete links.

Fixed links
Most links between standard modules can be deleted. However, some links between core
modules are fixed and cannot be deleted. These fixed links include:

• Data Acquisition module and all Power Meter modules.

• Data Acquisition module and all FFT modules.

• FFT module and all Harmonics Analyzer modules.

• FFT module and all Symmetrical Components modules.

If you attempt to delete a fixed link, Designer informs you that the link cannot be deleted.

Deleting visible links

If the linked modules are in the same window, simply click on the link line and press the Delete
key. This works well as long as you know which output register and input are involved. For
example, in the image below, to delete the link click on the line joining the Power Meter and the
Sliding Window Demand module (its color reverses to indicate it is selected) and press Delete.



If there are multiple lines between the same modules and you only want to delete one of the links,
you may want to use the method described in Deleting links that are not visible below.

Deleting links that are not visible

If you cannot see a line that links the modules (for example, if they are in different windows), or
you need to know which output registers and which inputs are involved, you must use a dialog to
delete the link between modules. You can look either at the output register owners of the first
module or you can look at the inputs of the second module to see what they are linked to, and then
delete the link from there.

Deleting a module's input links

Deleting links at a module's inputs is generally faster than deleting them at the module's output
registers because Designer does not need to check the entire node. On the other hand, there is
less information available if you view input links. All you see is the label of the output register that
is linked to the input. If this is sufficient information, proceed with this method; if not, go to the
output registers to delete the link.

Viewing a module's input links

1. Right-click the input symbol of the module icon to open the Delete Links dialog.

2. Each input and the label of the output register it is linked to are displayed in the dialog. To
delete one or more of these links, select the input and click Unlink. The output register label
is replaced with dashed lines.

3. When you have unlinked all the registers you need to, clickOK.

4. Select Send & Save to unlink the modules on the node.

Deleting a module's output links

You can also delete links from the Register Owners dialog. This method gives you the most
information about the link you are deleting (the output register label and the input and label of the
module it is linked to).

Viewing a module's output links

1. Right-click the output symbol side of the module icon to open the Register Owners dialog.
(To list the module's setup registers, hold the CTRL key while right-clicking on the symbol.)

2. Select the output register you want from the Registers section. The Owners section lists all
the module inputs to which the selected register is linked.

3. To delete one or more of these links, select the module input in the Owners list box and click
Unlink. The input name is replaced with a dashed line.

4. When you have unlinked all of the module inputs you want, clickOK.

5. Select Send & Save to unlink the module inputs on the node.
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NOTE: Owners that reside on a different node are NOT displayed in this dialog. If you need to
delete a link between modules on different nodes, use the procedure described in Deleting a
module's input links.

Configuring ION modules
After you have placed a module in a node diagram, you can configure the various setup
parameters of the module. It is not necessary to do this before you link the modules but you
should ensure the module is set up correctly before sending the configuration to the node.

WARNING
UNINTENDED EQUIPMENT OPERATION

Do not use a controlled output for any safety critical application due to possible unexpected
changes of state during power cycles, power outages, configuration changes, or firmware
upgrades.

Failure to follow these instructions can result in death or serious injury.

Only personnel with a thorough understanding of ION architecture and the system in which the
meters and software are installed can configure ION modules and registers.

Module setup parameters include the module's label; its setup registers, labels and values; and its
output register labels. To access these, right-click the module icon.

The IONModule Setup dialog opens.

The Setup Registers box lists all the setup registers of the module along with their current values
or settings. To change any of the settings or assign a custom label to a setup register, select the
register, then clickModify (or double-click on the register) to open theModify Register dialog
where you can make modifications.

In most cases, configuring a setup register is a simple matter of entering a number, entering text,
or choosing an option from a list. (To determine the options or ranges available for a setup
register, refer to the module's description in the ION Reference.)

When you have completed all your modifications to the module, clickOK to return to the node
diagram. The module icon appears pending until you send and save your changes.

Modifying enumerated, numeric bounded, and string setup registers

If the register you have selected is an enumerated, numeric bounded or string register, one of the
following dialogs appear when you clickModify:



Enumerated registers

To modify an enumerated register, select an option from the Options list.

Numeric bounded registers

To modify a numeric bounded register, type a number in the Value box. The allowable range is
shown under the Value box; you are alerted if you type a number outside this range.

To enter a formatted numeric value, click Format. In the Time Interval Value dialog, you can
enter the numeric value as a date (offset from Jan 1, 1970) or a time interval.

String registers

To modify a string register, type your text in the String box.

Note that when you clickModify for a string register that is the connection string for a Log
Acquisition module or Query module, theModify Database Connection Properties dialog
opens.

Modifying calendar setup registers

The ION Scheduler module has a special class of setup register called a calendar register.
Configuring a calendar register is only necessary for nodes that have a Scheduler module. For
detailed information on how to configure a calendar register, see the description of the Scheduler
module in the ION Reference.

Modifying address setup registers

All Distributed Numeric, Distributed Boolean, and Distributed Pulse modules contain an address
setup register that references another register. You can specify a new value or clear an existing
value as required. (Currently, the Virtual Processor is the only node offering these types of
modules.)

NOTE: Currently, you can only link the address setup register to External Numeric, External
Boolean, and External Pulse registers.

Modifying an address setup register

1. Right-click a Distributed Numeric, Distributed Boolean or Distributed Pulse to open the ION
Module Setup dialog.

2. In the Setup Registers section, select a register then clickModify to open theModify
Address Register dialog.

3. In theModify Address Register dialog, double-click on the node, manager, module and
output register you want to use. ClickOK to continue.

4. ClickOK in the ION Module Setup dialog.

NOTE: You can clear the value of an address setup register. On theModify Address Register
dialog, select Reset Register Value and then clickOK.

Parent module and shared setup registers

Setup registers that are surrounded by asterisks (for example, “**PM1 PT Sec**”) indicate that the
module shares its setup registers with another (“parent”) module. An example of this is the High-
Speed Power Meter or Meter Units Power Meter module (“HS Power Meter”, “MU Power Meter”).
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They share their setup registers with the parent Power Meter module.

If you try to modify a shared setup register, a prompt identifies the register as shared and gives
the name of the parent module.

Navigate to the parent module and change the setup register there.

Using custom labels

You can assign custom labels to modules, setup registers, output registers, and Boolean ON/OFF
conditions. All modules and registers have a default label and this label is what you see in node
diagrams, user diagrams and event logs unless you specify a custom label.

Creating custom labels allows you to clearly describe what the module and its registers have been
set up to do.

However, carefully consider which modules and registers should be assigned custom labels.
There is a fixed number of labels available, but there are thousands of registers you can assign
them to. Many of these registers do not benefit from custom labels. For example, most setup
registers can be left at their default names since the only place their names might appear is in the
event log.

NOTE: Some devices, such as the 9300 and 9700, have a 15-character limit for labels.

Customizing a module label

The IONModule Setup dialog allows you to edit the module label. The module label is the text that
appears across the top of the module icon in the node diagram. It is also the label that is used in
event logs and in the dialog for the ION tree.

1. In the ION Module Setup dialog, do one of the following:

To create a custom label, select Use Custom Label and then type a name for the label
in the box.

To use the default label, select Use Default Label.

2. ClickOK to return to the node diagram.

Customizing an output register label

By providing a custom label for an output register, you can clearly indicate the information that
register contains. For example, if you have linked the Vlna output register of a Power Meter
module to a Thermal Demand module, and in turn linked the ThrmDemand output register to a
Maximummodule, you may want to label the Maximummodule's output register as “Va TD
Maximum” (instead of using the default name of “Maximum 1”).

1. In the ION Module Setup dialog, select the output register in the Output Registers area and
then clickModify to open theModify Label dialog.

2. Do one of the following:

To create a custom label, select Use Custom Label and then type a name for the label
in the box.

To use the default label, select Use Default Label.

3. ClickOK to return to the ION Module Setup dialog.



Customizing Boolean ON/OFF labels

If the output registers of the module are Boolean, you can create custom labels to associate with
the ON and OFF conditions of these registers. These labels can clarify exactly what the ON or
OFF conditions represent. For example, if a Boolean output register is used to switch a fan on and
off, you could create a Boolean ON label called “Fan Running” and an OFF label called “Fan Not
Running.”

1. In the ION Module Setup dialog, select the Boolean output register and then clickModify to
open theModify Boolean Register dialog.

2. Do one of the following:

To create custom labels, select Use Custom Labels and then type names for the
Register Label, ON Label and OFF Label in the appropriate fields.

To use the default labels, select Use Default Labels.

3. ClickOK to return to the ION Module Setup dialog.

Customizing a setup register label

1. In the ION Module Setup dialog, select the setup register and clickModify.

2. Do one of the following:

To create a custom label, select Use Custom Label and then type a name for the label
in the field.

To use the default label, select Use Default Label.

3. ClickOK to return to the ION Module Setup dialog.

Resetting ION modules in a node diagram
Designer allows you to undo certain changes you have made in a node diagram since the last
time you saved and sent your changes to the node. It refreshes the selected module icons so they
reflect what is actually on the node. Reversible changes include:

• Changing the value of a setup register.

• Changing module or register labels.

• Changing the links between modules.

NOTE: Since adding and deleting modules happens immediately on a node, you cannot undo
the deletion or the creation of a module.

To reset ION Modules:

1. Select the module(s) you want to reset.

2. Select Edit > Reset.

All the changes made to the selected modules since the last time you sent and saved the node
diagram are discarded. Modules not included in the selection are unaffected (that is, if they had
pending changes, the changes are still pending.)
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Fast-linking ION modules in the Log Inserter

When linking modules in the Log Inserter, you can save time by using the Fast Linker utility. The
Fast Linker automates much of the linking process, enabling you to quickly link any combination
of event, data or waveform recorders. To access the Fast Linker options, press the CTRL key and
click on the Log Inserter inputs.

For more information on using the Fast Linker utility, refer to the description for the Log
Acquisition module in the ION Reference.

Configuring Security module
You can configure the device security through Designer. You can enable or disable security
settings of the device. The device supports standard security and advanced security.

To enable standard security,

1. Open a node diagram of the device.

2. SelectOptions> Change Standard Meter Security.

The Change Standard Meter Security window displays.

NOTE: If the Change Standard Meter Security option is disabled, refer to Changes in
security settings of device for more information.

3. Clear the Disable Standard Meter Password check box and type the password in the
Password field then re-type it in the Confirm Password field.

4. ClickOK.

A confirmation message displays.

5. ClickOK.

6. Send and save the changes in Designer.

To enable advanced security,

1. Open a node diagram of the device.

2. Right-click the Security Optionsmodule icon to open the module setup.

3. Highlight the SOP1 Enable Advanced Security register and clickModify.

NOTE: If the SOP1 Enable Advanced Security register is not listed and the SOP1
Legacy Security Support register is listed, refer to Changes in security settings of device
for more information.

4. Select Enabled in the options dropdown and clickOK in theModify Enumerator Register
dialog.

5. ClickOK in the ION Module Setup dialog to close it.

6. Add a new Security Module from the ION modules toolbox.

7. Right-click on the newly added Security Module icon to open the module setup.

8. Click Change Password button to open the Change Advanced Meter Security window.

9. Type the password in the Password field then re-type it in the Confirm Password field.



10. ClickOK.

A confirmation message displays.

11. ClickOK to acknowledge the message.

12. ClickOK in the ION Module Setup dialog to close it.

13. Send and save the changes in Designer.

Copying and pasting ION modules
You can easily create a new function in a node diagram by copying and pasting modules. You can
copy and paste a single module, a group of modules, grouping icons, text objects, or the entire
node.

You can copy modules from one node and paste them into another, as long as the node you are
pasting to supports the selected modules and has sufficient resources. When pasting modules,
you can replace existing modules or add new ones.

You can also copy modules and save them as a framework. You and other users can then reuse
this framework in other nodes. Saving a node's configuration as a framework provides a fast and
easy way to program a large number of nodes at once.

NOTE: Persistent modules cannot be deleted, but they can be overwritten during a framework
paste. Overwriting a persistent module effectively relinks its outputs and rewrites its label, but its
core functionality remains intact (for example, the Master Reset module may be relabeled, but
pulsing this module still initiates a master reset). When pasting a default framework onto a
meter, use lock-paste to ensure that all persistent modules in the "old" default framework are
overwritten by the corresponding persistent module in the "new" default framework. Persistent
modules are listed in the "ION Device Template Reference".

Copying modules

Designer offers two ways to create copies of modules: copy and paste using the product's
clipboard or copy or paste using a framework.

NOTE: The WinPM.Net Clipboard is a temporary storage area that holds any information cut or
copied from Designer. This clipboard should not be confused with the Windows Clipboard.

When you copy a selection of ION modules, you can use Copy, Cut, or Copy to Framework:

• Copy saves the selection to the clipboard and leaves the original module(s) intact.

• Cut saves the selection to the clipboard and removes the original module(s).

• Copy to framework saves the selection as a file and leaves the original modules intact.

Additional considerations include pasting with shortcuts, modules that cannot be pasted, and
cloning a node (copying and pasting an entire node configuration from one node diagram to
another).

Cutting or copying ION modules to the clipboard

Use the Cut or Copy command to save a temporary copy of the selected modules to the clipboard.
You can then use the Paste command to transfer the selection from the clipboard into any node
diagram. Each copy retains the setup register values, custom labels, link information and layout of
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the original selection.

NOTE: When selecting modules to be cut or copied, you can also include grouping icons and
text objects. If you select a grouping icon, all modules within the group are copied, as well as any
nested grouping icons.

1. Select the module(s) you want to cut or copy.

2. Do one of the following:

To cut the selection to the clipboard and remove the original, select Edit > Cut.

To copy the selection to the clipboard and retain the original, select Edit > Copy.

Designer copies the requested information to the clipboard.

After the selection has been copied to the clipboard, you can select Edit > Paste to paste it into
any user diagram.

Copying ION modules to a framework

You can use the Copy to framework command to create a framework from the selected
modules. A framework is a template that you can use to reproduce a group of modules. Unlike
regular copying and pasting, a framework is stored as a file so you can paste it later.

When you select Edit > Copy to framework, Designer copies the layout, linking and
configuration information of each module in the selected group. It saves the framework as an .fwn
file. You can then use the Paste from framework command to paste the group in another node
diagram.

You can use frameworks to simplify the process of programming multiple devices with similar
configurations. For example, if you wanted to program a single function into several nodes, you
could program the first node and then copy the configuration to a framework. You could then
quickly program the other nodes by simply opening their node diagrams and pasting the
framework you created. You can also use frameworks to program an entire node at once,
considerably reducing the amount of time required to set up a large installation.

Before you save a group of modules as a framework, consider carefully which modules you want
to include. If you include core modules in your framework, you will not be able to paste them
unless you overwrite the existing core modules that correspond to those in your framework.
Another approach is to select the modules “downstream” of the core module and save them as a
framework. Then when you paste the framework into another node diagram, you can use the
Maintain External Inputs option to preserve your links to the original core modules. (See Using the
Paste Summary dialog for more information.)

NOTE: After you have saved a framework, it can be used in another node diagram, as long as
the node supports the modules included in the framework. Although it is possible to create a
framework from one node type and use it with another node type, it is advisable to restrict your
use of frameworks to nodes of the same type.

Copying a group of ION Modules to a framework

1. Select the group of module icons you want to copy.

2. Select Edit > Copy to Framework to open the Copy to Framework dialog.



3. In the File Name field, type a name for the framework, then click Save. The framework
filename extension (.fwn) is added automatically and the selection is saved as a framework
file.

After you have copied a group to a framework, you can select Edit > Paste from framework to
paste it into a node diagram.

Pasting ION modules
You can paste a saved copy of one or more modules into any node diagram. Designer offers two
ways to paste modules:

• Paste inserts a selection that has been placed on the clipboard using the Cut or Copy
command

• Paste from framework inserts a selection that has been saved as a file.

Pasting modules is a little more complicated than copying them, because the action of adding
modules to the node may require you to replace existing modules. Whether you choose Paste or
Paste from framework, Designer displays a Paste Summary dialog that explains each aspect of
the proposed changes.

You can use the Paste Summary box to define how to integrate the source modules into the
destination modules. For example, if a source module is being pasted to a destination that is
already occupied, you can either lock paste the new module over the existing one or free paste
the new module into the next available destination.

If you paste a selection that contains a shortcut, Designer may paste the shortcut as a module.
(See Pasting shortcuts for more information.)

In some cases, Designer may not paste every module in your selection. (See Modules that cannot
be pasted for more information.)

Pasting ION modules from the clipboard or a framework

When pasting modules, the first thing to do is select the node diagram and window where you
want the modules to go. If you have more than one window open, you can click on the title bar of
the window you want to make it the active window.

NOTE: You can paste modules into the same node diagram they were copied from or into a
different one.

You can paste modules from two sources: the clipboard or a framework. When you paste a
selection from either source, Designer describes the proposed changes in the Paste Summary
dialog. You can use the Paste Summary area to review your changes and make modifications as
necessary.
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NOTICE
UNINTENDED DEVICE OPERATION

Do not use the lock paste option to overwrite existing destination modules.

Failure to follow these instructions can result in operational differences in required
modules.

Only use the lock paste option if you are an advanced user familiar with ION architecture.

NOTE: The lock paste option overwrites an existing module but the outputs from that module are
retained as inputs of other modules. Consequently, the module may not operate as expected.
(See Using the Paste Summary dialog for more information.)

Pasting ION modules into a node diagram

1. Open the window where you want the modules to go. Click in the background of the window
to clear any selected modules.

2. Do one of the following:

To paste a selection from the clipboard, select Edit > Paste.

To paste a selection from a framework, select Edit > Paste from Framework. In the
Paste from Framework box, select the file you want and then clickOpen.

3. The Paste Summary dialog opens. Use the Paste Summary area to review the proposed
changes (see Using the Paste Summary dialog, below, for more information). When you are
satisfied with the summary, clickOK to complete the procedure.

The selection is pasted into the active window. The entire selection is automatically selected so
you can easily move it to a clear area in the window. All module icons in the selection appear as
pending until you click Send & Save to save the changes to the node.

Using the Paste Summary dialog

Before Designer pastes a selection, it displays the Paste Summary dialog. Use the Paste
Summary dialog to review and modify the proposed changes to the node diagram.

The Paste Summary dialog lists each module to be pasted and indicates its destination in the
node. For each module, a short summary of the proposed modification as well as a more detailed
description of how the module is pasted or why it cannot be pasted as requested displays in the
dialog.



The following sections describe the various areas of the Paste Summary dialog.

Source

The Source column lists each module that was copied to the clipboard or framework. Each source
module is listed by its default label unless a custom label has been specified (in which case the
default name appears in brackets after the label). Select a module in this column to view
additional information in the Details area at the bottom of the dialog.

Destination

The Destination column indicates where the copy of each source module will be placed in the
node diagram. The module label listed in the Destination column may or may not match the
module label listed in the Source column. (If the destination module is to be overwritten, it is
reused; otherwise, the next available module is used.)

Summary

The Summary column indicates whether the source module is copied into the destination as a
new module or if it replaces (overwrite) an existing module. This column also indicates if a module
will not be pasted.

NOTE: You can sort the paste summary information alphabetically by source or destination, or
by importance of summary. Click on the Source, Destination, or Summary column headers to
sort the list by the chosen criteria.

Details

The Details area located at the bottom of the dialog provides more detail than the description in
the Summary column. When you click on a module in the Source column, you can view a
description of the proposed transaction in the Details box. This description explains how a module
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is pasted or offers reasons why it will not be pasted.

TIP: You can create a copy of the information displayed in the Details section of the Paste
Summary box. To copy it, use the mouse to highlight the text you want, right-click the selection,
then select Copy. You can then paste this selection into a word-processing program.

Maintain external inputs

TheMaintain External Inputs check box allows you to paste the module selection with all
external links intact. If this check box is cleared, all external links (links to modules outside the
selection) are discarded.

The following example depicts an external link to a Power Meter module.

If you copied the modules on the right but omitted the Power Meter module from the selection, the
link to the Power Meter module would be external. Upon pasting the selection, the external link to
this module would be lost unless you selected “Maintain external inputs” on the Paste Summary
box.

Check Boxes (Free Paste/Lock Paste/No Paste)
The check boxes to the left of each module indicate the proposed action (that is, how the module
will be pasted):

• A green check mark indicates a free paste.

• A check mark with a lock symbol indicates a lock paste.

• A red “X” symbol indicates the module will not be pasted.

• An “X” symbol without a check box identifies a module that has no possible destination
and cannot be pasted.

You can click on a check box to change the proposed action. For example, if you click on a “free

paste” or a “will not be pasted” symbol, it changes to a “lock paste” symbol. When you
change the type of paste, the descriptions in the Summary column and the Details box also
change to describe the new action. (See Free paste or lock paste?, below, for more information.)

TIP: To change multiple module check boxes in the paste summary at the same time, click the
first check box in your list, hold down the Shift key, and then click the last check box in the list
you want to change.



Free paste or lock paste?

You can use the free paste and lock paste options to instruct Designer how to respond to potential
conflicts. For example, if you want to paste the module “Setpoint 1” into a diagram that already
has a “Setpoint 1” module, you have two options. You can either add the new module under a new
name (for example, “Setpoint 2”) or you can overwrite the existing module with the new one and
reuse the old name.

The first option in the above example is a free paste. It can be used to paste new modules into a
diagram without deleting any existing modules. This is useful for integrating new functions into a
node without disrupting the node's existing functionality. Although this may seem desirable,
another option is available. By leaving existing modules intact, a free paste can result in needless
duplication of functions. In addition, some groups of modules are interdependent and may require
a lock paste to operate correctly.

The second option in the above example is a lock paste. It instructs Designer to recreate the
source modules exactly, even if this requires Designer to overwrite existing modules in the
diagram. When used to quickly replace old modules with new ones, lock pasting is an efficient
alternative to the time-consuming process of deleting a module, adding a new one and then
configuring it.

You can use a combination of both free paste and lock paste within a single paste operation.

NOTE: You can pre-select modules for Designer to reuse when free pasting. In the actual
diagram where you paste the selection, press the SHIFT key and then click on any module icons
that you don't want. When you paste the new selection, Designer has the option of replacing any
of the selected modules with the new ones.

NOTE: Overwriting a module is not the same as deleting the module and then pasting a
replacement module. If a module is overwritten, links from the outputs of that module are
retained as the inputs of other modules. If a module is deleted, these links are also deleted and
do not exist after the replacement module is pasted.

Pasting shortcuts

Identified by the symbol , a shortcut icon is a representation of a module icon that is located in
another window.

You can copy a shortcut in the same way you copy the original module, but when you paste a
shortcut, one of two things happens: It is either pasted as a shortcut to an existing module (if one
is available) or as a new module. In either case, it continues to perform its function as before.

There is a basic reason for replacing a shortcut with a module: a shortcut cannot exist in a node
without the module it represents. When you paste a selection containing a shortcut, Designer
searches both the selection to be pasted and the destination to locate the module the shortcut
represents. If it finds the module, it pastes the shortcut as a shortcut. If it doesn't find the module, it
replaces the shortcut with a copy of the module. In this way, Designer functions so that the pasted
selection is complete and not dependent on a module that is unavailable in the destination node.

Designer performs this process automatically; it requires no input from you.
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Modules that cannot be pasted

Some modules cannot be pasted because their settings are non-transferable between nodes. All
Factory, Communications, and Diagnostics modules must be individually configured for each
node.

When pasting a selection that contains a Factory, Communications or Diagnostics module,
Designer pastes the location of the icons only.

Cloning a node

You can quickly configure multiple nodes by cloning a node. Essentially, cloning a node involves
copying a node's entire configuration to a framework then pasting it onto another node. This
effectively reprograms the node receiving the framework as an exact copy of the original.

NOTE: When you paste an entire node's configuration, the Factory, Communications, and
Diagnostics modules are not pasted because they could disrupt the operation of the device's
communications. If you need to change the settings of these modules, you can do so manually.

Copying a node's entire configuration

1. Open the node diagram of the node you want to copy. Ensure that you are in the main or root
window of the diagram.

2. Select Edit > Select All. All core modules, standard modules, grouping windows and text
icons are selected.

3. Select Edit > Copy to framework to open the Copy to framework dialog.

4. In the File name box, type a name for the framework and then click Save. The framework
filename extension (.fwn) is added automatically and the entire node configuration is saved
in this framework file.

After you have saved the source node's configuration as a framework, you can paste it to other
nodes of the same type. This file can also serve as a backup in case you want to restore the
configuration of the source node.

Pasting a node's entire configuration into another node

1. Open the node diagram of the node to which you want to paste the configuration. Ensure
that you are in the main or root window of the diagram.

2. Select Edit > Select All. Press the Delete key to remove the node's existing configuration.
A dialog opens listing the standard modules that will be deleted and the core modules that
cannot be deleted. ClickOK to continue.

The standard modules and text icons are deleted, and the core modules (and any grouping
windows containing core modules) remain.

3. Select Edit > Select All to select the remaining module (and grouping) icons.

4. Select Edit > Paste from framework to open the Paste from framework dialog, select the
framework file that contains the node configuration you want to paste, and then clickOpen.

The Paste Summary dialog opens. (See Using the Paste Summary dialog for information
on using the Paste Summary box.)



5. Select all modules in the list (click last item, hold the SHIFT key, and then click first list item -
the entire list appears highlighted).

6. Change the paste type to lock paste (hold the SHIFT key and then click the paste type check

box until all modules are set to lock paste ).

7. ClickOK to complete the procedure.

The selected framework is pasted into the node diagram. All module icons in the selection appear
as pending until you select Send & Save to save the changes to the node.

Viewing output registers, setup registers, and inputs
Each module icon has an input symbol and an output symbol. The input symbol (on the left)
provides access to the module's inputs and the output symbol (on the right) provides access to the
module's output and setup registers.

A Input

B Output

A register is a type of memory bank that stores a module's linking and configuration information.
Each module uses two types of registers:

• Output registers store data that has been processed by the module (such as numeric values,
event log entries, and waveform data).

• Setup registers store the module's configuration information.

Both types of registers serve as storage locations for the module.

Viewing output register information
Output register information includes the module's available output registers, the real-time values
of the output registers and the owners of the output registers. Each of these can be accessed from
the output symbol located on the right side of the module icon.

A
Click the output symbol to
access the module's output
register information
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Viewing available output registers

Click the output symbol.

Viewing the real-time values of output registers

Press the SHIFT key and click the output symbol.

Viewing the owners of output registers
Right-click the output symbol. This displays an output register's owners so you can identify all
dependent modules on the node and determine the purpose of each dependent module. This is
useful when determining the effects and consequences of deleting a module.

Viewing setup register information
Amodule's setup registers contain its configuration information. When a module processes data,
it manipulates the data according to the guidelines stored in its setup registers. Setup register
information includes the module's available setup registers, the setup register settings, and the
setup register owners. Each of these can be accessed from the output symbol located on the right
side of the module icon.

A Right-click the graphic to access the ION Module Setup dialog.

B

Press CTRL and click the output symbol to access the
ION Module Setup dialog.
Press CTRL+SHIFT and click the output symbol to display the
ION Module Setup dialog to view Setup Register settings.
Press CTRL and right-click the output symbol to view
SetupRegister owners.

Viewing setup registers

Press the CTRL key and click the output symbol or right-click the graphic in the center of the
module to display the IONModule Setup dialog.

Viewing setup register settings

Press CTRL+SHIFT and click the output symbol or right-click the graphic in the center of the
module to display the IONModule Setup dialog.

Viewing setup register owners

Press the CTRL key and right-click the output symbol.

Viewing input information
Input information includes the module's inputs and a sample of its real-time input values. Each of
these can be accessed from the module's input symbol.



A
Click the input symbol to access the module's input
information

Viewing inputs

Click the input symbol.

Viewing real-time input values

Press the SHIFT key and click the input symbol.
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Chapter 6: Virtual Processor service (VIP)
The Virtual Processor is a service that operates on the WinPM.Net server, providing coordinated
data collection, data processing, and control functions for groups of meters. This makes
distributed operations possible, providing customized solutions to a variety of industrial,
commercial, and power utility needs.

WARNING
INACCURATE DATA RESULTS
• Do not incorrectly configure the software or the devices.
• Do not base your maintenance or service actions solely on messages and information
displayed by the software.

• Do not rely solely on software messages and reports to determine if the system is
functioning correctly or meeting all applicable standards and requirements.

• Consider the implications of unanticipated transmission delays or failures of
communications links.

Failure to follow these instructions can result in death, serious injury, equipment
damage, or permanent loss of data.

WARNING
UNINTENDED EQUIPMENT OPERATION
• Do not use control objects for time-critical functions because delays can occur between the
time a control action is initiated and when that action is applied.

• Do not create a custom control object in Virtual Processor for remote equipment operation
without configuring it with the appropriate access level, and without configuring a status
object to indicate the status of the control operation.

Failure to follow these instructions can result in death, serious injury, or equipment
damage.

The Virtual Processor lets you gather the information available from your network of power
monitoring devices, and enables you to categorize, manipulate, and/or customize the data before
distributing the information to the different departments in your company. You could think of the
Virtual Processor as a virtual device, capable of collecting and processing data from several
power monitoring devices, analyzing the information and performing control functions as required.
The Virtual Processor's name implies its characteristics:

• Virtual - The Virtual Processor runs in the memory of your PC, not as a remote device.

• Processor - The Virtual Processor contains a wide selection of ION modules, which it uses to
process information.
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Using the Virtual Processor
A VIP.DEFAULT Virtual Processor service is created by default. However, this Virtual Processor
is not configured at the factory. To perform data collection, data analysis, Modbus
communications, or distributed control, you must first create ION module frameworks, using
Designer. Refer to the ION Reference for information on IONmodules.

Configuring the Virtual Processor with Designer
Use Designer to perform all Virtual Processor configuration, including adding new modules,
configuring module setup registers, and linking module inputs and output registers to other
modules.

Creating a second Virtual Processor
Create a secondWinPM.Net Virtual Processor Service and start it using the following steps:

1. Open a command prompt window.

2. Register the Virtual Processor as a service from the ...\WinPM.Net\system\bin folder by
typing: vip.exe -Service -N<custom Virtual Processor name>

3. Open Control Panel > Administrative Tools > Services and start the new registered
Virtual Processor.

Viewing Virtual Processor data with Vista

After you have used Designer to add and link modules in the Virtual Processor, you can create a
user diagram in Vista and link it to the modules in the Virtual Processor. You can then use your
user diagram to display system data, monitor alarms, and control basic functions in your Virtual
Processor framework.

Configuring the Virtual Processor to interact with the desktop

1. Open Control Panel > Administrative Tools > Services.

2. Right-click the WinPM.Net Virtual Processor Service and select Properties.

3. Select the Log On tab.

4. Select the “Allow service to interact with desktop” check box and clickOK.

5. Stop and restart the WinPM.Net Virtual Processor Service.

Distributed control
Virtual Processor Distributed Control modules are a means of transferring information between
the different devices in your network. These modules can be used to build frameworks for control
processes such as alarm annunciation, plant-wide demand control, power factor control, load
shedding, paging, and generator switching.

Before you decide to use a Virtual Processor to implement a control system, it is important to
understand the various factors that influence the speed with which the Virtual Processor is able to
generate a control action. Some of these factors include network traffic, the number of polled
devices in your network, the reliability of your communications network, and the Virtual Processor
workstation's CPU usage.



WARNING
UNINTENDED EQUIPMENT OPERATION
• Do not use control objects for time-critical functions because delays can occur between the
time a control action is initiated and when that action is applied.

• Do not create a custom control object in Virtual Processor for remote equipment operation
without configuring it with the appropriate access level, and without configuring a status
object to indicate the status of the control operation.

Failure to follow these instructions can result in death, serious injury, or equipment
damage.

The information presented in this section assumes that you are familiar with the various ION
modules and their functions. Refer to the ION Reference for details on Distributed Control and
other modules.

Distributed control modules

The Virtual Processor uses four modules to implement Distributed Control frameworks. Three
types of Distributed Control modules (Distributed Boolean, Numeric, and Pulse modules) receive
data from devices or other Virtual Processors within your network and transfer this data to the
node address specified in the module's setup registers. The Data Monitoring module is used as a
means of disabling a control module, if the data at the source input (which is used to make the
control decision) becomes “stale”.

Distributed control module setup registers

All Distributed Control modules (Distributed Boolean, Distributed Numeric, and Distributed Pulse
modules) have a Source input and an Activate input. The Activate input must be linked to another
module, and it must be on for a Distributed Control module to function. These modules also
contain a Destination setup register that specifies the node receiving the data.

Distributed Boolean module

All Distributed Boolean modules have one input that must linked to an External Boolean output
register. Whenever this register’s Boolean value changes state, the new value is sent to the node
defined in the Destination setup register.

Distributed numeric module

A Distributed Numeric module's input must be linked to an External Numeric module. This input’s
value is sent to the node specified in the Destination setup register. This module has two
additional setup registers that are used to determine when and how often new data is sent to the
Destination node.

Distributed pulse module

All Distributed Pulse modules have one input that must link to an External Pulse module. This
module’s pulse is sent to the node defined in the Destination setup register.
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Data monitoring module

The Data Monitor module provides a means of alerting you to communication problems that may
occur between the Virtual Processor and any ION node referenced by the Data Monitor's Source
inputs.

NOTE: ACCESS meters with Advanced Security enabled do not accept control operations from
the Virtual Processor. In order to enable these control operations, you need to provide a device
password in Management Console for these applications to use. See Accessing meters with
security for information on configuring Advanced Security.

Distributed control network performance

It is important to maximize the speed at which the Virtual Processor receives the data used to
make control decisions. The performance of a Virtual Processor using Distributed Control is
sensitive to factors such as network traffic, the Virtual Processor's global parameters, and the
workstation's CPU usage.

The following sections provide some guidelines for improving a distributed control network's
performance.

System configuration
• Minimize the number of devices per site for sites including devices used for distributed
control.

• Minimize the number of applications (such as Vista diagrams) that are requesting data from
the control site.

• Decrease the Virtual Processor's Client Polling Period.

• Maximize the site's baud rate.

CPU performance
• Dedicate a single Virtual Processor for control purposes; an additional Virtual Processor can
be run for less critical functions.

• Do not run CPU intensive functions on the same workstation as your distributed control Virtual
Processor.

Distributed control applications

The Virtual Processor's Distributed Control frameworks can perform various control processes;
two examples are presented below. Ensure that you are familiar with the sections above before
using any of these module frameworks in a control system.



Example: Passing a value between devices
The following example shows how the numeric output of the Integrator modules in meter “A” is
sent to an External Numeric module in meter “B”.

Note that the Distributed Numeric module is disabled if the Data Monitor module detects a
communication problem between the meter “A” and the Virtual Processor (for example, timeouts
or slow network connections). As a result, control actions are only performed based on up-to-date
data.

Example: Device control
This example framework monitors total harmonic distortion (THD), which could cause a piece of
equipment (like a power transformer) to overheat. When a setpoint is reached, the system sends
a network message to a workstation and turns on a fan.

Example: Data aggregation

In the following example, meters monitor average current values (I avg). Every day at a specified
time (determined by the Periodic Timer module), the Data Recorder Module stores the maximum
average current value for each meter.
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Example: Logging data from meters

The Virtual Processor can be used to log data from meters that do not have Data Recorders. In
the following example, the total kWh from a meter’s Integrator module is recorded every 15
minutes by a Virtual Processor's Data Recorder module.

Note that the Virtual Processor holds only 100 records at a time, that is, it holds about one day of
15 minute data. If the Virtual Processor stops operating, data logging also stops.

Setting global parameters
The Virtual Processor global operating parameters and Modbus network setup are configured
using Virtual Processor Setup.

The global parameters do not need to be changed for normal operation. The Virtual Processor
operates properly in most applications with the default settings. See Modifying the Global
Parameters for details.

To set up the Virtual Processor’s Modbus network, see Virtual Processor setup.

NOTE: The WinPM.Net Virtual Processor Service must be restarted for any changes to take
effect, as the Virtual Processor only reads the vipsys.dat file once on startup. The WinPM.Net
Virtual Processor Service can be restarted, like any other service, using the Services window
found via the Control Panel service applet.



Chapter 7: Hierarchy Configuration Utility
The Hierarchy Configuration Utility is intended for Application Engineers or advanced users
working with hierarchies in WinPM.Net.

The utility is a command-line executable that allows you to save, restore, or add hierarchy
content.

The primary purpose of the utility is to give you a way to add a large number of entries to a
hierarchy rather than creating individual entries in Hierarchy Manager. This task consists of:

• Saving a skeleton hierarchy configuration in a CSV file.

• Editing the CSV file to associate the devices listed in the file to the nodes of the hierarchy.

• Populating Hierarchy Manager with the updated contents of the hierarchy configuration CSV
file.

The utility also provides options for:

• Saving or replacing a hierarchy configuration currently defined in Hierarchy Manager.

• Installing or saving a hierarchy template.

• Refreshing a configuration cache to ensure that all devices are included when you save a
hierarchy configuration.

• Deleting a hierarchy configuration prior to restoring a saved configuration.

Throughout this document, references to "configuration" and "template" should be interpreted as
follows:

• configuration – the entries representing the node types, devices, and virtual meters that
comprise the content of a hierarchy.

• template – defines the node names, attributes, relationships, and views in Hierarchy
Manager.

Hierarchy Configuration Utility command and options
Run the Hierarchy Configuration Utility command, HierarchyConfig.exe, from a Command
Prompt.

To open a Command Prompt window:

1. UseWindows Explorer to navigate to:

...\WinPM.Net\Applications.

2. Click the bin folder and press Shift + Right-click and selectOpen command window here
on the context menu.

The command syntax is:
HierarchyConfig.exe option <file path>\<file name>, where:

• option: see Command options below.

• <file path>: the location of the file that the command runs on.
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• <file name>: the name of the CSV or XML file, including the .csv or .xml file extension,
respectively.

Command options

Use the command as follows (type the command and press Enter):

Running the command without options
• To see a brief description of available command options:

HierarchyConfig.exe

Running the command using the config option
• To create a skeleton configuration CSV file that you can use to define a hierarchy
configuration:

HierarchyConfig.exe export config <file path>\<file name>.csv

Note that this process creates a header row in the CSV file with percentage, node type
names, and virtual meter column headings. It also includes a list of the devices in the system
that are not included in a hierarchy. This allows you to specify which devices you want to
include in the hierarchy when you import the configuration.

Optional: Including all devices

Add the alldevices option at the end of the export config command to create a CSV file that
lists all of the devices, whether or not they are included in a hierarchy. This option ensures
that apportioned devices or devices that constitute a virtual meter are included in the file.

To include all devices, type the following:

HierarchyConfig.exe export config <file path>\<file name>.csv

alldevices

Note that the CSV file created with the alldevices option is intended for reference purposes
only and not for updating an existing hierarchy.

• To add the contents of the updated skeleton configuration CSV file to Hierarchy Manager:

HierarchyConfig.exe import config <file path>\<file name>.csv

NOTICE
LOSS OF DATA
• Do not use the hierarchy configuration CSV file to incrementally update an existing
hierarchy.

• Use the Hierarchy Manager application to incrementally update an existing hierarchy.

Failure to follow these instructions can result in the corruption of hierarchy data.

Optional: Adding a timestamp to configuration entries



You can also add a timestamp to the configuration entries. Adding year, month, and day
information adds a start date to the imported references corresponding to the date entered. If
no date information is provided, the start date of the hierarchy information is the system start
date.

To add a timestamp, type HierarchyConfig.exe import config <file

path>\<file name>.xml [yyyy/mm/dd] where [yyyy/mm/dd] is the year, month and
day that the imported hierarchy references use as a start date.

• To back up a complete representation of the hierarchy and all virtual meters in an XML file:

HierarchyConfig.exe export config <file path>\<file name>.xml

This creates a backup of the hierarchy before you modify the hierarchy entries in Hierarchy
Manager.

• To restore a hierarchy configuration from a backup configuration XML file:

HierarchyConfig.exe import config <file path>\<file name>.xml

NOTICE
LOSS OF DATA
• Do not use the hierarchy configuration XML file to incrementally update an existing
hierarchy.

• Use the Hierarchy Manager application to incrementally update an existing hierarchy.

Failure to follow these instructions can result in the corruption of hierarchy data.

This process deletes the current hierarchy configuration defined in Hierarchy Manager and
replaces it with the hierarchy configuration in the XML file.

• To refresh a configuration cache to ensure that all devices are included in the saved
configuration:

HierarchyConfig.exe refresh config

• To delete a hierarchy configuration:

HierarchyConfig.exe delete config

Only use this process if you have previously saved your configuration.

Running the command using the template option
• To save the hierarchy template used in Hierarchy Manager:

HierarchyConfig.exe export template <file path>\<file name>.xml

The template defines the node names, attributes, and relationships used in Hierarchy
Manager.

• To replace an existing hierarchy template used in Hierarchy Manager with a different one:

HierarchyConfig.exe import template <file path>\<file name>.xml
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Populating a hierarchy
After installing and commissioning WinPM.Net, you can populate Hierarchy Manager by
associating devices to nodes in a skeleton configuration CSV file and importing the entries into
Hierarchy Manager. Following a successful import, you can use Hierarchy Manager to modify
your hierarchy information. You can then use hierarchies in other WinPM.Net applications, such
as in view-enabled reports in the Web-based Reports application, and in the Dashboards
application.

For illustration purposes, the default hierarchy template in Hierarchy Manager is used as a
reference for this task.

The skeleton configuration CSV file created from the default hierarchy template used in Hierarchy
Manager includes a header row with column headings of Devices_Full Name, _Percentage,
Site_Name, Buildings_Name, Areas_Name, and Virtual Meter_Name. It also includes a list of
the devices in the system that are not included in a hierarchy so that you can associate the
devices to the hierarchy nodes.

Different hierarchy templates can be used in Hierarchy Manager. Each hierarchy template
determines the information that is included in the configuration CSV file. For example, the Site
Building Area Tenant.xml hierarchy template file results in column headings of
Devices_Full Name, _Percentage, Site_Name, Buildings_Name, Areas_Name, Tenants_
Name, Tenants_Contact, Tenants_email, Tenants_Phone, and Virtual Meter_Name in the
configuration CSV file.
(Sample and generic hierarchy templates are located in the:
...\Applications\HierarchyManager\SampleTemplates folder.)

The procedure for updating a skeleton configuration CSV file follows a consistent pattern
regardless of the template used in Hierarchy Manager.

The process for adding a large number of entries to a hierarchy consists of:

• Saving a skeleton hierarchy configuration in a CSV file.

• Editing the CSV file.

• Updating Hierarchy Manager with the new entries and verifying the outcome.



NOTICE
LOSS OF DATA
• Do not use the hierarchy configuration CSV file to incrementally update an existing
hierarchy.

• Use the Hierarchy Manager application to incrementally update an existing hierarchy.

Failure to follow these instructions can result in the corruption of hierarchy data.

Before you begin
Before you export the skeleton configuration CSV file from Hierarchy Manager, make sure that
you complete the following tasks:

• Plan how the hierarchy is going to be configured, such as: naming conventions, which
devices are going to be mapped to which Node, and how the different elements are grouped
together. This can save time when you enter content in the configuration CSV file and it is
very important when dealing with a large number of devices.

For illustration purposes in this task, devices are going to be mapped to a physical layout
consisting of 4 areas within a building.

• Install Microsoft Excel, or another spreadsheet application that you can use to open and edit
CSV files on your system.

• Add devices or logical devices to WinPM.Net. You can add additional devices at a later time,
but you need to have an initial number of devices before you export the skeleton configuration
CSV file.

Saving a hierarchy configuration in a CSV file
This process creates a skeleton hierarchy configuration CSV file with a header row that includes
percentage, node type names, and virtual meter column headings. It also includes a list of the
devices in the system that are not included in a hierarchy. This allows you to specify which of
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those devices you want to include in the hierarchy when you import the contents of the hierarchy
configuration CSV file.

If devices have recently been added, use the refresh command to update the configuration cache
before proceeding. (See Refreshing the hierarchy cache for more information.)

1. Open a Command Prompt window:

a. UseWindows Explorer to navigate to:

...\WinPM.Net\Applications.

b. Click the bin folder and press Shift + Right-click and selectOpen command window
here on the context menu.

2. Type HierarchyConfig.exe export config <file path>\<file name> and
press Enter.

Where <file path> is the location for the exported CSV file, and <file name> is the
name of the file, including the .csv file extension. If you do not specify a file path, the current
directory is used.

NOTE: If you include spaces in the CSV file name and/or file path, you must enclose the
file path and file name in quotation marks. For example, HierarchyConfig.exe export

config "C:\test file.csv".

The items in the skeleton hierarchy configuration CSV file includes a list of devices not
included in a hierarchy, the heading _Percentage, headings for the node types, and the
heading Virtual Meter_Name.

Adding content to the configuration CSV file
The following steps describe:

• Defining the main elements (instances of a node) of the hierarchy.

• Associating devices to areas.

• Adding a virtual meters and associating devices.

Defining the main elements of the hierarchy
Define the site, building, and area names in the file as follows:

1. Open the hierarchy configuration CSV file in Excel.

2. On an empty row below the list of devices, type the names that you want to use for the site,
the building, and an area association in their respective columns.



As indicated in the previous description of the physical layout, there are 4 building areas.
You now need to define the association of the 3 remaining areas to the building and site.

3. Repeat the previous step for each of Area 2, Area 3 and Area 4, as shown in the following
image.

This completes the association of the 4 areas to the building instance, Building 1, and the
site instance, Test Site.

If there are additional buildings on the site, you can repeat the pattern that you entered. For
example, if there is a Building 2 on the site, your entries would include the same site name,
Test Site, but the building name is Building 2. Note that you should use unique names for
the areas. For example, for Building 2, define the area names like B2-Area 1, B2-Area 2,
and so on.

Associating devices to areas
Complete the following steps to associate devices to specific areas:

1. Type the area name that you defined in the previous set of steps, in the Areas_Name
column on the row identifying the device full name.

For example, to associate device Test_Site.Device1 to Area 1, type Area 1 in the Areas_
Name column in that row.
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2. Continue to associate any of the remaining devices to their respective areas. Note that you
can assign multiple devices to the same area. For example, the following image shows two
devices assigned to Area 3 and two to Area 4.

Adding a virtual meter and associating devices
To define a virtual meter:

1. Type the virtual meter name in the Virtual Meter_Name column on the row identifying each
device full name that you want to associate with the virtual meter.



2. To apportion a percentage of a device's value to the virtual meter, type a percent value for
the applicable device in the _Percentage column. For example, apportion 25% of Test_
Site.Test_8600_C and 75% of Test_Site.Test_8600_D to virtual meter VM1.

3. To associate a virtual meter to a specific area, add the virtual meter name to the Devices_
Full Name column on a row defining the area. For example, to associate VM1 to Area 2,
add VM1 to line 13 (in this example) in the CSV file.

You can also associate a virtual meter (VM1) to another virtual meter by including the virtual
meter name in the Devices_Full Name column and adding the additional virtual meter
name on the same row under the Virtual Meter_Name column.
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When you complete your updates in the hierarchy configuration CSV file, you can now update
Hierarchy Manager by importing the contents of the CSV file.

Adding your entries to Hierarchy Manager
Complete the following steps to add the contents of the hierarchy configuration CSV file to
Hierarchy Manager:

1. Open a Command Prompt window:

a. UseWindows Explorer to navigate to:

...\WinPM.Net\Applications.

b. Click the bin folder and press Shift + Right-click and selectOpen command window
here on the context menu.

2. Type HierarchyConfig.exe import config <file path>\<file name> and
press Enter.

Where <file path> is the location of the file you are importing, and <file name> is the
name of the file, including the .csv file extension. If you do not specify a file path, the current
directory is used.

The import process provides feedback during each stage of the import. If the import
operation is unsuccessful, the utility provides information about possible reasons for the
unsuccessful operation.

NOTE: If the CSV file name and/or file path contains spaces, you must enclose the file path
and file name in quotation marks. For example, HierarchyConfig.exe import

config "C:\test file.csv".

3. Verify the correct hierarchy configuration in Hierarchy Manager.

Saving and restoring a hierarchy configuration
The Hierarchy Configuration utility allows you to save (export) the configuration as an XML file.
The file contains a full representation of the current hierarchy in Hierarchy Manager, including:

• Nodes.

• Relationships between nodes, including their time dimensions.

• All apportionment nodes.

This lets you back up the hierarchy before modifying it in the Hierarchy Manager application. You
can import the hierarchy configuration saved in the XML file to restore your hierarchy in Hierarchy
Manager.

NOTE: Restoring (importing) a configuration XML file deletes the current hierarchy configuration
and replaces it with the one represented in the file.



NOTICE
LOSS OF DATA
• Do not use the hierarchy configuration XML file to incrementally update an existing
hierarchy.

• Use the Hierarchy Manager application to incrementally update an existing hierarchy.

Failure to follow these instructions can result in the corruption of hierarchy data.

Saving the entire hierarchy configuration in an XML file
To save a configuration XML file:

1. Open a Command Prompt window:

a. UseWindows Explorer to navigate to:

...\WinPM.Net\Applications.

b. Click the bin folder and press Shift + Right-click and selectOpen command window
here on the context menu.

2. Run HierarchyConfig.exe export config <file path>\<file name>, where
<file path> is the location where you want to save XML file, and <file name> is the
name of the XML file, including .xml as the file extension. If you do not specify a file path,
the current directory is used.

NOTE: If the XML file name and/or file path contains spaces, you must enclose the file path
and file name in quotation marks. For example, HierarchyConfig.exe export

config "C:\test file.xml".

Restoring the entire hierarchy configuration from an XML file

NOTE: Restoring a configuration XML file deletes the current hierarchy configuration and
replaces it with the one represented in the file.

NOTICE
LOSS OF DATA
• Do not use the hierarchy configuration XML file to incrementally update an existing
hierarchy.

• Use the Hierarchy Manager application to incrementally update an existing hierarchy.

Failure to follow these instructions can result in the corruption of hierarchy data.
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To restore the configuration XML file:

1. Open a Command Prompt window:

a. UseWindows Explorer to navigate to:

...\WinPM.Net\Applications.

b. Click the bin folder and press Shift + Right-click and selectOpen command window
here on the context menu.

2. Type HierarchyConfig.exe import config <file path>\<file name>, where
<file path> is the location of the file you are importing, and <file name> is the name of
the XML file, including .xml as the file extension, to be imported. If you do not specify a file
path, the current directory is used.

3. Verify the correct hierarchy configuration in Hierarchy Manager.

Installing or saving a hierarchy template
The import template command option lets you install a hierarchy template as a replacement
for the template used in Hierarchy Manager. The export template command option lets you
save a copy of the hierarchy template used in Hierarchy Manager. Prior to using these
commands, you should back up your existing hierarchy configuration (see Saving the entire
hierarchy configuration in an XML file).

Installing a hierarchy template
Use the import template option to replace the template currently installed in your system with a
different one.

NOTICE
LOSS OF DATA

The new template overwrites the existing template, which permanently removes all information
contained in the original. Export the existing hierarchy template fromWinPM.Net before
importing a new template.

Failure to follow these instructions can result in a loss of data.

When you import the hierarchy template XML file, the Hierarchy Configuration Utility performs a
validation test on the file. If the file validation is not successful, the utility does not import the file
and provides information indicating where the validation process stopped. Check for any
discrepancies in the file, save the changes and reimport the file.

To import a hierarchy template XML file:

1. Open a Command Prompt window:

a. UseWindows Explorer to navigate to:

...\WinPM.Net\Applications.



b. Click the bin folder and press Shift + Right-click and selectOpen command window
here on the context menu.

2. Type HierarchyConfig.exe import template <file path>\<file name>,
where <file path> is the location of the XML file, and <file name> is the name of the
XML file, including .xml as the file extension, to be imported. If you do not specify a file path,
the current directory of the Hierarchy Configuration Utility is used.

The utility provides feedback for each stage of the import. If the import operation is
unsuccessful, the utility provides information about why the import is unsuccessful.

NOTE: If the XML file name and/or file path contains spaces, you must enclose the file path
and file name in quotation marks. For example, HierarchyConfig.exe import

template "C:\test file.xml".

3. Verify that the template has been successfully imported in Hierarchy Manager.

Hierarchy Manager should now display the nodes defined in the newly imported template.

Saving a hierarchy template
Use the export template option to save the Hierarchy Manager template currently installed in the
system as an XML file. The file defines the node names, attributes, relationships, and views for
Hierarchy Manager.

To export a hierarchy template XML file:

1. Open a Command Prompt window:

a. UseWindows Explorer to navigate to:

...\WinPM.Net\Applications.

b. Click the bin folder and press Shift + Right-click and selectOpen command window
here on the context menu.

2. Type HierarchyConfig.exe export template <file path>\<file name>,
where <file path> is the location where you want to save the XML file, and <file
name> is the name of the XML file, including .xml as the file extension. If you do not specify
a file path, the current directory is used.

NOTE: If the XML file name and/or file path contains spaces, you must enclose the file path
and file name in quotation marks. For example, HierarchyConfig.exe export

template "C:\test file.xml".

3. Navigate to the location you specified to confirm that the XML file is successfully saved.

Refreshing the hierarchy cache
Use the refresh config option to refresh the configuration cache. If you recently added new
devices to WinPM.Net , use this command before you export a hierarchy configuration CSV file so
that an up-to-date list of devices is included in the file. If the refresh configuration is not run, there
is a possibility that devices recently added to WinPM.Net may not be present in the device list in
the hierarchy configuration CSV file. The best practice is to run the refresh config command
before exporting any CSV or XML file from Hierarchy Manager.
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To refresh the configuration cache:

1. Open a Command Prompt window:

a. UseWindows Explorer to navigate to:

...\WinPM.Net\Applications.

b. Click the bin folder and press Shift + Right-click and selectOpen command window
here on the context menu.

2. Run HierarchyConfig.exe refresh config.

The message Configuration cache refresh complete indicates that the refresh
operation has finished.

Deleting hierarchy configuration content
Use the delete config option to remove all hierarchy configuration content from Hierarchy
Manager, such as names and properties. This allows you to start with new content. Note that this
delete process does not remove virtual meters. You need to use Hierarchy Manager to delete
virtual meters.

NOTICE
LOSS OF DATA

Performing this operation permanently removes configuration content from the system. Ensure
that this operation is necessary before proceeding. This procedure cannot be undone.

Failure to follow these instructions can result in a loss of data.

To delete configuration content:

1. Open a Command Prompt window:

a. UseWindows Explorer to navigate to:

...\WinPM.Net\Applications.

b. Click the bin folder and press Shift + Right-click and selectOpen command window
here on the context menu.

2. Type HierarchyConfig.exe delete config. Type yes when prompted. The utility
deletes all hierarchy configuration content. To confirm the deletion, open Hierarchy
Manager. There should be no hierarchy content displayed.

Hierarchy template structure
WinPM.Net includes a number of standard hierarchy templates that provide a structure for
modeling the different aspects of your organization. This section describes the structure of a
hierarchy template XML file.

Sample and generic hierarchy templates are included with your software. You can use any of
these templates if they more closely represent the hierarchy organization you want to implement.
However, you need to have a thorough understanding of the structure of a template before



making any changes. Always back up your files before proceeding with any changes. The
additional hierarchy templates are located in:
...\Applications\HierarchyManager\SampleTemplates

NOTE: Any time you change a hierarchy template, you need to import it into Hierarchy Manager
before those changes take effect. See Installing a hierarchy template.

Localizing a hierarchy template XML file

You can localize a hierarchy template XML file to display national language text on the tabs and
views in Hierarchy Manager, and also wherever hierarchies are enabled in the Web Applications
component. For example, localized hierarchy node names will display in the Source Selector in
the Reports application.

To localize the text you need to edit the displayName attribute that is used throughout a hierarchy
template XML file. For example, the display name attribute for Site in the hierarchy template file
is displayName="Site". Change the text within the quotation marks to the national language
equivalent.

The displayName attribute is used in <Type>, <Attribute>, <Reference>, and <View> xml
elements in a hierarchy template file. (See The XML elements in the template file for descriptions
of these elements.) In some cases the same text is used on displayName attributes more than
once in the hierarchy template file. Be sure to change every occurrence in the file.

When you complete the edits, follow the process described in Installing a hierarchy template to
update the hierarchy template used by Hierarchy Manager.

The hierarchy template
The hierarchy template XML file defines the Node types, attributes, and relationships used in
Hierarchy Manager. Each element of the template is defined using information contained within
the various XML tags. For example, assume that Generic 5 Level Template.xml is
imported into Hierarchy Manager. (See the Generic 5 Level Template.)

The initial page in Hierarchy Manager shows the node types and attributes defined in the
hierarchy template file. The bottom three node types are configured for devices to be connected
to them.

(See Additional notes for considerations related to associating devices to more that one node
level in a hierarchy.)

The hierarchy view defined in the template is represented on the Hierarchy Manager Tree View
page as a physical layout:
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The following table summarizes the major elements in a hierarchy template XML file.

Tag Description Example

<Template>
Contains template namespace
information

<Template version="1.0"
xmlns="uri:application-
modules/power/model/template#">

<Types>
Container tag for Type and
Attribute elements

<Types> </Types>

<Type>

Defines elements that define
characteristics used by the node.
Each type represents a tab in
Hierarchy Manager.

<Type displayName="level_1".../>

<Attribute>
Defines the characteristics used
in each type.

<Attribute displayName="id"
dataType="String" uri="uri::application-
modules/power/model/attribute#name"
/>

<Reference>

Used to create relationships
between nodes. For a relationship
to exist between nodes, each
Type element must contain
reference information for every
other element it is associated
with.

<Reference displayName="level_2"
isReverse="true" target="uri:application-
modules/power/model/type#level_2"
uri="uri:application-
modules/power/model/relation#1_2" />

<Views>

Contains elements that define
how the Node types are
presented in different hierarchical
views.

<Views> </Views>

<View>
Specifies the node type the view
starts at. Contains Relation
elements.

<View displayName="Generic Layout"
rootNodeTypeUri="uri:application-
modules/power/model/type#level_1">

<Relation>
Contained in a View element.
Defines the order that the node
types are displayed in.

<Relation follow="uri:application-
modules/power/model/relation#1_2"
reverse="true" />

The XML elements in the template file
This section describes each element in the template XML file.



<Template>

The <Template> element is the container for all of the XML tags.

<Template version="1.0" xmlns="uri:application-

modules/power/model/template#">

<Types>

This is a containment tag for all <Type> elements. Make sure any <Type> elements are inside
this containment tag.

<Types>

<Type...>

...

</Type>

...

</Types>

<Type>

The <Type> tag contains all the information required to define the Node. Each defined type adds
a tab in Hierarchy Manager. The tab name is defined by displayName. The <Type> tag also
contains one or more <Attribute> and <Reference> tags.

<Types>

<Type displayName="level_1" uri="uri:application-

modules/power/model/type#level_1">

<Attribute... />

<Attribute... />

...

<Reference... />

...

</Type>

<Type>

...

</Type>

</Types>

To change the tab name in Hierarchy Manager from level_1 to new_name, modify
displayName in the template file from:

<Type displayName="level_1" uri= "uri:application-

modules/power/model/type#level_1">

to:

<Type displayName="new_name" uri="uri:application-

modules/power/model/type#new_name">
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<Attribute>
The <Attribute> tag defines the characteristics of the <Type>. It uses dataType to determine
the format of the edit dialog that opens in Hierarchy Manager.

You need to define at least one <Attribute> element with attribute#name in the uri:
uri:application-modules.com/power/model/attribute#name.

The datatypes on the <Attribute> element can be such things as name, floor number, or
breaker ratings, depending on the template layout.

• dataType="String" - For short blocks of text (for example, name).

• dataType="LongText" - For long blocks of text (for example, notes, contact information).

• dataType="Number" - For numeric fields (for example, breaker rating in Amps).

• dataType="Boolean" - For checkboxes (for example Rack Circuit).

<Types>

<Type displayName="level_1" uri="uri:application-

modules/power/model/type#level_1">

<Attribute displayName="id" dataType="String" uri="uri:application-

modules/power/

model/attribute#name" />

<Attribute... />

...

<Reference... />

...

</Type>

<Type>

...

</Type>

</Types>

To add an attribute to a node, determine the characteristic you need to capture with that attribute,
determine the appropriate dataType, and create the attribute. To define Name as one of the
characteristics for a type, the Attribute tag is written as:

<Attribute displayName="Name" dataType="String" uri="uri:application-

modules/power/model/

attribute#name" />



<Reference>
The <Reference> tag defines the relationship between types. To establish a relationship, each
<Type> element needs a <Reference> element, and each <Reference> element needs to
refer to the displayName of the related <Type>.

The following example contains references establishing a relationship between the <Type> with
displayName="level_1", and the <Type> with displayName="level_2".

Since the types are in a parent-child relationship, the reference in the child needs to contain
isReverse="true".

The last portion of the <Reference> element includes a relation name. It is used in the
Relation element within the <View> structure to define what appears on the Tree View page in
Hierarchy Manager.

<Types>

<Type displayName="level_1" uri="uri:application-

modules/power/model/type#level_1">

<Attribute displayName="id" dataType="String" uri="uri:application-

modules/power

/model/attribute#name" />

<Attribute... />

...

<Reference displayName="level_2" uri="uri:applications-

modules/power/model/

relation#1_2" target="uri:application-

modules/power/model/type#level_2 />

...

</Type>

<Type displayName="level_2" uri="uri:application-

modules/power/model/type#level_2">

<Attribute displayName="id" dataType="String" uri="uri:application-

modules/

power/model/attribute#name" />

<Attribute... />

...

<Reference displayName="level_1" isReverse="true"

uri="uri:applications-modules/

power/model/relation#1_2" target="uri:application-

modules/power/model/

type#level_1 />

...

</Type>

</Types>

A physical or logical device can be associated with any type. To configure a type to connect with a
device, create a Reference tag similar to the example below. Note that meteredBy is a
keyword, and it must be entered exactly as shown to correctly reference a device.
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<Reference displayName="device" uri="uri:application-

modules/power/model/relation#meteredBy"

target="uri:application-modules/power/model/type#device" />

<Views>

This is a containment tag for all <View> elements. Views are the means by which other
applications such as Dashboards and Reports discover the set of devices that are aggregated
together. All <View> elements need to be inside this containment tag.

<Types>

<Type...>

...

</Type>

<Type...>

...

</Type>

</Types>

<Views>

<View... >

</View>

</Views>

<View>

The <View> tag defines how a hierarchy can be viewed in WinPM.Net. These different views
provide different ways that a hierarchy can be displayed, or different ways the device data
associated with the hierarchy types can be grouped together.

The view displayName (for exampleGeneric Layout) is defined here. The name appears on
the Tree View page of Hierarchy Manager. You can select the view as a data source in the
Dashboards and Reports applications.

The <View> tag groups together the <Relation> elements whose order determines how the
view appears.



<Types>

<Type>

...

</Type>

<Type...>

...

</Type>

</Types>

<Views>

<View displayName="Generic Layout"

rootNodeTypeUri="uri:application-modules/power/model/

type#level_1 >

<Relation... />

<Relation... />

...

</View>

</Views>

<Relation>

The <Relation> tag is used to establish how the different views of the hierarchy are structured.
The initial relation is defined in the <Reference> element within a <Type>. Specify the node type
to start at (the initial <Relation> entry), then add <Relation> entries to complete the tree.

If a <View> element contains a <Relation> with reverse="true", then the view presented
follows the relationship in the reverse order.
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<Types>

<Type displayName="level_1" uri="uri:application-

modules/power/model/type#level_1">

<Attribute displayName="id" dataType="String" uri="uri:application-

modules/power/

model/attribute#name" />

...

<Reference displayName="level_2" uri="uri:applications-

modules/power/model/

relation#1_2" target="uri:application-

modules/power/model/type#level_2 />

</Type>

<Type displayName="level_2" uri="uri:application-

modules/power/model/type#level_2">

<Attribute displayName="id" dataType="String"

uri="uri:application-modules/

power/model/attribute#name" />

<Attribute... />

...

<Reference displayName="level_1" isReverse="true"

uri="uri:applications-modules/

power/model/relation#1_2" target="uri:application-

modules/power/model/

type#level_1 />

</Type>

<Type...>

...

</Type>

</Types>

<Views>

<View displayName="Generic Layout"

rootNodeTypeUri="uri:application-modules/power/model/

type#level_1 >

<Relation follow="uri:application-modules/power/model/relation#1_2"

/>

<Relation follow="uri:application-modules/power/model/relation#2_3"

/>

<Relation follow="uri:application-modules/power/model/relation#3_4"

/>

<Relation follow="uri:application-modules/power/model/relation#4_5"

/>

...

</View>

</Views>



Additional notes
Considerations when selecting a hierarchy view in a Web-based report

If devices are associated with more than one node in a parent-child relationship in a hierarchy
tree, only those devices first encountered in the tree are included in generated reports. All devices
lower in the hierarchy tree are ignored in generated reports.

For example, if a hierarchy tree is structured as:

Site 1

Building 1 (including associated devices)

Area 1 (including associated devices)

and you select Building 1 on the Views page of the Source Selector in a report, the generated
report includes data for the devices associated with Building 1, but not for devices in the lower
node in the tree – Area 1.

Similarly, if you select Site 1, which does not include a device association in the hierarchy, the
generated report includes data for the devices associated with the Building 1 level only, the level
in the hierarchy where devices are first encountered.

Using comment tags

If you do not require all the levels provided in the example hierarchy template XML file, you can
comment out the types you do not need, from the bottom type up. Commenting out the type,
rather than just deleting the type preserves the structure of the template file and allows you to
reinstate the type with a minimum of effort. Enclose the <Type> element within the start comment
tag <!-- and the end comment tag --> to comment it out. For example:

<!-- <Type... >

...

</Type> -->

Remove the comment tags to restore the type.

If you want to remove one or more view elements defined in a template, add comment tags
around the applicable <View> tags. Remove the comment tags to restore the View elements.

When you import the hierarchy template XML file, the Hierarchy Configuration utility performs a
validation test on the file. If the file validation is not successful, the utility does not import the file
and provides information indicating where the validation process stopped. Check for any
discrepancies in the file, save the changes and reimport the file.
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<Template version="1.0" xmlns="uri:application-modules/power/model/template#">

<!-- This is a template for a simple 5 level hierarchy. All the relations and nodes have been pre-configured. To customize for your
purposes, search and replace "level_1" with the name of your top-level type (e.g. Site),
...
"level_5" with the name of your lowest-level type (e.g. Room)
With this template you can attach "devices" to the lower 3 levels.
-->

<Types>

<Type displayName="level_1" uri="uri:application-modules/power/model/type#level_1">
<!-- every Type must have attribute#name - change displayName as needed -->
<Attribute displayName="id" dataType="String" uri="uri:application-modules/power/model/attribute#name" />
<!-- use these elements to add attributes to nodes -->
<Attribute displayName="string" dataType="String" uri="uri:application-modules/power/model/attribute#str" />
<Attribute displayName="notes" dataType="LongText" uri="uri:application-modules/power/model/attribute#note" />
<Attribute displayName="number" dataType="Number" uri="uri:application-modules/power/model/attribute#num" />
<Attribute displayName="boolean" dataType="Boolean" uri="uri:application-modules/power/model/attribute#bool" />

<!-- this is how to create one half of the relationship between two nodes, you need a similar reference on the other end of the
relationship -->

<Reference displayName="level_2" uri="uri:application-modules/power/model/relation#1_2" target="uri:application-
modules/power/model/type#level_2" />
</Type>

<Type displayName="level_2" uri="uri:application-modules/power/model/type#level_2">
<Attribute displayName="id" dataType="String" uri="uri:application-modules/power/model/attribute#name" />
<!-- this is the other end of the relationship marked above - isReverse is opposite, relation#... must be equal -->
<Reference displayName="level_1" isReverse="true" uri="uri:application-modules/power/model/relation#1_2"
target="uri:application-modules/power/model/type#level_1" />
<Reference displayName="level_3" uri="uri:application-modules/power/model/relation#2_3" target="uri:application-
modules/power/model/type#level_3" />
</Type>

<Type displayName="level_3" uri="uri:application-modules/power/model/type#level_3">
<Attribute displayName="id" dataType="String" uri="uri:application-modules/power/model/attribute#name" />
<Reference displayName="level_2" isReverse="true" uri="uri:application-modules/power/model/relation#2_3"
target="uri:application-modules/power/model/type#level_2" />
<Reference displayName="level_4" uri="uri:application-modules/power/model/relation#3_4" target="uri:application-
modules/power/model/type#level_4" />
<Reference displayName="device" uri="uri:application-modules/power/model/relation#meteredBy" target="uri:application-
modules/power/model/type#device" />
</Type>

<Type displayName="level_4" uri="uri:application-modules/power/model/type#level_4">
<Attribute displayName="id" dataType="String" uri="uri:application-modules/power/model/attribute#name" />
<Reference displayName="level_3" isReverse="true" uri="uri:application-modules/power/model/relation#3_4"
target="uri:application-modules/power/model/type#level_3" />
<Reference displayName="level_5" uri="uri:application-modules/power/model/relation#4_5" target="uri:application-
modules/power/model/type#level_5" />
<Reference displayName="device" uri="uri:application-modules/power/model/relation#meteredBy" target="uri:application-
modules/power/model/type#device" />

</Type>

<Type displayName="level_5" uri="uri:application-modules/power/model/type#level_5">
<Attribute displayName="id" dataType="String" uri="uri:application-modules/power/model/attribute#name" />
<Reference displayName="level_4" isReverse="true" uri="uri:application-modules/power/model/relation#4_5"
target="uri:application-modules/power/model/type#level_4" />

Generic 5 Level Template



<!-- this is how to connect up a logical/physical device to provide metered data to a node this can appear anywhere in the
hierarchy e.g. main meter for building, metering points for specific loads-->
<Reference displayName="device" uri="uri:application-modules/power/model/relation#meteredBy" target="uri:application-
modules/power/model/type#device" />
</Type>

</Types>

<Views>

<!-- View displayName shows up in the drop-down of Reports/Gadgets -->
<!-- specify the node type to start at, then add the relations to follow -->
<View displayName="Generic Layout" rootNodeTypeUri="uri:application-modules/power/model/type#level_1">
<Relation follow="uri:application-modules/power/model/relation#1_2" />
<Relation follow="uri:application-modules/power/model/relation#2_3" />
<Relation follow="uri:application-modules/power/model/relation#3_4" />
<Relation follow="uri:application-modules/power/model/relation#4_5" />
</View>

<!-- do not need to add the "meteredBy" relation in the View if a "meteredBy" relation has a mapped device no matter what level
of the hierarchy then the aggregation will return the value from the mapped device -->
</Views>
</Template>
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Chapter 8: Downstream Device Assistant
Downstream Device Assistant lets you manage downstream devices. With this tool, you can
rename downstream sources, change which measurement is associated with specific data from a
source, and apply these changes to previously recorded data in ION_Data (historical database).
You can also display and manage all the physical sources (devices) in your network.

Downstream Device Assistant is an advanced application and should only be used by users with
advanced technical skills and a clear understanding of how data is interpreted and stored in the
WinPM.Net databases.

CAUTION
INACCURATE DATA RESULTS
• Do not incorrectly configure the software or the devices.
• Do not base your maintenance or service actions solely on messages and information
displayed by the software.

• Do not rely solely on software messages and reports to determine if the system is
functioning correctly or meeting all applicable standards and requirements.

Failure to follow these instructions can result in injury or equipment damage.

Detecting downstream devices
A downstream device is one whose data is logged by a remote data recorder, for example:

• A Modbus slave device whose output registers are logged by a device with Modbus Mastering
capability (see illustration below).

• Any of various multiple sources in which the same measurement is being logged on a single
device, for example, an RTU that is collecting kWh pulses from multiple sources or a single
branch circuit monitor that is collecting current readings on multiple circuits.

A WinPM.Net server B Ethernet C kW D
Data
Recorder
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E
Physical source (Modbus
Master)

F RS-485 G
Downstream Devices (Modbus
Slaves)

WinPM.Net automatically detects downstream devices. The Log Inserter component does this by
looking for devices (called “physical sources”) that record or host data coming from various
downstream devices (for example, an ACCESSmeter that utilizes a Modbus Import module to
pass through data originating from a “downstream” Modbus device).

Log Inserter resolves the data from each of these downstream devices to the appropriate
measurement (for example, the label “Vll ab” resolves to the measurement “Voltage Phases AB”).
For data that cannot be resolved, Log Inserter creates measurements whose names are based on
the ION register labels.

Log Inserter uses a logical naming scheme to assign names to the downstream devices. For
example, “Modbus.34” is the name assigned to the downstreamModbus device with a slave
address “34”.



Downstream Device Assistant basics
Use Downstream Device Assistant to edit the names assigned to downstream devices or to
assign the correct measurement label for a register that has an incorrect measurement mapping.

IMPORTANT: Before using the Downstream Device Assistant, make sure you save a copy of the
ION_Network and ION_Data databases, in case you need to revert to the original configuration of
these databases.

Starting the Downstream Device Assistant
1. Run the program named “DownstreamDevices.DownstreamAssistant.exe” in the

...\WinPM.Net\system\bin folder.

2. Log in using your WinPM.Net credentials.

A message displays to remind you to back up your ION_Network and ION_Data databases.
ClickOK to continue.

3. Downstream Device Assistant opens in Basic view or Advanced view, depending on the last
view it was in before it was closed. The first time Downstream Device Assistant is started, it
opens in Basic view.

Basic view versus Advanced view
The view determines what columns are available as well as whether an action is global (applied to
all rows containing a parameter) or specific to a row.
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Columns descriptions

Columns in Both Basic and Advanced View

Column Name Description

IsDownstream1

The IsDownstream column identifies which devices in the
Assigned Source column are downstream devices. If
IsDownstream is selected, it means that the device identified in
the Assigned Source column is downstream to a physical device,
whose name is indicated in the Physical Source column. If
IsDownstream is cleared, this indicates that the device is a
physical source. Note also that a physical source has the same
Assigned Source name and Physical Source name, by default.

Assigned Source

This is the default name that Log Inserter assigned to a
downstream or physical device. For example,
“Modbus.109:MainFeed.9610” is the default name assigned for
the downstreamModbus device with unit ID “109”, whose
measurements are being logged to a data recorder on a Modbus
Master device named “9610” that is part of the “MainFeed” site
(group).

Updated Assigned
Source

This text field allows you change the current name under
Assigned Source. In Basic view, all rows that contain the same
Assigned Source name are automatically updated to the new
name when you enter it in the Updated Assigned Source
column. In Advanced view, you can select one or more rows and
rename the source using the Updated Assigned Source column,
while leaving the other rows unchanged. See Renaming the
assigned source for more details.

Physical Source2
This identifies the name of the physical device, for example a
Modbus Master device, that is performing the data logging for a
downstream device.

Measurement

This column displays either the ION label (for example, “Vln avg”)
or the descriptive name of the measurement (for example,
“Average Voltage Line-to-Neutral”), depending on the setting in
the Options dialog; see Downstream Device Assistant options.

Additional Columns in Advanced View

Updated Measurement

This lets you redefine what is currently assigned in the
Measurement column. Click the cell to display the list of
measurements to choose from. Depending on the setting in the
Options dialog, you can select from a list containing only the most
common measurement definitions or from a list of all available
measurements; see Downstream Device Assistant options.



Columns in Both Basic and Advanced View

Handle
This column displays a measurement’s register handle either in
hexadecimal format or decimal format, depending on the setting in
the Options dialog; see Downstream Device Assistant options.

Entered By
This identifies which user made a change to the source-
measurement definition.

Update Historical
Database

The Update Historical Database check box is automatically
selected after entering changes in the Updated Assigned
Source or Updated Measurement cell. This means that all
historical database entries that contain the old Assigned Source
name orMeasurement will be updated with the new name or
measurement. If you want to leave the existing data in the
database unchanged, clear the Update Historical Database
check box before saving the changes.

Manual (see the Note
below)

By default, Log Inserter automatically associates the proper
measurement to the appropriate piece of data in the data log.
Normally, theManual check box should remain cleared. However,
if you want to specifically change the measurement or register
handle associated with a particular address definition, select the
Manual check box for that measurement. This manually overrides
Log Inserter so that it uses this new address mapping from now on
(i.e., Log Inserter does not attempt to resolve that address ever
again).

1 Do not change the value of "IsDownstream" when making changes to source/measurement
definitions, as it is automatically set by the Downstream Device Assistant
2 Do not use the Physical Source column to modify the existing name of a valid physical device,
as Log Inserter uses this name to perform proper data logging.

NOTE: It is not recommended that you select the Manual check box. This reserves the ION
register for which Manual is checked for the selected measurement. This mapping remains in
place even if the device is reconfigured such that this register is used in an entirely different
context. This may cause unexpected problems in the ION_Data database. It should be used
only if you are certain that the configuration you have chosen will not change.

Basic view

To switch to Basic view, click View > Options. In the Advanced section of theOptions dialog,
clear the enable advanced features check box. ClickOK.

In Basic view, when you enter a new name in the Updated Assigned Source column, all rows
that contain the same Assigned Source name are automatically filled in with the new name.
Existing data in the historical database (ION_Data) is also automatically updated to reflect the
change.
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Advanced view

To switch to Advanced view, click View > Options. In the Advanced section of the Options
dialog, select the enable advanced features check box. ClickOK.

In addition to the columns displayed in Basic view, Advanced view displays all the other columns
for editing individual source-measurement definitions (i.e., Updated Measurement, Handle,
Entered By, Update Historical Database, and Manual). In Advanced view, you can:

• Select and make changes to a specific row without affecting the other rows. For example, you
may want to change the source name for one particular measurement while leaving the
original source name unchanged for all the other measurements.

• Select a different measurement for one that is incorrectly mapped to a particular register
handle.

• Select whether or not to update historical data for a changed source name or measurement
definition, by selecting or clearing the Update Historical Data check box, respectively.
Changing a name or definition automatically selects this check box.

• Select whether or not to allow Log Inserter to resolve the register handle to a particular source
measurement, by clearing or selecting theManual check box, respectively. The default
setting is cleared (i.e., Log Inserter automatically resolves the register handle to the source
measurement definition). If you want to force the change so Log Inserter does not resolve the
handle to the new measurement, select theManual check box.

Displaying physical sources
The default view for Downstream Device Assistant displays only the downstream devices. To
display the physical sources as well:

1. Click View > Select Physical Sources.

2. Select the check box beside the physical sources you want to display. Select the
Select/Clear All check box to select all physical sources or clear it to select none. ClickOK.

NOTE: The Physical Sources are not displayed if you restart Downstream Device Assistant. By
default, only downstream devices are displayed when Downstream Device Assistant is started.

Sorting data
Click a column heading to sort the row entries in ascending or descending alphanumeric order,
according to that column.

Downstream Device Assistant options
Click View > Options to open theOptions dialog. The dialog contains Measurements, Historical
Data, and Advanced options.

Certain options such as “show all measurements” and the “Handles” display options are disabled
in Basic View. To enable them, switch to Advanced View first (see Advanced).



Measurements

This section allows you to select whether to display the default ION label (for example, “Vln avg”)
in the Measurement column or to display the full descriptive name of the measurement (for
example, “Average Voltage Line-to-Neutral”).

In Advanced view only, you can also select whether to display all available measurements or only
the most common measurements in the list when picking a measurement in the Updated
Measurement column.

Displaying ION labels versus measurement names
To change the setting:

1. Click View > Options.

2. In the Measurements section, select display ION labels to display the ION label or display
measurement names to display the full name of the measurement.

NOTE: In some situations, if "display ION labels" is selected, the displayed label may not match
the label on your meter (for example, if a custom label was used). Instead, it displays the known
default label for that particular measurement.

Updated Measurement column display
To change the setting:

1. Click View > Options and ensure Advanced is selected.

2. In the Measurements section, select show all measurements to display all available
measurements in the Updated Measurement column. To display only the most common
measurements, clear show all measurements.

Historical data

If the show connection dialog check box is cleared, the ION_Data database is automatically set
as the “Default Connection” (for historical data).

If you want to select a different database, select the show connection dialog. With this setting
enabled, the database connection dialog is displayed every time you save your changes. When
the dialog opens, select Custom Connection and specify your database connection details.

Advanced

The enable advanced features check box sets the view to Basic View if it is cleared or Advanced
View if it is selected.

Handle

Available in Advanced View only, this option specifies whether register handles are displayed as
the hexadecimal value (with the “0x” prefix) or as the decimal value.

To change the setting:

1. Click View > Options and ensure the Advanced is selected.

2. In the Handles section, select display hex to display the register handle in hexadecimal
format or display decimal to display it in decimal format.
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If you want to manually resolve a register handle to a specific measurement, edit the value in the
Handle cell, then select theManual check box before saving the changes.

Downstream Device Assistant functions
This section describes different functions you can perform using the Downstream Device
Assistant.

CAUTION
INACCURATE DATA RESULTS
• Do not incorrectly configure the software or the devices.
• Do not base your maintenance or service actions solely on messages and information
displayed by the software.

• Do not rely solely on software messages and reports to determine if the system is
functioning correctly or meeting all applicable standards and requirements.

Failure to follow these instructions can result in injury or equipment damage.

Renaming the assigned source
One of the primary reasons for using the Downstream Device Assistant is to change the default
name assigned to a downstream device by the Log Inserter. For instance, instead of
“Modbus.34”, you may want to rename that device to something more meaningful such as “SM_
Bldg2_Boiler7”.

Renaming an Assigned Source typically only applies to downstream devices.

Renaming the assigned source for all its measurements

1. Switch to Basic view.

2. Find the source you want to rename. Enter the new name in the Updated Assigned
Source column. All rows with measurements associated with the renamed source are
automatically updated.

If you do not want to assign the existing data in the database to the new source name, switch
to Advanced View first, then clear the Update Historical Database check box for all
appropriate rows.

3. Click File > Save.

4. A dialog opens showing a summary of the changes. Click Yes to continue. or No to cancel.

5. When the operation completes, clickOK, then Close.

Renaming the assigned source for one or more measurements

1. Switch to Advanced View.

2. Select the row(s) you want to rename. To select a row, click the area just to the left of the first
column. The row is highlighted to indicate that it is selected.

3. Click Edit > Rename Source.

4. In the Source Rename box, type the new name for the downstream source. ClickOK.



NOTE: By default, the Update Historical Database check box is selected for all affected
rows— this applies the change to existing data in the database. To make the change only
to data going into the database from this point forward, clear the Update Historical
Database check box for the affected rows.

5. Click File > Save. A dialog open showing a summary of the changes.

6. Click Yes to continue or No to cancel.

7. When the operation has completed, clickOK, then click Close.

Cancelling changes
1. To undo all unsaved changes:

Click Edit > Reset, or

Click View > Refresh.

2. Click Yes to confirm.

Changing the measurement mapping
Log Inserter automatically associates logged data with a measurement by searching for a
mapping between the label and the measurement. However, in cases where no mapping exists,
Log Inserter creates a “measurement” that is based on the register label. To manually change this
measurement mapping:

1. Switch to Advanced View.

2. Click the Updated Measurement cell that you want to change, then select the new
measurement you want to map from the list.

3. Select theManual check box.

4. By default, the Update Historical Database check box is selected— this applies the
change to existing data in the database (if, for example, the source and measurement
mapping you are adding already exists). To make the change only to data going into the
database from this point forward, clear the Update Historical Database check box.

5. Click File > Save. A dialog opens showing a summary of the changes. Click Yes.

6. If prompted, select which database to update. ClickOK.

Adding a new downstream device mapping
To add a new address mapping that associates the source and measurement to a specific logged
quantity in the database:

1. Scroll down to the end of the table and click the last row (the one with the asterisk beside it).

2. Fill in the Updated Assigned Source and Physical Source columns. If the source is a
physical device (i.e., not downstream), the same name must be entered exactly in both
columns.

3. Click the Updated Measurement cell, then select the measurement from the list.

4. In the Handle cell, type the register handle for this measurement.
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5. By default, the Update Historical Database check box is selected— this applies the
change to existing data in the database (if, for example the source and measurement
mapping you are adding already exists). To make the change only to data going into the
database from this point forward, clear the Update Historical Database check box.

6. Click File > Save. A dialog opens showing a summary of the changes. Click Yes.

7. If prompted, select which database to update. ClickOK.

Updating the historical data at a later time
When you save your changes using the Downstream Device Assistant, a record of changes to the
source-measurement definitions is saved in the folder:

...\WinPM.Net\config\Diagnostic\Downstream Device Assistant\

with the following filename:

“Downstream Device DefinitionsYYYY-MM-DD_hh.mm.ss.csv”

where “YYYY-MM-DD_hh.mm.ss” means current YEAR-MONTH-DAY_hour.minute.second.

If you cleared the Update Historical Database check box when you saved your changes the first
time, you can update the existing data in the database at a later time, through the use of this csv
file.

How to use the Downstream Device Assistant .csv file
To update the existing data in the database with the source-measurement changes contained in
the csv file:

1. Click Edit > Historical Data. The Update Historical Data window appears.

2. Click File > Import CSV.

3. Downstream Device Assistant opens the folder that contains the csv files. Select the
Downstream Device Definitions file you want to use, then clickOpen.

4. Click File > Update Historical Data.

5. The Historical Data Update prompt displays how many source-measurement pairs will be
updated. Click Yes.

6. Click Yes at the Historical Data Update prompt.

7. After the operation has completed, clickOK, then Close.

You can update only one ION database at a time. To select a different database, first make sure
the show connection dialog check box is selected under View > Options. You can then use the
database connection dialog to specify which database you want to update.

NOTE: If you update address definitions that affect multiple historical databases, only the first
historical database you select is automatically updated. To update the remaining historical
databases, you must import the address definitions to each one, using Edit > Update Historical
Data.



Activity log
The saved changes in the Downstream Device Assistant are stored in a log file named
“Downstream Device Historical UpdatesYYYY-MM-DD_hh.mm.ss.txt”, that contains a description
of the activities carried out when Downstream Device Assistant was updating the source-
measurement definitions.

Downstream Device Assistant commands
The following summarizes the commands available in the Downstream Device Assistant:

• File > Save: Saves your changes. A copy of the changes are saved for future reference, in a
comma-separated value (.csv) data file in the ...\config\Diagnostic\Downstream Device
Assistant\ folder.

• File > Exit: Closes the Downstream Device Assistant.

• Edit > Reset: Clears the modifications made since the last save.

• Edit > Delete: Deletes the selected rows.

• Edit > Rename Source: Lets you change the name of an Assigned Source. See Renaming
the assigned source.

• Edit > Update Historical Data: Opens the “Update Historical Data” window that allows you
to open a previously-saved source-measurement definition data file (with a .csv file
extension), for the purpose of updating existing data in the database. You can also manually
add, edit or delete data entries. See Updating the historical data at a later time.

• View > Refresh: Loads the current downstream definitions from the database. Functionally
the same as Edit > Reset, as this command clears the modifications made since the last
save.

• View > Options: Displays theOptions dialog where you can change the settings that control
what level of detail is displayed for the source-measurement definitions.

• View > Select Physical Sources: Displays the Select Physical Sources dialog where you
can select which physical devices you want displayed in the Downstream Device Assistant.
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Chapter 9: OPC Server Support
Introduction to OPC

OPC is a set of open standards for connectivity and interoperability of industrial automation and
the enterprise system. OPC provides a bridge betweenWindows based applications and process
control hardware, thereby eliminating the need for proprietary or custom interfaces and drivers for
the various data types and sources residing in your corporate information network. Having
information readily available in a universally-recognized format can cut costs, speed up
development and increase operations efficiency. This is especially true when many diverse
software applications, hardware, and operating systems exist in the corporate and operations
networks.

RECOMMENDATION: Use an OPC tunneling application for OPC data exchange over a
network

WARNING
INACCURATE DATA RESULTS
• Do not incorrectly configure the OPC Server.
• Do not base your maintenance or service actions solely on messages and information
displayed by the software.

• Do not rely solely on software messages and reports to determine if the system is
functioning correctly or meeting all applicable standards and requirements.

• Consider the implications of unanticipated transmission delays or failures of
communications links.

Failure to follow these instructions can result in death, serious injury, equipment
damage, or permanent loss of data.

OPC is supported through the implementation of WinPM.NetReal Time Data Service, a .NET-
based system that takes the traditional “register handle-based” ION data and transforms it into
structured “measurement-based” data that complies with open standards such as OPC.
WinPM.Net Real Time Data Service facilitates the translation and organization of data in this new
measurement classification system.

WinPM.Net supports OPC server and OPC client functionality. The OPC server translates ION
data into OPC data, for exporting and viewing in other third-party OPC client systems. The OPC
client, on the other hand, takes OPC standardized measurements from third-party systems and
translates them into a data format that WinPM.Net can use.

This appendix provides basic configuration and operation instructions for the OPC server
component of WinPM.Net.

NOTE: The OPC client is available in all WinPM.Net installations. However, due to the number of
different third-party OPC-compliant servers in the industry, as well as different methods and
syntax for connecting to these servers and accessing their data, it is highly recommended that
you contact Technical Support for assistance in configuring the OPC client.
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Optional OPC server license
WinPM.Net can be ordered with or without the optional OPC server license. You can also order
the OPC server license at a later date. If you purchased your OPC server license after you have
installed WinPM.Net, enable the OPC server functionality simply by entering your new product
key in Management Console (under Tools > License Manager).

OPC server type
TheWinPM.Net OPC server complies with the "OPC Data Access Custom Interface Standard
Version 2.05A". The class of data that the current release of OPC Data Access server is able to
provide is Read-Only data (i.e., control functions are not currently supported).

OPC measurement support
OPCmeasurement support for WinPM.Net allows you to easily translate data from ACCESS
devices and compatible Modbus devices into OPC-compliant measurement data formats, then
make this measurement data available to OPC clients through the OPC server.

Management Console has a command that lets you export default measurements from
compatible devices to the OPC server. In addition, Designer and Device Type Editor user
interfaces let you view and select which OPCmeasurement data you want the OPC server to
expose to OPC clients.

Creating/updating default OPC mapping
WinPM.Net can create the default ION-to-OPC data mapping based on the devices contained in
the ION_Network database. This default mapping translates the most commonly-used
WinPM.Net data to OPC data and exports the data to the OPC server.

1. Launch Management Console.

2. Click Tools > System > Update OPC Server.

3. Click Yes to create/update the OPC server.

A summary of the configuration details is displayed.

4. ClickOK.

NOTE: If you add a new device to the ION_Network database at a later date, you must repeat
the above procedure in order to map the new source device’s data to the OPC server.

OPC Server Assistant
The OPC Server Assistant is a mechanism that lets you select which OPCmeasurements to
expose to the OPC server. Custom labels are not mapped to OPC server by default. They need to
be manually exported to OPC server.

OPC Server Assistant is accessible through Designer.



A
Unavailable registers (Grayed-
out)

B
Output
Register

C
Setup
Registers

Exporting OPC measurements through Designer
If you customized an ACCESS device’s default templates (for example, custom labels), those
measurements are not exposed to the OPC server by default. To manually export those
measurements to OPC server:

1. Launch Designer and open the ACCESS device node.

2. Navigate to the IONmodule that contains the register that you want to expose to OPC
server. Right-click to display the module setup dialog.

3. ClickOPC to open the OPC Server Assistant.

4. Select (check) the box beside each item you want to expose to the OPC server. Clear
(uncheck) the box beside each item you do not want to expose to the OPC server.

NOTE: Grayed-out items (such as “PF sign a” in the Power Meter module) cannot be
selected or changed. Those registers cannot be removed using OPC Server Assistant.

5. Click File > Export. Click Yes to save your changes.

Description of commands
This section describes the commands available in the OPC Server Assistant.

Command Result

File > Export
Saves your configuration changes. Items that are selected
(checked) in the OPC Server Assistant are exposed to the OPC
server, while cleared (unchecked) items are not.

File > Exit Closes the OPC Server Assistant.

Edit > Reset values
Discards your changes and reverts to the last saved configuration
(for the items that are exported to the OPC server).

WinPM.Net 10.0 User Guide Chapter 9: OPC Server Support

© 2021 Siemens Industry, Inc. All Rights Reserved. 250



Chapter 9: OPC Server Support WinPM.Net 10.0 User Guide

251 © 2021 Siemens Industry, Inc. All Rights Reserved.

Command Result

Edit > Select All Selects (checks) all registers.

Edit > Clear All Clears (unchecks) all registers that are not grayed out.

View > Setup Registers
Displays the setup registers, in addition to the output registers, for
the module.

View > Measurements
Displays a column containing the measurement names associated
with the registers.

Viewing OPC data
A third-party OPC client can connect to the WinPM.Net OPC server using a valid connection
address, which consists of the network node or host machine name where the OPC server is
running and the OPC program ID (ION.OpcDaServer). For example:

opcda://WORKSTATION3/ION.OpcDaServer

NOTE: Syntax use varies across different OPC clients. Refer to your OPC client documentation
for details.



Chapter 10: Time synchronization for SIEMENS 9xxx
series meters

You can synchronize the internal clocks of all networked SIEMENS 9xxx series meters and
devices through the Management Console component of WinPM.Net. When they are
synchronized, all data logs have time stamps that are relative to a uniform time base.

NOTE: This information is specific to SIEMENS 9xxx series devices. It is not applicable to
devices that are not based on ION architecture.

Time synchronization signals are broadcast periodically over the network; each meter continually
assesses its ability to remain synchronized with the incoming broadcasts. Over a brief period,
each meter learns how its internal timing differs from that of the broadcast source and adjusts its
timekeeping to compensate. Very accurate time synchronization is achieved with this method.

Meters at modem sites are synchronized each time they are connected. The longer the duration
between connections, the larger the error in time synchronization. In the extreme case, this can
result in missing or duplicated logs. If this occurs, you can increase the frequency of connections
through the WinPM.Net software connection.

NOTE: This information assumes that you are using the time synchronization function in
WinPM.Net. Although other methods of time synchronization are available, such as with ION
Setup, a Network Time Protocol (NTP) server, a Global Positioning System (GPS) receiver, or
3rd party protocols, it is important that you use only one method of time synchronization on each
network. If you use multiple methods, the timestamps will differ for the sites and devices that are
using separate time synchronizing methods.

Before you configure time synchronization on your network, you should familiarize yourself with
the Clock module settings. Once you have done this, you can decide which synchronization
method you want to use.

Enabling and configuring time synchronization
Time synchronization in WinPM.Net is initially disabled and needs to be enabled and configured
through Management Console. The communications port and protocol used for communications
between the software and the networked SIEMENS 9xxx series devices is automatically used to
send time synchronization signals to all connected SIEMENS 9xxx series devices. The software
sends a time sync packet and the time is set when the packet is received.

When reviewing time synchronization messages in the system log, remember that the time in the
message is not the time to which the meter was time synced, but rather it is the time the message
was posted to the system log. The message is posted after the meter is time synced.

Note that ION time synchronization only uses the UTC setting; the LOCAL setting cannot be used.

Time synchronization values are set when sites or Ethernet devices are defined in a WinPM.Net
network. Enable time synchronization or set custom intervals for supported devices in any site
through Management Console as follows:
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1. Start Management Console.

2. Select Sites or Devices on the System Setup pane:

Select Sites if you want to customize a particular serial, modem, or Ethernet Gateway
site.

Select Devices if you want to customize an individual Ethernet device.

3. Right-click the device or site and select Configure Device or Configure Site to open the
related configuration dialog.

4. Right-click inside the dialog and select Advanced Properties.

5. Configure the Time Synch ION Enabled or Time Synch Ethernet Enabled, and Time
Synch Interval Ethernet fields as required for your system.

6. ClickOK to save you changes.

The default time synchronization interval of 3600 seconds (displayed in milliseconds) is
acceptable in most software installations.

NOTE: You need appropriate permissions to configure meters on your network. Refer to the
WinPM.Net System Security technical note for details on software and meter security.

Time synchronization blackout
Time synchronization blackout is defined as a period when time synchronization cannot occur.
Utilities often record power usage at regular, predetermined intervals. For example, the utility may
schedule a recording every five minutes during an hour period (that is, 5, 10, 15, 20,..., 55, 60). If a
time sync moves the meter clock forward, the meter may miss one of the recording intervals. If a
time sync moves the meter clock backwards, the meter may get two records with the same
timestamp. The time synchronization blackout feature seeks to protect the time before and after
these recording intervals by not sending out any time sync signals at those times.

WinPM.Net has time synchronization blackouts enabled automatically even though time syncing
is disabled by default in WinPM.Net. The blackout intervals are every five minutes as follows: 0, 5,
10, 15, 20, 25, 30, 35, 40, 45, 50, 55. Each blackout is 2 minutes and 30 seconds in duration. This
duration is distributed evenly before and after the interval. The diagram below illustrates the time
synchronization blackout feature in WinPM.Net.



If a regularly scheduled time sync is not sent because of a blackout interval, the software
continues trying to send the time synchronization signal every 15 seconds until the blackout
period expires and the time sync is sent.

Changing default blackout settings
To change the default settings for the interval or the blackout duration, you must edit the registry
of the computer where WinPM.Net is installed. Changing the default registry settings should be
performed only by personnel with a thorough knowledge of their computer's operating system and
registry entries.

NOTICE
IRREVERSIBLE OPERATING SYSTEM DAMAGE OR DATA CORRUPTION

Before making any changes, back up your Windows Registry in a network folder or other
remote location.

Failure to follow these instructions can result in irreparable damage to the operating
system of the computer and all existing data.

NOTE: Registry edits must be performed only by qualified and experienced personnel.

There are two registry entries that control the time-synchronization blackout behavior.

Create the following registry REG_DWORD values under the HKEY_LOCAL_
MACHINE\Software\Wow6432Node\Siemens\WinPM.Net\<version_number> key.

TimesyncBlackoutInterval_mins

Default value: 5
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This entry is specified in minutes. It must have a value greater than 1 in order for
time-synchronization blackouts to occur. A value of 60 or greater configures
blackouts to occur once an hour.

TimesyncBlackoutDuration_secs

Default value: 150 (2 minutes 30 seconds in seconds)

This entry is specified in seconds. A value of 0 (zero) disables the blackout feature.
This entry cannot have a value greater than or equal to 3600 (one hour).

NOTE: If you want to disable the blackout feature but keep time synchronization enabled, set the
TimesyncBlackoutDuration_secs register to 0.

Do not use the following settings. They disable both the blackout feature as well as time
synchronization in general.

• TimesyncBlackoutInterval_mins < 1

• TimesyncBlackoutDuration_secs >= 3600 (1 hour)

• TimesyncBlackoutDuration_secs (the value converted to minutes) >=
TimesyncBlackoutInterval_mins

To disable time synchronization for a particular device, use Management Console. Refer to
Enabling and configuring time synchronization.

Time-synchronization blackout considerations
• Remember to specify TimesyncBlackoutInterval_mins in minutes and
TimesyncBlackoutDuration_secs in seconds.

• If your blackout values conflict or are out of range, an error is sent to the system log database.
If time synchronization signals are not occurring, check the system log to see if there’s an
error message about your blackout values.



Chapter 11: System maintenance and Disaster
recovery

This section provides recommendation related to system maintenance and disaster recovery.

Use the links in the following table to find the content you are looking for:

Topic Content

Systemmaintenance
Provides information on database maintenance and
recommended actions.

Disaster recovery strategy
Provides information on disaster recovery and recommended
strategy.
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System maintenance
Once aWinPM.Net system is installed and commissioned, it must be maintained on a regular
basis. Without periodic, proactive system maintenance, system performance degrades over time
and the system operates with poor performance (timeouts and sluggish response) and eventually
becomes unusable.

This section provides guidelines and recommendations for creating a maintenance schedule.
Proper adherence to the maintenance guide ensures a steady-state operation of a WinPM.Net
system.

This section does not detail troubleshooting system issues, but identifies the steps to develop a
maintenance plan that should allow for a commissioned system to continuously run at optimal
performance.

A maintenance plan keeps your WinPM.Net system healthy. A comprehensive maintenance plan
starts in the system planning stage before commissioning. The plan should include frequent
monitoring and system reviews, and maintenance tasks to ensure the system is operating under
healthy conditions.

The following sections provide recommendations for developing your maintenance plan:

• Designing for maintenance

• Database maintenance

• System health review

Designing for maintenance
Before installing and deploying a system, it is important to plan and design the IT architecture in
support of maintenance and backup activities. Maintenance and backup activities often require
additional resources (CPU, RAM and hard drive space) to perform and complete the activity. The
recommendations are as follows:

• System sizing

Size a system for the final state (for example: maximum devices, maximum logging
parameters, etc) to ensure that the system runs in a healthy state for a longer time. See
Introduction chapter of Install Guide for recommended system sizing.

• Storage space allocation

Make sure there is enough hard drive space to perform database maintenance, archive and
trim operations. See Storage Performance and Availability topic of Install Guide for
recommended hard drive sizing.

• Disk I/O performance

Disk read/write operations impacts system performance. Plan to have different storage
devices installed for the system files, the database files, and the Microsoft Message Queuing
(MSMQ) files. See Choosing Data Storage topic of Install Guide for recommended storage
information.



• Pre-size databases

By default, ION_Data database is configured with a 10% auto-growth parameter. This growth
operation can lead to a fragmented database and hard drive and can impact database
performance over time. To minimize the use of the auto-growth feature, pre-allocate hard
drive space for the ION_Data database during system commissioning, including systems
running SQL Server Express. See Database growth topic of Install Guide for recommendation
on database growth.

• Database auto growth

For systems expected to have large ION_Data databases (> 100 GB), change the default
auto-growth setting to a fixed size rather than by percentage (Default is 10%). In this case, the
database auto-grows when the database exceeds the preset container size. This ensures
better control of database growth. Auto-growth events are expensive operations that slow
down the performance of your database. Take the following preventive steps to ensure your
auto-growth is in control:

Minimize future auto-growth events by monitoring the growth of your databases, and re-
establishing auto-growth settings when a database growth profile changes.

Monitor auto-growth events so you can be alerted when your databases grow.

Consider defragmenting your database file system.

See SQL Server Database Growth and Autogrowth Settings for more information.

Database maintenance
WinPM.Net uses databases to store information such as system configuration, data logs, and
system event log messages. These databases must be maintained to preserve performance,
manage disk space usage, and guard against data loss in case of database failure. Maintenance
is the key to a healthy system that supports system longevity and future scalability. You must not
ignore maintenance. Non-maintenance may lead to system downtime and you might need to
rebuild the system from scratch.

NOTICE
LOSS OF DATA
• Back up the database at regular intervals.
• Back up the database before upgrading or migrating the system.
• Back up the database before trimming it.
• Back up the database before making manual database edits.
• Verify correct database behavior after making database or system changes.

Failure to follow these instructions can result in permanent loss of data.

Database maintenance for WinPM.Net includes the following key activities:

• Performance maintenance

• Accurate and up-to-date query statistics
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• Minimize index fragmentation

• Data archive and trim

• Database integrity check

Based on the key activities, see Consolidated recommendation for database maintenance.

Performance maintenance

For performance maintenance, enable and schedule the following daily maintenance tasks for all
WinPM.Net systems of any configuration:

Database Type of Data

Maintenance Tasks*

Maintenance
(update statistics
and index
defragmentation)

Trim**
Size
Notification

ApplicationModules
Web Applications related
configuration data and
system event log entries.

✓ ✓ –

ION_Data

Historical power system
data such as interval data
logs, waveforms and
alarms.

✓ ✓

✓

NOTE: For
systems with
SQL Server
Express,
enable SQL
Express
Database
Size
Notification.

ION_Network
Device network and other
system configuration data. ✓ – –

ION_SystemLog
Non-Web Applications
related system event log
entries.

✓ ✓ –

* See Default maintenance task settings for basic task definitions.
** Keep the last 30 days of data.

In Standalone WinPM.Net systems, the database maintenance tasks are pre-configured and
scheduled to run automatically by default. For Distributed Database WinPM.Net systems, you
need to configure the tasks and set up the schedules manually.

For more information, see the Database maintenance section in the Configuring chapter of this
guide.



Accurate and up-to-date query statistics

SQL Server uses statistics to create query plans that improve query performance. As the
database increases and holds more data, the statistics becomes less relevant over the time.
Updating statistics ensures that queries run with relevant statistics.

For all systems, it is recommend to update database statistics daily. The following table shows the
default database maintenance task schedules for standalone systems:

Database Task* Trigger Time

ApplicationModules Maintenance Daily at 03:30

ION_Data Maintenance Daily at 02:00

ION_Network Maintenance Daily at 07:30

ION_SystemLog Maintenance Daily at 07:05

* See Default maintenance task settings for basic task definitions.

In distributed systems, the database maintenance tasks are not pre-configured. You need to set
up these tasks manually.

These scheduled tasks trigger the DatabaseMaintenance.ps1Windows PowerShell script. This
script executes the local [Maintenance].[UpdateStatisticsAll] stored procedure in each database.

Check the WinPM.Net system logs and SQL Server logs to confirm that the scheduled tasks are
completed successfully. The log might report errors if an issue arises. As the database grows,
these jobs will take longer time to complete.

See Microsoft’s SQL Server documentation on SQL Server Query Statistics for more information
about query statistics.

For more information, see the Database maintenance section in the Configuring chapter of this
guide.

Minimize index fragmentation

Database index maintenance is important to ensure optimal performance. When data is written to
the databases, fragmentation occurs. Heavy fragmented indexes can degrade query
performance and reduce WinPM.Net’s response time.

To minimize index fragmentation, monitor the fragmentation regularly and perform re-indexing.

For small to medium size systems:

It is recommend to re-index daily. The following table shows the default database maintenance
task schedules for standalone systems:

Database Task* Trigger Time

ApplicationModules Maintenance Daily at 03:30

ION_Data Maintenance Daily at 02:00

ION_Network Maintenance Daily at 07:30

ION_SystemLog Maintenance Daily at 07:05

* See Default maintenance task settings for basic task definitions.
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In distributed systems, the database maintenance tasks are not pre-configured. You need to set
up these tasks manually.

These scheduled tasks trigger the DatabaseMaintenance.ps1Windows PowerShell script. This
script executes the local [Maintenance].[ DefragIndexAll] stored procedure in each database.

Check the WinPM.Net system logs and SQL Server logs to confirm that the scheduled tasks are
completed successfully. The log might report errors if an issue arises. As the database grows,
these jobs will take longer to complete.

For large systems:

For large systems with ION_Data growing over 100 GB in size, it is important to review the
frequency of the [ION_Data] database maintenance scheduled task and switch to running them
manually.

Index fragmentation in ION_Data is unavoidable for large systems because of the amount of data
written to the system and queried on a regular basis. Index fragmentation is also common when
database reads exceeds database writes, that is, whenWinPM.Net is configured with added
components to move data fromWinPM.Net to another non-WinPM.Net system.

For large systems, you need to monitor the index fragmentation daily. To monitor, run the
following SQL commands against the database:

• DBCC SHOWCONTIG

• sys.dm_db_index_physical_stats

Both the commands generate a report on index fragmentation. The time it takes to complete these
statements depend on the amount of data in the table and the level of fragmentation. The more
fragmented the index, the longer the query will run. You should expect the query to return results
within 1 to 20 minutes.

DBCC SHOWCONTIG

DBCC SHOWCONTIG displays fragmentation information for the data and indexes for specified
tables.

NOTE: This command applies to SQL Server 2008 to 2019 and is expected to be deprecated in
a future version of SQL Server.

For ION_Data, run the following commands:

USE ION_Data

GO

DBCC SHOWCONTIG WITH TABLERESULTS, ALL_INDEXES

Review the output from DBCC SHOWCONTIG for the following three statistics:

Average Page Density:

Shows the accurate indication of how full your pages are. A high percentage means the pages are
almost full, and a low percentage indicates much free space. This value should be compared to
the fill factor setting specified when the index was created to decide whether or not the index is
internally fragmented. The fill factor is the percentage of space on each leaf-level page that



should be filled with data, and it is applied only when the index is created, rebuilt or reorganized. If
the Average Page Density and Fill Factor are close in value, then it would suggest that there is
little index fragmentation.

Scan Density:

Shows the ratio between the Best Count of extents that should be necessary to read when
scanning all the pages of the index, and the Actual Count of extents that was read. This
percentage should be as close to 100% as possible. Defining an acceptable level is difficult, but
anything under 75% definitely indicates external fragmentation.

Logical Scan Fragmentation:

Shows the ratio of pages that are out of logical order. The value should be as close to 0% as
possible and anything over 10% indicates external fragmentation.

See DBCC SHOWCONTIG (Transact-SQL) for more information on DBCC SHOWCONTIG
command.

sys.dm_db_index_physical_stats

sys.dm_db_index_physical_stats also returns size and fragmentation information for the data and
indexes of the specified table or view in SQL Server. This command is available in SQL Server
2005 or later.

For ION_Data, run the following commands to show fragmentation details for tables with more
than 100,000 rows and a fragmentation level of greater than 50%. Comment out the WHERE
clause to show results for all table indices. The output is sorted by fragmentation level from
highest to lowest.

USE ION_Data

GO

SELECT

DB_NAME(db_id()) AS DatabaseName,

OBJECT_NAME(object_id) AS TableName,

object_id,

index_id,

index_type_desc,

avg_fragmentation_in_percent,

fragment_count,

page_count,

avg_page_space_used_in_percent,

record_count

FROM

sys.dm_db_index_physical_stats(db_id(),DEFAULT, DEFAULT,

DEFAULT, 'SAMPLED')
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WHERE

(record_count > 100000) AND (avg_fragmentation_in_percent > 50)

ORDER BY

avg_fragmentation_in_percent DESC;

When reviewing the output from sys.dm_db_index_physical_stats, review the values in the avg_
fragmentation_in_percent column. You should defragement the indexes, if the fragementation is
10% and above.

See sys.dm_db_index_physical_stats (Transact-SQL) for more information on sys.dm_db_
index_physical_stats command.

Correcting index fragmentation

Any index with over 10% fragmentation should be corrected.

There are different corrective statements depending on the level of fragmentation. For
WinPM.Net, select the statements as follows:

Fragmentation
Percentage

Corrective Statement Remarks

10 to 30%
ALTER INDEX
REORGANIZE

Reorganizing an index uses minimal
system resources and is an online
operation, which means WinPM.Net can
remain online during this operation.

> 30%
ALTER INDEX REBUILD
WITH (ONLINE = OFF)

Rebuilding an index drops and re-creates
the index. Depending on the type of index
and Database Engine version, a rebuild
operation can be done online or offline.
For large indexes, it is recommended to
perform this operation offline.

See Resolve index fragmentation by reorganizing or rebuilding indexes for more information on
correcting index fragmentation.

Data archive and trim

The archive strategy supports data retention and compliance, while the trim strategy supports
disaster recovery goals.

Archive and Trim shortens the backup process by keeping only business critical data in the live
database and also reduces the resource demands in the disaster recovery efforts by shrinking the
database to backup and restore.

Archiving is not recommended since it fractures the data into multiple databases. WinPM.Net is
unable to query multiple databases at the same time to make comparisons in the data. It is
possible to run reports against an archived database, but it can only be done on one database at a
time.

However, the ION_Data database may need to be reduced in size for two reasons:

https://docs.microsoft.com/en-us/sql/relational-databases/system-dynamic-management-views/sys-dm-db-index-physical-stats-transact-sql?view=sql-server-ver15
https://docs.microsoft.com/en-us/sql/relational-databases/indexes/reorganize-and-rebuild-indexes?view=sql-server-ver15


• SQL Server Express is used as the database engine, which has a limit of 10 GB for the .mdf
file.

• SQL Server (Standard or Enterprise edition) is used as the database engine and the ION_
Data database has become so large that query performance (in Vista for example) is not
acceptable to the WinPM.Net system users. It is also important to ensure that the ION_Data
database is trimmed well within the hard drive size, as it can affect the operation of
WinPM.Net.

For WinPM.Net systems with considerable database growth (medium to very large systems), it is
important to consider frequent removal of older and lesser used data from ION_Data. WinPM.Net
includes an ION_Data data archive maintenance task by default. The database archive task is
pre-configured and disabled for standalone systems, while it must be manually added for
distributed systems.

To determine if data archiving is needed, you must:

• Understand the importance of archive and trim

• Determine the data retention needs

• Develop the archive and trim strategy

Understand the importance of archive and trim

The purpose of the archive is to remove data from the live ION_Data database to reduce its
overall size. An archive is a copy of a subset of data from the live ION_Data database based on a
date range and the type of data (Data Records, Waveforms and Events).

When an ION_Data archive is created, it is attached to the SQL Server database engine so that
its data is still accessible to Vista and Diagrams. However, the data is not available to other
applications in the Web Applications component.

NOTE: Data archival in WinPM.Net is different from the normal terminology of archiving.
WinPM.Net's archive task does not remove data from the database, it only copies data to the
archive. Once the data is archived in WinPM.Net, it cannot be re-imported back.

We recommend to manually trim the database of historical data after each archive task.

Determine the data retention needs

The live system only needs to hold as much data as needed for business. Consider the following
questions along with the business use cases to determine the data retention needs:

• What is the oldest date of data that is needed for trends and alarms?

• Is it sufficient to review older data trends only through web reports or diagrams?

• What date range of data is needed for historical reporting – start and end dates?

• How often should data be archived?

Develop the archive and trim strategy

These questions determine key aspects of the archive and trim strategy, in particular:

• When to archive data from the live database?

• When to trim data from the live database?

WinPM.Net 10.0 User Guide Chapter 11: Systemmaintenance and Disaster
recovery

© 2021 Siemens Industry, Inc. All Rights Reserved. 264



Chapter 11: Systemmaintenance and Disaster
recovery WinPM.Net 10.0 User Guide

265 © 2021 Siemens Industry, Inc. All Rights Reserved.

• When to delete historical archives?

Example: Archive and Trim Strategy

The following diagram illustrates an example ION_Data archive and trim strategy for a small to
medium system that started data collection in Q4 2016 and the strategy planned till 2021.

Based on the business needs, the data retention requirements are:

• Perform analysis with at least two calendar years of data in the main WinPM.Net system

• Reporting on the last 3 calendar years of data

• Data older than 3 calendar years can be deleted

The example strategy is as follows:

• Keep two calendar years of data in the main ION_Data database.

• Start archive activity at the end of Q1 of the third year.

NOTE: There should be 2 years and 3 months of data in ION_Data.

In this example, archive data from start of Q4 Year 1 to end of Q1 Year 3 into the database
called ION_Data Archive Year 1. This results in a new archive database named ION_Data_
Archive_2017 containing data from 01 September 2016 to 01 April 2018.

• Backup the newly created archive database.

• Schedule the archive activity once per year starting at the end of Q1 of the current year.

NOTE: Archive the older year of data with an additional 3 months on each side of the year of
interest.

• After each successful archive, backup the newly created archive database.

• Schedule the trim activity to trim data in the last 3 months of the dataset from the main ION_
Data database.

• Schedule the trim to run every 3 months.



• When an archive database contains data older than 3 years, mark the archive database for
deletion.

• Delete the marked archive database after 12 months of non-use.

NOTE: This strategy creates an overlap of data for every year.

Recommendation for archive and trim
• Archive and trim the ION_Data database often and in small batches. Together these two
tasks reduce the size of ION_Data and its backup files.

• Archive historical data often even when disk space is not an issue or when not using SQL
express.

• Trim historical data in small batches and often.

• Always perform a database trim after verifying a new archive.

Recommended consolidated archive and trim plan for systems

The recommended consolidated archive plan of ION_Data database for the different purpose of
WinPM.Net system are as follows:

Archive
strategy
parameter

Purpose of WinPM.Net system

Analysis & decision
making (Capacity
management, Energy
usage analysis)

Real-time monitoring &
troubleshooting
(Electric distribution
monitoring & alarming)

Critical large advanced
distributed system

Maximum data
retention (ION_
Data and
Archive
databases)

4 years 1 year 4 years

Live data in
ION_Data

3 years 1 year 2 years

ION_Data
archives

Start after end of year 3 Not applicable Start after end of year 2

Archive
frequency

Annually Not applicable Every 3 months

Number of
archives to store
on server

1 Not applicable 8

Additional IT
resources
needed for
archive
databases*

Use database growth
calculator to estimate
size archive database

Not applicable
Use database growth
calculator to estimate
size archive database

*See Database growth topic of Install Guide for recommendation on database growth.
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The recommended consolidated trim plan of ION_Data database for the different purpose of
WinPM.Net system are as follows:

Trim strategy
parameter

Purpose of WinPM.Net system

Analysis & decision
making (Capacity
management, Energy
usage analysis)

Real-time monitoring &
troubleshooting
(Electric distribution
monitoring & alarming)

Critical large advanced
distributed system

Trim
Data with timestamps
older than 3 years from
today

Data with timestamps
older than 1 year from
today

Data with timestamps
older than 2 years from
today

Trim frequency Monthly Monthly Monthly

Database integrity check

Database corruption is a rare event that is usually caused by inoperative hardware on the server.
A database integrity check reviews the allocation and structural integrity of all objects in each
database to ensure it is not corrupt.

Run DBCC CHECKDB in SQL Server Management Studio on all WinPM.Net related databases
once per month or quarter.

Check for errors reported in the output of DBCC CHECKDB. A database with integrity displays the
following at the end of the output.

CHECKDB found 0 allocation errors and 0 consistency errors in database

'ION_Data'.

DBCC execution completed. If DBCC printed error messages, contact your

system administrator.

See DBCC CHECKDB (Transact-SQL) for more information on database integrity.

Consolidated recommendation for database maintenance

Based on the key activities discussed, the following is the consolidated recommendation for
database maintenance as per the systems:

For all systems (Small, Medium, and Large):

• Schedule the ApplicationModules database trim task to run daily.

• Schedule the ION_SystemLog database trim task to run daily.

• If the number of connected devices have increased over time, review hardware and hard
drive space requirements at least once per year to ensure server specifications meets
growing demand.

• Review the frequency of the ION_Data database maintenance task as the system grows.
Reduce the frequency from daily to weekly to monthly as the database grows and the
maintenance tasks (Update statistics and re-indexing) take longer to complete.

• Never shrink the database container; it causes fragmentation.

https://docs.microsoft.com/en-us/sql/t-sql/database-console-commands/dbcc-checkdb-transact-sql?view=sql-server-ver15


• Archive and trim the ION_Data database regularly and in batches, such as 3 to 12 month data
sets. Refer to Historical Data Archive and Trim Strategy for more information.

• Commission WinPM.Net’s default ION_Data archive Windows scheduled task.

• Develop a process and schedule for:

Verifying the newly created archive database

Backing up the newly created archive database

Deleting the archive database when necessary

For large ION_Data databases (> 100 GB):

Large ION_Data databases require additional effort to maintain because all the maintenance task
might not run completely.

• Disable the ION_Data database maintenance task

With large systems, index fragmentation occurs quickly and is unavoidable.

Defragmentation takes lot of time and the performance gained because of
defragmentation is comparatively less.

If you plan to rebuild indexes, ensure that you have an equivalent amount of free space
as the database size.

• If ION_Data database increases over 100 GB unexpectedly, it can be due to following
reasons:

Database fragmentation can occur when there are more database read than database
write actions.

More data points are logged than usual and frequent logging is performed.

• Defragmenting indexes may require a lot of free hard drive space to allow reindexing to
succeed. Review hard drive space requirements.

System health review
You can adjust the system for optimal performance by monitoring the state of a system.

Frequent review of system health is to ensure optimal system health over the long term. This task
involves identifying and resolving potential issues. It is recommended to perform system health
checks at least once per month or quarter depending on the amount of data flowing into the
system and how often the system is used.

It is recommended to use the following approach to set up regular system health checks:

1. Determine which system health checks are appropriate. The following is a list of system
health checks appropriate for most of the WinPM.Net system. Customized WinPM.Net
systems might include additional checks or have some removed, however all system health
checks listed should be considered:

List of checks Application Server Database Server

Anti-malware ✓ ✓
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List of checks Application Server Database Server

Services running ✓ -

Message queues ✓ -

Device communication ✓ -

Processor usage ✓ ✓

Memory usage ✓ ✓

Disk usage ✓ ✓

File system growth ✓ ✓

File system fragmentation ✓ ✓

Log files ✓ ✓

Windows scheduled task history and status ✓ ✓

Database growth - ✓

Database fragmentation - ✓

Database integrity - ✓

Database backup - ✓

Software licensing ✓ ✓

Software updates ✓ ✓

2. Identify and document how the above information can be collected for the system health
review. Note the following tools:

WinPM.Net Diagnostic Tool - Install and deploy this tool to obtain a snapshot of the
current state of the system.

WinPM.Net Diagnostics Viewer. See Diagnostics Viewer for more information.

3. Create a template system health report. This report should contain at least the following
information:

Report date

Contact information

A list of each system health check with the following information for each line item:

Status – Passed, Caution, or Failed

Description of contributing factor to the given status

Recommended action

4. Determine a storage location for system health reports. Reports should be stored in a
consistent location and they should be accessible by administrators and support users.

5. Create an initial system health report.

6. In the location created in step 4, save the template report and the initial system health report.

The following table provides the information on list of system checks on why the check is required
and what you need to check:



List of checks Why What to check

Anti-Malware

If the WinPM.Net server has an
internet connection, it is at risk for
viruses and malware. The anti-
malware software should be
monitoring for threats in real-time
and running full scans once per
month.

• Check for warnings and threats.

• If threats were found, were the
infected files quarantined?

• Check that the latest anti-malware
definitions are installed.

Services running
These services are core of
WinPM.Net and must always be
running.

• Use Windows Services, Windows
Event Logs and Diagnostics
Viewer – Service Diagnostics to
ensure all ION, SQL Server and
IIS services are running.

• If they are stopped, investigate
logs for root cause.

See Diagnostics Viewer for more
information.

Message
queues

• Log Inserter writes log data into a
message queue instead of
writing it to SQL Server directly.
Another process (the Log
Subsystem Router Service)
reads the messages from the
queue and writes the data to
SQL Server.

• The message queues should be
at or near zero the majority of the
time. One indicator of poor
system health is when
WinPM.Net is operating in
steady-state and the message
queue size stays above zero for
any queue for an extended
period of time.

Use Diagnostics Viewer – Log
Pipeline Service to check status of
WinPM.Net MSMQs.

See Diagnostics Viewer for more
information.
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List of checks Why What to check

Device
communication

Networking issues can lead to
communication loss with devices.
For devices without onboard logging,
communication loss means data
loss. Monitor device communications
often to ensure the expected devices
are communicating.

• Use Diagnostics Viewer –
Communication Diagnostics to
check for communication issues,
such as Timeouts or Log Inserter
issues.

• Repeated and frequent timeouts
are common for long daisy chains
– this is a sign that the loop
performance needs to be
assessed.

• The LogInserter service
diagnostic will reveal which
devices cannot log data at the
device level, and which
DataRecorders have issues
(reference LogHandle column).

See Diagnostics Viewer for more
information.

Processor
usage

CPU usage over time should be less
than 80%.

• Is CPU trend showing at least
20% free?

• Are processes using and
releasing CPU resources?

In Windows Resource Monitor, track
the following object counters:

• Processor: % Privileged Time

• Processor: %User Time

• System: Processor Queue Length

See Monitor CPU Usage for more
information.

Memory usage

Prevent low memory problems by
applying the appropriate server
resources (RAM, CPU) as the
system grows. Take into
consideration future extensions of
the system and upgrades, which
could be performed in-place if the
server is prepared ahead. Monitor
memory usage to confirm that it is
within range.

UseWindows Resource Monitor to
track the following object counters
over time to determine normal usage
and identify issues:

• Memory: Available Bytes

• Memory: Pages/sec

See Monitor Memory Usage for more
information.

https://docs.microsoft.com/en-us/sql/relational-databases/performance-monitor/monitor-cpu-usage?view=sql-server-ver15
https://docs.microsoft.com/en-us/sql/relational-databases/performance-monitor/monitor-memory-usage?view=sql-server-ver15


List of checks Why What to check

Disk usage
There is a risk of disk I/O issues
particularly in WinPM.Net systems
with large ION_Data databases.

UseWindows Resource Monitor to
track the following object counters for
each disk:

Primary

• PhysicalDisk: Avg. Disk sec/Write

• PhysicalDisk: Avg. Disk sec/Read

Secondary

• PhysicalDisk: Avg. Disk Queue
Length

• PhysicalDisk: Disk Bytes/sec

• PhysicalDisk: Disk Transfers/sec

Track these counters over time to
determine normal usage and identify
issues. See Monitoring Disk Usage for
more information.

File system
growth

If a disk completely fills up, data loss
occurs. You must ensure the all disks
have adequate disk space for all
maintenance tasks
(defragmentation, backups,
database reindexing). There should
be at least 20 - 30% free disk space
at all times for optimum performance.
Possible causes of file system
growth include database file growth,
log file growth, data archives, and
space used by 3rd party software.

The best preventive measure is to
track of the disk space usage and
assess the growth over time. If the
used space for a disk has
consistently increased for several
months and the percent free disk
space is below 30% then action is
required. Investigate the root cause
of the growth, and develop a plan to
either prevent more disk space from
being used or for more disk space to
be added.

• Ensure file system fragmentation
job is running regularly

• Check for unsustainable file
system growth. If found, take
preventive action to reduce the
risk of a full disk, that is, add more
disk space or adjust system
configuration to reduce disk
space usage.
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List of checks Why What to check

File system
fragmentation

If file system (or disk) fragmentation
is greater than 40% on the database
drive, SQL server experiences a
thrashing/page faulting condition
when manipulating a large volume of
rows.

For WinPM.Net, file system
fragmentation usually results in
database auto-growth. It is most
common in small and medium
databases because of the SQL
express database size limit.

• Pre-allocate hard drive space for
the ION_Data database. See
Diagnostics Viewer for more
information.

• Check file system fragmentation
on all drives used by WinPM.Net
at least once per month

• Schedule time and perform file
system defragmentation if
necessary. For standalone
systems, ensure SQL Server
services are stopped before
defragmentation.

Log files

There are many logs that contain
critical error information, non-critical
error information, warnings, and
informational messages. Logs can
be a good source of information for
how well a system is performing as
well as gathering data for
troubleshooting specific issues.

IIS logs should be trimmed regularly.

Check:

• ION_SystemLog

• IIS Logs

• Windows Event Logs

• SQL Server Logs

• Check for unexpected errors in
the log files

• Check for errors related to
WinPM.Net components

• Check log size to ensure total size
is not excessively large (> 1 GB)

• Archive historical logs if folder has
too many log files.

Sometimes certain irrelevant errors or
warnings can be ignored. Any
anomalous messages in these logs
should be recorded and investigated.

Windows
scheduled task
history and
status

WinPM.Net’s default database
maintenance tasks are configured as
Windows Scheduled tasks.

Ensure scheduled tasks are
successfully launched at the
scheduled time and completing.

• Check Windows Scheduled Task
Logs, if any.

• Check WinPM.Net System Logs
for errors related to these tasks.



List of checks Why What to check

Database
growth

Unexpected database growth can
lead to poor performance. Usually
significant database growth is a
trigger.

Unexpected database growth
suggests possible excessive data
logging due to device
misconfiguration. For example,
unexpected high-frequency logging
(1 second logging intervals) or
waveform logging when waveform
data is not necessary.

Check database growth since the last
system health check. Does the growth
align with expectations?

Database
fragmentation

Database fragmentation, if not
addressed, is a common cause of
poor system performance.

Check for index fragmentation over
10%

Database
integrity

Database corruption is a rare event
that is usually caused by inoperative
hardware on the server. A database
integrity check reviews the allocation
and structural integrity of all objects
in each database to ensure it is not
corrupt.

• Run DBCC CHECKDB on all
WinPM.Net related databases.

• Check for errors reported in the
output of DBCC CHECKDB.

Database
backup

Confirm that the backup scheduled
tasks are completing successfully.

• Review SQL Server Logs for
errors related to each job.

• Confirm that the expected
database backup files exist, and
that copies of the backups have
been made to another media and
off-site.

Software
licensing

To ensure all WinPM.Net and SQL
Server features are functional.

Check that the license is still valid.

Software
updates

The latest updates ensure the
system has the latest cybersecurity
protection, and known software bugs
are fixed.

Check to see if software is out-dated
and identify when is the correct time
for an upgrade.
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Disaster recovery strategy
Disaster recovery requires planning and assessment to develop a strategy that meets both the
business requirement and WinPM.Net system configuration. The disaster recovery strategy is the
result of two objectives:

• Data retention - The amount of data required in the active system.

• System recovery - The minimal state of the system that should be recovered after a disaster
and the acceptable limit of data and time loss.

Disasters can occur at any time and, if unprepared, such events can lead to data loss and service
disruptions. Factors leading to system disasters include:

• Inoperative hardware

• Sudden power interruption / outage

• External threats such as malware, virus attacks, hacking

• Human errors such as accidental data deletion

• Implementation or upgrade issues

• Database corruption, such as a database exceeding the maximum expected size or allowable
hard drive space

• Natural disasters (For example, earthquakes, fire, flood, storms, and so on)

Some SQL Server disasters cannot be prevented, so it is important to prepare a complete
disaster recovery plan (DRP) to ensure minimal impact on service and data availability.

An effective disaster recovery plan should comprise:

• Identify disaster recovery objectives

• IT architecture and resources plan

• Backup plan

• Recovery plan

Developing the plan requires collaboration with the IT team, application champions
(administrators, power users) and recovery experts.

NOTE: If you have limited time and resource to define the strategy, you can consider third-party
products and services for assistance.

Identify disaster recovery objectives
The plan starts with identifying disaster recovery objectives. This includes the business aspect of
the system. You might want to consider the value of the WinPM.Net system and the data it
contains:

• What is the business cost of one day of downtime, both explicit and implied?

• What would be the result if an hour’s, day's or month's worth of analysis, reporting, alarming
and data were lost?

• What would be the result of a complete loss of the WinPM.Net system?



If your system is not critical, you may decide the best strategy is a simple one where a new
WinPM.Net system is redeployed in the event of a disaster and device data is re-imported and
you experience potentially irrelevant historical data loss. If your system is critical, you may
develop a plan for a quick recovery with minimal data loss.

You must set a written expectation of what constitutes an acceptable loss. Consider the following
questions:

• What is an acceptable level of data loss in your WinPM.Net systems?

The answer to this question determines the Recovery Point Objective (RPO) objective. It is
the maximum amount of recent data the business can lose when a disaster strikes. It helps to
measure how much time can occur between your last data backup and the disaster without
causing serious damage to your business. RPO is used to determine how often to perform
data backups.

For example, your backup schedule is set to daily at midnight and a disaster occurs at 8 AM.
At the point of the disaster, you would have lost 8 hours’ worth of data. If your RPO is one day
of data then the loss of the last 8 hours of data is not an issue. However, if your RPO is one
hour of data, then you must revise your backup schedule to at least one backup per hour.

• What is an acceptable recovery time?

The answer to this question determines the Recovery Time Objective (RTO) objective. It is
the amount of time the business can survive without the system after a disaster and before
operations are restored to normal. It determines how quickly you need to recover the
WinPM.Net system after a disaster.

For example, if your RTO is 24 hours, you can wait up to 24 hours before the system must be
available to users. If data and infrastructure are not recovered within 24 hours, the business
might be impacted.

• What level of disaster should we be prepared for?

Identify the possible disasters that could affect your WinPM.Net system and the level of
impact of each disaster. For example: If your WinPM.Net system is an on-premise solution,
you should prepare for disasters such as power loss, fire, flood, etc. If your WinPM.Net
system is hosted on off-site servers in a data center, prepare for natural disasters but with low
priority compared to cybersecurity risks.

IT architecture and resources plan
It is important to design the IT architecture so you can allocate the necessary hardware and
networking resources in support of optimal performance and disaster recovery. Maintenance and
backup activities often require additional resources (CPU, RAM and hard drive space) to perform
and complete the activity. You can also prevent disasters using additional hardware. The
recommended best practices are as follows:

• Hard drive space allocation

Ensure there is enough hard drive space to perform backup operations and take at least two
backup files. The spare hard drives can ensure minimal rebuild time. RAID arrays (commonly
used on all WinPM.Net systems) can protect against disk damages. See Storage
Performance and Availability topic of Install Guide for recommended hard drive sizing.
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• Backup power

UPS systems and redundant power supplies to servers can prevent server power
interruption.

• Connection redundancy

If available, redundant data links can protect critical data transmission when the
communication cannot be established in the network.

• Standby servers

With supporting infrastructure and cost, standby servers can provide another set of hardware
that can replace the WinPM.Net system hardware in the event of an inoperative server. This
approach is valuable whenWinPM.Net is a critical system.

Backup plan
Creating backups are a key part of every WinPM.Net deployment. A backup solution unique to the
WinPM.Net deployment can be created based on the recovery objectives, the WinPM.Net
system, and available IT resources. The backup plan should comprise:

• Components backup

• Backup frequency

• Storage and retention of backup

• Test the backup

Once you have a strategy with details, document the details and supporting processes. Whenever
a system or process change occurs, review and update this document. Store the document
outside of the WinPM.Net server.

Components backup

The following table contains the components of a standard WinPM.Net system that must be
considered for backup:

Component Name Description

WinPM.Net
Database

ION_Network

Sometimes called the NOM (Network Object
Model), the ION_Network database stores
device information, such as, device name,
device type and connection address (for
example, IP address and TCP/IP port or
device/Modbus ID). It also contains information
about the optional Application Module settings,
other ION Servers, Sites, Dial Out Modems,
and Connection Schedules. There is only one
ION_Network per system



Component Name Description

WinPM.Net
Database

Application Module

The Application_Modules database contains
configuration settings (for example, layouts,
colors, application events, and so on) and
cached historical data for some of the Web
Applications (for example, Dashboards and
Trends).

WinPM.Net
Database

ION_Data

The ION_Data database contains the historical
data, events and waveforms from devices
connected to the system. This includes:
onboard logging configured on devices; and,
PC-based logging configured in the device
translators and the Virtual Processors.

WinPM.Net
Database

ION_Data archive
The ION_Data archive databases contain
historical data that have been sectioned off
from the main ION_Data database.

System Database master

The master database is the core system
database for a SQL Server installation. It
contains information such as SQL Server
credentials and system configuration settings.

System Database model
The model database is used as a template for
all databases created on the SQL Server
instance.

System Database msdb

The msdb database is used by SQL Server
Agent for scheduling alerts and jobs. msdb
also contains history tables such as the backup
and restore history tables.

WinPM.Net Files WinPM.Net

The application folder is where all the program
and configuration files for WinPM.Net are
stored. By default this is “%Program
Files%\Siemens\WinPM.Net”

System Files SQL Server

The SQL Server folder is where all the program
and configuration files for SQL Server, SQL
Server Reporting Services, and SQL Server
Agent are stored. By default, this is “%Program
Files%\Microsoft SQL Server”.

System Files Windows registry
Contains configuration information for the
entire server
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Component Name Description

System
and 
WinPM.Net Files

Full Server Backup

It is advised to take an image of the entire
WinPM.Net application and database servers
(excluding the actual database files – MDF,
NDF, and LDF files). This backs up other
important configuration information such as
service credentials, security policies, and IIS
setup. It can be important when simplifying and
reducing the time taken for a system recovery.

All WinPM.Net databases should be backed up frequently and a full server backup should be
taken upon system configuration changes (for example, Vista diagrams, updating device drivers,
registry settings, VIP framework changes, and so on). Use Configuration Manager for performing
the backup. See Configuration Manager topic in Install Guide for more information.

Database recovery model

When backing up databases it is important to choose an appropriate recovery model. The
recovery model is a database property that controls how transactions are logged, whether the
transaction log requires (and allows) backing up, and what types of restore operations are
available.

WinPM.Net databases use one of two recovery models:

• Simple recovery model

Complete database backup is taken and a restore can only be done up to the point when the
backup was taken.

• Full recovery model

Provides backup options such as differential, incremental, and transaction log. The restore
can be done using different options.

All WinPM.Net databases are configured with the simple recovery model by default. The ION_
Data database recovery model should be updated to reflect your backup plan.

The recovery model is determined by comparing the disaster identification time with the backup
schedule. For example, as per the following diagram:



A system that is configured to have a single backup cannot be recovered. System is not accessed
by users over the weekend, and becomes inoperative such that the automated backup jobs are
still able to run. In this case, the backup would not be valid and there would be loss of the
complete WinPM.Net system.

You can prevent this situation by setting the ION_Data database recovery model to Full, thus
allowing more refined backup options.

In the case of critical WinPM.Net systems, consider:

• Being aware of your disaster identification time and adjust your backup schedule
appropriately

• Using a full recovery model with several differential backups (advanced configuration)

• Keeping multiple backup copies on a rotational basis

The key benefit of the full recovery model is that it can restore a database exactly to any point in
time since the last full backup was taken, including potentially to the point the disaster occurred,
resulting in no data loss. It should only be used if simple recovery is not sufficient to meet the
recovery needs as it incurs cost of performance and storage space.

Backup frequency

By default, WinPM.Net is configured to backup the ApplicationModules and ION_Network
databases on a daily basis, while the ION_Data database is backed up once per week. This
default configuration assumes that meters installed throughout the network have onboard
memory and onboard logging enabled with a log of at least 14 days of data. This weekly

WinPM.Net 10.0 User Guide Chapter 11: Systemmaintenance and Disaster
recovery

© 2021 Siemens Industry, Inc. All Rights Reserved. 280



Chapter 11: Systemmaintenance and Disaster
recovery WinPM.Net 10.0 User Guide

281 © 2021 Siemens Industry, Inc. All Rights Reserved.

frequency balances the need for performance in steady state and disaster recovery preparation.
Frequent transaction log backups can lead to an unnecessarily bloated LDF file, which can cause
performance issues.

If your WinPM.Net system is critical, it is important to ensure you have a frequent backup strategy
to support quick recovery. In this case, the recommended practices are:

• Set the ION_Data database recovery model to Full

• Schedule daily full backups

• Schedule hourly transaction log backups

• Continue to keep the last 2 full backup files on the server

• Increase hard drive storage space by the 2 x size of a ION_Data.MDF file for the additional
transaction log backup files

• Keep the last 24 transaction log backup files on the server

The recommended backup configuration and frequency for WinPM.Net and system database are
as follows:

Component Name Description
Recovery
Model

Backup
Frequency

WinPM.Net
Database

ION_Network All Simple Daily

WinPM.Net
Database

Application Module All Simple Daily

WinPM.Net
Database

ION_Data
For systems with meters
that have at least 14 days
of onboard logging

Simple Weekly

WinPM.Net
Database *

ION_Data

For systems without
onboard logging or for
critical systems

NOTE: Perform hourly
transaction logs backup.
Review data storage
requirements for the
additional transaction
log backup files

Full Daily

WinPM.Net
Database

ION_Data archive All Simple
Upon
creation

System Database master All Simple Daily

System Database model All Full As required

System Database msdb All Simple Daily

Additionally, all the components should be manually backed up after an update.



The recommended backup configuration and frequency for WinPM.Net and system files are as
follows:

Component Name Backup frequency

WinPM.Net Files WinPM.Net

• Backup upon significant system change

• Use Configuration Manager to backup and archive
WinPM.Net files. Be sure to deselect the database
options. See Configuration Manager topic in Install
Guide for more information.

System Files SQL Server

• Backup upon significant system change

• Backup “%PROGRAMFILES%
Microsoft SQL Server” folder upon major system
changes (hotfixes and upgrades)

System Files Windows registry Monthly and after a significant system change

System
and 
WinPM.Net Files

Full Server
Backup

• Annually or upon significant system change

• Backup the entire WinPM.Net application and
database servers (excluding MDF, NDF, and LDF
database files) once a year and after each significant
system change (upgrade)

Storage and retention of backup

In the WinPM.Net Planning stage, we recommend to have enough additional hard drive space to
support at least three times the expected size of the main ION_Data (MDF) database. This
estimation assumes that two backup files are stored on the production server.

We recommend the following storage and retention strategy:

• Follow the 3-2-1 Rule

Store backups locally on a RAID protected drive for the shortest amount of recovery time.

Store a copy of backups on a centralized set of disks so you can recover the backups on
another server if the production SQL Server encounters a critical issue.

Store a copy of the backups off-site on external drives or in the cloud in case a site
disaster occurs.

• Set up automated processes to backup and move files to separate locations.

• Maintain a reasonable set of backups off site and outside of the WinPM.Net servers. We
recommend the following backup retention strategy. Check with your legal team on keeping
certain amount of critical data in the event of a disaster.

10 daily backups

5 weekly backups

6 monthly backups

3 on-demand or annual backups

• Historical backup files should be stored off-site.
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• Delete the old backup files on a regular basis in order to manage the storage cost.

Test the backup

A critical aspect to the backup strategy is to ensure that you can recover files from the backups.
Prepare a test procedure to verify that the backup files contain the expected data and that the
backups can actually be restored, that is, the backup files are not corrupt.

When practicing the restore procedure, ensure that you restore to a different server and at a
different location.

This practice ensures that the recovery team:

• Knows the steps to follow when recovering from a data loss or disaster.

• Has existing infrastructure to support a recovery.

• Can stay calm and act efficiently in a real disaster situation.

Recovery plan
Backup files are worthless if they cannot be restored, so you must have a recovery plan with the
goal of getting a recovered WinPM.Net system functional with minimum downtime and data loss.
The disaster recovery objectives and backup and archive strategies help create a recovery
strategy.

The most important point to remember when creating a recovery plan is that it is not valid until it is
actually tested, and your recovery position is good as your last recovery test. Once you have a
recovery plan, allocate some time to test your disaster recovery strategy. Be aware of who is
executing the recovery as well. Do not assume that a specific person is available to restore the
WinPM.Net system.

We recommend the following approach to developing a recovery strategy:

1. Set a time expectation for recovery (Recovery Time Objective).

2. Identify the necessary hardware, software, backup and archive files and types (full,
differential, and log).

Ensure resources – physical (servers, software, network) and personnel – are allocated and
assigned, so they are readily available if a disaster strikes.

3. Document the entire recovery procedure.

If you have a large recovery time window, such as 1 week, you may have enough time to
contact WinPM.Net support team to assist in a recovery procedure. If you have a smaller
time window then any WinPM.Net administrator (factoring in employee turnover) should be
capable of performing a restore, so this procedure should be well documented. At a
minimum, all backup and archive locations should be documented and accessible to any
WinPM.Net administrator. Store the documentation outside of the WinPM.Net production
servers.

NOTE: Training WinPM.Net administrators and / or support staff on WinPM.Net disaster
recovery may be important to ensure you have redundant personnel available.



4. Schedule system downtime and test the restore procedure. This is a necessary step to
ensure the disaster recovery strategy is valid. Track the time the recovery procedure takes
to verify your time expectation for recovery is valid. Take corrective action for any areas
missed in your recovery documentation, backup, or archive strategies.

5. Progressively update recovery documentation after any major system changes are made
that changes the restore procedure.

NOTE: See SQL Server Limitations on Restoring System Databases in cases where a full SQL
server recovery is needed.

Recommended consolidated disaster recovery strategy plan
The recommended consolidated disaster recovery strategy plan of ION_Data database for the
different purpose of WinPM.Net system are as follows:

Disaster
recovery
strategy
parameter

Purpose of WinPM.Net system

Analysis & decision
making (Capacity
management, Energy
usage analysis)

Real-time monitoring &
troubleshooting
(Electric distribution
monitoring & alarming)

Critical large advanced
distributed system

Device memory
On board logging (14 to
30 days)

None None

Recovery point
objective

Up to 1 week Yesterday
As close to the point of
disaster as possible

Recovery time
objective

24 hours 36 hours 24 hours

Database
recovery model

Simple Simple Full

Full backup with
frequency

Full with weekly Full with weekly Full with daily

Additional
backup with
frequency

Not applicable Differential with daily
Transaction logs with
hourly

Number of full
backup files to
store on server

2 2 2

Number of
additional
backup files to
store on server

Not applicable 2 to 6

Depends on how often
the transaction log
backup files are
validated

WinPM.Net 10.0 User Guide Chapter 11: Systemmaintenance and Disaster
recovery

© 2021 Siemens Industry, Inc. All Rights Reserved. 284

https://docs.microsoft.com/en-us/sql/relational-databases/backup-restore/back-up-and-restore-of-system-databases-sql-server?view=sql-server-ver15#limitations-on-restoring-system-databases


Chapter 11: Systemmaintenance and Disaster
recovery WinPM.Net 10.0 User Guide

285 © 2021 Siemens Industry, Inc. All Rights Reserved.

Disaster
recovery
strategy
parameter

Purpose of WinPM.Net system

Analysis & decision
making (Capacity
management, Energy
usage analysis)

Real-time monitoring &
troubleshooting
(Electric distribution
monitoring & alarming)

Critical large advanced
distributed system

Additional IT
resources
needed for
additional
backup files*

Standard
Additional storage
required for differential
backup

Additional storage
required for transaction
log backup

*See Introduction chapter of Install Guide for recommended system sizing.



Chapter 12: Reference
This chapter contains specific information on technical details related to WinPM.Net. This
information is referenced in the other sections of this Help.

You access the information in this chapter through links from other chapters.

Operating Environment
WinPM.Net supports the following environments and software:

NOTE: The operating system and SQL Server combination you choose must be supported by
Microsoft. This applies to edition, version, and 32-/64-bit.

Software Supported Versions

Operating system

Windows 10 Professional/Enterprise
Windows Server 2012 Standard
Windows Server 2012 R2 Standard/Enterprise
Windows Server 2016 Standard
Windows Server 2019 Standard

Database system**

SQL Server 2012 Express
SQL Server 2014 Express
SQL Server 2016 Express
SQL Server 2017 Express
SQL Server 2019 Express (included with WinPM.Net 10.0)
SQL Server 2012 Standard/Enterprise/Business Intelligence
SQL Server 2014 Standard/Enterprise/Business Intelligence
SQL Server 2016 Standard/Enterprise/Business Intelligence
SQL Server 2017 Standard/Enterprise/Business Intelligence
SQL Server 2019 Standard/Enterprise/Business Intelligence

Virtual environment***

VMWare Workstation 10
VMWare ESX1 6.0
Oracle Virtual Box 5.0.4
Microsoft Hyper-V fromWindows 8.1, Windows Server 2012
Citrix XenServer 6.2
Parallels Desktop 10
QEMU-KVM

Microsoft Excel Microsoft Excel 2013, 2016, 365

Desktop Web browser

Google Chrome version 42 and later
Mozilla Firefox version 35 and later
Apple Safari versions 7 or 8 and later
Microsoft Edge

Mobile Web browser
Safari on iOS8.3+ operating systems, Chrome on Android
systems

.NET Framework .NET 4.6 or higher
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** WinPM.Net includes a free version of SQL Server Express. You have the option to install this
Express version during the installation of WinPM.Net, if you don't want to use a different SQL
Server.

*** You must configure virtual environments with a supported Windows operating system and
SQL Server edition. It is possible to mix virtual and non-virtual environments for WinPM.Net
server and clients.

WinPM.Net Windows services
All WinPM.Net applications without a user interface run as Windows services. The following table
lists all WinPM.Net services:

Service Name
Startup
Type

Log On
Account

Description

WinPM.Net
Application Modules
Alarm Services Host

Manual
Local
System *

Allows the Event Notification Module (ENM) to
read alarms directly from the ION_Data
database.
Starts on demand from other services (for
example, from the Event Notification Module).

WinPM.Net
Application Modules
Core Services Host

Automatic
Local
System *

Hosts common web services used by the Web
Applications component.

WinPM.Net
Application Modules
Data Services Host

Automatic
Local
System *

Hosts web services that provide low-level
access to system data (that is, real-time,
historical, alarming, and authentication) for the
Web Applications component.

WinPM.Net
Application Modules
Provider Engine Host

Automatic
Local
System *

Hosts web services that provide data
processing for the Web Applications
component.

WinPM.Net
Component Identifier
Service

Manual
Local
Service *

Locates local and remote product components.

Starts shortly after startup by request of
WinPM.Net Connection Management Service.

WinPM.Net
Connection
Management Service

Manual
Local
Service *

Determines the connection status of sites and
devices in the system, and handles allocation
of resources such as modems. This service
manages the state of site and device
connectivity for the system. In order to
establish the most appropriate state for the
system, each connection and disconnection
request is evaluated against the overall state of
the system and availability of communications
channels.

Starts shortly after startup by request of
WinPM.Net Network Router Service.



Service Name
Startup
Type

Log On
Account

Description

WinPM.Net Event
Watcher Service

Automatic
Local
Service *

Monitors system events for conditions specified
in Event Watcher Manager.

WinPM.Net Log
Inserter Service

Automatic
(Delayed
Start)

Local
Service *

Provides historical data collection for the power
monitoring system (that is, devices and Virtual
Processor), and stores it in the ION_Data
database.

WinPM.Net Log
Subsystem Router
Service

Automatic
(Delayed
Start)

Local
Service *

Transfers data received from power monitoring
devices to storage and processing.

WinPM.Net Network
Router Service

Automatic
Local
Service *

Routes all ION requests between the software
components, such as client workstations, the
Real Time Data Service, Log Inserter, and the
Query Server. The service dynamically detects
changes to the network configuration, including
the addition of new servers. It can also
recognize new software nodes, such as Vista,
that are added to an existing server.

WinPM.Net OPC
Data Access Server

Manual
Local
Service *

Serves real-time OPC data (OPC DA) to OPC
client applications.

Starts on an OPC client request for data, if the
OPC license has been activated.

WinPM.Net PQDIF
Exporter Service

Manual
Local
Service *

Translates power quality data from the ION_
Data database into PQDIF file format and
manages scheduled PQDIF exports.

WinPM.Net Query
Service

Automatic
Local
Service *

Provides historical data retrieval from the ION_
Data database for client applications (for
example, Vista and Diagrams).

WinPM.Net Real
Time Data Service

Automatic
Local
Service *

Manages and provides access to real-time data
for all client applications (Vista, Diagrams,
Trends, and so on).

WinPM.Net Report
Subscription Service

Automatic
(Delayed
Start)

Network
Service *

Runs Reports subscriptions according to user-
defined schedules.

Starts several minutes after the server starts.
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Service Name
Startup
Type

Log On
Account

Description

WinPM.Net Site
Service

Automatic
Local
Service *

Manages communication links to and from the
product. WinPM.Net Site Service is responsible
for handling packet communications to system
devices and controlling direct device
communications. The service reacts to
changes in network configuration: for example,
changes to certain channels, configuration
parameters, ports, or device parameters can
often interrupt a connection.

WinPM.Net Software
Data Processing
Service

Automatic
(Delayed
Start)

Local
Service *

Performs evaluations based on real time data
from the power monitoring system.

WinPM.Net Virtual
Processor Service -
NVIP.DEFAULT

Automatic
Local
Service *

Provides aggregation, control, and
mathematical analysis of power monitoring
system data.

WinPM.Net XML
Subscription Service

Automatic
Local
Service *

Manages subscriptions to XML data for Vista
user diagrams. This service is used only by the
Diagrams application. When you open a Vista
user diagram in a web browser, the WinPM.Net
XML Subscription Service creates a
subscription and delivers the real-time data in
XML format.

WinPM.Net XML
Subscription Store
Service

Automatic
Local
Service *

Stores XML data subscriptions for the power
monitoring devices on the network. This
service is used only by the Diagrams
application.

SQL Server (ION) Automatic
Local
System

Provides storage, processing and controlled
access of data, and rapid transaction
processing for the ION_Data, ION_Network,
ION_SystemLog, and the ApplicationModules
databases.

* WhenWinPM.Net is installed with Windows Integrated Authentication, the Windows account
that is used to access the database is also used to run the WinPM.Net services.

WinPM.Net Databases
WinPM.Net uses four databases to store device communication parameters, system
configuration settings, and logged historical data.



ION_Network database
Sometimes called the NOM (Network Object Model), the ION_Network database stores device
information, such as, device name, device type and connection address (for example, IP address
and TCP/IP port or device/Modbus ID). It also contains information about the optional Application
Module settings, other ION Servers, Sites, Dial Out Modems, and Connection Schedules. There
is only one ION_Network per system.

ION_Data database
The ION_Data database contains the historical data, events and waveforms from devices
connected to the system. This includes: onboard logging configured on devices; and, PC-based
logging configured in the device translators and the Virtual Processors.

Application Modules database
The Application_Modules database contains configuration settings (for example, layouts, colors,
application events, and so on) and cached historical data for some of the Web Applications (for
example, Dashboards and Trends).

ION_System log database
The ION_SystemLog database holds system events and their timestamps, which is accessible to
view in Management Console. Event priorities can range from 0-255 and are grouped into
Diagnostic (0 - 5), Information (6 - 20), Warning (21 - 63), Error (64 - 191), and Critical (192 - 255)
categories. System events can include:

• ION Service stopped or is starting or user connection to an ION Service is lost.

• Device has been declared offline / online.

• ION Site Service connected, disconnected or failed to connect to a Site.

• ION User logs on / off Vista or Designer.

• ION User saves a Vista or Designer node diagram.

• Plus many other Warnings and Errors relating to WinPM.Net system functions.

Default device type support
The following tables list the pre-configured device types in WinPM.Net 10.0.

Device Type

4300

4700

4720

9410

9810

3300 ACM

3710 ACM
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Device Type

3720 ACM

3800 RTU

7SJ62

7SJ64

7UM62

ACCESS 9200

ACCESS 9200 MODBUS

ACCESS 9300

ACCESS 9330

ACCESS 9340

ACCESS 9350

ACCESS 9360

ACCESS 9500

ACCESS 9500 RTU

ACCESS 9510

ACCESS 9510 RTU

ACCESS 9600

ACCESS 9610

ACCESS 9700

ASCO 7000 Controller

BCPM

CM3000 Series

CM4000 Series

Digi Trip 1150

ION 6200

ION 6200 MODBUS

ION 7300

ION 7330

ION 7350

ION 7500

ION 7500 RTU

ION 7550

ION 7550 RTU

ION 7600



Device Type

ION 7650

ION 7700

ION 8300

ION 8400

ION 8500

ION 8600

ION 8600C

ION 8650

ION 8650C

ION 8800

ION 8800C

ION 9000

IQ Analyzer

ISGS

PAC3100

PAC3200

PAC4200

PM200 Series

PM700 Series

PM800 Series

PM8000

PM810 LE

S7-I/O

SAMMS

SB-EC

SER 3200

Static Trip III

VL 555

VL 586

VL Breaker

WL Breaker
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VIP Modbus Slave port settings
NOTE: To view or change these settings in your system, open Management Console and go to
Tools > System > ION Virtual Processor Setup. For the VIP for which the Modbus Slave is
configured, expandModbus Network > Slave Ports.

Serial Port settings:

Setting Range

Unit ID 1 - 247 (default: 100)

Receive Timeout (ms) 100 - 10000 (default: 1800)

Transmit Delay (ms) 10 - 60000 (default: 50)

Baud Rate 300 - 115200 (default: 9600)

Parity NONE, ODD, EVEN, MARK, SPACE (default: NONE)

Stop Bits 1, 1.5, 2 (default: 1)

Modbus TCP settings:

Setting Range Notes

Unit ID 1 - 247 (default: 100)

Receive Timeout (ms) 100 - 10000 (default: 10000)

Transmit Delay (ms) 10 - 60000 (default: 50)

Listening Port 1 - 9999 (default: 502)

It is possible that other Modbus
Slaves are configured on the system,
such as the IONModbus Gateway
Service that is used for breaker aging
calculations. Configure different
listening ports for the different
Modbus Slaves. Each Modbus Slave
needs its own, unique listening port.

Max Number
Connections Allowed

1 - 32 (default: 5)

Configure this setting to only allow as
many connections as needed for
your application. Allowing more
connections than needed increases
that attack surface for unauthorized
system access. Keeping the attack
surface as small as possible is a
basic security measure.

Tunneling of OPC data
The networking protocol for OPC is DCOM. DCOM is difficult to configure, responds poorly to
network interruptions, produces high network traffic, and has significant security weaknesses.



OPC tunneling applications are designed to overcome these limitations when using OPC over a
network. The goal of OPC tunneling is to eliminate DCOM by replacing it with a network protocol
like TCP. Instead of connecting the OPC client to a networked OPC server, the client program
connects to a local OPC tunneling application, which acts as a local OPC server. The tunneling
application accepts requests from the OPC client and converts them to TCP messages, which are
then sent across the network to a companion tunneling application on the OPC server computer.
There the request is converted back to OPC and is sent to the OPC server application for
processing. Any response from the server is sent back across the tunnel to the OPC client
application in the same manner.

Diagram: OPC data is sent over the network by OPC tunneler using common network protocols.

OPC tunneling products are available from several vendors, including Kepware and Matrikon.

When selecting OPC tunneling applications, look for products that

• keep the synchronous OPC transactions local to the client and server, with an asynchronous
tunnel connection

• provide link monitoring

• handle network disruptions effectively

• meet your security needs

Database maintenance task definitions
The following are high level definitions of WinPM.Net relevant database maintenance tasks.

Archive
Database archiving copies older data from the operational database into a separate, new
database. The goal of archiving is to keep data safe for future reference. Data is typically archived
based on calendar time intervals, for example by month or by year.

The WinPM.Net archive task creates a new archive database each time the task is run. Each new
archive database is attached to SQL server and is available to be accessed by WinPM.Net.

NOTE: The WinPM.Net archive task does not trim data from the operational database; it only
makes a copy of the archived data, leaving the original data in the operational database. See
Considerations for trimming archived data from ION_Data for important information on this topic.

Backup
Backing up a database creates a copy of the operational database. The goal of a backup is to
have an identical duplicate of the operational database that can be used to restore the system in
case the operational database becomes nonfunctional. Database backups should be created on
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a regular basis, for example daily or weekly.

Maintenance
TheWinPM.Net database Maintenance task defragments the database and updates the
database statistics. The goal of these activities is to maintain database performance.
Maintenance tasks should be run on a regular basis, for example daily.

Size Notification
The size notification task is used to monitor the size of the database and to notify users when a
certain size threshold is reached. When the size threshold is reached, the task logs a system log
event message and triggers a Critical alarm in WinPM.Net every time the task runs.

NOTE: The Size Notification task is only configured for systems using SQL Server Express,
which has a maximum database size limitation of 10 GB.

Trim
Trimming a database deletes data from the database. The goal of trimming is to prevent the
database from growing to a size that could affect system performance. Databases should be
trimmed on a regular basis, for example daily or weekly. For WinPM.Net only the system log
databases are trimmed.

Considerations for trimming archived data from ION_Data
When archiving and then trimming data from the ION_Data database, you are moving this data
from the operational database into an archive store for long-term retention. This data is then no
longer available in the ION_Data database for analysis in WinPM.Net. WinPM.Net has very
limited access to archived data.

We recommend that you only trim archived data from the ION_Data operational database, when:

• It approaches its size limit, for example 10 GB for a SQL Server Express database.

• It reaches a size that impacts query performance.

• The database drive is low on available free space and you cannot switch to a larger drive.

When you trim data from an SQL database, the database file size remains unchanged. After the
trim, the database will first fill the new free space before growing the database file size again. To
reduce the database file size after trimming, Shrink the database, using standard SQL Server
tools.

NOTE: The WinPM.Net archive task does not trim the database; it only copies data to the
archive.

Archive data access in WinPM.Net:

Application Archive Data Access

Vista Yes



Application Archive Data Access

Reports
Can access either data from the operational database or from an
archive database but not both at the same time.

Dashboards No

Diagrams Yes

Trends No

Alarms No

Default maintenance task settings
The default WinPM.Net database maintenance tasks are defined as Windows PowerShell scripts,
and scheduled and executed using Task Scheduler in Windows. The following table shows the
different configuration settings for these tasks, their defaults, and where they are configured:

Setting Location Default Value Comments

Windows account
used to run the task Task Scheduler User account that is

creating the task.

Use IONMaintenance for Standalone systems.
Create a new, dedicated account for
Distributed systems.

Task trigger times Task Scheduler See default task
schedules.

The default schedules are configured
automatically for Standalone systems.
The schedules for Distributed systems must be
configured manually.

Task enabling or
disabling Task Scheduler See default task

schedules. n/a

Backup folder
location

PowerShell script :
Configuration.ps1
Variable:
$locationForBackupFiles

...\
WinPM.Net
\Database\Backup*

Sets the folder to which the database backups
are saved. The backup script will create the
following subfolders in this location:
...\Data for ION_Data
...\Network for ION_Network
...\SystemLog for ION_SystemLog
...\Applications for ApplicationModules

Archive folder
location

PowerShell script :
Configuration.ps1
Variable:
$locationForArchiveDBFiles

...\
WinPM.Net
\Database\Archive*

Sets the folder to which the database archives
are saved.

Data to keep when
trimming

PowerShell script :
Configuration.ps1
Variable:
$diagnosticsDaysToKeep

30 Sets how many days' worth of data is left in the
database after trimming.

Database size
(max)**

PowerShell script :
Configuration.ps1
Variable:
$maximumDatabaseSizeIn
Gigabytes

9

Sets the maximum database size. This value is
used by the size notification task to assess
what percentage of database space has been
used.
The maximum size for a SQL Express
database is 10GB. The maximum size in the
script is set to 9GB to allow for a 1GB warning
buffer before the database stops logging data.

Database size
notification limit**

PowerShell script :
Configuration.ps1
Variable:
$databaseSizeNotification
ThresholdPercentage

85 Sets the threshold for when a database size
notification will be issued.

* Default setting for Standalone systems.
** The database size notification is only configured for systems with SQL Server Express
databases.
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Using IONMaintenance for database maintenance tasks
IONMaintenance is a Windows user account that is created automatically whenWinPM.Net is
installed in a Standalone architecture. This account is used to run the pre-configured WinPM.Net
database maintenance tasks in Task Scheduler in Windows. To make changes to the task
schedules in Task Scheduler, you need to enter the password for the IONMaintenance account.
By default, the password for the account is generated automatically by the installer and cannot be
retrieved. To have access to the password, you need to set a custom password for this account.

To set a custom password for IONMaintenance, run the WinPM.Net installer in maintenance
mode and select Reset Accounts to start the account password reset procedure. Follow the
installer instructions to reset the password.

NOTE: If you set a custom password for the Windows Accounts during the installation of
WinPM.Net, then this is the password used by IONMaintenance and you can use this password
to make changes to the task schedules in Task Scheduler.

NOTE: IONMaintenance shares the same password with IONUser, another account that is
generated automatically by the installer and which is used for report subscriptions.

NOTE: If you change the password for the Windows accounts, the password you are providing
must comply with the password policies of the Windows server and the SQL server. The
software installer cannot validate the password at the time you enter it. If the password is not
valid, the password reset and reconfiguration will not be successful. In that case, complete the
reconfiguration, skipping any unsuccessful steps.

Database maintenance account requirements
WinPM.Net uses Task Scheduler in Windows for the scheduling and execution of database
maintenance tasks. Task Scheduler requires a Windows account to run the tasks. In Standalone
WinPM.Net systems, an account, IONMaintenance, is created by the installer and automatically
assigned to the Task Manager tasks. In Distributed WinPM.Net systems you need to create an
account manually. This account must meet the following minimum requirements:

In Windows on the computer where the database server is installed, the account:

• must be a member of the Users group.

• must have the following Windows policy settings: Log on as a batch; Deny log on locally.

In SQL Server, the account:

• must have a public server role

• (for archive task only) must have a sysadmin server role

• must have the following role memberships for the WinPM.Net databases (ION_Data, ION_
Network, ION_SystemLog, ApplicationModules):

db_backupoperator

db_ddladmin



Maintenance

public

NOTE: You will need the password for this account during the initial task setup, and later if you
want to edit the tasks in Task Manager in the future.

Changes in security settings of device
The security settings for the following device types have changed starting the firmware version
3.0.0:

• 9810 series devices

• 9410 series devices

The changes in the device security settings are:

• Standard security mode is removed

• Legacy security support is an interim solution for users that use standard security mode.

Because of these changes, configuring the devices and viewing the diagram with firmware
version 3.0.0 or higher requires changes in the WinPM.Net.

To access an existing device in Management Console after firmware upgrade:

1. Right-click the device that has Advanced Security enabled and select Security to open the
Meter Security Settings dialog.

2. From the Software Access drop down list, select User1.

3. ClickMatch Password and type the password in the Password field then re-type it in the
Confirm Password field.

4. Select the check box if you want to allow the software to send secure time synchronization
signals to the device. Clear the check box if you do not want to send secure time
synchronization signals to the device.

5. ClickOK.

To configure the security module in Designer for an existing device after
firmware upgrade:

NOTE: The Change Standard Meter Security option is disabled and hence standard security
can not be enabled.

To enable advanced security,

1. Open a node diagram.

2. Right-click the Security Optionsmodule icon to open the module setup.

3. Highlight the SOP1 Legacy Security Support register and clickModify.

4. Select Disabled in the options drop down and clickOK in the Modify Enumerator Register
dialog.
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5. ClickOK in the ION Module Setup dialog to close it.

6. Send and save the changes in Designer.

To perform control object function of diagram in Vista for an existing device after
firmware upgrade:

1. Enter the username and password. See Controlling system functions for more information.

Device Type Editor User Interface
Main user interface

A
Measurement
Tree pane

B String Register Details pane C Modbus/OPCMap pane

Menu bar

Menu Options

File

New: Create a new Modbus or OPC device type.
Open: Open an existing device type.
Save: Save the current device type.
Save As: Save the current device type to a different location.
Export: Export the current device type as text file in csv format
Exit: Close the Device Type Editor.



View

Measurement Tree: Show or hide the Measurement Tree
display pane
Register Detail: Show or hide the String Register Details display
pane
Register Map: Show or hide the Modbus Register Map display
pane. Show or hide the Enumerations, Address Blocks, Invalid
Addresses, and Device Info tabs.

Advanced
Show or hide the Handle Exclusions, Transaction Configuration,
Time Sync Info, and Plugin Info tabs.

Tools

Configure Software Logging: Open the Configure Logging and
Calculation tool
Expose OPC Measurements: Update the OPC measurement
definition in the system
Clean Measurement Tree: Remove any unused managers,
modules, registers from the tree
Install Device Type: Open the Device Type Installer

Help Device Type Editor Help: Open the Device Type Editor help file.

Context Menus

Right-click on a manager, module, or register in the ION Tree to open a context menu. The
context menu provides access to the actions you can perform on the Measurement Tree, such as
adding and editing managers, modules, and registers.

Right-click anywhere inside the Modbus/OPCMap table to open a context menu. The context
menu provides access to the actions you can perform on the Map , such as inserting or deleting
rows.

Right-click anywhere inside the Map table header row to open a context menu. The context menu
provides access to actions related to the table format, such as sorting of the table content or
showing or hiding table columns.

Configuring Logging and Calculation User Interface
Use the Configure Logging and Calculation utility to:

• Enable register logging, including setting log frequency.

• Enable low (minimum), high (maximum) and mean (average) calculations and logging.

• Configure stale data settings.

• Append downstream device information to labels.

NOTE: Only numeric output registers can be calculated and logged. All other types of registers
(for example, enumerated) do not appear on the Configure Logging and Calculation screen.
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Screen overview

A Select this check box to make the downstream device columns appear

B Register area C Stale data link D Low area

E High area F Mean area G Help link

H Global register edit area. Use this area to globally edit all rows selected in the upper pane.

All the register information from the device type in the Device Type Editor is pre-populated in this
table when you open the application.

Show downstream device columns: Select this to show all the columns for selecting and
setting the downstream device properties for registers.

Register area: Use this area to individually configure registers.

Low area: Use this area to enable calculation and set logging of low values.

High area: Use this area to enable calculation and set logging of high values.

Mean area: Use this area to enable calculation and set logging of mean values.

Global register edit area: Use the bottom half of the screen to edit individual registers or multiple
registers, after selecting them in the list.

Help link: Click this link to open the Device Type Editor online help.

Stale data link (All): Click this link to open the Configure Stale Data Settings dialog.

Configuring register logging
To edit registers on an individual basis, select the row of the register and edit the cells in the row
or use the editing tools in the Global area.

To editmore than one register, select the rows you want to configure similarly and use the
editing tools in the Global area.

Log: Select to enable logging of the register.



Interval: This value determines the logging frequency for the register. Note that this value also
controls the reset interval for the min, max and averaging modules, even if these calculations are
not being logged. The valid range is 1 to 4,000,000 seconds.

Configuring Low, High and Mean Calculation and Logging
To edit the suffix used for Low, High and Mean, click on the applicable link. For example, if you
change the suffix to Maximum, VoltsA High becomes VoltsAMaximum.

Low

Select Calculate to enable calculation of low (minimum) values for this register. Select Log to
enable logging of this value. Note how the label is appended to reflect that this is the low value.

High

Select Calculate to enable calculation of high (maximum) values for this register. Select Log to
enable logging of this value. Note how the label is appended to reflect that this is the high value.

Mean

Select Calculate to enable calculation of mean (average) values for this register. Select Log to
enable logging of this value. Note how the label is appended to reflect that this is the mean value.

Configuring Stale Data settings
The “staleness” of data is measured from time data was last read from a physical device until the
current time.

Click the All (Stale Data) link to open the Configure Stale Data Settings dialog.

Mark data stale after: Enter the time you want to elapse before data from this register is marked
stale in the data recorder. The valid range is 0 to 7200 seconds.

When data is stale: Select how you want stale data values logged. The setting “log an empty
row” logs an empty row in the data recorder, while “use last known value” logs the last non-stale
value in the data recorder until the end of the current interval.

NOTE: Stale data settings are global (they apply to all registers) for a device type.

Configuring downstream device functionality
You must select the Show downstream device columns check box in the Configure Logging
and Calculation window before you can edit downstream device functionality.

Show downstream device columns: Select this check box to make the downstream device
columns appear.

Is Downstream Device: Select this checkbox to indicate the register belongs to a downstream
device.

Downstream Device Name: Enter the name of the downstream device in this field. The register
label is appended with this name. For example, if the device name is Meter01, the register label
becomes VoltsA@Meter01.
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NOTE: Using this optionwithout also using the Include Name of Device Instance option causes
multiple devices to appear as a single device in your energy management system. Do not use
this option on its own unless only a single instance of this device is present in your system.

Include Name of Device Instance: Select this check box to append the actual device instance
name to the register label. The placeholder !!DeviceName!! is then added to the label — the name
of the actual device instance gets inserted when it is created.

For example, if the device instance is named Device01:

VoltsA@!!DeviceName!!Meter01

is replaced with

VoltsA@Device01Meter01

This allows for the creation of unique names within WinPM.Net, as well as enabling each device
instance to appear in the product as multiple virtual devices.

For more information on downstream devices and naming conventions, see Downstream Device
Assistant in the WinPM.Net User Guide.

Saving and exiting
To exit the Configure Logging and Calculation screen:

• ClickOK to save your settings.

• Click Cancel to exit without saving.

You are returned to the main Device Type Editor console screen.

Modbus Data Formats
WinPM.Net supports the following data formats:

Format Type Description

SINT16
A 16-bit signed value in 2-1 (or big ENDIAN) format. The high
order byte is first, the low-order byte second.

UINT16
A 16-bit unsigned value in 2-1 (or big ENDIAN) format. The high
order byte is first, the low-order byte second.

SINT32 or S32-4321

A 32-bit signed value returned in two consecutive 16-bit registers.
The high-order word is returned in the first register, the low order
word in the second. In effect, the 4 bytes are returned in 4-3-2-1
(or big ENDIAN) format.

UINT32 or U32-4321

A 32-bit unsigned value returned in two consecutive 16-bit
registers. The high-order word is returned in the first register, the
low-order word in the second. In effect, the 4 bytes are returned in
4-3-2-1 (or big ENDIAN) format.



Format Type Description

S32-2143

A 32-bit signed value returned in two consecutive 16-bit registers.
Contrary to S32_4321, the high-order word is returned in the
second register, the high-order word in the first. In effect, the 4
bytes are returned in 2-1-4-3 format.

U32-2143

A 32-bit unsigned value returned in two consecutive 16-bit
registers. Contrary to U32_4321, the high-order word is returned
in the second register, the low-order word in the first. In effect, the
4 bytes are returned in 2-1-4-3 format.

S32-MFP or
S32-M10k-4321

A 32-bit signed value returned in two consecutive 16-bit registers.
The word stored in the first 16-bit register is multiplied by 10000
and added to the word stored in the second 16-bit register. Also
known as ‘signed Modulo 10000’.

U32-MFP or
U32-M10k-4321

A 32-bit unsigned value returned in two consecutive 16-bit
registers. The word stored in the first 16-bit register is multiplied by
10000 and added to the word stored in the second 16-bit register.
Also known as ‘unsigned Modulo 10000’ or mod-10K.

S32-M10k-2143

A 32-bit signed value returned in two consecutive 16-bit registers.
Contrary to S32_M10k_4321, the word stored in the second 16-bit
register is multiplied by 10000 and added to the word stored in the
first 16-bit register.

U32-M10k-2143

A 32-bit unsigned value returned in two consecutive 16-bit
registers. Contrary to U32_M10k_4321, the word stored in the
second 16-bit register is multiplied by 10000 and added to the
word stored in the first 16-bit register.

S48-M10k-21-65

A 48-bit signed value returned in three consecutive 16-bit
registers. R3*10,000^2 + R2*10,000 + R1, where R3 is the last
register and R1 is the first register. Each registers range is -9,999
to +9,999

U48-M10k-21-65

A 48-bit unsigned value returned in three consecutive 16-bit
registers. R3*10,000^2 + R2*10,000 + R1, where R3 is the last
register and R1 is the first register. Each registers range is 0 to
+9,999

S64-M10k-21-87

A 64-bit signed value returned in four consecutive 16-bit registers.
R4*10,000^3 + R3*10,000^2 + R2*10,000 + R1, where R4 is the
last register and R1 is the first register. Each registers range is -
9,999 to +9,999

U64-M10k-21-87

A 64-bit unsigned value returned in four consecutive 16-bit
registers. R4*10,000^3 + R3*10,000^2 + R2*10,000 + R1, where
R4 is the last register and R1 is the first register. Each registers
range is 0 to +9,999
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Format Type Description

S64-87-21

A 64-bit signed value returned in four consecutive 16-bit registers.
The highest order word is returned in the first register, the lowest
order word in the fourth. In effect, the 8 bytes are returned in 8-7-6-
5-4-3-2-1 (or big ENDIAN) format.

U64-87-21

A 64-bit unsigned value returned in four consecutive 16-bit
registers. The highest order word is returned in the first register,
the lowest order word in the fourth. In effect, the 8 bytes are
returned in 8-7-6-5-4-3-2-1 (or big ENDIAN) format.

S64-21-87

A 64-bit signed value returned in four consecutive 16-bit registers.
The highest order word is returned in the fourth register, the lowest
order word in the first. In effect, the 8 bytes are returned in 2-1-4-3-
6-5-8-7 (or little ENDIAN) format.

U64-21-87

A 64-bit unsigned value returned in four consecutive 16-bit
registers. The highest order word is returned in the fourth register,
the lowest order word in the first. In effect, the 8 bytes are returned
in 2-1-4-3-6-5-8-7 (or little ENDIAN) format.

S16-1-15
A 16-bit signed value. Bits 1 to 15 bits are unsigned data. If bit 16
is 0, the value is positive, if bit 16 is 1, the value is negative.

IEEEFloat or F32-4321

A 32-bit IEEE floating point value returned in two consecutive 16-
bit registers. The high-order word is returned in the first register
and the low order word in the second. In effect, the 4 bytes are
returned in 4-3-2-1 format.

SwappedFloat or
F32-2143

A 32-bit IEEE floating point value returned in two consecutive 16-
bit registers. Contrary to F32_4321, the high-order word is
returned in the second register and the low order word in the first.
In effect, the 4 bytes are returned in 2-1-4-3 format.

MaskedBool or
PackedBool

A 16-bit value that is interpreted according to the bit pattern
described by the Mask attribute. Bits exposed by the mask can be
read or written without affecting the value of other bits. Unmasked
bits are interpreted as 0 on a read and are unaffected on a write.
Undeclared bits of a mask are interpreted as unmasked (i.e.,
mask="0x7F" is interpreted as 0x007F). The value that is read or
written is determined by using enumeration ordinals, described
below. If used for read-only Boolean data, enumerations are not
required. If no mask is specified, all bits are relevant.

PF-Nexus
A 16-bit unsigned value, range 0 to 3999, representing 3 decimal
places of accuracy.

BCD (Binary Coded
Decimal)

A number is expressed as a sequence of decimal digits and then
each decimal digit is encoded as an 8-bit binary number. For
example, decimal 92 is encoded as 00001001 00000010.



Format Type Description

The following data types can have their length specified by the “Number of Registers to
Request” setting.

Packed BCD
A number is expressed as a sequence of decimal digits and then
each decimal digit is encoded as a 4-bit binary number (nibble) For
example, decimal 92 is encoded as 1001 0010.

ASCII
A sequence of bytes representing the ASCII character set. Each
word stores two ASCII characters. Trailing spaces are removed.

ASCII-Reverse
Same as ASCII except every second character is in the reverse
order.

Additional supported formats: U16-21, S16-21, U16-12, S16-12, U64-M10k-87-21, S64-M10k-87-
21, U48-M10k-65-21, S48-M10k-65-21, U48-65-21, S48-65-21, U48-21-65, S48-21-65,
InvertedMaskedBool, F64-87-21, F64-12-78, PF32, PF_ALT, U16-21-ARRAY, U16-12-ARRAY,
DateTime4_UTC, DateTime4_LOCAL, DateTime4, DateTime3_UTC, DateTime3_LOCAL,
DateTime3, DateTime_YMDhms_UTC, DateTime_YMDhms_LOCAL, DateTime_YMDhms,
DateTime_IEC870_UTC, DateTime_IEC870_LOCAL, DateTime_IEC870, DateTime3_IEC870_
UTC, DateTime3_IEC870_LOCAL, DateTime3_IEC870, DateTime3_MDYhms_UTC,
DateTime3_MDYhms_LOCAL, DateTime3_MDYhms, DateTime4_MDYhms_UTC, DateTime4_
MDYhms_LOCAL, DateTime4_MDYhms, DateTime2_s2000, DateTime3_s2000, DateTime4_
shmMDY, DateTime6_smhDMY, DateTime7_YMDhms, DateTime8_MDYdowhmsc,
DateTime6_MDYhmms, DateTime_NSX2_UTC, DateTime_NSX2_LOCAL, DateTime_NSX3_
UTC, DateTime_NSX3_LOCAL, S64-M1K-87-21, U64-M1K-87-21.

Modbus Register Properties
The following register properties can be configured:

Name

The Modbus register name is an identifier for the register. It is used internally, but not displayed in
the measurement selector user interfaces. The ION register label, to which the Modbus register is
mapped, is used for display. If no ION register label is defined, then the ION register name is used
for display.

For multi-circuit devices, such as the BCPM, the Modbus register name is used to identify the
different circuits, with a special naming convention (example: Real Energy@!!DeviceName!!_

1PH_Ch1). These special register names are then used for the creation of managed circuits, if that
feature is configured for the device type in the Management Console.

NOTE: The register name has amaximum character limit of 50, including spaces. This is
important to consider when creating names for multi-circuit devices.

Constant Value vs. Mapped Value

To have an ION register linked to a measured value from a device, map this register to the
appropriate Modbus register. To assign a constant value to an ION register, enter this value into
the Value box for the ION register in the String Register Details pane. You must unmap a mapped
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register first before you can edit the value of an ION register. To unmap a register, delete the
ION Handle number for the mapped Modbus register, or delete the entire Modbus register row for
the mapped Modbus register in the Register Map.

Disable Not Available Check

Use this field to skip the Not Available check for a register.

Enumeration

Enumeration is used to convert ordinals (position numbers) read from the device into the values
these ordinals represent.

For example, a device may represent the Baud rate with a number from 0 to 3, where 0 = 19200
Baud and 3 = 115200 Baud. Using enumeration, the value 0 is converted to the string "19200
Baud", and the value 3 is converted to "115200 Baud". There are many applications for using
enumerations when reading Modbus register data.

To create an enumeration:

1. In Device Type Editor, open the device type for which you want to define enumerations, and
then browse to the Enumerations tab.

NOTE: This tab is hidden by default. To show the tab, check View > Register Map >
Enumerations.

2. In Enumerations, insert a new row, using the context menu commands.

3. Enter a name in the Name field to identify this enumeration.

For the example above, the name could be "Baud_Rate".

4. Enter a default value for the enumeration in the Default Enum Value field.

For the example above, this could be "19200 Baud".

5. Click the Enum Info Option icon in the name field for this enumeration to open the Enum
Info Option table.

6. In Enum Info Option, insert new rows, using the context menu commands and enter the
ordinals into theOrdinal fields and the corresponding values into the Value fields.

For the example above, ordinal 0 has a value of 19200 Baud, ordinal 1 a value of 38400
Baud, ordinal 2 a value of 57600 Baud, and ordinal 3 a value of 115200 Baud.

7. Click the icon in the op left corner of the Enum Info Option grid to return to the
Enumerations table.

8. Browse to the Register Map table and enter the enumeration name created in step 3 into
the Enum Name field for the registers to which it applies.

Format

This data format is used for decoding the values returned from the meter. The selected data
format must match the format delivered by the device. See Modbus Data Formats for the
supported formats.



ION Handle

The ION handle is the reference ID used by WinPM.Net to identify the ION register that is mapped
to the Modbus register. The ION handle is automatically assigned when you map a Modbus
register from the Register Map to the ION register in the ION Tree.

Mask

The mask is used to read individual bit values from a Modbus register value. It is applied to the
register data using an AND logic. For example, if the mask “0x4” is applied, then the register value
displayed is only nonzero if the 3rd least significant bit in the register is a 1. You can apply masks
to both numeric and Boolean data types.

NOTE: For integer values, the bit order of the mask corresponds to the bit order of the actual
data and NOT the order in which the bytes representing the data are returned over Modbus. The
high-order nibble of a 32-bit value is selected as ‘0xf0000000’ regardless of whether the format
is U32_4321 or U32_2143. It should also be noted that the resulting value of a masked integer is
NOT bit shifted. A mask of ‘0xf000’ applied to a 16-bit value of ‘0x1234’ results in ‘0x1000’ (4096
decimal) and NOT 1.

Modbus Address

This is the physical address of the Modbus register. You can find this address number in the
device documentation. Enter the number in either decimal or hexadecimal format. The address
range depends on the register type as follows:

COIL STATUS = 0xxxx
INPUT STATUS = 1xxxx
INPUT REGISTER = 3xxxx
HOLDING REGISTER = 4xxxx

NOTE: When entered in hexadecimal format, the value is only the register offset and does not
include the Register Type identification.

Not Available Value

If the Modbus register has a control signal value to indicate when the register is not available, then
you can enter this value in this field. The value must match the control signal value that is received
from the device. This allows the user interfaces that display data for this register in WinPM.Net to
indicate when the value is not available.

Number of Registers

This option is only available if the data type is set to ASCII, ASCII-Reverse or Packed BCD. It
allows you to specify the number of registers to retrieve from the device on a request.

Request Type

This tells the system whether the register is for read (R) or write (W). Other options are read/write
(RW), and command write (CW).
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Scale, Multiplier, Offset

The scale, multiplier and offset can be set to any decimal value within the range of -3.402823466
E + 38 to 3.402823466 E + 38. These values are applied to the measured value returned from the
device in the following way:

ION value = (Modbus value - offset) * multiplier / scale

Instead of setting these values to a constant, you can also map them to ION registers that hold
these values. This is useful if the value of the ION registers can be read from the device. It is also
useful if you want to use the same scale, multiplier, or offset for multiple registers. In this case you
can map all of the registers to the same ION registers, and set their values to constants. You can
only map to registers already created in the Device Type Editor.

To map the scale, multiplier, or offset to an ION register, enter the ION handle value for this
register, in hex, into the Scale, Multiplier, or Offset fields in the Modbus Register Map.

Setup Reg

Use this field to indicate that a register is a setup register on the device. Setup registers are read
at a lower polling rate than regular data registers, improving the overall performance of the device
driver.

Write Value

This only applies to pulse registers. Use this field to specify the value that is written to the Modbus
register on the device when the ION register is pulsed.

Measurement Tree
The Measurement Tree organizes the device measurements into a structure that is recognized by
WinPM.Net and that determines how you access these measurements in the software. The
Measurement Tree consists of managers, modules, and registers.

Managers
Managers are at the top level of the tree. Managers group together modules of the same type. For
example, a manager calledMaximum Readings could contain the modulesMax Current,Max
Frequency andMax Voltage. You are free to choose a name for a manager that best meets your
needs. Choose a name that is relevant to the type of modules it contains. You can create up to
127 managers.

Modules

Modules are contained inside managers. Modules group together related registers. For example,
a module calledMax Current could contain the registersMax Current A,Max Current B,Max
Current C. You are free to choose a name for a module that best meets your needs. Choose a
name that is relevant to the type of registers it contains. You can create up to 4095 modules inside
a given manager.

Registers

Registers are contained inside modules. (ION) Registers are linked to the Modbus registers and
hold the measured values. You can map registers to a Modbus address, then use WinPM.Net to
read and write data to this Modbus device. You can create up to 255 registers per module.



Factory registers

You cannot add or remove Factory registers, but you can edit them. All Factory registers are
initially set to a default constant value. You can change these constant values, or map the
registers to a valid Modbus address.

OPC Tags
A complete OPC tag contains the elements shown in the following example:

Manual Data Editor user interface
Data editor user interface (UI)

1

Load New Data.
Click Load New Data to open the Load Data dialog box. In Load Data you select the
sources, measurements, time range, and display options for the data that is loaded into the
data editor. Load Data opens automatically when you start Manual Data Editor. See Load
Data UI for more information.

2

Locate Changes.
Use Locate Changes to find and step through any changes you made to the data loaded
into the data editor, before you apply those changes. After you apply the changes, they
become part of the data set in the database and Manual Data Editor no longer identifies
them as changes.

WinPM.Net 10.0 User Guide Chapter 12: Reference

© 2021 Siemens Industry, Inc. All Rights Reserved. 310



Chapter 12: Reference WinPM.Net 10.0 User Guide

311 © 2021 Siemens Industry, Inc. All Rights Reserved.

3
Locate Issues.
Use Locate Issues to find and step through any issues identified by Manual Data Editor in
the data loaded into the data editor.

4
View Issue Report.
Use View Issue Report to see which data issues were identified by Manual Data Editor in
the data loaded into the data editor.

5

Insert Timestamp.
Insert a new data record in the data loaded into the data editor with a timestamp you can
specify. The timestamp must be in the time range of the data that is loaded into the editor.
The new record has <no data> data values. When adding new data records, keep in mind
that a historical data log timestamp marks the end of the logging interval. For example, a
data log with a 15 minute logging interval and timestamp of 17:00 represents data for the
time interval of 16:45 - 17:00.

6

Smart Gap Fill.
Use Smart Gap Fill to fill in missing data in the data set loaded into the data editor. You can
select a range of data that you want to fill the gaps in or you can fill all gaps in the entire
loaded data range. When selecting a data range in the editor, only select the data values,
not the timestamps. See Smart Gap Fill UI for more information.

7

Data grid.
The data grid shows the sources/measurements that you specified in the Load Data dialog
box. Use the grid and the functions in the data editor to edit the data as needed.

TIP: Move the pointer over the header of a data column to see a tooltip with additional
information.

8
Context menu.
Right-click a data cell in the data grid to open the context menu. The Context menu gives
you access to the commands and functions for editing the data loaded into the data editor.

9
Color legend for issues highlight
The data editor uses different color highlights to mark data issues. This legend tells you
which colors are used for which type of issues.

10
View Log
Click View Log to open the Manual Data Editor historical audit log. See Audit Log UI for
more information.

11

Undo All Changes
You can undo changes that have not been applied yet. After changes have been applied to
the database, they are permanent and can only be modified be manually editing the data
again in the Manual Data Editor.

12

Apply Changes
After you have completed your data edits, click Apply Changes to write the changes to the
database. After changes have been applied to the database, they are permanent and can
only be modified be manually editing the data again in the Manual Data Editor.



Load Data UI

1
Available Sources.
Select the source for which want to load the data.

2

Available Measurements.
Select the measurement for which you want to load data. You have the option to only see
those measurements that have logged data for the selected source in the drop-down
control, or see all measurements that are defined in the software.

3

Add Data to Selection
Click Add Data to Selection to add the source/measurement you selected, to the list of
data to be loaded into the data editor. You can add multiple measurements from the same
source, and measurements from different sources to the list.

4
Selected Pairs
This shows the list of selected source/measurement pairs that are to be loaded into the
data editor.

5
Edit commands for the Selected Pairs list
Use Clear All to remove all selected list items. Use Remove Selected to remove items
that you selected from the list.
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6

Create new Measurement
Use this to create a new measurement in the software. This function is needed if you want
to add data that was manually collected for a measurement that does not exist in the
software. For example, if you wanted to add a daily count of cars parked in a parking lot,
you could define a measurement called Number of Cars, which doesn't exist in the
software by default. Then you can select this measurement and a source in Manual Data
Editor and add data records with the daily counts.

NOTE: Check the list of available measurements to see if one exists for your application
before creating a new measurement.

7

Preset
Save and load settings for the Load Data dialog box. This is a way to simplify the data
selection for data sets that you frequently access. Set all the settings in Load Data for the
data sets you want and then save the settings to an external file using Save Preset. Load
a pre-defined set of settings into Load Data using Load Preset.

8
Time Range
Select the time range for which you want to load the data from the sources/measurements.

9

Timezone
Set the timezone for the display of the configurable timestamp in the data editor. The data
editor shows two timestamps for each data record, one timestamp in UTC and one in a
configurable timezone.

10
Timestamp Format
Set the format for the timestamp display in the data editor.

11

Number Format
Set the number of decimals that are displayed for the logged data in the data editor.

NOTE: This setting only affects the display of the data in the data editor and the accuracy
to which you can enter new data values. It does not affect data that is loaded into the
editor and then applied to the database without editing the values.

12

Is Interval Data
Set the expected logging interval for the data. This setting ensures that there is a data row
in the editor for every expected log entry. If there is no data record for an expected entry in
the database, then the Manual Data Editor inserts a timestamped row with a <no data>
data values in the editor. This makes it easier to identify missing records and correct them.

NOTE: The data editor shows all logged records in the selected time range, regardless of
the Interval Data settings. No records are hidden or filtered out.

13
Load Data
Click Load Data to open the selected sources/measurements data in the data editor.



Audit Log UI

1
Data.
Select the source/measurement for which want to see the audit data. The available options
include all sources/measurements that have been loaded into the data editor.

2

Audit log.
View the change history for edited data records including timestamp, username, action,
original value, new value. You can use the information in the audit log to reset data values to
their original value if they were changed accidentally or incorrectly.

Smart Gap Fill UI

1

Time Range.
Select the range of data that you want to fill the gaps in or you can fill all gaps in the entire
loaded data range. When selecting a data range in the editor, only select the data values,
not the timestamps.
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2
Data.
This is a list of all the sources/measurements that are loaded into the editor. Select the
source/measurement pairs for which you want to fill gaps.

3

Interpolation Mode
Choose which algorithm is used to fill the gaps. You have the following choices:

Linear
interpolation
between
known values.

Gaps are filled with the average of the last recorded value before the
gaps and the first recorded value after the gaps. All consecutive gaps
between the known values are filled with the same value.

Last known
Value

Gaps are filled with the last recorded value before the gaps. All
consecutive gaps after the known value are filled with the same value.

Constant Value Gaps are filled with the value that you specify in the value box.

4

Optional Invalid Value
You can define a data value that is treated by the gap fill algorithm as if it was a gap. For
example, if you define 0 (zero) as the Invalid Value, then any data record in the Smart Gap
Fill range that has a value of 0 is treated as if it was a gap.

5

Change Log
The Change Log shows how many gaps were filled, for each of the selected
source/measurement pairs, after you click Fill Gaps.

NOTE: This is different from the Manual Data Editor audit log. The audit log records
changes that are applied to the data in the database. The Change Log shows which gaps
where filled in the data editor.
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