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1 Introduction 

Select the Open option from the File menu to obtain the Open dialog box. Select (for example) the file ex31a.lis. 

Click Open when done. The contents of the file ex31a.lis are displayed.  

 

 
 

To run LISREL, click the Run LISREL icon button. Make sure that the Run LISREL icon button is selected when 

running LISREL or SIMPLIS syntax and that the Run PRELIS icon button is selected when running PRELIS syntax. 
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To produce the path diagram shown below, the keyword PD (Path Diagram) was entered between the lines 

containing the words Esayabil and OU in ex31a.lis.  

 

 
 

The file ex31a.out is also produced. This file may be viewed by either closing the path diagram window or by 

clicking on the output window, which is partially hidden behind the path diagram window.  

 

2 Creating Syntax by Drawing Path Diagrams 

 

LISREL allows the user to create LISREL or SIMPLIS syntax by drawing the appropriate path diagram on the screen 

and then building the corresponding syntax directly from the path diagram. This procedure will be demonstrated 

by fitting a CFA (Confirmatory Factor Analysis) model to the data. To obtain correct standard errors of the 

estimators of the parameters, the CFA model should be fitted to the observed covariance matrix. However, in order 

to illustrate the various features of the program, the model will be fitted to the observed correlation matrix. 

 

In confirmatory factor analysis, one builds a model assumed to describe or account for the empirical data in terms 

of relatively few parameters. The model is based on a priori information about the data structure in the form of a 

specified theory or hypothesis or knowledge from previous studies based on extensive data. 

 

Holzinger & Swineford (1939) collected data on twenty-six psychological tests administered to 145 seventh- and 

eighth-grade children in the Grant-White school in Chicago. Six of these tests were selected and for this example 

it was hypothesized that these measure two common factors: visual perception and verbal ability such that the 

first three variables measure visual perception and the last three measure verbal ability. The six selected variables 

and their intercorrelations are given below: 
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VIS PERC 1.000                
CUBES 0.318 1.000              
LOZENGES 0.436 0.419  1.000          
PAR COMP 0.335 0.234  0.323 1.000       
SEN COMP 0.304 0.157  0.283 0.722 1.000     
WORDMEAN 0.326 0.195  0.350 0.714 0.685  1.000 

 

The path diagram for this model is given below: 

 

 
 

The corresponding SIMPLIS syntax file is: 

 
Six Psychological Variables-A Confirmatory Factor Analysis  
Observed variables  
‘VIS PERC’ CUBES LOZENGES ‘PAR COMP’ ‘SEN COMP’ WORDMEAN  
Correlation Matrix From File EX5.COR  
Sample Size: 145  
Latent Variables: Visual Verbal  
Relationships:  
‘VIS PERC’ - LOZENGES = Visual  
‘PAR COMP’ - WORDMEAN = Verbal  
Number of decimals = 4  
Print Residuals  
End of Problem 

 

Some important aspects contained in the SIMPLIS syntax file given above are  

o The correlation matrix is read from an external file 

o There are two latent variables in the model: Visual and Verbal 

o The statement Number of decimals = 4 specifies that we wish to have the results in the output file given 

to an accuracy of four decimals. LISREL uses two decimals by default. 
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3 Title, Labels and Data  

 

Select the File, New option and click on Path Diagram. In the Save As dialog box, select a filename and a folder 

in which the path diagram should be saved. For the present example the file name selected is cfa6.pth. When 

done, click Save. 

 

 
 

From the Output menu select SIMPLIS Outputs. The dialog box below will appear.  

 

 
 

 

Customize this dialog box according to your preferences. For example, change the Number of Decimals in the 

Output option to 4. Make sure that the Invoke Path Diagram check box (the default) is checked. When done, click 

OK.  

 

Before drawing the path diagram, select Toolbars from the View menu and ensure that the items shown below are 

selected. These are: Toolbar, Status Bar, Typebar, Variables, Drawing Bar. Also check the Grid Lines option. 
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Select the Title and Comments option from the Setup menu to obtain the Title and Comments dialog box. 

 

 
 

 

The first item on the Title and Comments dialog box is the Title for the analysis. Provision is also made for any 

additional Comments that the user may wish to enter. After typing in the title and (optionally) the comments, click 

on Next to go to the Group Names dialog box. 

 

 

 
 

Since the present example is based on the analysis of one correlation matrix, nothing is entered in the space 

allowed for Group Labels and Next is clicked to go to the Labels dialog box. The default number of variables 

shown on the Labels dialog box is 3, these being CONST, VAR 1 and VAR 2. Click in the CONST textbox and 

change the name to VIS PERC. Enter the label CUBES in the VAR 1 textbox and LOZENGES in the VAR 2 text box. 

Move the mouse cursor into the LOZENGES textbox and use the down arrow to create a fourth text box. Type in 

PAR COMP and repeat the procedure for SEN COMP and WORMEAN.   
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In a similar manner, use the down arrow key to create text boxes in the Latent Variables column and enter the 

names Visual and Verbal.  

  

 
 

When done with the assignment of names, click the Next button to go to the Data dialog box. 
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Select Correlations from the Statistics from: drop-down list box and also Correlations from the Matrix to be 

analyzed drop-down list box. In the Number of Observations string field type 145. For File type, select External 

ASCII Data and use the Browse button to locate exs.cor in the SIMPLIS examples folder. Click OK when done.  

 

4 Drawing the Path Diagram  

 

We now proceed with the actual drawing of the path diagram. Start by clicking on the VIS PERC label under the 

Observed variables portion of the Labels window. Hold the mouse button down and "drag" the label to the draw 

area indicated by the grid lines. A rectangular-shaped object will appear on this part of the screen when the mouse 

button is released as shown below. Note also that 

 

• The observed variables are assumed to be X (or independent) variables unless appropriate squares under 

the Y-column are clicked. 

 

• The latent variables are assumed to be KSI (or independent) variables unless appropriate squares under the 

Eta-column are clicked. 
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Repeat the same procedure for each of the remaining 5 variables by clicking on a label (left mouse button) and 

dragging the object to the draw area on the screen. The result of these operations should look similar to the image 

given below: 

 

 
 

The rectangles representing the six observed variables can be properly aligned by going through the following 

steps: 

 

o Choose Select all from the Edit menu or draw a rectangle with the mouse pointer around all the objects 

to be included. 

 

o Move the mouse pointer to the vicinity of the selected objects and click the right mouse button. The 

menu shown below will appear on the draw part of the screen.  
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o Select the Align>Left option. Once this is done, select the Even Space > Vertically option. One can, 

alternatively, use the Align option on the Image menu to achieve this. 

 

 
 

 

 
 

The rectangular objects will now be aligned and one can proceed by dragging the latent variables, Visual and 

Verbal to the path diagram window. Note that latent variables are represented by elliptically shaped objects. 
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Finally, arrows can be drawn pointing from the latent variables to the observed variables. To accomplish this, 

click on the single-headed arrow of the Draw toolbar (seen on the right of the picture given below) and move the 

mouse pointer to within one of the elliptically shaped objects. With the left mouse button held down, drag the 

arrow to within a rectangular-shaped object. Release the mouse button when the colors of both objects change. 

Note that the Draw menu on the main menu bar can also be used when drawing path diagrams. Related draw tool 

options are contained in this menu. 

 

 
 

 

Proceed in a similar fashion to graphically display the relationships between the observed and latent variables as 

shown on the next image. 
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Select the Build SIMPLIS Syntax option from the Setup menu. SIMPLIS syntax (not shown below) will be built 

from the path diagram and is stored in a system file named cfa6.spj. Click the Run LISREL icon button to fit the 

CFA model to the data. Parameter estimates are shown on the path diagram given below. 
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By modifying the path diagram, model specifications may be changed. The covariance between Visual and Verbal 

may, for example, be fixed at a value of 0.5 by clicking (right mouse button) on the two-headed arrow representing 

this covariance. This will enable the pop-up menu shown below. Select the Fix option using the left mouse button. 

Once done, select the Set Value… option. 

 

 
 

 
 

 

Click the Run LISREL icon button to fit the revised CFA model to the data. The path diagram, 
2 -fit statistic and 

RMSEA are shown below. 
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5 Multi-Sample Analyses Using Path Diagrams 

 

In the previous sections we showed how LISREL models may be specified and estimated by drawing the 

appropriate path diagram from which the SIMPLIS or LISREL syntax is created. The examples used were based on 

data from a single sample. The path diagram can, however, also be used to create syntax for models based on data 

from several samples simultaneously, according to a multiple-group LISREL model with some or all parameters 

constrained to be equal over groups.  

 

Consider a set of G mutually exclusive groups of individuals. It is assumed that a number of variables have been 

measured on a number of individuals from each of these populations. This approach is particularly useful in 

comparing a number of treatment and control groups regardless of whether individuals have been assigned to the 

groups randomly or not.  

 

Any LISREL model may be specified and fitted for each group of data. However, LISREL assumes by default that 

the models are identical over groups, i.e., all relationships and all parameters are the same in each group. Thus, 

only differences between groups need to be specified.  

 

6 Testing Equality of Factor Structures  

 

Table 1 below gives sample covariance matrices for two samples ( 1N = 865, 2N  = 900, respectively) of candidates 

who took the Scholastic Aptitude Test in January 1971. The four measures are, in order, VERBAL40, a 40-item 

verbal aptitude section, VERBAL50, a separately timed 50-item verbal aptitude section, MATH35, a 35-item math 

aptitude section, and MATH25, a separately timed 25-item math aptitude section.  

 
Table 1: Covariance Matrices for SAT Verbal and Math Sections 
 
Covariance Matrix for Group 1 
               
Tests VERBAL40 VERBAL50 MATH35 MATH25 
VERBAL40 63.382          
VERBAL50 70.984 110.237       
MATH35 41.710 52.747 60.584    
MATH25 30.218 37.489 36.392 32.295 

 
Covariance Matrix for Group 2 
 
 
Tests 

VERBAL40 VERBAL50 MATH35 MATH25 

VERBAL40 67.898          
VERBAL50 72.301 107.330       
MATH35 40.549 55.347 63.203    
MATH25 28.976 38.896 39.261 35.403 

  

The data are used here to illustrate how one can test equality of factor loadings and factor correlations in a 

confirmatory factor analysis model, while allowing the error variances to be different. 

 

We regard VERBAL40 and VERBAL50 as indicators of a latent variable Verbal and MATH35 and MATH25 as 

indicators of a latent variable Math. The model we consider is shown in the figure below.  
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  There are three sets of parameters in the model:  

 

o the four factor loadings corresponding to the paths from Verbal and Math to the observed variables,  

o the correlation between Verbal and Math, and  

o the four error variances of the observed variables.  

 

We begin by constructing a data file pdex10.cov containing the two covariance matrices. In free format, each 

covariance matrix can be written on one line.  

 

 

 
 

We assume that all parameters are the same in both groups. The syntax file pdex10a.spl is:  

 
Group 1: Testing Equality Of Factor Structures Model A: Factor Loadings, Factor Correlation, Error Variances Invariant 
Observed Variables: VERBAL40 VERBAL50 MATH35 MATH25  
Covariance Matrix from File PDEX10.COV  
Sample Size = 865  
Latent Variables: Verbal Math  
Relationships: VERBAL40 VERBAL50 = Verbal  
MATH35 MATH25 = Math  
Group 2: Testing Equality Of Factor Structures  
Covariance Matrix from File PDEX10.COV  
Sample Size = 900  
Set the error variances of VERBAL40-MATH25 free 
End of Problem  
 

In the syntax above, the data in the covariance matrices and the sample sizes are different. The names of the 

variables, observed as well as latent, are the same, and the model is the same.  

 

Select the New option from the File menu and select Path Diagram in the New dialog box. Click OK when done. 

Enter the name pdex10.pth. When done, click Save.  

 

It is possible to control specific SIMPLIS default features such as Maximum Number of Iterations or Method of 

Estimation. From the Output menu, select SIMPLIS Outputs.  
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The SIMPLIS Outputs dialog box will appear. Customize this dialog box according to your preferences, for 

example, by changing the Number of Decimals in the Output option to 4 and by making sure that the Invoke path 

diagram option is selected. Click OK when done. 

 

 

 
 

Before drawing the path diagram, select Toolbars from the View menu and ensure that the items shown below are 

selected. These are: Toolbar, Status Bar, Typebar, Variables, Drawing Bar. Optionally, check the Grid Lines option. 

 

 

 
 

 

Select the Title and Comments option from the Setup menu to obtain the Titles and Comments dialog box. 
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The first item on the Setup dialog box is the Title for the problem. Provision is also made for any additional 

Comments that the user may wish to enter. After typing in the title and (optionally) the comments, click Next to 

go to the Group Names dialog box. 

 

 
 

Next, we enter a description for each group. Group labels can be inserted by clicking on the first string field, 

entering the label for the first group and then using the down arrow on the computer keyboard to create the next 

group’s string field. When done, click Next to go to the Labels dialog box. 

 

 

 
 

The default number of variables shown on the Labels dialog box is 3, these being CONST, VAR 1 and VAR 2. Move 

the mouse pointer to the Observed Variables box and click in the string field of CONST. Rename this variable to 

VERBAL40. Press the "down arrow" on the keyboard to move to the second observed variable string field and enter 

the label VERBAL50. Proceed in a similar way to enter the labels MATH35, MATH 25 and the labels Verbal and Math 

for the latent variables. Click Next when done to go to the Data dialog box. 
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From the Data dialog box, select Covariances from the Statistics from: drop-down list box and also Covariances 

from the Matrix to be analyzed drop-down list box. Enter 865 in the Number of Observations string field. For File 

type select External ASCII Data.  

 

 
 

Click the Browse button to select the path and name of the file that contains the values of the covariance matrices 

of the 2 groups. For the present example, the file is pdex10.cov, which was created earlier in this section. Click 

Open when done.  
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From the Data dialog box, select the second group from the Groups: drop-down list box. Proceed as outlined 

above to enter the number of observations (900), file type and matrix to be analyzed.  

 

7 Drawing the Path Diagram  

 

We now proceed with the actual drawing of the path diagram. Start by clicking on the VERBAL40 label under the 

Observed variables portion of the Variables window. Hold the mouse button down and drag the label to the draw 

area. A rectangular-shaped object will appear on this part of the screen when the mouse button is released as 

shown below. Repeat this procedure until all observed variables are dragged to the drawing area as shown in the 

next image.  

 

Note also that: 

 

• The observed variables are assumed to be X (or independent) variables unless appropriate check boxes 

under the Y-column are checked. 

• The latent variables are assumed to be Ksi (or independent) variables unless appropriate check boxes under 

the Eta-column are checked.  

 

 
 

Proceed by dragging the latent variables, Verbal and Math, to the draw area of the path window. Note that the latent 

variables are represented by elliptically shaped objects. 

Finally, arrows can be drawn pointing from the latent variables to the observed variables. To accomplish this, 

click on the single-headed arrow of the Draw toolbar (seen on the right of the picture given below). As an 

alternative, use the Draw menu on the main menu bar. The related drawing tool options may be selected from this 

menu. 

 

Once the single-headed arrow (or One-way Path option) has been selected, move the mouse pointer to within one 

of the elliptically shaped objects. With the left mouse button held down, "drag" the arrow to within a rectangular-

shaped object. When the colors of both objects change (see diagram below) release the mouse button.  
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Proceed in a similar way to graphically display the relationships between the observed and latent variables: 

 

 
 

Select Build SIMPLIS Syntax from the Setup menu. SIMPLIS syntax will be built from the path diagram and is 

stored in a system file named pdex10.spj shown below.  
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Click the Run LISREL icon button to fit the multi-sample model to the data. The parameter estimates and 
2  

goodness-of-fit index are shown on the path diagram displayed below:  

 

 
 

The values shown on the path diagram are the parameter estimates. This is the default selection. It is, however, 

also possible to view the t-values, modification indices or expected changes by selecting the View menu on the 

main menu bar. Alternatively, use the drop-down list by clicking in the Estimates: pane as shown below. To view 

t-values, select the T-values option. The figure below shows how this is done and also indicates the t-values on 

the path diagram.  
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To view the corresponding t-values for the second group, select group 2 on the menu bar. The resultant changes 

in the path diagram are shown in the next image. 

 

 
 

In the example above, the error variances, factor loadings and factor covariance are constrained to be equal 

(invariant) across the two groups. To test for invariance of factor loadings and covariance only, the error variances 

can be freed as follows. Make sure that the path diagram is displayed, and then select Group 2 from the Groups: 

text box. Right-click in the error variance of VERBAL40 and click the Free option.  Repeat this procedure for the 

remaining three error variances, and then select the Setup, Build SIMPLIS Syntax option. 
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The actions described above result in a new SIMPLIS project file that contains the syntax required to free the error 

variances across groups. 

  

When done, click the Run LISREL icon. The output file reveals two solutions, one for each group. The value of  
2  is reported only after the second group. 

 

In a multi-sample analysis, the 
2  is a measure of fit of all models in all groups, and, in general, this 

2  cannot 

be decomposed into a 
2  for each group separately. For our example, 

2  is 10.87 with 7 degrees of freedom (p 

= 0.14), so that the model does fit the data.  

 


