
Altair S-FRAME 2021.1

3D Structural Analysis 
an Introduction



Altair S-FRAME 2021.1 
3D Analysis

Proprietary Information of Altair Engineering 

Disclaimer 

Considerable time, effort and expense have gone into the development and documentation of S-FRAME. It 
has been thoroughly tested. However, in using the product (including manuals), the user understands and 
accepts that no warranty on the accuracy or reliability of the product is expressed or implied by the 
developers or distributors. Users must understand the assumptions used in the product, know its limitations, 
and verify their own results. 
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Manual Setup and Conventions 

Within the Manual there are screenshots and diagrams, emphasizing a certain step or results. In some cases, they 
indicate the correct data entry for a specific dialog: 

In other cases, they may show the expected output of a process: 

Notes: This symbol is used to highlight ‘’Notes’’ on specific topics throughout this manual. 

Good to Know: This symbol is used to highlight “Good to Know” facts throughout this manual. 

Need to Know: This symbol is used to highlight “Need to Know” facts throughout this manual 

Further Information: This symbol is used to highlight additional resources for specific topics. 
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Tutorial 3D 

The best way to learn any software application is to use it. This is why we suggested that you create your own 
simple model as you read through the Overview of Modeling procedure chapter, and why we provided a simple 
2D example to get you up and running in the Tutorial (2D) chapter.  

In this chapter, we shall use S-FRAME to create a simple 3D structure. Much of what we do in this chapter will 
extend what you read and did earlier. If you have not run through the two chapters mentioned above, then we 
would recommend that you do so now, before starting this 3D example. If you find that you do not know how to 
perform an action in this 3D example, then we suggest that you use the 2D example again to re-familiarize yourself 
with the basics. 

Again the model shown in this tutorial is not intended to be realistic, nor is the method shown 
the best way to create it. Both model and method are intended to show you how to use the 
various features of S-FRAME when creating a model. 

We shall create the model using Metric units and American sections to demonstrate the flexibility of S-
FRAME. 

Figure 1. Isometric View Figure 2. Top View 

Figure 3. Left View (YZ View) Figure 4. Front View (XZ View) 

p. 1
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The view names shown above are those of the standard views which are relative to the current 
user coordinate system; they are not named using standard building terms where the Side View 
noted above would normally be referred to either as End elevation or Gable. 

General 3D 
modeling advice 

We would advise you to take much more care when you are modeling in 3D to 
ensure that the model you create is what you intend. In order to be careful, you 
have to be in complete control of the software. Generally for 3D modeling (but 
more specifically for large models) this means that you must be able to use 
some, if not all, of the more advanced tools described in the S-FRAME 
Introduction manual - Detailed modeling hints and tips. In particular, we 
would highlight the sections on:  

• Rendering,
• Grouping / Folders,
• The User Coordinate System, and
• Views.

Starting the model 1. Start S-FRAME, create a new model, set the model type to 3D, and set the
units to metric.

2. If the Geometry window does not have a Groups pane, then click View/
Groups to reinstate it.

3. Make sure that you can see the Aerial window (click Window > Aerial
Window or click the Show/Hide Aerial window icon from the Status Bar)
and in that window click the Zoom to grid extents icon.

Setting Preferences Set your Preference settings to the initial set we suggested earlier. 

For details see “General Modeling Environment Settings” in the 
Introduction Manual – 2D Tutorial 

Setting display 
options – Geometry 
window 

1. Ensure that the Edit toolbar, Views and Grids toolbar and the Geometry Tools
toolbox are shown for the Geometry window.

2. Ensure that the Grid, Title Bar, Legend, Zoom Extents, Local ‘x’ Axis, Joints, 
Redraw, Status Bar, Floating point format and Coordinate System interface
options are set.

Resizing and 
Repositioning a 
Structure 

As you work through this example, and when you work on your own structures you 
will need to resize and/or reposition the view of the structure in the window in order 
to see the part on which you want to work. 

For details see “Resizing and Repositioning a Structure” in the 
Introduction Manual – 2D Tutorial 

p. 2
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Selecting Objects You also need to be familiar with the different options available for selecting 
objects. In this example you will simply be told to select or deselect the required 
objects, it is up to you to use whichever means you prefer. 

For details see “Acquainting yourself with selection” in the 
Introduction Manual – 2D Tutorial. 

Defining Geometry 
- Overview

The following outline explains how we are going to create the basic frame 
geometry: 

1. Build half the roof.
2. Move the roof into its final position.
3. Copy a part of the roof to create the foundation joints.
4. Add a column to the global origin.
5. Add one of the cantilever members to that column.
6. Copy and generate new columns and cantilevers along the XZ-face.
7. Use Member Links to generate beams parallel to the X-axis.
8. Add braces to the ZX-face.
9. Heighten the first story.
10. Reflect and copy the half-built structure.

We will also edit other geometrical attributes, supports, releases, properties and 
such like as we go along. 

Defining the roof 
geometry 

1. Use the Grids Definitions dialog to create a Basic Grid with grid lines along the
X-axis at 0, 6, 12 and 18 m and along the Y-axis at 0 and 12 m. Having done this
zoom to the extents of the grid.

Figure 5.  

p. 3
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 2. Now we can proceed to define the members using this grid. We could do this 
one member at a time. However S-FRAME allows us to define ranges of 
members in a single operation. We shall use one of these now.  

3. Since our sections are American, we should also use American steel for the 
material, therefore choose Def Steel (US) from the list in the Views and Grids 
toolbar.  

4. Click the Member Definition Tool from the Geometry Toolbox.  
5. Now click on the Top View and Zoom to grid extents icons from the Aerial 

window. 

 
 

The Data Bar changes to include an extra list of options. 

 6. In the Data Bar choose the Rectangular option from this list.  
7. Now drag a rubber rectangle round the entire grid. This will automatically 

create separate members between all the grid intersection points in both the 
X- and Y-direction and will also create the joints at their ends.  

 

Figure 6. 
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Setting section 
properties 

Now we shall define the properties that we want to use for all members of our frame, 
both for those we have defined already and for those we are yet to define. 

1. Click the Section Properties Tool from the Geometry Toolbox.  
2. Use this to include the following AISC sections in the local database for this 

model:  
• W21X147 – roof beams (I section), 
• HSS3.5X.216 – roof braces and side braces (hollow section),  
• W10X49 – columns (I section),  
• S6X17.25 – cantilevers (I section).  

 
 

By thinking ahead in this way and listing all the sections, we need in the 
structure; we can save time by defining all the properties at once. 
Otherwise, we would have to access the Section Properties Tool dialog 
repeatedly to add new sections as we came to them. 

Defining roof 
bracing 

Now we want to add K bracing to the left-hand bay of our roof. In order to do this, 
we shall see another feature of S-FRAME, that to split an existing member in two 
when you create a member that intersects with it.  

1. In order to use this feature, you need to switch the grid off (or lock it). For this 
example switch the grid off now.  

2. Click the Member Definition Tool from the Geometry Toolbox.  
3. Choose the HSS3.5X.216 section size from the list in the Views and Grids 

toolbar.  

 
 

Setting the section here means that this section will be used for new 
members we create. Again this saves time since we would otherwise have 
to change the section to the correct one after creating the members. 
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 4. Click on joint 3 to start creating the bracing from that point, then click on the 
member which runs between joints 1 and 2. You will see the Subdivide 
Connecting Member dialog.  

 

Figure 7. 

This allows you to specify exactly where S-FRAME has to break the existing 
member. 

5. Ensure that the At mid-point option is selected and then click OK.  

 
 

The buttons down the left-hand side of the dialog relate to the member 
you are creating, and not to that which you are splitting. Each portion of 
the split member retains the details of the un-split member. S-FRAME will 
also adjust any loads to take account of the split if you have checked the 
Always preserve loads during element subdivision option in the 
Preferences sheet). 
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 6. Create another bracing member running from joint 9 to joint 4. When you have 
done, you should have achieved the layout below. 

 

Figure 8. 

Saving the Model Now save the model as Tutorial 2.tel. 

Moving the roof to 
its final position 

We have now defined of one-half of our roof but at an elevation of zero meters. We 
now need to move the members and joints that we have defined up to their final 
level. First change back to the southwest isometric view of the structure. 

 
 

In an actual model, you would create the roof at its finished level. 

 If you have followed the previous instructions exactly, everything in your structure 
should already be selected. If they are not, then click the Select All icon from the 
Edit toolbar.  

1. Click the Move icon ( ) from the Edit toolbar.  
2. Now translate the roof by 7 m along the Z-axis.  

p. 7



Altair S-FRAME 2021.1 
3D Analysis

Proprietary Information of Altair Engineering 

 

Figure 9. 

Creating the 
columns 

We have now defined the roof steelwork and can proceed to define the columns. 
To do this, we need to be able to see the existing roof joints and the grid. 

1. Switch the grid on again and adjust the display to show the grid extents 
(this should allow you to see the grid and all the joints along the edge of 
the roof). 

2. Make sure that the Member Definition Tool is selected. 
3. Choose the W10X49 section size from the list in the Views and Grids toolbar.  
4. Now click on the grid intersection point immediately below joint 1 and create 

your column from this point to joint 1.  

 

Figure 10. 
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Creating the 
columns 

5. Repeat this process to create columns from the relevant grid intersection point 
up to joints 3, 5 and 7. When you have done this, change back to the W21X147 
section which we shall use for the side beams. 

6. Click on the column which runs from joint 10 to joint 1. Again you will see the 
Subdivide Connecting Member dialog.  

 

Figure 11. 
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 7. This time choose the At a distance from ‘I’ node option and then enter 5.5 
into the new box that appears. Click OK to split the column at 5.5 m from its 
base.  

8. Repeat steps 5 and 6 for the column which runs between joints 13 and 7. This 
creates a single member which runs between the first and last columns of the 
model. 

 

Figure 12. 

9. However, we want a series of separate members which connect to each of the 
internal columns as well. Fortunately, S-FRAME can do this automatically. 

Simply click on the Connect Intersecting Members icon ( ) on the Edit toolbar 
and S-FRAME works out which of the selected members intersect and splits 
them appropriately. 

 

 

Figure 13. 
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Adding the 
cantilever 

Now we shall add the cantilever to the joint part way up the column. 

1. Click the Joints Tool from the Geometry Toolbox and then click on joint 14 – 
the Data Bar will show its coordinates. 

 
 

If you were to click on a joint which had no members connected to it, then 
this would delete the node. 

 2. Now type 1.5 into the Y box in the Data Bar and click Accept Data. This creates 
a new joint 1.5 m in the Y-direction from joint 14.  

3. Choose the S6X17.25 section from the list in the Views and Grids toolbar.  
4. Click the Member Definition Tool from the Geometry Toolbox and create a 

new member between joint 14 and the new joint (joint 18).  

Copying cantilever 
along the XZ face 

We now need to copy the cantilever to the other columns along the XZ-face. There 
are several ways of doing this. However, we shall use the Clone Tool. 

1. Unselect everything apart from the cantilever element (including for the 
purposes of this example the joints at the cantilever’s ends). 

2. Now click the Copy to clipboard icon from the Edit toolbar to copy the details 
of the selected members to the clipboard. 

3. Now click the Clone Tool from the Geometry Toolbox and then right click the 
tool to view its dialog. 

 

Figure 14. 

 
 

We could just use the Generate Tool and click on the joints at the base 
of the columns we want to generate. We used this feature in the Tutorial 
(2D). However, the tool dialog gives a more elegant solution. 

 4. Type 6 as the Repeat at X value – this will generate our first copy at 6 m along 
the X-axis from the current user coordinate system origin.  
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5. Type 2 as the Repeat again at Number value – this will generate two further 
copies at the Repeat again at X-, Y- and Z- values. For our purposes, we only 
need to type 6 as the Repeat again at 1 Delta X value.  

6. Click OK to generate the copies. 

 

Figure 15. 

 
 

This is still a trivial use of the power of this tool’s dialog which can be used 
to great effect on towers, sloping foundations and soon. 

Although we only copied the members, S-FRAME has automatically 
created the joints that these require. We can tell which joints have been 
created since they are selected. 
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Defining the wall 
bracing 

Now we shall define the wall bracing. 

1. Choose the HSS3.5X.216 section from the list in the Views and Grids toolbar. 
2. Click the Member Definition Tool and add the braces as shown below to the 

left-most bay of the XZ-face.  

 

Figure 16. 

Saving the structure Save the structure at this point.  
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Defining the 
supports 

Now we shall proceed to define the supports for the structure. Since all these lie on 
the XZ-plane and at a single level an alternate view of the structure would be 
appropriate. 

1. Click the Front View icon in the Aerial window to view the structure from that 
direction 

 
 

With the Options we have specified the Geometry window 
automatically resizes the structure to fit the window. 

 2. Select all the nodes at the base level.  
3. Click the Supports Tool from the Geometry Toolbox.  
4. Now drag to select all four foundation nodes. This will create fully fixed 

supports at these locations.  
5. We want the inner supports to be completely free to rotate and to have restraint 

against translation only in the X-axis and Y-axis directions (we shall add springs 
in the Z-axis in a minute). Make these settings for the Support Tool. 

 

Figure 17. 

6. Now identify the inner two supports again to replace the existing fully fixed 
supports with those with these settings. When you have done this select the 
entire structure and change back to the southwest isometric view to see the 
restraint that we have provided at each joint. 

 

Figure 18. 
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Single-headed arrows indicate restraint against movement in that 
direction. S-FRAME uses double headed arrows to indicate restraint 
against torsion. 

Defining springs Now we can add the springs to provide support to the inner pair of columns.  

1. Click the Ground Spring Tool from the Geometry Toolbox. 
2. In the Data Bar ensure that the Z – Translation option is set and enter a stiffness 

of 42000.  
3. Now click the nodes at the bottom of the two inner columns to create springs 

with these properties at these points. 

 

Figure 19. 
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Adding releases At the moment all the members are fully restrained at each end. We want the wall 
and roof braces to be pinned at each end. 

1. We first need to select these and deselect the other objects. The special 
selection offers one way of doing this. Click Select > Special...  

2. We want to select all the braces. The easiest way to do this is to check Section 
Numbers and then type 2 into the Section range box and then click OK.  

 

Figure 20. 

This allows us to choose the members we want to select in many ways. We can select 
only the members that match the criteria we specify (clearing all other selections), 
or add them to the already selected objects. 

 
 

If instead, we had checked the By geometry – Diagonals box, then this 
would have only selected the wall braces since the roof braces are 
horizontal at the moment. 

 3. Click the Member Release Tool from the Geometry Toolbox and then view its 
settings. 

 

Figure 21. 
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You should never set both ends of a member to have the torsion 
component released. If you do, then you are making the member free to 
rotate about its axis and the analysis may fail or give spurious results. 

 4. These are the settings we want to apply so click OK.  
5. Identify the selected members to apply these releases to them. 

 

Figure 22. 

 
 

The display as you see it above is indicative only. It simply tells you that 
releases of some description have been applied to these member ends. 
S-FRAME allows you to choose to see to which local axes releases have 
been applied. 

 6. To do this click Options > Releases. Double arrows indicate a release in that 
local axis direction at the end of the member nearest the arrows. 
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Figure 23. 
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Shearing the roof We have now nearly completed one-half of our structure, apart from adding a 1 in 
10 rise to the roof. The easiest way to do this is to use the Move dialog. 

1. Select just four joints that will eventually lie in the center of the roof and the 
joint at the sharp end of the K-brace. 

 

Figure 24. 

2. Now click the Move icon from the Edit toolbar  
3. Pick the Shear option, In the ZY Plane and enter 0.1 into the Z’=Z + ......... x Y. 

edit box. This will add 0.1 times the distance along the Y-axis to the Z-
coordinate of all the selected nodes. Click OK and S-FRAME will perform the 
shear.  

 4. Now select the entire structure and zoom to see the structure extends. 

 

Figure 25. 
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Creating the rest of 
the structure 

We have now defined all the details for one-half of our frame. We shall now create 
the remainder of the structure by copying the information we have already defined. 

1. Click the User Coordinate System Tool from the Geometry Toolbox. 
2. Click on joint 2 (at the end of the left-hand rafter) to move the user coordinate 

system to that joint. 

 

Figure 26. 

 
 

When you move the user coordinate system to this new position, the grid 
moves with it. 

 3. Now click the Move icon from the Edit toolbar. 
4. Choose the Reflect option, specify that this is About the ZX Plane, check the 

option to Make a Copy and then click OK.  

 

 

Figure 27. 
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5. Now click on the original user coordinate system origin joint (joint 10) to return 
the coordinate system to global.  

 
 

This process has reflected all the joints and members; it has also reflected 
all the attributes that we have applied to the structure (releases, supports 
and so on) as well. You will find it best to use this powerful option as late 
in the day as possible so that it includes as much detail as possible. 

 6. Now zoom to the extents of the structure.  

 

Figure 28. 

7. Now that we have defined our model switch the grid and the display of joint 
numbers off.  
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Rendering the 
structure 

Now that we have completed the definition of our structure, it is a good time to 
review it to ensure that the details we have defined are what we expect. A good way 
to review the structure is to render it, in this way we can see that the members look 
correct, and also that they have the correct orientation. 

1. On the Status Bar below, switch the Render Model option to ON ( ) or 
click View > Render … 

 

Figure 29. 

2. Click the Render model option, change the Length shrink factor to 0.75, set 
the option to Render Selected members only. 

 

Figure 30. 
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 3. Click OK to render the model with these settings. 

 

Figure 31. 

 

 
 

We suggest that you always check Selected members only. Otherwise 
S-FRAME will render all sections irrespective of their selection state. 

 4. Zoom in to one of the front columns. 

 

Figure 32. 

As you can see these have the wrong orientation, they are oriented to take their 
bending to which they are obviously subject about their minor axis. 
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 5. Click the Member Axis Orientation Tool ( ) from the Geometry Toolbox 
and then set the tool’s properties.  

6. Set the Gamma angle to 90o and click OK. 

 

Figure 33. 

7. Set this gamma angle for each column (top and bottom). If you zoom in to the 
same area as before, you will now see that the columns have the correct 
orientation. 

 

Figure 34. 

8. The rendering is fast enough to allow you to work with it switched on at all 
times. However, you may find that this obscures the view of other information. 
Switch rendering off now. 
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Saving the structure We have defined the entire structure, now is a good time to save it. 

 
 

You can view and change the information we have defined graphically 
using the Spreadsheet window. The various pages show the details for 
various parts of the structure. You might want to investigate these at this 
point. 

Structuring the 
model 

Now that we have defined all the members in the model and their appropriate 
details we shall use the Groups pane to add some structure to our model. You can 
group a model in any way that you want, however, for this tutorial, we shall group 
the members of our model into the following categories: 

• Rafters 
• Columns 
• Cantilevers 
• Link beams 
• Roof bracing 
• Side bracing 

 
 

Although you can create groups as-you-go, it is more efficient to define 
the group structure that you want to use, define the group folders and 
then add your members to these folders. 

 1. In the Groups pane, right-click on My Structure and click New Group from the 
context menu. Type in the name of the group – Rafters. 

2. Repeat step 1 and define the following groups: 
• Columns 
• Cantilevers 
• Link beams 
• Bracings 
• Side Bracing 
3. In the Groups pane, right-click on Bracings and click New Group from the 

context menu. Type in the name of the group – Roof bracing. Your Groups pane 
should now look like this: 

 

Figure 35. 
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4. In the Status Bar ensure that the Automatically update open folder icon (

) is switched Off. 
5. Click on the Rafters folder; you will see that the folder opens, and also that all 

the selections are cleared. This is because the Rafters folder does not yet 
contain any elements. 

 6. Select all the rafters and joints as shown below. 

 

Figure 36. 

 
 

For this group select the joints at the ends of the rafters for reasons that 
will become apparent later. You can select the joints automatically by 
checking the Include joints when selecting/unselecting objects in the 
Preferences dialog. 

 7. Now right click the Rafters folder and choose Update Group from the context 
menu. S-FRAME adds the selected members into this group, and its as easy as 
that.  

8. If you now click on My Structure, you will see that everything is selected, and 
if you then click on Rafters you will return to the selection as shown above. 

 

 
 

My Structure automatically contains every element in your model, and 
you cannot change this. 

 9. S-FRAME can automatically set the contents of a folder to match your current 
selection. We shall look at this now. In the Status Bar ensure that the 

Automatically update open folder icon ( ) is switched On. 
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 10. Click the Columns folder, and then select the columns as shown below.  

 

Figure 37. 

 
 

The quickest way to do this is to do a Select > Special and then select by 
Geometry – Verticals. 

 And that’s it. S-FRAME automatically sets the current folder to contain all the 
selected elements. 

11. Use either of the methods above to create the following group contents: 
• Cantilevers 

 

Figure 38. 
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For this group select the joints at the ends of the cantilevers, since we 
later need to add joint loads to these. 

 • Link Beams 

 

Figure 39. 

• Roof Bracing 

 

Figure 40 
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 • Side Bracing 

 

Figure 41. 

12. Now that we have defined all our grouping let’s take another look at the group 
structure. You might remember that it is: 

 

Figure 42. 

Ideally, the Side bracing folder should be in the Bracings folder together with the 
Roof bracing, and it would be nice for the Bracings folder to contain all the bracing 
members, as well as the two sub-groups which allow you to look at a particular 
bracing type. This is easy as S-FRAME provides some sophisticated folder handling 
facilities. 

13. Right-click on the Side bracing folder, and select Move Group. Select move to 
Bracings and click OK. 
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Figure 43 

S-FRAME moves the Side bracing folder into the Bracings one.  
14. If you click on the Bracings folder, you will see that no elements are selected. 

This is because folders do not automatically inherit the elements contained in 
any folders that they contain. However, it is easy to copy the elements from 
such folders up the folder tree. 

15. Right-click on the Side bracing folder and select copy group. Select Copy 
Group, then the Bracings folder and click OK. If you select the Bracings folder, 
you will see that it now shows the side bracings. This time S-FRAME has copied 
the contents of the Side bracing folder into the Bracings one (you can check this 
by clicking on the Side bracing folder to see that it still contains the side 
bracings). 

16. Repeat step 15, this time copying the contents of the Roof bracings folder into 
the Bracings one. The final group layout should be: 

 

Figure 44. 

Saving the structure We have now defined the entire structure and the grouping that we want to apply 
to it. All that remains is to define the loading, so now is a good time to save the 
structure again. 
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Loading the 
structure 

Now that we have defined our structure completely we can proceed to load it. To 
do this, we need to change to the Loads window. 

We can use the groups that we have just defined to speed up the definition of the 
loading. Since we do not want to risk inadvertently changing the grouping that we 
have just done ensure that the Automatically update open folder icon is switched 
to Off. 

Setting display 
options – Loads 
window 

1. Ensure that the Edit toolbar, the Load Tools toolbox and the Views and Grids 
toolbar are shown for the Loads window. 

2. Ensure that the Title Bar, Zoom Extents, Local ‘x’ Axis Joints, Redraw, Status 
Bar, Floating point format and Coordinate System interface options are set. 

Creating the Self-
weight load case 

Define the self-weight load case for this model in exactly the same way as for the 2D 
model. 

 
 

For a 3D model, you need to apply the self-weight loads in the Z-axis 
direction. 

 
 

For further information see “Defining self-weights” in the Introduction 
Manual – 2D Tutorial 

Creating the Roof 
Dead Load case 

1. Create a new load case titled Roof Dead Loads. 
2. Select only the roof members. 

 
 

You can use the groups that we have just defined to do this. 
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 3. Now apply Full Uniform Global loads (not global projected loads!) of value -
0.7 in the Z-global direction to the inner roof beams, and similar loads with a 
value of -0.35 to the outer ones. 

 

Figure 45. 

 
 

The quickest way to do this is to apply the load of -0.35 to all the rafters, 
and then to apply the same load again to the inner ones. S-FRAME 
automatically adds the two loads together. 

You might find it easier to apply the loads if you move to the standard 
Top View first. 

Creating the Snow 
Load case 

1. Create a new load case titled Snow Loads. 
2. Now apply Partial Varying Global Projected loads with the settings a shown 

below to the inner roof beams at one side of the structure. 

 

Figure 46. 
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 Define further loads with the settings below, to the rear outer one. 

To define the load on the front rafter (which is split by the K bracing), we could 
calculate the values of the load at the point where the bracing is split, and then 
apply two separate loads. Fortunately, S-FRAME provides a much more elegant way 
of doing this. With the Data Bar set as shown above click on joint 1, then move the 
pointer and click on joint 2. S-FRAME automatically applies the load over the entire 
length between these two joints (which is the same length as for the other rafters) 
and performs all the calculations for you in order to apply the correct loads to their 
respective members. 

 

Figure 47. 
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Creating the Wind 
Load case 

1. Create a new load case titled Wind Loads.  
2. Click the Local Load Tool from the Loads Toolbox.  
3. Now apply Full Uniform Local loads of value 0.7 in the direction shown below 

(using a local axis direction) to the back columns, and similar loads with a value 
of 1.25 to the front ones, ensure that the loads are applied in the direction 
shown. 

 

Figure 48. 

 
 

In this case, it would be better to define the loads using the global axis 
system, however for this example use the member’s local axis system. 
This shows: 

• the difficulty of working with the local axis system, 
• that the global and local axis system do not align. 

 
 

You can switch back to the Geometry window and set the Local Axis 
Orientation Tool to show the local axes of the members to determine 
the appropriate direction and sign. 
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Creating the Crane 
Load case 

1. Create a new load case titled Crane Load.  
2. In the Aerial window click the Left View icon.  
3. Now pick the group which has the nodes at the end of the cantilevers  

selected.  
4. Click the Joint Load Tool choose a Z-Force of value -11.  
5. Now draw a window around the nodes at the ends of the cantilevers.  

 

Figure 49. 

 

6. In the Data Bar now choose an X-Force of value 3. Again window the same 
area.  

 
 

The display no longer shows the details of the force that we have just 
applied in the Z-direction. Don’t worry, remember that the load is still 
there. S-FRAME normally only shows forces of the type you are applying, 
and in the direction you are applying them. This keeps screen clutter to a 
minimum. You can override this behavior and force the display to show 
the load types and directions that you require. 

 To view all the loads on your structure click the Display Joint Loads icon and the 
Display Member Loads icon from the Status Bar. Click these two buttons (switch 
them to On) now. 

As you set Display Joint Loads to On, you will see that your Z-Force reappears. 

 
 

The other loads that you have defined previously do not appear as they 
are in different load cases. 
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Figure 50. 

Defining 
Combinations 

Now that we have defined the load on our model, we shall create a series of 
combinations – these are the actual loads to which our model may be subjected. 

Click Edit > Load Combinations... and then define the combinations shown below. 

 

Figure 51. 

Saving the structure We have loaded the structure and defined our combinations, now is a good time to 
save it. If you want to take a break from this tutorial, then now would be a good time 
to do so. 
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Analyze the 
structure 

Now that we have defined our model, defined a structure for it and the views that 
we want to use, let’s analyze it. Run a linear static analysis. 

Setting Graphical 
Results window 
options 

Before we continue to review the results we need to make sure that the 
configuration of the Graphical Results window is correct. If you have carried 
straight on with this example from the 2D one, then they should be. If not then make 
the same settings as for the 2D Tutorial. 

If you cannot see the Structure pane down the left side of the Graphical Results 
window, click View > Groups to enable it. We shall use this pane in reviewing our 
results. 

 
 

For further information see “Setting Graphical Results window 
options” in the Introduction Manual – 2D Tutorial 

 
 

You would usually ensure that the grouping that you defined for loading 
purposes also included any additional groups that you need for output 
purposes. In reality, this usually turns out to be the same thing – similarly 
loaded members are the ones you will want to review as a group in the 
results and output. 

Reviewing the 
results 

Once you have defined your structure, loaded it, defined any combinations you 
require and analyzed it, then you will need to understand the results of that analysis. 
In doing this, you will find that the groups you have defined are invaluable and that 
they allow you to concentrate on particular members in your structure. All the 
features of a 2D analysis are available, and we shall not go through these again here. 
If you like, you can review the 2D example now and try out the same features on this 
3D model. 

In this section, we shall concentrate on the features that we believe you will find 
most valuable when working with a 3D model. Many of these only come truly into 
their own for models which are much larger than our example here, but we would 
advise you to get into good habits right from the start. 

We also try to give you a few hints and tips on the best or most appropriate way to 
use the features we cover here. 
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Summarizing 
support reactions 

For simple static analysis, probably the first check that you would want to make 
would be the fundamental one, that the Sum of applied loads = Sum of Reactions. 

1. Click on the Reactions Tool from the Result Tools toolbox. 
2. S-FRAME will display all the individual base reactions for the load case or 

combination you choose from the Views and Grids toolbar. The Legend displays 
the summary of all the loads in the appropriate directions. 

 

Figure 52. 

Although the legend gives the overall details clearly, the screen display which 
shows all the members and textural values for the reaction in each direction is 
mainly illegible. 
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 We can reduce the clutter somewhat by just selecting the support joints (using the 
Select > Special dialog), and we can choose to see the results in a specific direction 
by choosing that direction from the Data Bar. 

 

Figure 53. 

You can also change the format of the numbers by clicking Settings > Diagrams... 
or clicking the Diagram scale factors and styles icon from the Edit toolbar to see 
the Diagrams dialog, then click Format, and reduce the number of decimal places 
to say 2. 

 

Figure 54. 

You can now see the details clearly, and for a more complex structure you could 
zoom and pan to view particular areas of your structure. 
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If your support reactions are in the same plane, then you might also 
consider changing to 2D mode and viewing the details just for that plane. 

Adding Numerical 
Values to Diagrams 

You have the option to display various numerical values on diagrams. This is 
controlled from the Diagrams dialog.  

1. Click Settings > Diagrams... or click the Diagram scale factors and styles icon 
from the Edit toolbar. 

 

Figure 55. 

2. Check the Display Numerical Values on Diagrams and the dialog is reconfigured 
with the additional options shown above. You can use these additional items 
to control the text that you would like to see on your force and deflection 
diagrams separately. 

 
 

We would always recommend that you choose the option to Specify 
maximum projected length. A value between 5 and 10 mm (0.25 to 0.5 
in) usually yields good results. 
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If you use these options carelessly you can easily obtain meaningless 
displays such as the one shown below. 

 

Figure 56. 

 3. You will probably find that adding text to diagrams is much more useful when 
you are working in a 2D view, however, with care, you can obtain useful 
information even in a 3D view. 

 

Figure 57. 
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 4. If you define an appropriate user coordinate system, switch to a 2D view and 
switch the Legend off, then you can get clear, informative views such as shown 
below. 

 

Figure 58. 

 
 

You might consider creating another standard 2D view with these 
alternative settings – once again if you have set up a series of user 
coordinate system you can go into this 2D view and swap between a 
series of floor and elevation views. 

 5. Finally, the diagram below shows a 2D view with the envelopes option 
activated and all load combinations included in the envelope. 

 

Figure 59. 

This ends this S-FRAME (3D) tutorial. We hope that you have found it useful. 
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