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NOTICE

Be sure that the user receives this manual before the product is used.

Copying or duplicating this user’s manual in part or in whole is 
forbidden. The information and specifications in this manual are subject 
to change without notice.

Considerable effort has been made to ensure that this manual is 
free from inaccuracies and omissions. If you should find an error or 
omission, please contact Yamatake Corporation.

In no event is Yamatake Corporation liable to anyone for any indirect, 
special or consequential damages as a result of using this product.

©2010 Yamatake Corporation ALL RIGHTS RESERVED



Conventions Used in This Manual

■	 In describing the product, this manual uses the icons and conventions listed below.

	 Handling Precautions:
Handling Precautions indicate items that the user should pay attention to when 
handling the SLP-NX.

	 Note: Notes indicate information that might benefit the user.

This indicates the item or page that the user is requested to refer to.

[1], [2], [3]: Numbers within parentheses indicate steps in a sequence or parts of an 
explanation.

[Online (O)], 
[XX]:

Square brackets indicate a window name, menu, or button shown on the PC screen.

[Ctrl] + [N]: Refers to the operation of pressing the [N] key while holding down the [Ctrl] key.

Check the following items when removing the SLP-NX (SLP-NX-J70 or SLP-NX-J71) from its package:
	 1.	 Check the model number to make sure you received the correct product.
	 2.	 Check for any obvious damage.
	 3.	� Check the contents of the package against the packing list to make sure that all items are included.

Handle the SLP-NX and its accessories with care to prevent damage or loss of parts.

If there is some problem with your order, please contact your dealer immediately.

Name Model or Document No. Qty Remarks

Smart Loader Package
SLP-NX installation CD

- 2 Japanese and English versions.

USB loader cable - 1 For the SLP-NX-J70 only.

Installation Guide CP-UM-5559JE 1 �This manual. 
Please read prior to installing.

Software license Agreement
Customer Registration card

CP-UM-5603JE 1 Please read the software license 
agreement carefully before your 
installation. If you can agree,please mail 
the customer registration card to us.

Software license Agreement

Installation Guide
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The Role of This Manual

A total of 6 different manuals are available for the NX-D15/25. Read them as necessary for your specific 

requirements. If a manual you require is not available, contact Yamatake Corporation or its dealer.

Alternatively, you can download the necessary manuals from “http://www.yamatake.com”.

Network Instrumentation Module 
User’s Manual 
Network Design Version	 Manual No. CP-SP-1313

Personnel who are in charge of design of a network using the Network 
Instrumentation Module should read this manual thoroughly. It describes 
how to design a network and gives examples.

User’sManual

CP-UM-0123 WARNING

CAUTION

WARNING

CAUTION

Network Instrumentation Module 
NX-D15/25/35 Controller Module User’s Manual for Installation 
	 Manual No. CP-UM-5561JE

This manual is supplied with the NX-D15/25/35. Personnel in charge of 
design and/or manufacture of a system using the NX-D15/25/35 should 
thoroughly read this manual. It describes safety precautions, installation, 
wiring, and primary specifications.
For further information about operation, refer to the user’s manual, Abridged 
Version.

Network Instrumentation Module 
NX-D15/25 Controller Module User’s Manual Abridged Version 
	 Manual No. CP-UM-1308E

Personnel who are using the NX-D15/25 for the first time or who are in 
charge of hardware design and/or maintenance of a control panel containing 
the NX-D15/25 should read this manual thoroughly. This manual describes 
the hardware, surveys the NX-D15/25 and other products used with it, 
explains installation, wiring, and troubleshooting, and gives hardware 
specifications.

User’sManual

CP-UM-0123 WARNING

CAUTION

WARNING

CAUTION

Network Instrumentation Module 
NX-CB1 Communication Box User’s Manual 
	 Manual No. CP-UM-5558JE

This manual is supplied with the NX-CB1. Personnel in charge of design 
and/or manufacture of a system using the NX-CB1 should read this manual 
thoroughly. It describes safety precautions, installation, wiring, and primary 
specifications.
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User’sManual

CP-UM-0123 WARNING

CAUTION

WARNING

CAUTION

Network Instrumentation Module 
Smart Loader Package SLP-NX   Installation Guide 
	 Manual No. CP-UM-5559JE

This manual is supplied with the SLP-NX Smart Loader Package and 
describes installation of the software on a personal computer.

Network Instrumentation Module 
Smart Loader Package SLP-NX 
User’s Manual	 Manual No. CP-UM-5636E

This Manual.
This manual is included in the SLP-NX Smart Loader Package as a PDF file.
Personnel in charge of design or configuration of a system using the 
Network Instrumentation Module should read this manual thoroughly. 
The manual describes the software used to configure the Network 
Instrumentation Module using a personal computer. It also describes 
installation of the software on a personal computer, operation of the 
personal computer, various functions, and setup procedures.
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Organization of This User’s Manual

This manual is organized as follows:

Chapter 1.	 INTRODUCTION
Be sure to read this chapter before you start using the loader. 

This chapter describes the required operating environment for personal computers, 

explains how to install the package, and briefly introduces the functions.

Chapter 2.	 STARTING AND QUITTING THE LOADER
This chapter describes how to start and quit the loader.

Chapter 3.	 LOADER WINDOW LAYOUT
This chapter explains the configuration of windows for this loader and the roles of 

each window.

Chapter 4.	 WORK FLOW
This chapter explains how to set up parameters in the modules and the work flow 

for operating modules.

Chapter 5.	 ACTUAL MODULE COMMUNICATION SETTINGS
This chapter explains the address settings and communication settings required for 

module communications.

Chapter 6.	 PARAMETER SETTING
This chapter explains how to set up parameters for operating modules.

Chapter 7.	 UNIVERSAL MONITOR
This chapter explains how to change settings and describes the screens for 

monitoring the operation status.

Chapter 8.	 RESTRICTIONS AND IMPORTANT NOTES ON USE
This chapter explains restrictions and important points for use.

Appendix	 EXPLANATION OF TERMINOLOGY
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Chapter 1.	 INTRODUCTION
1  -  1	 Overview

The Smart Loader Package: SLP-NX (called the “loader” from here on) is a software package for monitoring the 

settings and operational status of all Network Instrumentation Module (called “modules” from here on).

Loader Functions■■
This loader mainly performs the following operations for modules via Ethernet or 

when connected to a loader jack.

Confirms/sets communication settings such as IP addresses.  •	

(With separate or combined modules. Combined operation is only done via 

Ethernet.)

Reads/writes parameters •	

(With separate or combined modules. Combined operation is only done via 

Ethernet.)

Monitors online data, changes parameters, and samples data (with separate or •	

combined modules. Combined operation is only done via Ethernet.)
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The following system environment is required to use this loader.

System Environment■■

Item Description Description

Hardware Computer �PC/AT compatibles with Pentium chip or higher 
Recommended: 1.5 GHz or higher Core 2  Minimum: 1 GHz

Operating system �Windows XP SP3 32 bit (English) 
Note: Home Edition is not supported.

Memory �Windows XP 
Recommended: 1.5 GB or more, Minimum: 512 MB or more

Hard disk drive �Windows XP 
Recommended: 40 GB or more, Minimum: 20 GB or more

Display �1024 × 768 pixels or more, 16 bit or higher color recommended

CD-ROM drive �One drive

Ethernet port �1 port or more (If modules are connected via an Ethernet cable). 
Note: do not use USB Ethernet adapter.

USB port �1 port or more  
(When connecting modules via the special-purpose cable) 
Note: The USB loader cable only can be used.

Pointing device Windows-compatible mouse or equivalent device

Other �Install the following software if required. 
.NET Framework 3.5 SP1 
Windows Installer 4.5 
SQL Server 2008 Express SP1 *

 Handling Precautions
* �•	 The loader uses SQL Server 2008 Express. Please uninstall SQL 

Server 2005 or SQL Server 2008 R2. 
The operation is not guaranteed if SQL Server 2005 or SQL Server 2008 
R2 is installed. 
If you have application software that uses SQL Server 2005 or SQL 
Server 2008 R2, please contact your application software supplier 
to confirm whether the software is able to run on SQL Server 2008 
Express. 
Also, running old DB engines such as SQL Server 2000 alongside 
SQL Server 2008 Express may cause problems with SQL Server 2008 
Express. It is recommended that you use a separate PC if you need to 
run old versions.

1  -  2	 System Requirements
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Connection to Modules■■

 Handling Precautions
Multiple SLP-NXs cannot be connected to a single module at the same •	
time.

Connection via dedicated cable●●

This connection method is limited to projects consisting of a single module.

Module

USB loader 
cable

PC
NX-D25N

LOCK

Ethernet Connection 1  Connection Via Communication Adapter●●

Modules

Ethernet cable

PC Communication 
adapter

NX-D25N

LOCK

NX-D25N

LOCK

NX-D25N

LOCK

C
A

	Handling Precautions

This connection is allowed only with non-ring communication •	
modules.

Ethernet Connection 2  Connection Via Communication Box●●

Modules
(All modules have the 
same connection system.)

Ethernet cable

PC Communication box

NX-D25N

LOCK

NX-D25N

LOCK

NX-CB1N

4

3

2

1

NX-D25N

LOCK

	�Handling Precautions

�Connection is allowed with both ring and non-ring communications. •	
However, make sure all modules are of the same type.
Connection is still allowed when a general-purpose switching hub is •	
located between the PC and communication box. 
Use a UTP cable (4P) Cat 5e or higher (straight), (ANSI/TIA/EIA-•	
568-B) for the Ethernet cable. 

	 Note
For details, refer to: •	

Network Instrumentation Module User’s Manual for Network Design 
(CP-SP-1313E), 2-5 Configuration With External Devices ■ SLP-NX 
(page 2-18) 
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1  -  3	 Installing the Loader

Install the SLP-NX on the PC hard disk. Keep the installation CD-ROM as a backup.  

This section describes how to install the SLP-NX on a personal computer.

 Handling Precautions
The CD does not contain an operating system (OS), and cannot be used •	
on a PC that lacks an OS.
If you start the installer while another application is running, the installer •	
may malfunction.  Shut down other applications and then start the 
installer.  The SLP-NX sometimes cannot be started due to a particular 
combination of other applications and drivers.  For details on Windows 
and PC settings, refer to the user’s manuals provided with Windows and 
with the PC.
The loader uses Microsoft SQL Server 2008 Express as its database •	
engine. If other versions of Microsoft SQL Server such as Microsoft SQL 
Server 2005 or SQL Server 2008 R2 are installed, please uninstall these 
before installing the loader.

Loader installation procedure■■

Starting the installation●●

[1]	 Insert the SLP-NX installation CD in the PC and open Windows Explorer.
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[2]-1	 Double-click [Setup.exe].

This starts the loader installation and displays the opening screen.

[2]-2	 Next, the installer prepares the installation.

If the software required by the loader is already installed: 

● Proceed to step [5]-1.

If the software required by the loader is not already installed: 

● Proceed to step [3]-1 to install the necessary software.

Installing the software required by the loader●●

[3]-1	 When installation preparation is complete, a list appears showing the 

software required to run the loader.

Click the [Install] button.

[3]-2	 This starts installation of the required software.
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[4]-1	 If the installation requires the PC to be rebooted, the following screen 

appears.

[4]-2	 In this case, select [Yes I want to restart my computer now], then click the 

[OK] button to reboot the PC.

If further required software needs to be installed after rebooting, the 

installation continues.

[4]-3	 Click the [Install] button.

Installing the loader●●

[5]-1	 Once installation preparation and installation of other required software have 

completed, the loader installation screen appears.
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[5]-2	 Click the [Next] button.

>>	The following screen appears.

[5]-3	 To agree to the terms and conditions of the software user license agreement 

and start the installation, click the [Yes] button.

>>	The following screen appears.

[5]-4	 Enter your user name and company name, then click the [Next] button.

>>	The following screen appears.
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[6]-1	 Select [Complete] and then click the [Next] button.

>>	The following screen appears.

[6]-2	 Click the [Install] button.

>>	This starts the loader installation.

Proceed to step [7]-1.

	 Note

	The following message appears if WinPcap is already installed on your PC. •	

In this case, please click the [Cancel] button.

Proceed to step [7]-6.
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[7]-1	 After installation of the loader is complete, the installer for the WinPcap 

software required by the loader starts.

[7]-2	 Click the [Next] button.

>>	The following screen appears.

[7]-3	 Click the [Next] button.

>>	The following screen appears.
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[7]-4	 Click the [I Agree] button.

>>	The following screen appears.

[7]-5	 Click the [Install] button.

>>	This starts the WinPcap installation.

[7]-6	 When the installation completes, the following window appears.
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[7]-7	 Click the [Finish] button.

>>	The installation complete screen appears.

[8]	 Click the [Finish] button

>>	This completes the installation.
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1  -  4	 Installing the USB Loader Cable Device Driver

A device driver must be installed before using the USB loader cable.

Follow the procedure below to install the device driver.

Installing the Device Driver■■

 Handling Precautions
Be sure to follow the procedure below when installing the device driver. •	
The USB cable may not be recognized if the procedure is not followed. If 
the cable is not recognized, uninstall the driver and then install it again.
Administrator privileges on the computer are required for device driver •	
installation. Installation should be done by the administrator or by a user 
who belongs to the administrator group. 
The USB loader cable is supported on Windows XP (32-bit version).
If there are multiple USB ports, connect the USB loader cable to •	
the same port every time. If it is connected to a different port, driver 
installation may be required again.

1.	 Install the USB loader cable driver.

>>	Open “Drivers” folder in Explorer. 

If the install destination has not been changed, it can be found here:  

C:\Program Files\SLP\SLP-NX(enu)\Drivers

[1]	 Double-click [drvsetup.exe].

>>	The following screen appears:
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[2]	 Click [Next >].

>>	The following screen appears:

[3]	 If you agree to the software license agreement and wish to install the 

program, select [AGREE], then click [Next >].

>>�The following screen appears :

[4]	 Click the [Continue Anyway] button.

>>�The installation program then starts up, and after it is completed, the 

following screen appears:

[5]	 Click [Finish] to complete installation.
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2.	 Insert the USB loader cable into the USB port.

>>	When Windows recognizes the USB cable, the notification shown below 

appears on the task tray and the driver installation wizard appears.

3.	 Install the device driver.

[1]	 Usually, when Windows recognizes the USB loader cable, the window 

shown below appears. (In some cases, depending on the Windows 

environment, it may not appear.) 

Select [No, not this time] and click the [Next >].

[2]	 For the retrieval location of the device driver to be installed, select [Install 

the software automatically (Recommended)] and click [Next >].

>>	Retrieval of the device driver starts.
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>>	When the device driver is found, the following window appears:

[3]	 Click [Continue Anyway].

>>	Installation of the device driver starts

>>	When the device driver installation is complete, the following window 

appears:

[4]	 Click [Finish].�

>>	When the installation is completed, the notification shown below appears 

on the task tray, and Windows now correctly recognizes the USB loader 

cable.
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[5]	 Select [Control Panel] → [System] → [Hardware] → [Device Manager], and 

find the port number for the Yamatake USB Loader Comm.Port from [Ports 

(COM & LPT)].

[6]	 Start up the loader, then from the Project window’s menu bar, select [Online] 

→ [Communications Path] to open the [Communications path] dialog box, 

and select [Loader jack]. 

Click [Advanced] to open the [Serial Communication] dialog box, confirm 

that the communication port checked in [5] is set, and click [OK].

Uninstalling the Device Driver■■

 Handling Precautions
Removing the driver requires restarting the computer. Close other •	
applications first, and then uninstall the driver.
To uninstall the driver, administrator rights are required on the computer. •	
Installation should be done by the administrator or by a user who 
belongs to the administrator group.

1.	 Execute the driver removal program.

[1]	 Select [Control Panel] and click on [Add or Remove Programs]. Then, select 

[Windows Driver Package - Yamatake (YCslp) USB (04/10/2008 2.0.2.8)] 

and click [Change/Remove].

[2]	 Click [Yes].

[3]	 Restart the computer.
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Chapter 2.	 STARTING AND QUITTING THE LOADER
2  -  1	 Starting the Loader

Select [SLP-NX] from the Start Menu.

>>	Once started up, a Project window is displayed as shown below.

	 Note
A network profile function is provided that allows you to temporarily change •	

the network settings of the PC to which the module will be connected, but only 

while the loader is starting up. 

■ Network Profile (page 5-31), or 

■ How to Select [Automatic configuration from actual module] to Create 
a Project - Step [4] (page 6-8), if a network profile to be used for the loader is 

already created, the following dialog box will appear at startup:

	 In this case, use the Radio button to select [Original profile] (current network 

settings), or select the name of the network profile used when previously 

running the loader. 

When you select a network profile name, change the PC’s network settings with 

the values for that network profile and then continue starting up the loader. 

After the loader has started up, change the network profile with the same 

procedure used for ■ Network Profile (page 5-31).
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If the loader is exited abnormally during project editing, the following message •	

box will be displayed the next time it is started up. 

[Yes], that project will open.

	 Handling Precautions

If the loader is exited abnormally while running, the PC’s network •	
settings will remain as they were while the loader was running. 
Start up the loader, open the Network Profile window, then take 
appropriate action as described in ■ Network Profile (page 5-31). 
You can return to the network settings used before the loader’s 
previous startup.
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2  -  2	 Quitting the Loader

To quit the loader, select [File] from the Project window’s menu bar, then select [Exit],

	 Note
If the computer’s network settings were changed with the network profile •	

function, they will return to normal when you quit the loader.
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Chapter 3.	 LOADER WINDOW LAYOUT
3  -  1	 The Layout and Role of Windows

The Layout and Role of Loader Windows■■
The loader has the following basic windows:

Project window•	

[Actual module configuration] window•	

[Universal monitor] window•	

Explanations for each of these windows are provided below.

Name Role Window Image

Project window This window is used to set the 
parameters of the modules required 
for system operation.
For details, refer to:

 �This chapter and Chapter 6, 
PARAMETER SETTING

[Actual module configuration] window This window is used to configure 
the settings for modules required for 
basic communication with the outside 
of them.
For details on each menu, refer to:

 �5-1  How to Display Actual 
Module Configuration Window

[Universal monitor] window This window is used to monitor 
module operations.
It enables you to monitor multiple 
module operations at once.
For details on each menu, refer to:

 �7-3  Universal Monitor Window
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Project Window Layout■■

Title Bar

Project Tree Contents Area

Menu Bar
Tool Bar

Status Bar

Title Bar●●

The opened project name, loader name and version are displayed here.

Menu Bar●●

Used to select or run various operations. 

Available operations vary depending on what is displayed in the project tree and 

contents area.

Tool Bar●●

Frequently used operations from among menu items are available as buttons on the 

tool bar.

Project Tree●●

Items to be managed in projects are displayed in a hierarchical structure. 

Click on an item to select it, and its corresponding setup screen will be displayed in 

the contents area.

For details on the project tree, refer to: 

 ■ Project Tree Levels (next page)

Contents Area●●

A setup screen is displayed here for items selected from the project tree.

Status Bar●●

High-level communication addresses, setting ranges, etc. are displayed here for 

selected parameters.
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Project Tree Levels■■
The project tree hierarchy is constructed as follows.

Workgroup View

Project View

Module Configuration View

Parameter Bank View

Mapping View

Individual Mapping Name View

 page 3-3

 page 3-4

 page 3-5  page 3-7

 page 3-6  page 3-8

The following explains what is displayed in the contents area when you select each 

of these levels from the project tree.

Project View●●

Project Name Comments

[Edit] Button
[Add] Button
[Delete] Button

[Project] is displayed at the top level of the project tree.

When you select [Project] from the project tree, a project view is opened. 

Workgroups can be added or deleted in the contents area.

[Project name] •	

Sets the project’s name.

[Comments] •	

Defines comments.

[Edit] button •	

The applicable workgroup in the project tree is selected.

[Add] button •	

Adds a workgroup.

[Delete] button •	

Deletes a workgroup.
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Workgroup View●●

Workgroup Name Comments

Operation List

The [Workgroup] view is one level below the [Project] view.

In the [Workgroup] view, you define a cluster of methods, consisting of more than 

one module.

[Operation list] in the contents area contains the following items for the entire 

workgroup:

[1: Module definition] •	

When you click this, the Module Configuration view is displayed.

[2: Module mapping] •	

When you click this, the Mapping view is displayed.

[3: Parameter writing] •	

This allows you to write all parameters onto the module.

[4: Monitor] •	

This allows you to initiate the Universal Monitor.

[5: Parameter reading] •	

This allows you to read all parameters from the module.

For each workgroup, [Workgroup name] and [Comments] can be defined.
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Module Configuration View●●

Type

[Down] Button

[Add a copy] Button
[Delete] Button
[Up] Button

[Add] Button

[Edit] Button

[Initialize] Button

Name Model No.

[Set model number] Button

[Module configuration] and [Mapping] views are one level below the [Workgroup]

view.

When [Module configuration] is selected in the project tree, you can define the 

configuration of modules belonging to the workgroup in the contents area.

When an actual module is used, selecting [Automatic configuration from actual 

module]  in the [Create new project] dialog box allows you to automatically define 

the module configuration, so you don’t have to do it manually. 

The following the following settings can be made in the [Module configuration] 

view:

[Add] button •	

Adds a module.

[Add a copy] button •	

Adds a module with the parameter settings of any defined module.

[Delete] button •	

Deletes a module.

[Up] button •	

Moves the definitions of the selected module up one level in the list.

[Down] button •	

Moves the definitions of the selected module down one level in the list.

[Edit] button •	

Moves to the Parameter Bank view for the module selected in the project tree.

[Set model number] button •	

Displays the [Module model number setting] dialog box for the selected module.

[Initialize] button •	

Restores the initial parameters of the selected module.

[Type] •	

Defines the module’s type (typical model number).

[Name] •	

Defines the module’s name.

[Model number] •	

In this box, you enter the module’s model number manually.
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Parameter Bank View●●

Editor Grid

The Parameter Bank view is one level below the [Module configuration] view. 

The Parameter Bank view has categories for each module on the tree, which are 

divided into levels. 

Refer to each module’s manual for the meaning and operation of each parameter.

Editor Grid •	

In this area, you can set the values of parameters belonging to the Parameter 

Bank.
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Mapping View●●

[Add] Button

[Delete] Button

[Edit] Button
[Set communication]
Button

[Module configuration] and [Mapping] views are one level below the [Workgroup]

view.

When [Mapping] is selected in the project tree, the following settings can be made 

in the contents area.

[Add] button •	

Adds mapping to each module and actual module belonging to a workgroup.

[Delete] button •	

Deletes mapping from each module belonging to a workgroup, to an actual 

module.

[Edit] button •	

Moves to the Individual Mapping Name view for the selected mapping.

[Set communication] button •	

This allows you to configure communication settings that are common to all 

modules within a workgroup, and RS-485 communication settings for each 

module.

[Up] [Down] buttons are unsupported.•	
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Individual Mapping Name View●●

[Acquisition of actual module 
configuration] Button

[All unmap] Button

[Set communication] Button

[Automatic numbering] Button

Workgroup ID
Node ID

IP Address
Mapping Name

The Individual Mapping Name view is one level below the [Mapping] view. When 

an Individual Mapping Name is selected in the project tree, you can move the 

mapping from each module to an actual module in the contents area.

[IP address], [Node ID], [Workgroup ID] •	

In each of these boxes you can set a value manually.

[Mapping name] •	

You can change the name of a mapping.

[Acquisition of actual module configuration] button •	

Used to map a scanned module. 

The [Actual module configuration] window is displayed.

[Set communication] button •	

The [Communication settings (module)] dialog box is displayed.

[All unmap] button •	

Unmaps the modules. 

Module illustrations are grayed out in the Actual Module Configuration contents 

area.

[Automatic numbering] button •	

Numbers all IP address and node IDs.
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Project Window - Menu Configuration List■■

Menu Submenu 1 Submenu 2 Description
Shortcut 

Keys
Remarks

File New — Creates a new project.
(Offline, from Actual Module 
Configuration)

[Ctrl + [N]

Open — Opens the project. [Ctrl] + [O]

Save — Overwrite saves the project. [Ctrl] + [S] When the project is open.

Save as — Saves the project with a different 
name.

—

CSV output — Outputs parameter settings as a CSV 
file.

—

Exit — Exits the loader. — If the Universal Monitor is 
running, it will also exit.

Edit Cut — Cuts data. [Ctrl] + [X] Enabled when data that 
can be cut is selected.

Copy — Copies data. [Ctrl] + [C] Enabled when data 
that can be copied is 
selected.

Paste — Pastes data. [Ctrl] + [V] Enabled when pastable 
data has been cut or 
copied.

Workgroup 
independent mode

— Switches to Workgroup independent 
mode.

— Unsupported

Data check — Checks parameter settings. —

Display [Logical 
operation 
definition] window

— Displays the [Logical Operation 
Definition] window.

— Unsupported

Online Actual module 
configuration

— [Displays the [Actual Module 
Configuration] window.

—

Write Parameters — Writes parameters to a module. — Writes the target selected 
on the tree. For details, 
refer to:  6-5 Writing 
Parameters (page 6-37).

Monitor — Initiates the Universal Monitor. — For details, refer to: 
 6-6 Monitoring 

Module Operations (page 
6-40) and Chapter 7.

Read Parameters — Reads parameters from a module. — Reads to the target 
selected on the tree. For 
details, refer to:  

 6-7 Reading 
Parameters (page 6-45).

Communications 
path

— Changes communication path from 
PC to module.

— For details, refer to: 
 ■ Communication 

Path (page 5-29).

Network Profile — Switches network settings such as 
computer’s IP address.

— For details, refer to: 
 ■ Network Profile 

(page 5-31).

Communications 
options

— Loader communication time out 
settings.

— For details, refer to: 
 ■ Communications 

Options  (page 5-37).
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Menu Submenu 1 Submenu 2 Description
Shortcut 

Keys
Remarks

View Go Back Moves one position back on the 
project tree.

[Alt] + Left When the project is open.

Forward Moves one position forward on the 
project tree. 

[Alt] + Right

Up Moves one level up on the project 
tree.

Home Moves to the workgroup level 
belonging to the current project tree 
position.

[Alt] + [home]

Display line graph — Displays line table as a graph. — Unsupported

Set user level — Changes the parameter user level. — For details, refer to: 
 ■ User Levels (page 

6-18).

Help Help — Displays the online help. — Unsupported

About SLP-NX — Displays version and license 
information.

—

Tool Bar■■

Icon Name Icon Function Remarks

Back Moves one position back on the project 
tree.

When the project is open the project 
tree.

Next Moves one position forward of the project 
tree.

Up Moves one level up the project tree.

Home Moves to the workgroup level belonging  
to the current project tree position.

Create Creates a new project.
(Offline, from Actual Module 
Configuration)

Open Opens the project.

Save Overwrite saves the project. When the project is open.

Expand Expands the project tree. When the project is open.

[Actual module configuration] 
window

Displays the [Actual Module 
Configuration] window.

Read
 
* Reads parameters from a module. Reads from a device selected on 

the tree. For details, refer to:  6-7 
Reading Parameters (page 6-45).

Write
 
* Writes parameters to a module. Writes to a device selected on the 

tree. For details, refer to:  6-5 
Writing Parameters (page 6-37).

Monitor Initiates the Universal Monitor. For details, refer to:  6-6 
Monitoring Module Operations  
(page 6-40).

If working via the USB loader cable, *	  (Read)  (Write) icons are displayed.
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Version Information■■
Select [Help] → [About SLP-NX] from the Project window’s menu bar.

>>	The following version and license information is displayed for this loader.
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Chapter 4.	 WORK FLOW
4  -  1	 General Work Flow

This section explains the basic procedures to set up parameters and actual module communication settings for 

modules to operate.

Operating window Operation Reference page

1. Enable the actual module for 
    communication.

4. Confirm the operation of the module.

5. Confirm and save the settings to 
    the module.

2. Determine the configuration of the 
    processing module.

3. Set the parameters and let the module 
    go into operation.

Mainly the [Actual module 
configuration] window

Prepare the actual module and 
configure the actual module 
communication settings.

5-2 Defining IP Address and Node 
Address (page 5-7)

5-3 Communication Settings  
(page 5-12)

[Project] window Create the module configuration 
offline.
OR
Create the module configuration 
online.

6-1 Creating a Project (page 6-1)

6-2 Defining Module Configuration 
(page 6-11)

[Project] window Edit the parameters.

Specify the target module.

Write the parameters.

6-3 Editing Parameters (page 6-15)

6-4 Mapping (page 6-29)

6-5 Writing Parameters (page 6-37)

[Universal monitor] window Confirm the operation on the 
Universal monitor.

6-6 Monitoring Module Operations 
(page 6-40)

[Project] window Read the parameters from the 
module.

Output the settings in CSV format.

Save the project.

6-7 Reading Parameters  
(page 6-45)

6-10 Output to CSV File  
(page 6-51)

6-8 Saving a Project (page 6-48)

Open the saved project. 6-9 Opening a Project (page 6-49)
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4  -  2	 When There is Any Available Module

If any modules can be used, follow the steps explained below to set parameters and mapping for them to operate.

Operating window Operation Reference page

1. Enable the actual module for 
   communication.

4. Confirm the operation of the module.

5. Confirm and save the settings to 
    the module.

2. Determine the configuration of the 
    processing module.

3. Set the parameters and let the module 
    go into operation.

Mainly the [Actual module 
configuration] window

Prepare the actual module and 
configure the actual module 
communication settings.

5-2 Defining IP Address and Node 
Address (page 5-7)

5-3 Communication Settings  
(page 5-12)

[Project] window Create the module configuration 
online.

6-1 Creating a Project (page 6-1)

[Project] window Edit the parameters.

Write the parameters.

6-3 Editing Parameters (page 6-15)

6-5 Writing Parameters (page 6-37)

[Universal monitor] window Confirm the operation on the 
Universal monitor.

6.6 Monitoring Module Operations 
(page 6-40)

[Project] window Read the parameters from the 
module.

Output the settings in CSV format.

Save the project.

6-7 Reading Parameters  
(page 6-45)

6-10 Output to CSV File  
(page 6-51)

6-8 Saving a Project (page 6-48)

Open the saved project. 6-9 Opening a Project (page 6-49)
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4  -  3	 When There is No Available Module

If any modules cannot be used initially, follow the steps explained below to set parameters and mapping for them to 

operate.

Operating window Operation Reference page

1. Determine the configuration of the 
    processing module.

7. Confirm the operation of the module.

8. Confirm and save the settings for 
    the module.

2. Set the parameters.

6. Set the parameters and let the module 
    go into operation.

3. Confirm and save the settings for 
    the module.

4. Open the saved project after acquiring 
    the module.

5. Enable the actual module for 
    communication.

[Project] window Create the module configuration 
offline.

6-1 Creating a Project (page 6-1)

6-2 Defining Module Configuration 
(page 6-11)

[Project] window Edit the parameters.

Define the mapping information.

6-3 Editing Parameters (page 6-15)

6-4 Mapping (page 6-29)

[Project] window Output the settings in CSV format.

Save the project.

6-10 Output to CSV File  
(page 6-51)

6-8 Saving a Project (page 6-48)

[Project] window Open the saved project. 6-9 Opening a Project (page 6-49)

[Project] window
[Actual module configuration] 
window

Prepare the actual module and 
configure the actual module 
communication settings to the 
module using mapping information.

6-4 Mapping (page 6-29)

5-3 Communication Settings  
(page 5-12)

[Project] window Write the parameters. 6-5 Writing Parameters (page 6-37)

[Universal monitor] window Confirm the operation on the 
Universal monitor.

6.6 Monitoring Module Operations 
(page 6-40)

[Project] window Read the parameters from the 
module.

Output the settings in CSV format.

Save the project.

6-7 Reading Parameters  
(page 6-45)

6-10 Output to CSV File  
(page 6-51)

6-8 Saving a Project (page 6-48)

Open the saved project. 6-9 Opening a Project (page 6-49)
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4  -  4	 When You Change Module Configuration

Follow the steps explained below when you change the configuration of the processing module later, and set 

parameters and actual module communication settings again for them to operate.

Operating window Operation Reference page

1. Determine the configuration of the 
    processing module.

7. Confirm the operation of the module.

8. Confirm and save the settings for 
    the module.

2. Set the parameters.

6. Set the parameters and let the module 
    go into operation.

3. Confirm and save the settings for 
    the module.

4. Open the saved project after acquiring 
    the module.

5. Enable the actual module for 
    communication.

[Project] window Open the saved project.

Modify the module configuration 
offline.

6-9 Opening a Project (page 6-49)

6-2 Defining Module Configuration 
(page 6-11)

[Project] window Edit the parameters.

Define the mapping information.

6-3 Editing Parameters (page 6-15)

6-4 Mapping (page 6-29)

[Project] window Output the settings in CSV format.

Save the project.

6-10 Output to CSV File  
(page 6-51)

6-8 Saving a Project (page 6-48)

[Project] window Open the saved project.    6-9 Opening a Project (page 6-49)

[Project] window
[Actual module configuration] 
window

Prepare the actual module and 
configure the actual module 
communication settings to the 
module using mapping information.

6-4 Mapping (page 6-29)

5-3 Communication Settings  
(page 5-12)

[Project] window Write the parameters. 6-5 Writing Parameters (page 6-37)

[Universal monitor] window Confirm the operation on the 
Universal monitor.

6.6 Monitoring Module Operations 
(page 6-40)

[Project] window Read the parameters from the 
module.

Output the settings in CSV format.

Save the project.

6-7 Reading Parameters  
(page 6-45)

6-10 Output to CSV File  
(page 6-51)

6-8 Saving a Project (page 6-48)

Open the saved project. 6-9 Opening a Project (page 6-49)
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Chapter 5.	 ACTUAL MODULE COMMUNICATION SETTINGS
5  -  1	 Displaying Actual Module Configuration Window

Before using this module, number it with an IP address and node address (workgroup ID and node ID).

Also, configure other communication settings as needed.

Configuring communication settings for a module, such as numbering an IP address and node address, is done in 

the [Actual module configuration] window.

How to Open the Actual Module Configuration Window■■
Click the  ([Actual module configuration] window) icon in the Project window, 

or go to the Project window’s menu bar and select [Online] → [Actual module 

configuration]. 

>>	The [Actual module configuration] window is displayed. 
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Actual Module Configuration Window Layout■■
The [Actual module configuration] window is as follows:

Actual module configuration tree Contents Area

Title Bar
Menu Bar

Tool Bar

The names and functions for each window part are described below.

Title Bar●●

Displays the [Actual module configuration] window.

Menu Bar●●

This is used to select or run various operations. Operable content differs depending 

on what is displayed in the Actual Module Configuration tree and contents area.

Tool Bar●●

Frequently used operations from among menu items are available as buttons on the 

tool bar.

Actual Module Configuration Tree●●

The actual module configuration is displayed here as a chain. Selecting any chain 

will display the applicable setup screen in the contents area.

For details on the Actual Module Configuration Tree, refer to: 

 ■ Actual Module Configuration Tree Levels (page 5-4)

Contents Area●●

A screen is displayed here for items selected in the Actual Module Configuration 

Tree.
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Actual Module Configuration Window - Menu Configuration List■■

Menu Icon Submenu 1 Submenu 2 Description
Shortcut 

Keys

File — Close — Closes the [Actual module configuration] 
window.

—

Edit — Cut — Cuts data. [Ctrl] + [X]

— Copy — Copies data. [Ctrl] + [C]

— Paste — Pastes data. [Ctrl] + [V]

Online — Workgroup 
independent mode

— Unsupported —

— Communications path — Changes communication path from PC to 
module.
For details, refer to: 

 ■ Communication Path (page 5-29).

—

— Network profile — Allows you to change the PC’s IP address 
settings.
For details, refer to: 

 ■ Network Profile (page 5-31).

—

— Communications 
options

— Loader communication time out settings.
For details, refer to:  

 ■ Communication Options (page 5-37).

—

View Go Back Moves one position back on the Actual 
Module Configuration Tree.
Enabled when the project is open.

[Alt] + [Left]

Forward Moves one position forward on the Actual 
Module Configuration Tree.
Enabled when the project is open.

[Alt] + [Right]

Up Moves one level up on the Actual Module 
Configuration Tree.
Enabled when the project is open.

—

Home Moves to the top level (All) of the Actual 
Module Configuration Tree.

[Alt] + [home]

— [Workgroup] screen — Moves to the workgroup view in the Project 
window for the selected module.
Enabled when a module is selected in the 
[Actual module configuration] window.

—

— Return to Project 
window

— Returns focus to the Project window. —

— Error display — Displays module errors.
Displayed when an error occurs for a 
module selected in the [Actual module 
configuration]  window.

—

— Set user level — Changes the user level. —
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Tool Bar■■
Icon Name Icon Function

Back Moves one position back on the Actual Module 
Configuration Tree.

Next Moves one position forward on the Actual Module 
Configuration Tree.

Up Moves one level up on the Actual Module Configuration 
Tree.

Home Moves to the top level (All) of the Actual Module 
Configuration Tree.

Expand Expands the Actual Module Configuration Tree.

Actual Module Configuration Tree Levels■■
The Actual Module Configuration Tree is made up of the following levels.

 page 5-5

 page 5-6

 page 5-4All

Chain Name

Module Name

All●●

The Actual Module Configuration Tree’s top level is called [All].

This enables you to scan the actual module configuration, configure the 

communication settings common to all modules, etc.

[Edit] Button

[Set communication] Button
[Return] Button

[Execute] Button

[Execute] button •	

Scans the actual module configuration.

[Edit] button •	

Displays a list of modules connected to the selected chain.

[Set communication] button •	

The [Communication settings (all)] dialog box is displayed.

[Return] button •	

Returns focus to the Project window.
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Chain Name●●

A Chain Name is located one level below [All]. 

You can configure the settings for each module (such as an IP address and node ID) 

here.

By clicking the [Write] button, you can write actual module communication 

settings to the module. 

[Details] Button
[Set communication] Button

[Lit LED] Button

[List] [Chain name][Actual module configuration tree]

[Automatic numbering] Button
[Write] Button

[Workgroup ID] [IP address]       [Node ID]

[Chain ID]

[Target]

Each component of a Chain Name tab is explained below.

[Chain ID] •	

Can be set the chain ID.

[Chain name] •	

Can be set the chain name.

[Target] Check Box •	

These boxes are to be checked for LED lights, writing, and automatic 

numbering.

[Workgroup ID] •	

Displays the workgroup ID (the same value for Chain ID is displayed).

[IP address] •	

Can be set the IP address.

[Node ID] •	

Can be set the node ID.

[Details] button •	

Displays module information for the selected module.

[Set communication] button •	

Can be configured. Individual communication settings for the selected module.

[Lit LED] button •	

Turns on an LED light for the module with the [Target] check box checked. 

[Automatic numbering] button •	

This allows you to automatically set the IP address and node ID.

[Write] button •	

When clicked, the altered actual module communication settings will be written 

onto the modules  with the [Target] check box checked.
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Module Name●●

Module Name is one level below a Chain Name.

Here is displayed module information acquired when executing a scan of the actual 

module configuration.

[Item name]  [Setting value] [Read value]

[Item name] •	

Name of acquired information.

[Setting value] •	

Setting value while editing in the [Actual module configuration] window.

[Read value] •	

Module value acquired when executing a scan of the actual module 

configuration.
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Address numbering is done in the [Actual module configuration] window. 

If there is no available module, you can configure module settings via  

6-4 Mapping (page 6-29).

Steps■■

[1]	 In the [All] tab of the [Actual module configuration] window, click [Execute] 

button.

>>	The [Confirmation of module startup] message box appears. 

[2]	 Turn on the module to be numbered with an address, then connect the cable 

selected via communication path to a running PC.

	 Note

If multiple modules are concatenated, and the Ethernet is used as a •	

communication path, these modules can be numbered at once.

[3]	 Confirm connection, and click [OK].

>>	The [Progress] dialog box is displayed.

	 Note

Make sure whether the loader and the module are properly connected in an •	

appropriate environment. 

 Refer to ■ Communication Path (page 5-29) and ■ Network 
Profile (page 5-31).

5  -  2	 Defining IP Address and Node Address
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After this, one of many message boxes will be displayed depending on the module 

status.

[4]-1	 If an error occurs during actual module configuration scan: 

A message box containing the error description will be displayed. 

Check the error description and take appropriate action.

	 Note

For details on the errors, and counter measures, refer to: •	

 ■ Message List (page 5-16).

[4]-2	 If no error occurs during actual module configuration scan, but the project is 

not open in the Project window:  

The following message box is displayed. When you want to configure the 

communication settings for modules (such as address numbering), click the 

[No] button.

	 Note

When you click the [Yes] button in the message box shown above,  •	

6-1  Creating a Project  ● Selecting [Automatic configuration from 
actual module] to create (page 6-1).

[4]-3	 If no error occurs during actual module configuration scan, but you are 

editing a workgroup in the Project window:  
The following message box is displayed. When you want to configure the 

communication settings for modules (such as address numbering), click the 

[No] button.
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[5]	 Scan results are displayed on the screen for each chain. 

	 Note

If an error occurs:  •	

An error icon  will flash for the module with a scan error. By right 

clicking on the module with the flashing error icon, and selecting [Error 

display], you can see the error description. 

[6]	 For each chain, number the modules with addresses (IP addresses, node IDs, 

and workgroup IDs).

	 Handling Precautions

Node IDs are required for data transmission between modules. If the •	
function of data transmission between modules is not used, you do 
not have to change any node IDs.
The workgroup ID displayed on the screen is the identifier of a work •	
group which represents a group made up of modules in the Project 
window. Since the workgroup ID is linked with the chain ID, it cannot 
be edited.
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[6]-1	 To configure the settings manually, click the line of the target module, and 

set the desired value directly in the edit box. 

[6]-2	 To configure the settings automatically (sequential numbering), click 

[Automatic numbering].

>>	The [Automatic module numbering] dialog box will then be displayed.

	 Note

When there is any module which is not applicable for auto numbering, •	

uncheck the appropriate [Target] box in the module list. 

After confirming the range of available IP addresses, specify the first IP 

address and node ID for the modules to be numbered, and click [OK].

[7]	 After completing numbering the IP addresses, node IDs, and workgroup 

IDs, click [Write] on the[Module list] screen to write actual module 

communication settings.
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>>	The [Writing of chain information, address information, and 

communication settings.] message box will then be displayed.

	 Handling Precautions

Once writing is completed, the module will be reset (restarted). •	
Confirm operational status and start working.

	 Note

Writing of actual module communication settings to the module is done for •	

each chain.

If there are multiple chains, a different chain ID will be assigned to each •	

chain, but if an appropriate chain name has already been set, comparative 

management for the actual chain is easy.

The settings are written only to modules with the [Target] check box •	

checked.

If you want to confirm mapping with the target module before writing, •	

perform the steps described in  5-4 Module LED Lights (page 5-15) to 

turn on the module’s LED light for confirmation.

[8]	 Click [Yes] on the [Writing of chain information, address information, and 

communication settings.] message box.

>>	The [Progress] dialog box is displayed.

[9]	 Actual module configuration information is then automatically acquired 

from the module.
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5  -  3	 Communication Settings

Communication settings other than the module’s IP address and node address are to be configured in the [Actual 

module configuration] window [Set communication] button. The following settings can be configured. 

If there is no available module, you can configure module settings via 6-4 Mapping (page 6-29).

Settings Screen

Type Name Description
All

(page 5-13)
Chain Name
(page 5-14)

Module basic 
setting

Set the following value to 
all modules

Checks this box when performing the 
automatic address numbering prohibition 
function for all modules

 —

Automatic address 
numbering is prohibited.

Excludes modules from auto address 
numbering.
(Check mark will be removed from the list 
of target modules.)

 

IP setting Netmask IP net mask  —

Default gateway IP default gateway  —

Port settings Set next value to all 
modules

Checks this box when you want port 
settings to apply to all modules.

 —

Dedicated communication 
port number

Cannot be changed.  

MODBUS communication 
port number

MODBUS/TCP function’s port number  

CPL communication port 
number

CPL/TCP communication port number 
(Unsupported)

 

RS-485
detailed settings

Set the following value to 
all modules

Checks this box when you want the 
changes to RS-485 setting to apply to all 
modules.

 —

RS-485 device address Device address used for host 
communication (RS-485).

— 

RS-485 protocol Host communication (RS-485) protocol 
selection

 

RS-485 transmission rate Transmission speed used for host 
communication (RS-485)

 

RS-485 bit length Bit length used for host communication 
(RS-485)

 

With/without RS-485 parity 
status

With/without parity used for host 
communication (RS-485)

 

RS-485 stop bits Stop bit used for host communication 
(RS-485)

 

RS-485 minimum 
response time

Minimum response time used for host 
communication (RS-485)

 
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Setting Procedure■■
The following explains the setting procedure.

To configure the settings common to all modules:  •	

Select [All] from the Actual Module Configuration Tree, then select a chain 

from the [All] tab’s contents area and click [Set communication].

>>	The [Communication settings (all)] dialog box will then be displayed.

	 Set the necessary items, then click [OK].
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To configure the settings for each module individually:  •	

Select a desired Chain Name from the Actual Module Configuration Tree, then 

select a line in the [List] tab for the module you want to set (when clicking the 

line for the target module, the background will turn gray), then click the [Set 

communication] button.

>>	The following dialog box will then be displayed.

	 Set the necessary items, then click [OK].

	 Note
You can simultaneously change the actual module communication settings (IP •	

address, node address, and communication settings) and write to the module.
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The module LED light function is used to confirm which module is an actual module when numbering a module’s 

IP address, etc.

[1]	 Select a desired Chain Name from the Actual Module Configuration Tree 

in the [Actual module configuration] window, then check a check box 

under [Target] for the module you want to light up from the [List] tab in the 

contents area, and click [Lit LED].

>>	The [Lit module LED] dialog box will then be displayed.

[2]	 Set the values in the [Lighting indication] area, and click [OK]. 

In this area, you can select as the lighting type as [Timer], [ON], or [OFF].   

When you select [Timer], you can also set the lighting time(s) as a value 

between 1 and 255 seconds.

>>	All top LED lights will flash at a low speed for target modules.

5  -  4	 Module LED Lights
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5  -  5	 Confirming Mapping with Workgroups

Overview■■
When you create a project offline and manually edit module configuration, or 

when you create a project with auto configuration from the actual module, but add 

module configuration or change the model number, you must maintain consistency 

between workgroup information and actual module configuration information.

Check the consistency with the actual module configuration scan function, etc.

Message List■■
The following messages are displayed when you confirm mapping with 

workgroups.

No. Message Cause and Action

1

An error was found during scanning of actual module 

configuration.

xxx: �Duplicate IP addresses exist. IP address setting is 

required.

Please set/confirm the valid values and then write.

<Module Error>
The IP address is already used.

Set a different IP address in the [Actual module 
configuration] window, and click [Write] to write to 
the module.

2

An error was found during scanning of actual module 

configuration.

xxx: Duplicate chain IDs exist.

Please set/confirm the valid values and then write.

<Module Error>
The chain ID is already used.

Set a different separate chain ID for each chain in 
the [Actual module configuration] window, then click 
[Write] to write to the module.

3

An error was found during scanning of actual module 
configuration.
xxx: �IP address of base does not match that of main 

device.
Please set/confirm the valid values and then write.

<Module Error>
The module device and base combination has been 
changed.
Return the module device and base combination 
to normal, or click [Write] in the [Actual module 
configuration] window to write to the module.

This operation will write the IP address	
information etc. that was written to the module 
to the base as well, eliminating any difference 
between the module device and base.

4

No module was found on the selected communication 
path.

<Module Error>
No module was found during scan.

Confirm the following:
• The module is turned on
• The module and PC are connected properly
• [Communications path settings] are set correctly
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No. Message Cause and Action

5

An error was found during scanning of actual module 
configuration.
xxx: Chain ID does not match that of initial module.
•  •  •
Writing from actual module configuration window is 
required.
Please set/confirm the valid values and then write.

<Module Error>
A module was found with different chain ID within 
the same chain.

Confirm chain ID in the [Actual module 
configuration] window, then to make sure all chain 
IDs are the same within the chain, click [Write] to 
write to the module.

6

An error has occurred.
Some module model numbers are not matched in 
modules defined for project and scanned modules.
•  •  •

<Project and Module Error>
Model number of module defined in the project 
differs from that of the scanned module.

Clicking [OK] will display the [No. 8] message box, 
and this message box will be displayed again.
In this case, confirm [Module configuration] in the 
Project window, and match it to the module’s model 
number.

7

An error has occurred.
Significant differences in configuration exist between a 
module defined for the project and a scanned module.
(28)

An error has occurred.

Type, position, IP address, node ID, and workgroup 

ID are not matched in module defined for project and 

scanned module.(26)

Significant differences in configuration exist between a 

module defined for the project and a scanned module. 

(28)

<Project and Module Error>
An error occurred during map processing. Because 
the type, position, IP address, node ID, and 
workgroup ID of the module defined in the project 
do not match  those of the scanned module.

Clicking [OK] will display the [No. 8] message box.
If mapping cannot be performed after the [No. 8] 
message box is displayed, this message box will 
be displayed again. Please confirm project module 
settings when this occurs.
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No. Message Cause and Action

8

Do you wish to perform mapping by overwriting scanned 
information with module IP address and node ID as 
defined in the project?
(In single-chain and workgroup linked mode, workgroup 
IDs will also be overwritten.)

<Confirmation of Mapping Retry>
Displayed after an error message when there is 
significant difference between project settings and 
modules.

Selecting [Yes] will transfer the scanned module’s 
IP address and node ID to the project, and start 
mapping.
When in workgroup linked mode with only one 
chain, the scanned workgroup ID will be used in the 
project, and mapping will be performed.
When selecting [No], project settings will not be 
changed, and mapping will not be performed.

Moreover, if you want to write project settings to 
the actual module, select [No] to cancel mapping, 
and after mapping with drag & drop in the Project 
window’s [Mapping] screen, write to the module by 
clicking [Write] in the [Actual module configuration] 
window.

9

No IP address has been set for module defined for the 
project.
Click [YES] to update project with scanned IP address 
and node ID and to perform mapping.
OK to continue?

<Confirmation of Mapping Continuation>
An IP address has not been set to the project 
module defined in the project. 

Clicking [Yes] will transfer the scanned project, and 
mapping will occur.
When selecting [No], project settings will not be 
changed, and mapping will not occur.

10

Some modules defined for the project cannot be found.
Click [YES] to perform mapping with found modules  
only.
OK to continue?

<Confirmation of Mapping Continuation>
Some modules defined in the project were not 
found when scanning.

Clicking [Yes] will only perform mapping for modules 
that were found during scanning that are consistent 
with modules defined for the project.
When selecting [No], mapping will not occur.

11

A module not defined for the project has been found.
•  •  •
Click [YES] to perform mapping with a module other 
than that above.
OK to continue?

<Confirmation of Mapping Continuation>
Module(s) not defined in the project were found 
when scanning.

Clicking [Yes] will only perform mapping for modules 
that were found during scanning that are consistent 
with modules defined in the project.
When selecting [No], mapping will not performed.
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No. Message Cause and Action

12

Configuration data has been acquired for the number of 
chains (x) and the number of modules (y).
The project will be configured based on this information.
Do you also wish to read module setting parameters?

<Build Project>
Displayed when creating a new project with 
[Automatic configuration from actual module], and a 
module scan occurs normally.

Clicking [Yes] will read the module parameters and 
include them in the project.
When selecting [No], the project will be created, but 
parameters will not be read.
When selecting [Cancel], the project will not be 
created.

13

Do you wish to build project with scanned information?

<Project Construction>
Displayed when there is no project, but a scan of 
actual module configuration is performed normally.

Clicking [Yes] will create a project.
When selecting [No], a project will not be created.

14

Do you wish to move to the actual module configuration 
window?

<Confirmation of Transition to the Actual Module 
Configuration Window>
Displayed if there is any error during module scan 
when a new project is created using [Automatic 
configuration from actual module], and an error 
occurs. 

Clicking [Yes] will display the [Actual module 
configuration] window, and module status can be 
confirmed.
When selecting [No], the [Actual module 
configuration] window will return to its original 
empty state.

15

Do you wish to overwrite project mapping information 
with actual module communication settings?

<Confirmation of communication setting 
overwriting>
Displayed when module scanning and mapping 
occur normally.

Selecting [Yes] will apply actual module 
communication settings of the scanned module to 
the project mapping data.
When selecting [No], project mapping data set 
during mapping will not be changed.

16

There is a difference between scanned module 
communication settings and project communication 
settings.
Please confirm the data on the actual module 
configuration window.

<Communication Setting Differences>
Displayed when selecting [No] in the [No.15] 
message box, and there are differences between 
the project’s communication settings and the 
communication settings of the scanned modules.

Please confirm communication settings in the 
[Actual module configuration] window.
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No. Message Cause and Action

17

Do you wish to read module setting parameters and use 
them to update the project?

<Parameter Reading>
Displayed when selecting [Yes] in the [No.15] 
message box.

Clicking [Yes] will read the module parameters and 
apply them to the project.
When selecting [No], the parameters will not be 
read.

18

Scanning of actual module configuration has been 

completed.

<Scanning Complete>
Displayed when an actual module configuration 
scan is executed normally.

19

Receiving parameters has been completed.

<Setting Parameter Reading Complete>
Displayed when reading of module parameters is 
complete.

20

Chain information, address information, and 

communication settings will be written.

Module will be restarted after writing.

OK to proceed?

<Write Confirmation>
Displayed when clicking [Write] in the [Actual 
module configuration] window.

When selecting [Yes], actual module communication 
settings are written to the module.
The module is restarted when writing takes place.
When selecting [No], nothing will be written to the 
module.

21

An error was found in a post-writing scan.
xxx: �Duplicate IP addresses exist. IP address setting is 

required.
Please set/confirm the valid values and repeat the 
writing process. (729)

<Error After Writing>
All information was successfully written to the 
module, but after that a scan detected duplicate IP 
address.

Confirm module IP address via [Actual module 
configuration]  and then click [Write] again to 
execute writing once more.
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No. Message Cause and Action

22

Failed to write to module or some data has not been 
written.
xxx: �Certain chain information, address information, and 

communication settings.
Please write any such chain information, address 
information, or communication settings in an available 
chain.

<Error After Writing>
There is an unwritten module in the [Actual module 
configuration] window.

Check that the module is marked with “*” in 
the [Actual module configuration] window’s 
[Modification] column, and then click [Write] to write 
the actual module communication settings to the 
module as needed.

23

Failed to write to module or some data has not been 
written.
xxx: Actual module configuration has been changed.
Please clear the previous configuration and re-execute 
the process.

<Error After Writing>
A difference was detected between project module 
configuration and scanned module configuration 
when writing to module.

Click the [Execute] button from [Actual module 
configuration] to re-acquire actual module 
configuration, and then click [Write] again to write to 
the module.  

24

Failed to write to module or some data has not been 
written.
xxx: Chain ID does not match that of initial module.
•  •  •
Please write chain information, address information, or 
communication settings in a chain without data.  

<Error After Writing>
When writing to modules, a module with a chain ID 
differing from other modules in the same chain was 
found.

Check for chain IDs in the [Actual module 
configuration] window, and click [Write] so that all 
modules in the chain have the same chain ID.  

25

Writing of module has been completed successfully.

<Writing Modules Completed>
Displayed when all information has been written to 
the module.
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Typical Methods of Confirmation■■
The following are three typical methods to confirm mapping between workgroups 

and actual module configuration.

1.	 Apply actual module communication settings to new modules

2.	 Apply parameters prepared in advance to actual modules

3.	 Read the parameters of an operating module and change the settings

The steps for each method are explained below.

Apply actual module communication settings to new modules●●

Start up the loader, and acquire actual module configuration from the new project.

[1]	 Click the  icon in the Project window, or select [File] → [New] from 

the Project window’s menu bar.

>>	The [Create new project] dialog box will then be displayed.

[2]	 Select [Automatic configuration from actual module] and click [OK].

>>	The Collection of the module’s information begins, and the [Progress] 

dialog box is displayed.

[3]	 A message box appears, explaining there are duplicate IP addresses. 

Click [OK].

[4]	 The [Confirmation of transition to the actual module configuration window] 

message box is displayed. 

Click [Yes].
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[5]-1	 There are currently duplicated IP addresses and node IDs in the [Actual 

module configuration] window.

[5]-2	 Click [Automatic numbering] to number the IP address and node ID of all 

modules at the [Automatic module numbering] dialog box, or enter each 

module’s IP address and node ID individually in text boxes in the [Actual 

module configuration] window’s contents area. (The example below shows 

the [Automatic module numbering] dialog box is shown below as an example.)  

[5]-3	 If the IP address and node ID have been changed, they are marked with 

a “*” in the [Modification] column. Click [Write] to write actual module 

communication settings to the module.
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[6]	 The [Writing of chain information, address information, and communication 

settings] message box is displayed. Click [Yes].

>>	The [Progress] dialog box is displayed for writing progress.

[7]	 The [Project construction] message box is displayed. 

Click [Yes].

[8]	 The message box for reading parameters is displayed. 

Click [Yes]. 

Parameters are then applied to the project.

>>	The [Progress] dialog box is displayed for reading progress.

[9]	 The [Parameters received] message box is displayed. 

Click [OK].

	 Select [File] → [Save as] from the Project window’s menu bar, and save the 

project with an appropriate name.
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Apply parameters prepared in advance to actual modules●●

[1]	 Start up the loader, and open the project prepared in advance. 

Open the [Actual module configuration] window, then click the [Execute] 

button for [Scanning of actual module configuration].

[2]	 The [Confirmation of module startup] message box is displayed. 

Click [OK].

>>	The [Progress] dialog box is displayed.

[3]	 Confirm that no error has occurred during the [Scanning of actual module 

configuration].

If an error has occurred, refer to the “Message” and “Cause and Action” •	

sections of ■ Message List (page 5-16), and after taking appropriate 

action, start again from step [1].

If no error has occurred, resume process from step [4].•	

[4]	 The [Confirmation of communication setting overwriting] message box is 

displayed. 

Click [No].

[5]	 The [Build project] message box is displayed. 

Click [No].
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[6]	 The [Scanning of actual module configuration complete] message box is 

displayed. 

Click [OK].

[7]	 Select a workgroup from the Project window, and use one of the following 

methods to write parameters to the modules.

Select [3: Parameter writing] under [Operation list] in the [Workgroup] •	

view’s contents area.

Select [Online] •	 → [Write Parameters] from the Project window’s menu 

bar.

Select the •	  icon from the Project window’s tool bar.

[8]	 The [Confirmation of parameter write] message box is displayed. 

Click [Yes].

>>	Writing begins, and the [Progress] dialog box is displayed.

[9]	 The [Parameter sending complete] message box is displayed. 

Click [OK].
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Read the parameters of an operating module and change the settings●●

Start up the loader, and acquire actual module configuration from the new project.

[1]	 Click the  icon in the Project window, or select [File] -> [New] from 

the Project window’s menu bar.

>>	The [Create new project] dialog box will then be displayed.

[2]	 Select [Automatic configuration from actual module] and click [OK].

>>	The Collection of the module’s information begins, and the [Progress] 

dialog box is displayed.

[3]	 The [Build project] message box is displayed. 

Changes will occur as the module setting parameters are being read, so click 

[Yes].

[4]	 The [Progress] dialog box is displayed for reading progress.

[5]	 The [Parameters received] message box is displayed. 

Click [OK].
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[6]	 When changing the actual module communication settings, change them at 

the [Actual module configuration] window, and perform writing. 

When changing parameters, first change settings in the [Project] window, 

then perform parameter writing.

[7]	 Save the project under different names as necessary.
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5  -  6	 Other

Communication Path■■
A method of module-to-loader connection (Ethernet or USB loader cable) must be 

selected in the communication path. 

When connecting via Ethernet, network interface assignment must be done for the 

PC to be used with the loader.

Select [Online] → [Communications path] from the [Actual module configuration] 

window or Project window’s menu bar.

>>	The [Communications path] dialog box is then displayed.

	 Note

To select a USB loader cable, the following requirements must be met:•	

The USB loader cable must be recognized by the PC when connected.•	

Only 1 module must be registered to the project’s module configuration. •	

Connecting via USB loader cable●●

Connection can only be done via USB loader cable when the project consists of a 

single module.

[1]	 Select [Loader jack] in the combo box of the [Communications path] 

dialogue box.

Click the [Advanced] button, and select the serial port to which the USB 

loader cable is connected. Normally the serial port to which the USB loader 

cable is connected will be automatically selected, so this doesn’t have to be 

changed. 

	 Note
When selecting the loader jack, you can use the radio button in the •	

[Communications path] dialogue box to select either [Normal comm. path] or 

[Custom comm. path]. 
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Connecting via Ethernet●●

Ethernet connection can be done with a project made up of a single or multiple 

modules.

[1]	 Select [Ethernet] in the combo box of the [Communications path] dialog 

box.

[2]	 Select the [Custom comm. path] radio button, then click [Advanced].

[3]	 Assign a network interface to the PC to be connected to module(s).
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Network Profile■■
You can set or change network settings for the loader (IP address, default gateway, 

net mask) in the [Network Profile Explorer] dialog box.

The network setting selected as [Activate] here will be used as a network setting 

for the PC while the loader is starting up. Each time the loader starts up after this, 

you can select which network profile to use in the [Network profile initialization 

process] dialog box. 

Also, when the loader is terminated, the network settings will automatically return 

to the same status as before the loader startup (displayed as [Original] in the 

[Network profile] window). 

 Handling Precautions
If the loader is terminated abnormally, the network profile will recognize •	
that the loader is still being used. To return the PC’s network settings 
to the same status as before the loader startup, restart the loader, 
then terminate it. The [Select profile] window will be displayed. Select 
[Original] in this window to return the network settings to the same status 
as before the loader startup.
When using the network profile function to change the PC’s network •	
settings, do not remove the Ethernet cable during  processing. 
Otherwise, network settings may not be changed correctly.

Select [Online] → [Network profile] from the [Actual module configuration] 

window or Project window’s menu bar.

>>	The [Network Profile Explorer] dialog box is then displayed.
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New●●

Select [New] from the [Network Profile Explorer] dialog box’s tool bar.

>>	A new network profile will be created. 

Currently used network settings will be copied as they are, so make changes as 

necessary. 

For details on how to make changes, refer to: 

 ● Edit (page 5-36).

 Handling Precautions
Before creating a new network profile, confirm that the name “New •	
Profile” is not being used by any existing profile. If a profile with the name 
“New Profile” already exists, change it to a different name. Refer to ● 

Edit Profile Name (page 5-35) for details on renaming a profile name.
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Activate●●

Select a profile name (with a folder icon attached) from the [Network Profile 

Explorer] dialog box’s tree view, then click on the tool bar’s  icon, or 

select [Activate] from the right click menu.

>>	This will apply the selected network profile as settings for the PC starting up 

the loader, and will also cause the selected network profile to be selected as a 

default value each time the loader starts up from now on.

When selecting [Activate]:

>>	A check mark will be added to the tree view’s profile name with “In use” as a 

profile, when that network profile has actually been enabled as a network setting 

for the PC.
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Delete●●

Profiles other than the “In use” profile and “Original” profile can be deleted.

Select a profile name (with a folder icon attached) from the [Network Profile 

Explorer] dialog box’s tree view, then click on the tool bar’s  icon, or select 

[Delete] from the right click menu.
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Edit Profile Name●●

Profiles other than the “In use” profile and “Original” profile can be renamed.

Select a profile name (with a folder icon attached) from the [Network Profile 

Explorer] dialog box’s tree view, then directly alter the name from the tree view, or 

change it via the profile name edit pane text box.

Network Device Information●●

When you want to view the network interface IP address, sub net mask, or default 

gateway information of a certain profile, select a network interface name under the 

tree view’s profile name.

>>	The information will be displayed in the Network Device Information pane on 

the right.
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Edit●●

The network interface IP address, sub net mask, and default gateway for profiles 

other than “Original” can be edited.

Select a network interface name from under the tree view’s profile, then click 

[Edit] from the tool bar, or from the network device information pane.

Exit●●

This button exits the [Network Profile Explorer] dialog box.

Select [File] → [Exit] from the menu bar, or click the [Exit] button in the lower 

right corner of the dialog box.

Chapter 5. ACTUAL MODULE COMMUNICATION SETTINGS

5–36



Communications Options■■
Set message timeout, etc. for module communication when connected via loader 

cable.

Normally this does not have to be changed.

Select [Online] → [Communications options] from the [Actual module 

configuration] window or Project window’s menu bar.

>>	The [Communications options] dialog box is then displayed.

Minimum Communication Interval (ms)●●

Determine the interval to send  the next request message after the reception of the 

response to the previous one.Values cannot be changed.

Timeout (ms)●●

Determine the time taken for the response to a request message.

If there is no response within the timeout period, and the number of times of 

resending a request is specified, the request will be resent the specified number of 

times.

Resend (number of times)●●

Determine the number of times of resending a request message when the response 

to the request message is timed out. 
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Chapter 6.	 PARAMETER SETTING
6  -  1	 Creating a Project

Overview■■
Modules handled with the loader, such as module parameter settings, etc. are called 

projects. This chapter describes how to create a project.

Select [File] → [New] from the Project window’s menu bar, or click the  

icon.

>>	The [Create new project] dialog box will then be displayed.

The [Module configuration selection] radio buttons are described below.

Selecting [Single module configuration] to create●●

When selecting the [Single module configuration] radio button to create a project, 

module configuration is registered as a single unit. The model number of the 

registered module is NX-D15NT4T00.

After creating the project, the model number can be changed, and additional 

modules can be added. For details, refer to:

 ■ Selecting [Single module configuration] to Create a Project (page 6-2).

Selecting [Multiple module configuration] to create●●

When selecting the [Multiple module configuration] radio button to create a 

project, the project will be created without any module being registered.

After the project is created, module configuration will be defined. For details, refer 

to:

 ■ Selecting [Multiple module configuration] to Create a Project  
(page 6-4).

Selecting [Automatic configuration from actual module] to create●●

When selecting the [Automatic configuration from actual module] radio button to 

create a project, a scan is performed of the actual module configuration to detect 

and register module configuration information from the actual module. For details, 

refer to:

 ■ Selecting [Automatic configuration from actual module] to Create a 
Project (page 6-6).
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Selecting [Single module configuration] to Create a Project■■
The following steps explain how to automatically register the module configuration 

for a single module while creating a project.

The model number of the registered module is NX-D15NT4T00.

[1]	 Select [File] → [New] from the Project window’s menu bar, or click the 

 icon.

>>	The [Create new project] dialog box will then be displayed.

[2]	 Select [Single module configuration] and click [OK].

	 Note

If a new project is created while another project is already open, the  •	

[Confirmation of new creation] message box will be displayed. To close the 

opened project and start a new one, click [Yes]. 

If you don’t want to close the opened project, click [No].
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[3]	 A [New project] message box is displayed when the new project has been 

created. Click [OK].

>>	A workgroup display will then appear in the project tree.

[4]	 Select [1: Module definition] from the workgroup display’s contents area.

>>	Here you can confirm the model number NX-D15NT4T00 is registered 

for a single module configuration.

	 Note
You can change NX-D15NT4T00 to another model number by changing the •	

module type or model number. You can also add modules.
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Selecting [Multiple module configuration] to Create a Project■■
The following steps explain how to create a project without automatically 

registering module configuration.

[1]	 Select [File] → [New] from the Project window’s menu bar, or click the 

 icon.

>>	The [Create new project] dialog box will then be displayed.

[2]	 Select [Multiple module configuration] and click [OK].

	 Note
If a new project is created while another project is already open, the  •	

[Confirmation of new creation] message box will be displayed. To close the 

opened project and start a new one, click [Yes]. 

If you don’t want to close the open project, click [No].
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[3]	 A [New project] message box is displayed when the new project has been 

created. Click [OK].

>>	A workgroup display is then shown at the project tree.

[4]	 Select [1: Module definition] from the workgroup display’s contents area.

>>	Here you can confirm that no modules have been registered to the module 

configuration. 

	 Note
For details on module configuration settings, refer to: •	

 6-2  Defining Module Configuration (page 6-11).
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Selecting [Automatic configuration from actual module] to Create a Project■■
The following steps explain how to use the actual module configuration scan 

function to acquire module communication settings from the actual module when a 

project is created. 

 Handling Precautions
The following steps describe how actual module communication settings •	
are applied to a module. 
If you are not going to set actual module communication settings, first 
refer to 

 5-2  Defining IP Address and Node Address (page 5-7) , and then 
number an IP address, etc. to the module.

[1]	 Select [File] → [New] from the Project window’s menu bar, or click the 

 icon.

>>	The [Create new project] dialog box will then be displayed.

[2]	 Select [Automatic configuration from actual module] and click [OK].

	 Note
If a new project is created while another project is already open, the  •	

[Confirmation of new creation] message box will be displayed. To close the 

opened project and start a new one, click [Yes]. 

If you don’t want to close the open project, click [No].
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[3]	 The actual module configuration scan will begin.

>>	The [Progress] dialog box is displayed.

Depending on actual module configuration scan results, the project will 

differ as follows.

[3]-1	 If there are no errors

>>	The [Build project] message box is displayed.

If you want to coordinate a parameter reading 

click [Yes] in the [Build project] message box. Then move on to step [4].

If a parameter reading is not necessary 

click [No] in the [Build project] message box. Then move on to step [7].

To cancel an actual module configuration scan 

click [Cancel] in the [Build project] message box. 

[3]-2	 If an error occurs

>>	The [Error in scanning of actual module configuration] message box will 

be displayed. 

	 Note

For details, refer to: •	

 ■ Message List (page 5-16).

Click [OK] in the [Error in scanning of actual module configuration] 

message box.

>>	The [Confirmation of transition to the actual module configuration 

window] message box will be displayed. 

When clicking [Yes] in the [Confirmation of transition to the actual module 

configuration window] message box, the [Actual module configuration] 

window shown in step [5] in 5-2 Defining IP Address and Node Address 
(page 5-7) will be displayed. 

Clicking [No] will end the process. First work to avoid the displayed error.
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[4]	 If the settings are unable to directly communicate with modules connected 

via PC network settings, a [Network profile search] dialog box is displayed.

If the settings are able to directly communicate with modules connected via 

PC network settings, the parameter receiving process begins.

In this case, move on to step [5].

 Handling Precautions
If no appropriate profile exists in the list of registered profiles and the •	
[Profile search result] dialog is displayed, an error may be generated 
when an attempt to create a new profile is made by pressing the [OK] 
button. This means that a profile with the name “New Profile” already 
exists. Change it to a different name. Refer to ● Edit Profile Name (page 
5-35) for details on renaming a profile name.

[4]-1	 If an applicable profile is available among those registered, a dialog box is 

displayed to confirm whether or not the found profile will be used.

<When using a registered profile that is displayed>

	 Click [OK] and move on to step [5].

<When not using any profile that is displayed >

	 Click [Cancel].

Note)	When network settings are incorrect, and parameters cannot 

be read, a [Confirmation of continuation] message box will be 

displayed. In this case click [Cancel], then confirm module and 

PC network settings.

When clicking [OK] in the [Confirmation of continuation] 

message box, the process in step [5] will resume, but since the 

module and PC network cannot directly communicate with each 

other, the [Process failure] message box is displayed.
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[4]-2	 If an applicable profile is not available among those registered, a dialog box 

is displayed to confirm whether or not you want to create a new profile.

<When creating a new profile>

Click [OK] to create a new applicable profile, and a dialog box will be 

displayed to confirm whether or not you will use it.

When clicking [OK] again, the profile will switch to a new one. In this 

case, move on to step [5].

If you do not want to use the new profile, click [Cancel].

Note)	When network settings are incorrect, and parameters cannot 

be read, a [Confirmation of continuation] message box will be 

displayed. In this case click [Cancel], then confirm module and 

PC network settings.

When clicking [OK] in the [Confirmation of continuation] 

message box, the process in step [5] will resume, but since the 

module and PC network cannot directly communicate with each 

other, the [Process failure] message box is displayed.

<When not creating a new profile>

Click [Cancel].

Note)	When network settings are incorrect, and parameters cannot 

be read, a [Confirmation of continuation] message box will be 

displayed. In this case click [Cancel], then confirm module and 

PC network settings.

[5]	 When receiving parameter files, the [Progress] dialog box is displayed.

[6]	 When the files have been received, the [Parameters received] message box is 

displayed. Click [OK].

Then move on to step [8].
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[7]	 A [New project] message box is displayed when the project has been 

created.Click [OK].

[8]	 A workgroup display will then appear in the project tree.

[9]	 Select [1: Module definition] from the workgroup display’s contents area.

When information acquired from network modules is shown on the module 

configuration display, registration of module configuration settings can be 

confirmed.
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6  -  2	 Defining Module Configuration

When selecting [1: Module definition] in the Project window → [Workgroup] view’s contents area, the module 

configuration belonging to the workgroup will be displayed.

	 Note
The actual module configuration’s chain is a workgroup.•	

Select [1: Module definition] from the [Workgroup] view’s contents area.

>>	The [Module configuration] screen is then displayed.
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In the [Workgroup] view’s [Module configuration] screen, module types (basic model number), module names 

(automatically named by loader if a module that acquired information has no name), and model numbers that 

belong to the workgroup are listed.

 Handling Precautions
If  a module type on the list is changed, the [Confirmation of module  •	
type modification] message box is displayed. When a module’s type is 
changed, all of its parameters will be initialized.

Adding Modules■■
To add a module to the workgroup’s module configuration, select the [Add] button 

or [Add a copy] button.

Selecting the [Add] button to add a module●●

A single, undefined module will be added. In [Type], select a basic model number, 

then register a name and model number.
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Selecting the [Add a copy] button to add a module●●

Select the module to be copied in the module list, and then click [Add a copy].

>>	The [Add copy confirmation] dialog box will then be displayed. 

This function will also copy parameters of the copied module.

Set the copy conditions (number of copies), and click [OK].

Clicking [Cancel] will cancel the process.

When setting the number of copies and clicking [OK], the [Add copy completed] 

message box is displayed, and the designated number of copied modules are added.
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Delete■■
Select the module to be deleted in the module list, and then click [Delete]. When 

the [Delete confirmation] message box is displayed, click [Yes].

>>	The selected module will then be deleted.

Edit■■
Have a module to edit selected in the module list, then click [Edit].

>>	The selected module will then be selected in the project tree. 

Select  from the tool bar, or double click the selected position on the project 

tree to display parameters for the selected module on the project tree. 

For details on parameter editing, refer to: 

 6-3 Editing Parameters (page 6-15).

	 Note

Parameters displayed in the project tree will differ according to user level. •	

For details on user levels, refer to: 

 ■ User Levels (page 6-18).

Set Model Number (Confirm or Change a Module’s Model Number Details)■■

[1]	 When information is acquired via the actual module configuration scan, it 

is usually unnecessary to change model number details. When you want to 

confirm or change a module’s model number details, select the module in the 

module list, and then select [Set model number].

>>	The [Module model number setting] dialog box is displayed.

[2]	 Select a radio button for the model number you want to change, then click 

[OK]. The selected model number will be changed.

	 Note

When you already know the model number, it can be changed directly by •	

entering it in the [Model number] text box. (Excluding basic model numbers)

When entering a model number manually, or changing it after creating a •	

project with the actual module configuration scan function, a write error will 

occur during parameter writing if it is inconsistent with the actual module’s 

model number.

Initialize■■
Have a module selected for parameter initialization in the module list, then click 

[Initialize].

>>	 Parameters for the selected module will be initialized.
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6  -  3	 Editing Parameters

Each parameter can be edited by performing the following steps.

[1]	 Select the module to be edited in the module configuration display list, and 

then click [Edit].

>>	The selected module will then be selected in the project tree.
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[2]	 Click the [+] mark displayed on the left of the module name’s node.

>>	Categories will then be displayed.

[3]	 Click the [+] mark on the left of any category name.

>>	The parameter bank will then be displayed.
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[4]	 Click the parameter bank name.

>>	An editor grid will then be displayed for that parameter bank in the 

contents area.

For basic/setup•	

For basic/loop (extended)•	
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[5]	 Enter data values directly, or select an option from the combo box to change 

parameters.

For combo box•	

User Levels■■
Parameters displayed by the loader will differ depending on the user level.

There are three user levels in total, as shown below.

Simple	 : Only basic settings are displayed.•	

Standard	 : Standard functions are displayed.•	

Multi-function	 : More advanced functions are displayed.•	

For details, refer to:

 Each module’s user manual.

[1]	 To change the user level, select [View] → [Set user level] from an open 

project, or from the [Actual module configuration] window’s menu bar.

>>	The [User level setting] dialog box is then displayed.

[2]	 Select a level you want to change from the combo box, then click [OK].

	 Note

When the loader is started next time by the same user of the Windows, the •	

user level will be the same as when the loader was terminated previously. 
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Copy■■
Select a single parameter cell, string numbers (select all strings), or line numbers 

(select all lines), then right click and select [Copy] (or press Ctrl+C), to copy the 

selected data area to the copy buffer.

Paste■■
Select a single parameter cell, string numbers (select all strings), or line numbers 

(select all lines), then right click and select [Paste] (or press Ctrl+V), to paste the 

data values copied to the copy buffer. Note that “select all strings” and “select all 

lines” will be pasted within the same parameter bank.

When pasting, the data setting range of the paste destination will be applied.

Edit■■
Selecting and right clicking a single parameter cell, then selecting [Edit], enables 

you to directly change data. (Parameters normally entered in a combo box can also 

be used.)

Setting Up the Inter-Module Data Forwarding Function■■
This function enables you to use monitor data or parameters from other modules as 

actual module parameters via the actual module’s user-defined bits or user-defined 

numbers.

	 Note
User-defined bits and user-defined numbers are used one at a time for •	

parameters each time remote data is used. 

For details on which parameters can use the inter-module data forwarding 

function, refer to: 

 Network Instrumentation Module User’s Manual for Network Design 
(CP-SP-1313).

 Handling Precautions
The model numbers of certain modules are not compatible with the inter-•	
module data forwarding function. 
Example: NX-D15 is not compatible with the inter-module data 
forwarding function.
Modules using the inter-module data forwarding function must have •	
different node IDs within the same workgroup.
After setting up the inter-module data forwarding function, parameters •	
must be written tor the actual module and other module as shown in 6-5 
Writing Parameters (page 6-37). 
Write parameters for both modules or all workgroups.

Steps for this process are explained below.
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Basic Steps●●

As an example, the Logical Operation Function’s input assignment A data will be 

used in the DI input port status of another module.

To use the Logical Operation Function, the user level must be set to [Standard] or 

[Multi-function].

[1]	 Click the down arrow on the combo box for the [Input assignment A] 

parameter setting in the [Logical operation] parameter bank.

[2]	 There are two types of combo boxes: Level 1 and Level 2. Select a user-

defined bit from Level 1, then select a number that is not being used for 

anything else from Level 2.

	 Note

If the user-defined bit is already in use, the remote data name will be •	

displayed in its place.

[3]	 Click [Yes] on the [Remote data confirmation] message box.

	 Note

When clicking [No], the user-defined bit number of the selected number will •	

be assigned.
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[4]	 The [Remote data selection] dialog box is then displayed. 

Select the necessary data. Select [DI1 terminal status] from the targeted 

module’s [Standard bit] bank.

	 Note

This data number is displayed when the far right pane is divided by channel •	

or loop. If there is only one, it will be selected automatically.

[5]	 Click [OK] to confirm, and when exiting the [Remote data selection] 

dialog box, you can confirm that data from another module is selected for 

parameter as seen below.

Clicking [Cancel] in the [Remote data selection] dialog box will register the 

assigned user-defined bit number, but not the remote data.
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Steps for using the same remote data for multiple parameters●●

The following steps explain how to use remote data being used as parameters for 

different parameters within the same module.

As with basic steps, the process of registering the DI input terminal status of 

another module to the Logical Operation Function’s 2 (Input) Input Assignment A 

will be used as an example.

[1]	 Make sure the basic steps have already been completed.

In order to use the same remote data for other parameters click the down 

arrow on the combo box - 2 (input) - for [Input assignment A] in the Logical 

Operation Function as done in the basic steps.

[2]	 When selecting a user-defined bit from the Level 1 combo box, the remote 

data name is displayed in the user-defined number, which has already been 

in use on the Level 2 combo box since basic steps were performed. Select 

that. (The DI1 terminal status of D25_2 is used in the example below.)

	 Note

If already in use, the remote data name will be displayed in place of the user-•	

defined bit’s data name.
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[3]	 Click [Yes] on the [Remote data confirmation] message box.

	 Note

When clicking [No], only the selected user-defined bit number will be •	

assigned. Parameters set during the basic steps will also be user-defined bit 

numbers.

[4]	 Data will already be selected in the [Remote data selection] dialog box. 

Click [OK] or [Cancel].

[5]	 You can confirm that the same remote data is being used for different 

parameters.
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Steps for cancelling the use of a single parameter when the same remote data is being ●●

used for multiple parameters
The following steps describe how to cancel single parameter use of remote data 

being used for multiple parameters. The steps performed when using the same 

remote data for multiple parameters will be used as an example. The same remote 

data will be used for the Logical Operation Function’s (Input 1 and Input 2) Input 

Assignment A.

[1]	 The same remote data is already selected from ● Steps for using the 
same remote data for multiple parameters. To only cancel some use of 

the remote data for parameters, click the down arrow in the combo boxes of 

those parameters.

[2]	 You can confirm that remote data is selected in the combo boxes.

[3]	 In the combo box, change to a user-defined bit number that hasn’t been 

assigned to remote data, or change to an option other than the user-defined 

bit. This allows you to change exclusive use of those parameters to local 

data. (In the example below, [Always 0 (Off)] has been selected in the [ON/

OFF] option.
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[4]	 You can confirm that only a portion of the parameters have been set to local 

data.
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Steps for clearing all remote data use when the same remote data is being used for ●●

multiple parameters
The following steps explain how to clear all remote data use when remote data is 

being used for more than one parameter.

The same remote data used for basic steps, with the Logical Operation Function’s 

Input Assignment A, will be used for this example.

[1]	 The “● Steps for using the same remote data for multiple parameters” 

must already be completed. To clear the use of remote data for multiple 

parameters, click the down arrow in the combo box of any parameter.

[2]	 You can confirm the remote data is selected in the combo box.

[3]	 After performing step [2] above, click the 2nd level’s selection status name 

(in the example above, it is the DI1 terminal status of D25_2).

[3]-1	 Click [Yes] on the [Remote data confirmation] message box.
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[3]-2	 Click [Clear] on the [Remote data selection] dialog box.

[4]	 You can confirm that remote data is no longer assigned as any of the 

parameters.

	 Note

If using the same remote data  while using different user-defined bit •	

numbers/user-defined numbers, perform the clear process for each instance.

After performing the clear process, parameters will be the same  as user-•	

defined bit numbers/user-defined numbers that were being used. When 

assigning different remote data to those user-defined bit numbers/user-

defined numbers, all parameters using those numbers can use the remote 

data. 
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Steps for clearing remote data use from the [Remote data selection] combo box●●

Remote data use can also be cleared by right clicking numbers you want to clear •	

from the Level 2 combo box, then selecting [Clear].

Data Check■■
With a project open in the Project window, selecting [Edit] → [Data check] from 

the menu bar enables you to check the parameters of all modules registered to the 

project. If no problems are indicated by the data check results, the following will 

be displayed.

If problem(s) are indicated by the results, the following [Data check] message box 

is displayed.

	 Note
The setting range will be inspected during normal input, but changing upper/•	

lower limits, or altering the decimal point position, etc. will check the range of 

other settings if they are changed. 

Fields output to each line of the error display are as follows.

No. Description

1 The mapping data module’s IP address

2 Module name

3 The parameter category name

4 The parameter bank name

5 The parameter item name

6 Error message

Chapter 6. PARAMETER SETTINGS

6–28



6  -  4	 Mapping

Overview■■
Mapping is to associate a module configured via workgroup with an actual module.

Mapping data are module communication settings.

Mapping data can be set up in the view of [Mapping], on the Project window’s 

project tree.

If there is an available module, you can use the actual module configuration scan 

function to acquire module configuration and actual module communication 

settings, and set up mapping data automatically.

Module communication settings will be defined and written to the module in the 

[Actual module configuration] window.

If there is not any available module, you can set module communication settings as 

mapping data in advance by following this mapping procedure.

Creating a Mapping■■
Since a mapping can be created when you create a project, or when you use the 

actual module configuration scan function, the tasks described in this section are 

usually not necessary.

When you want to delete and re-create the mapping, follow the steps described 

below.

[1]	 Go to the Project window’s project tree and select the [Mapping] workgroup 

for creating mapping data. Confirm that mapping data is empty in the [List] 

screen,  then select [Add].
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Editing Mapping Data■■
When you use the actual module configuration scan function to acquire module 

configuration and actual module communication settings, mapping data can be set 

up automatically. Therefore, the tasks described in this section are not necessary. 

When you create a project offline, a mapping will be created, but mapping data will 

not be set up.

To edit mapping data, perform the following steps.

[1]	 Select the [Mapping] workgroup from the Project window’s project tree.

Confirm that the mapping data is displayed in the [List] screen, and click 

[Edit].

[2]	 The [Individual Mapping] screen is then displayed.
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[3]	 Set the IP address and node ID. Clicking the text box enables you to enter 

them directly. Also, by clicking [Automatic numbering], setting the first IP 

address and node ID in the [Automatic module numbering] dialog box, and 

clicking [OK], you can perform setup via consecutive numbering.

	 Note
If multiple workgroups are on the same network, workgroup ID will be used for •	

identification.

Editing/Managing Communication Settings■■
Communication settings other than the module’s IP address and node address are 

set via the Mapping view’s [Set communication].

You can set the following.

Settings Screen

Type Name Description
All

(page 6-32)
Chain Name
(page 6-33)

Module basic 
setting

Set the following value to 
all modules

Checks this box when performing the 
automatic address numbering prohibition 
function for all modules.

 —

Automatic address 
numbering is prohibited.

Excludes modules from auto address 
numbering.

 

IP setting Netmask IP net mask  —
Default gateway IP default gateway  —

Port settings Set the following value to 
all modules

Checks this box when you want port 
settings to apply to all modules.

 —

Dedicated communication 
port number

Cannot be changed.  

MODBUS communication 
port number

MODBUS/TCP function’s port number  

CPL communication port 
number

CPL/TCP communication port number 
(Unsupported)

 

RS-485
detailed settings

Set the following value to 
all modules

Checks this box when you want the 
changes to RS-485 setting to apply to all 
modules.

 —

RS-485 device address Device address used for host 
communication (RS-485).

— 

RS-485 protocol Host communication (RS-485) protocol 
selection

 

RS-485 transmission rate Transmission speed used for host 
communication (RS-485)

 

RS-485 bit length Bit length used for host communication 
(RS-485)

 

With/without RS-485 parity 
status

With/without parity used for host 
communication (RS-485)

 

RS-485 stop bits Stop bit used for host communication 
(RS-485)

 

RS-485 minimum 
response time

Minimum response time used for host 
communication (RS-485)

 
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When configuring communication settings common to a workgroup●●

The steps are explained below.

[1]	 Go to the Project window’s project tree and select the [Mapping] workgroup 

for editing mapping data. 

Confirm that workgroup configuration is not empty in the [List] screen, and 

click [Set communication].

[2]	 The [Communication settings (all)] dialog box will then be displayed. 

Set the necessary items, then click [OK].
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When configuring communication settings for each module●●

The steps are explained below.

[1]	 Go to the Project window’s project tree and select the [Mapping] workgroup 

for editing mapping data. 

Confirm that workgroup configuration is not empty in the [List] screen, and 

click [Edit].

[2]	 Select a module line in the [Individual Mapping] screen, then click [Set 

communication].
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[3]	 The [Communication settings (module)] dialog box will then be displayed.

Set the necessary items, then click [OK].

Mapping to Actual Module with Edited Mapping Data■■
When there is not any available module, and module communication settings (IP 

address/node address, communication settings, etc) have been set as mapping data, 

you need to write the mapping data to the actual module before you use the module 

actually.

The steps are explained below.

[1]	 Display the mapping data to be written.

Confirm that the mapping data is displayed in the [List] screen, then click 

[Edit] to display the [Individual Mapping] screen.

Click [Acquisition of actual module configuration] at the [Individual 

Mapping] screen.

[2]	 The [Actual module configuration] window opens.

Execute an actual module configuration scan.
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[3]	 If an error with the actual module is confirmed during the actual module 

configuration scan, close the [Actual module configuration] window, and 

return to the [Individual Mapping] screen.

	 Note

For details on error messages, refer to: •	

 ■ Message List (page 5-16).

[4]	 Actual module configuration data acquired through the actual module 

configuration scan is then displayed in [Actual module configuration] in the 

contents area.

* Select the chain.

[5]	 By dragging and dropping a module (illustration) under [Mapping] onto 

a module (illustration) under [Actual module configuration], the mapping 

data will be mapped to the actual module configuration information. Once 

mapping is completed, the module (illustration) under [Actual module 

configuration] will change in color from gray to black.

Drag & drop
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	 Handling Precautions

If the module’s basic model number (module type) does not match •	
up, drag and drop cannot be performed. In this case, you will have 
to change the module type in the module configuration display, or 
change the actual module.

	 Note

If there are multiple workgroups, the same operation will have to be •	

performed for each one as necessary.

By holding down [Shift] and clicking to select multiple modules, then •	

dragging and dropping them, mapping can be performed for multiple 

modules at once.

In the tasks described in this section, you would only do mapping on the •	

loader. (The mapping data is not written to the actual module.) 

To write the mapping data to the actual module, write actual module 

communication settings from the [Actual module configuration] window.
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6  -  5	 Writing Parameters

Parameters can be written to all modules in a workgroup at once, or to an individual module.

 Handling Precautions
Once parameter writing is complete, the module will be reset (restarted). •	
Confirm operational status and start working.

Workgroup Batch Writing■■
This is a method for writing parameters to all modules in a workgroup.

This method is possible only via Ethernet. (USB loader cable is not supported.)

Set up the communication path and network profile in advance.

[1]	 Select a workgroup from the Project window’s project tree for batch 

parameter writing. 

By performing one of the following operations, all parameters can be written 

to modules belonging to the workgroup.

Select [3: Parameter writing] under [Operation list] in the [Workgroup] •	

view’s contents area.

Select [Online] •	 → [Write Parameters ] from the Project window’s menu 

bar.

Select the •	  icon from the Project window’s tool bar.

[2]	 When the [Confirmation of parameter write] message box is displayed, click 

[Yes] to write parameters.

[3]	 When writing parameter files, a [Progress] dialog box is displayed.
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[4]	 When writing is completed normally, and the [Parameter sending complete] 

message box is displayed, click [OK] to end the process.

If writing is completed abnormally, error information will be displayed.

After dealing with the error situation, write parameters again.
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Writing to a Single Module■■
This is a method for writing parameters to all modules in a workgroup.

When writing parameters to a single module, it can be performed via Ethernet, 

or via USB loader cable. Set up the communication path and network profile in 

advance (when using Ethernet).

 Handling Precautions
When using a USB loader cable, the USB driver must be installed in •	
advance. 

 Refer to “1-4 Installing the USB Loader Cable Device Driver” (page 
1-12).

The USB loader cable’s connection path can only be set when mapping •	
data of a single module has been set to the project. When the mapping 
data of multiple modules is set to the project, a USB loader cable cannot 
be used.

When using the inter-module data forwarding function, make sure the •	
project has mapping data from multiple modules. 
In order to be executed, the inter-module data forwarding function 
requires the setting information of each module that data will be 
exchanged between. Please note that when reading the parameters 
of a single module, then writing them after that, the inter-module data 
forwarding function may operate in an unintended way.

[1]	 Select a module from the Project window’s project tree for parameter 

writing. Parameters can be written to the module via one of the following 

methods.

Select [3: Parameter writing] under [Operation list] in the [Workgroup] •	

view’s contents area.

Select [Online] •	 → [Write Parameters] from the Project window’s menu 

bar.

Select the •	  icon (when using Ethernet) or the  icon (when using 

USB loader cable) from the Project window’s tool bar.

[2]	 Steps after this are the same as with ■ Workgroup Batch Writing. 

 Refer to page 6-37.
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6  -  6	 Monitoring Module Operations

Overview■■
Monitoring of module operations is done in the [Universal monitor] window. For 

details, refer to:

 Chapter 7. UNIVERSAL MONITORING.

 Handling Precautions
When changing parameters in the universal monitor, the changes are •	
applied to modules, so the loader’s project data remains unchanged. 
If the changes need to be applied to the project data as well, perform 
parameter reading.

Method of Operation■■
A simple sequence method is explained as follows.

[1]	 Select a workgroup from the Project window’s project tree to display the 

[Workgroup] view. Perform one of the following operations to start up the 

universal monitor.

Select [4: Monitor] under [Operation list] in the [Workgroup] view’s •	

contents area.

Select [Online] •	 → [Monitor] from the Project window’s menu bar.

Select the •	  icon from the Project window’s tool bar.

>>	 The Universal Monitor Startup dialog box is then displayed.
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[2]	 When the startup process has ended, the [Universal monitor] window will be 

displayed.

[3]	 When selecting [Monitor] → [Start] from the [Universal monitor] window’s 

menu bar, the status bar’s communication status will change from [Wait] to 

[OK], and the monitor will start up.

Monitor startup operation•	
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After monitor startup •	

(When a module is selected for monitoring from [Module configuration] 

at the [Universal monitor] window’s monitor tree.)

[4]	 To change a specific module’s parameters and operational status, select a 

target module from the [Universal monitor] window’s monitor tree, display 

the numeric monitor settings tab, double click the target for performing 

numeric grid changes, change values in the [Writing online] dialog box, and 

click [OK] to confirm the changes.
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[5]	 To cancel a monitor operation, select [Monitor] → [Stop] from the 

[Universal monitor] window’s menu bar.

[6]	 When cancelling a monitor operation, the [Universal monitor information] 

message box is displayed, asking whether or not a CSV-format trend log file 

should be output. 

If a trend log file is needed, click [Yes].

	 Note

Even when clicking [No], a CSV-format trend log file can still be created.•	

[1]	Select [File] → [Log file conversion] from the [Universal monitor] 

window’s menu bar.

>> The [Open log file] dialog box will then be displayed.

[2]	Select a file that you want a CSV-format trend log file output from, and 

click [Open].

>> The [Save As] dialog box will then be displayed.

[3]	Click the [Save] button.

>> �A CSV-format trend log file is created, and the [Universal monitor 

information] message box is displayed.

[4]	Click [Yes], and Explorer will start up.
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[7]	 To exit the universal monitor, select [File] → [Exit] from the [Universal 

monitor] window’s menu bar.
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6  -  7	 Reading Parameters

There are two methods to read parameters: parameter reading on a workgroup basis. and parameter reading on a 

module basis.

Workgroup Batch Reading■■
This is a method for reading parameters from all modules in a workgroup.

This method is possible only via Ethernet. (USB loader cable is not supported.)

Set up the communication path and network profile in advance.

[1]	 Select a workgroup from the Project window’s project tree for batch 

parameter reading. By performing one of the following operations, 

parameters can be read from all modules belonging to the workgroup.

Select [5: Parameter reading] under [Operation list] in the [Workgroup] •	

view’s contents area.

Select [Online] •	 → [Read Parameters] from the Project window’s menu 

bar.

Select the •	  icon from the Project window’s tool bar.

[2]	 When the [Confirmation of parameter read] message box is displayed, click 

[Yes] to read parameters.
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[3]	 When reading parameter files, the following [Progress] dialog box is 

displayed.

[4]	 When reading is completed normally, and the [Parameters received] message 

box is displayed, click [OK] to end the process.

If reading is completed abnormally, error information will be displayed in a 

message box.

After dealing with the error situation, read parameters again.
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Reading from a Single Module■■
This is a method for reading parameters  on a single module basis.

The parameters of a single module can be read via Ethernet, or via USB loader 

cable. Set up the communication path and network profile in advance (when using 

Ethernet).

 Handling Precautions
When using a USB loader cable, the USB driver must be installed in •	
advance. 

 Refer to “1-4 Installing the USB loader cable device driver” (page 
1-12).

The USB loader cable’s connection path can only be set when mapping •	
data of a single module has been set to the project. When the mapping 
data of multiple modules is set to the project, a USB loader cable cannot 
be used.

When using the inter-module data forwarding function, make sure the •	
project has mapping data from multiple modules. 
In order to be executed, the inter-module data forwarding function 
requires the setting information of each module that data will be 
exchanged between. Please note that when reading the parameters 
of a single module, then writing them after that, the inter-module data 
forwarding function may operate incorrectly.

[1]	 Select a module from the Project window’s project tree for parameter 

reading. Parameters can be read from modules via one of the following 

methods.

Select [5: Parameter reading] under [Operation list] in the [Workgroup] •	

view’s contents area.

Select [Online] •	 → [Read Parameters] from the Project window’s menu 

bar.

Select the •	  icon (when using Ethernet) or the  icon (when using 

USB loader cable) from the Project window’s tool bar.

[2]	 Steps after this are the same as with ■ Workgroup Batch Reading. 

 Refer to page 6-45.
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6  -  8	 Saving a Project

Overview■■
This section describes how to save a project as a file.

Method of Operation■■

[1]	 A project file can be saved by using one of the following methods.

Select [File] •	 → [Save] from the Project window’s menu bar.

Select [File] •	 → [Save as] from the Project window’s menu bar.

Select the •	  icon from the Project window’s tool bar.

[2]	 When saving a new project, or saving a project under another name, the 

[Save project] dialog box will appear. Set the saving options (name, location) 

and click [OK].

[3]	 When the file has been successfully saved, and the [Save project] message 

box is displayed, click [OK].

	 Note
The project file is kept in a folder (of multiple files). When moving the project •	

file to a different destination, move the entire folder.
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6  -  9	 Opening a Project

Overview■■
Saved projects can be opened again with the loader.

Method of Operation■■

[1]	 Select [File] → [Open] from the Project window’s menu bar, or click the 

 icon on the Project window’s tool bar.

[2]	 When the project is opened, a [Confirmation of opening] message box will 

be displayed.

To exit a project that is already open, click [Yes].

If you don’t want to exit the open project, click [No].

	 Note

When clicking [Yes] and continuing on with work, the project will remain •	

open when cancelling from step [3].
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[3]	 The [Open] dialog box will then be displayed.

If a previously saved project exists, that project is designated as the initial 

value.

If you want to go with the previously saved project, click [Open], and if you 

want to open a different project, designate it and click [Open].

If you want to cancel, click [Cancel].

[4]	 Once reading of the project file has completed, a [Reading projects] message 

box is displayed. Click [OK], and a Workgroup view is displayed.

Chapter 6. PARAMETER SETTINGS

6–50



6  -  10	 Output to CSV File

Overview■■
All module parameter settings registered to the project (including IP address, etc.) 

can be output to a CSV file. 

Method of Operation■■

[1]	 Select [File] → [CSV output] from the Project window’s menu bar.

[2]	 In the [Save as] dialog box, specify a [Location] and [File name], then select 

[Save].

The CSV file will be output.

Fields output to each line are as follows.

No. Field Name Description

1 IPAddress The mapping data module’s IP address
2 WorkgroupID The mapping data module’s workgroup ID
3 WorkgroupName The workgroup’s name
4 ModuleName The module’s name
5 ModuleType The module’s model number
6 NodeID The mapping data module’s node ID
7 FolderName Parameter category name
8 BankName Parameter bank name
9 Name Parameter item name

10 DataType Parameter type
11 RAM Address RAM address for access via host communication
12 EEPROM Address EEPROM address for access via host communication
13 Value Setting value
14 DefaultValue Initial value (default)
15 Diff Difference from initial value (default) output with “*” mark

	 Note
Parameters output via CSV file output are organized by user level. For details on •	

user levels, refer to: 

 6-3 Editing Parameters (page 6-15), and the user manual of each 

module.
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Chapter 7.	 UNIVERSAL MONITOR
7  -  1	 Monitoring Function Overview

Universal monitor is used for monitoring the module status, or verifying the operation status during test running or 

actual running after a parameter is changed, etc. 

 Handling Precautions
Universal monitor does not include general-purpose 24-hour data-logger •	
functionality. 
It can be used for temporary monitoring such as in test-run adjustment. 
Please do not use the universal monitor function for long-term data 
sampling or continuous alert monitoring, etc. 
Because universal monitor is not an application software designed for 
long-term operation, such usage may result in the stoppage of data 
sampling, effects on the other application software due to a high load on 
the computer being used, or insufficient hard-disk space. 
Make sure that the computer’s power option settings will not allow it to go 
into sleep or standby mode when universal monitor is operating. Also, be 
sure to ensure that there is sufficient space on the hard disk by checking 
it and moving log files accordingly, etc., even when not using this function 
continuously.

Universal monitoring flow of operation■■

Starting Universal 
Monitor

page 7-2
Universal Monitor Window 
page 7-3 
- Simple monitor operations 
- Available windows 
- Performing the monitoring

Offline 
page 7-37 
- Redisplaying and analyzing 

the collected trend log

Settings 
page 7-25 
- Setting dialog box

Custom Monitoring
page 7-29 
- Customizing the monitoring 

target 

Trend Memo 
page 7-35 
- Registering/listing a memo in 

the trend graph 
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Start the universal monitor using one of the procedures below: 

In the workgroup display of the [Project] window, select [4. Monitor] from the [Operation list]•	

Select [Online] •	 → [Monitor] from the menu bar of the [Project] window. 

Click the  icon on the tool bar of the •	  [Project] window. 

The selection of [Online] → [Monitor] from the menu bar of the [Project] window is shown below. 

The following window is displayed after starting the Universal monitor.

	Note
Universal monitor will operate with a user level based on the status when it was •	

started. To change the user level of parameters for the universal monitor, make 

the changes (“6-3 Editing Parameters”, 6-15), and then close and restart the 

universal monitor. 

When the [Universal monitor] window is closed, the position of each window •	

is stored and windows are displayed the same way when the program is started 

next. 

7  -  2	 Starting Universal Monitor
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7  -  3	 Universal Monitor Window

The structure of the [Universal monitor] window is shown below. 

[Monitor tree] [Trend monitor] [Trend group] [Bit display monitor]

[Numeric monitor] Tab
[Crossline data] Tab Numeric Monitor and Crossline Data

[Alarm monitor] Tab
Tool Bar
Menu Bar

Status Bar

Numeric Monitor
[Monitor] Tab

Numeric Monitor
[Settings] Tab

Title Bar

Categories 
Individual

The window names and functions displayed in the [Universal monitor] window are as follows. 

The window can switch between floating and docking modes.

[Monitor tree] window●●

In conjunction with the [Numeric monitor] window, displays a list of monitored 

modules and loops that can be selected.  

[Trend monitor] window●●

Displays graph data for each monitor in real time.

[Trend group] window●●

Shows graph view/hide, colors, and the latest data values for the [Trend monitor] 

window. 

[Bit display monitor] window●●

Displays the bit display target parameters for the module(s) selected in the 

[Monitor tree].

[Alarm monitor] window●●

Displays alarm status in a grid and in front automatically when an alarm occurs.

Also, if the mouse cursor is placed over the [Alarm monitor] tab, the [Alarm 

monitor] window will be displayed in front. 

[Numeric monitor] window●●

Displays in a grid the parameters of modules and loops selected in the [Monitor 

tree], making them editable. When the [Numeric monitor] tab is clicked, the 

[Numeric monitor] window is displayed. 
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	Handling Precautions

When the [Setting] tab of the [Numeric monitor] window is selected, •	
an editable grid is displayed. Changes cannot be made with the 
[Monitor] tab. Also, depending on the parameters, changes cannot be 
made in some cases. For details,  

 please refer to the user’s manual for each module.

[Crossline data] window●●

Displayed when the [Crossline data] tab is clicked. Displays the crossline cursor 

value from the [Trend monitor] window. This can be used when monitoring is 

being stopped. 
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Project Window - Menu Configuration List■■

Menu Submenu 1 Submenu 2 Description Remarks

File Log file Open log file Reads the log file (CSV format) and displays 
the trend monitor.

Enabled only when 
monitoring is being 
stopped.Open log file [Multi-

time mode]
Reads multiple log files (CSV format) and 
groups the data if the same data type exists.

Log file conversion — Select the file and then select the output 
format.

Copy graph to 
clipboard

— Copies the graph drawing region of the trend 
monitor to the Clipboard.

Start control profile — Not supported —

Exit — Closes the [Universal monitor] window. Enabled only when 
monitoring is being 
stopped.

Monitor Start — Starts monitoring. Enabled only when 
monitoring is being 
stopped.

Exit — Stops monitoring. (The graph is not cleared.)
After monitoring is stopped, the [Universal 
monitor information] dialog box is displayed, 
prompting whether to output a CSV file of the 
trend log.

The graph is not 
cleared until [Start] is 
selected again.

Settings Edit monitoring data — For details, refer to  7-7 Custom Monitoring 
(7-29).

Enabled only when 
monitoring is being 
stopped.Communication 

destination
— For details, refer to  “Communication 

destination” (7-25).

Monitor settings — For details, refer to  “Monitor settings” 
(7-25).

Trend color settings — For details, refer to  “Trend monitor color 
settings” (7-26).

Options — For details, refer to  “Options” (7-27).

Record View trend memo — For details, refer to  “7-8 Trend Memo” 
(7-35).

—

Trend memo 
registration

— For details, refer to  “7-8 Trend Memo” 
(7-35).

—

Window Fixed-position 
window

— Prohibits floating of windows. Turn ON/OFF by 
adding/removing a 
check mark.

Return to standard 
position

— Returns the position of each window to their 
standard positions.

Enabled only when the 
[Fixed-position window] 
menu item is OFF.

View Monitor tree Displays the [Monitor tree] window. If the window is already 
displayed, it becomes 
active.

Trend monitor Displays the [Trend monitor] window.

Crossline Data Displays the [Crossline data] window.

Trend Group Displays the [Trend group] window.

Numeric monitor Displays the [Numeric monitor] window.

Alarm monitor Displays the [Alarm monitor] window.

Bit display Monitor Displays the [Bit display monitor] window.

Favorite Add favorites Registers the current window configuration. —

Organize favorites Changes or deletes the names of window 
configurations registered to favorites.

—

Help Show help — — Nothing is displayed.

About (version info) — Displays the [Version] dialog box. —
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Window configuration operations■■
The [Universal monitor] window consists of multiple windows placed together. 

Size adjustments, as well as switching between floating and docking modes, can be 

made by dragging these windows.

Positionally fix window●●

By selecting [Window] → [Fixed-position window] from the menu bar of the 

[Universal monitor] window, the positions of all windows are fixed, and floating is 

prohibited.  

Checked: Fixed-position window

Return to standard window position●●

Clicking on [Window] → [Return to standard position] from the menu bar of the 

[Universal monitor] window will return all windows to their standard positions. 

	 Handling Precautions

[Return to standard position] is only enabled when [Fixed-position •	
window] is not checked. 

•	
Window redisplay●●

From the pop-up menu displayed by clicking [Window] → [View] from the menu 

bar of the [Universal monitor] window, the selected window is displayed in front. 

Window position memory●●

When the [Universal monitor] window is closed, the position of each window is 

stored and each window is displayed in the same position when the program is 

started next. 

Closing windows●●

To close a window, click the  icon on the window’s title bar. 
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7  -  4	 Starting or Stopping Monitoring

Starting monitoring■■

[1]	 Select [Monitor] → [Start] from the menu bar of the [Universal monitor] 

window.

>>	Monitoring begins.

[2]	 Select [Module] in the [Monitor tree].

>>	[Numeric monitor] and [Bit display monitor] are displayed. 

	 Handling Precautions

Do not edit or delete module configurations when monitoring is being •	
started. When changing module configuration, close the [Universal 
monitor] window, and restart it after writing to the module(s). 
When using the Universal monitor with a USB loader cable in an •	
environment with multiple modules, do not connect the USB loader 
cable to a different module after starting monitoring. Restart the SLP 
or reopen the project. 

Stopping monitoring■■

[1]	 Select [Monitor] → [Exit] from the menu bar of the [Universal monitor] 

window.

>>	The [Universal monitor information] message box is displayed.

	Note

Even if the [No] button is selected, monitoring will stop. •	

To reopen monitoring, follow the procedure in ■ Starting monitoring. 

Even if the [No] button is selected, a CSV-format trend log file can be •	

created afterward using the procedure below.

1.	 Select [File] → [Log file conversion] from the menu bar of the [Universal 

monitor] window. 

2.	 Select a CSV-format trend log file as the file that you want to output in 

the [Open log file] dialog box that is displayed. 

3.	 Click on the [Open] button. 

4.	 Click on the [Save] button in the [Save As] dialog box. �
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[2]	 When outputting a trend log file, click on the [Yes ] button.

>>	A trend log file (CSV format) is created, and the [Universal monitor 

information] message box is displayed confirming whether or not to open 

the location where the file was stored with Explorer.

[3]	 To confirm the CSV-format trend log file with Explorer, click the [Yes] 

button.

>>	The output trend log file (CSV output) is displayed in Explorer. 
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7  -  5	 Explanations of Individual Windows

Monitor tree window■■
The Monitor tree window is as follows.

 

➞

 

Configuration●●

The [Default] and [Custom] tabs make up this window. 

[Default] tab •	

Displayed based on each category and the individual units for categories for the 

workgroup configuration.

[Custom] tab •	

Information is displayed in the [Custom] tab once the custom monitoring 

function (“7-7 Custom Monitoring”, 7-29) has been registered. 

Coordination with the [Numeric monitor] window and the [Bit display monitor] window●●

The [Numeric monitor] window and the [Bit display monitor] window are 

displayed in conjunction with the selection of modules and module categories. 

Right-click menu●●

Menu items Functions Remarks

Copy data Copies the level of the 
monitor tree.

—

Paste data Pastes the copied level to 
the applicable level. This 
menu is enabled when the 
[Custom] tab is selected in 
the [Monitor tree] window.

—

Register to trend monitor Registers the selected tree 
to the trend monitor.

Enabled only when the 
[Custom] tab is selected in 
the [Monitor tree] window.

Move to the previous 
module

Moves to the tree of the 
module previously edited.

Enabled only when the 
previously edited module 
exists.

Back to function Not supported —
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[Numeric monitor] window■■
The [Numeric monitor] window displays data related to a category selected in the 

[Monitor tree]. 

Example: � When modules are selected on the Monitor tree of the controller module

Displayed data●●

Displayed data comes from a model prepared as a loader from each category, the 

data from which is displayed in the [Default] tab of the [Monitor tree] window. 

When the necessary data is not in this model,  

 7-7 Custom Monitoring (page 7-29), build custom data, and display the 

[Custom] tab. 

Right-click menu●●

Menu items Functions Remarks

Copy items Copies cell data. Disabled when a column or 
row header is selected.

Add copied items Adds data copied with 
[Copy items] to the end 
of the columns on the 
Numeric monitor (in the 
case of Custom).

Enabled only when the 
[Custom] tab is selected in 
the [Monitor tree] window 
and the column header 
of the numeric monitor is 
selected.

History of PID parameter 
change*

Checks the changed PID 
setting parameters.

—

* The History of PID parameter change function is enabled for controller modules. 

Settings tab and Monitor tab●●

The [Numeric monitor] window is divided into the [Setting] tab and the [Monitor] 

tab. 

In the [Setting] tab, with data writable to a module, data can only be written when 

monitoring is being started. 

In the [Monitor] tab, even with data writable to a module, data can only be viewed 

when monitoring is being started. 
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Numeric grid display■■
The tabs of the [Numeric monitor] window are displayed in the following format 

based on a category or the individual units in a category selected in the [Monitor 

tree] window. 

If a category has been selected •	

The lists of the main data for the selected category and the data for the 

individual units in the category are displayed in the [Numeric monitor] window.  

If the cells of the numeric grid are clicked, item names are displayed as tool tips.

If the individual units in a category have been selected •	

The list of data for the individual units in the selected category is displayed in 

the [Numeric monitor] window.  

Example: �Select the controller module loop in the Monitor tree

Editing values●●

In the [Numeric monitor] window [Setting] tab, if monitoring has been started, 

When a grid cell is double-clicked•	

or

When the [Enter] key is pressed•	

Values can be set in the [Writing online] dialog box that is displayed. 

Clicking the [OK] button in the [Writing online] dialog box writes the input values 

to the module(s). 

If the [Cancel] button is clicked, the values entered in the [Writing online] dialog 

box are not applied. 

Based on the data type of the target value, one of the two [Writing online] dialog 

boxes below will be displayed.
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Change by numeric input•	

Enter a numeric value in the edit box of the [Writing online] dialog box, click 

the [OK] button, and when the dialog box is closed, the value is written to the 

module.  

If the [Cancel] button is clicked, the value entered is not applied.  

When the [OK] button is clicked, a check of the upper and lower limit values of 

the edited value is performed, and if the data is out of range the entered value 

will remain the same as previously confirmed.  

Change by selection (2 options)•	

A list box with two options is displayed in the [Writing online] dialog box.  

Select one of these from the list box and click the [OK] button. The value is 

written to the module when the dialog box is closed.  

If the [Cancel] button is clicked, the value entered is not applied. 

Editing the row unit value●●

When a row header is clicked, the data in the same row is selected.

Also, if a row header is double-clicked, the [Writing online] dialog box 

corresponding to the selected row data is displayed, and the edited value is applied 

to all selected data. 

For the initial value displayed in the [Writing online] dialog box, the value of the 

leftmost item is displayed, even in the case of an edit box or radio button. 

Example:	 If the “Setting value (LSP)” cell is double-clicked and settings made 

with multiple loops displayed, all “Setting value (LSP)” for the target 

loops can be changed.
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Data registration to unconfigured groups in the [Trend group] window●●

[Monitor tree] window, if categories or individual units for each category are 

selected, the applicable data is displayed in the Numeric monitor. If a drag-and-

drop operation from the [Numeric monitor] window to a [Trend group] window 

unconfigured group is performed with either a numeric monitoring cell, column 

header, or row header selected, a trend group with the selected data range 

registered is created. 

When a column header is selected the item name is set for the trend group category 

name, when a row header is selected the column name is set, and when a cell is 

selected the module name is set.

	 Handling Precautions

This operation can only be used when monitoring is being stopped.•	

Data registration to existing groups in the Trend group window●●

[Monitor tree] window, if categories or individual units for each category are 

selected, the applicable data is displayed in the Numeric monitor. If a drag-and-

drop operation from the [Numeric monitor] window to a [Trend group] window 

existing group is performed with either a numeric monitoring cell, column header, 

or row header selected, the data dragged from the source is added to the group data 

of the drop target. 

In this case if a column header or row header is selected, all selected column or 

row data is added.

	 Handling Precautions

This operation can only be used when monitoring is being stopped.•	

History of PID parameter change (with controller modules)●●

If a right-click is performed with a column header in the [Numeric monitor] 

window selected, [History of PID parameter change] is displayed. 

If the [History of PID parameter change] menu is selected, the [History of PID 

parameter change] dialog box is displayed. 
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Trend monitor window■■
The [Trend monitor] window is displayed in the following way. 

Trend monitoring can display the graphs of up to eight groups at the same time. 

If the mouse cursor is placed on the graph area, the name of the [Trend group] 

window will be highlighted. 

Graph display area scrolling•	  

Dragging the vertical axes on the left or right, or the graph display area (left/

right mouse button for vertical axes, right button for graph area) will scroll the 

graph rendering area. 

Scroll vertically by trend group units, or scroll the entire group when including 

the horizontal axis. 

This function can be used when rendering a graph during monitoring or 

displaying a graph after stopping monitoring. 

* Can also be used in the Universal monitor [Offline]. 

To return to initial status (entire monitor is an updated graph), use the same 

method as for cancelling [Zoom], described below. 

	Note

When scrolling only the vertical axis while monitoring is being started, •	

graph rendering will be continued.  

When scrolling to the future area with the horizontal axis, graph rendering 

will continue until the graph reaches the right side of the display area, but 

will stop after it has been reached. Also, when scrolling to the past area, 

rendering will stop with the current graph. Data sampling will continue. 

Example:	 The vertical axis on the left of the graph is specified with the 

mouse pointer. 
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Zoom•	  

By holding down the left button of the mouse and dragging from upper left to 

lower right to form a rectangle in the graph area, the graph display for the trend 

group where you performed the operation will be enlarged. 

To cancel zoom display, perform the reverse, dragging the mouse from lower 

right to upper left to draw a rectangle. 

This function can be used when rendering a graph during monitoring or 

displaying a graph after stopping monitoring. 

* Can also be used in the Universal monitor [Offline]. 

Graph rendering stops when zoom is used. 

* When zooming includes the future area, graph rendering will continue until 

the graph reaches the right side of the display area, but will stop after it has been 

reached. Data sampling will continue. 

Crossline cursor•	  

When the mouse cursor is placed within the graph area, the lines displayed on 

the vertical axis are called crosslines. These can be used in conjunction with the 

[Crossline data] window. This function can be used for the entire group.  

* Group units are used in the [Crossline data] window. 

Moving the cursor	:	 The data for points where the crossline cursor and graph •	

overlap is displayed in the [Crossline data] window.

Double-clicking	 :	 The starting point for the crossline cursor is established. •	

(Changes to bold line display. ) If the crossline cursor is 

moved with the mouse, the start point data established 

in the [Crossline data] window and end point data for 

points overlapping with the crossline are displayed.  

* When establishing the start point, if the crossline is 

single-clicked again it is fixed as the end point. Clicking 

again cancels the fixed end point. Double-click the start 

point to cancel it.

Display time	 :	 Time displayed in trend monitoring is displayed in •	

relative time and absolute time, and is updated on the 

monitoring cycle. Display time is switched between 

absolute time and relative time by selecting [Settings] → 

[Options] from the menu. 

	 Handling Precautions

This can be used when graph data is being displayed in the graph •	
area. 
This operation can only be used when monitoring is being stopped.  •	
Can also be used in the Universal monitor [Offline].

•	  ■ Crossline data window (page 7-21) regarding the [Crossline data] 

window display contents. 
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Absolute time	 :	 Displays the current time. The horizontal axis display •	

format is “MM/dd hh:mm:ss.fff”.

Relative time	 :	 Displays monitoring start time as 0. The horizontal axis •	

display format is “hh:mm:ss.fff”. The trend graph is 

displayed in the range of 0:00:00-23:59:59, and when 24 

hours has elapsed the time display is reset to 0:00:00. 

Display time length (X axis on a graph)●●

Select [Settings] → [Monitor settings] from the menu bar of the [Universal 

monitor] window. 

The [Monitor settings] dialog box is displayed. 

Select one of the seven display lengths (1 min, 2 min, 10 min, 1 h, 12 h, 24 h, and 

automatic) in [Display time length] in [Trend graph settings]. 

Settings can also be made using  in the [Universal monitor] window 

tool bar. 

	Note

Display time length settings can be changed from the tool bar even when •	

monitoring is being started. 

Display length settings will be stored and become the initial settings next •	

time that universal monitor is started. 

	 Handling Precautions

Display time length cannot be changed by using [Settings] •	 → [Monitor 
settings] from the menu bar of the [Universal monitor] window while 
monitoring operations are active. 

Chapter 7. UNIVERSAL MONITOR

7–16



Set trend high and low limit values (graph Y axis) to desired values●●

Select [Settings] → [Monitor settings] from the menu bar of the [Universal 

monitor] window. 

The [Monitor settings] dialog box is displayed. 

Either “Automatic” or “Fixed” (range entry setting) can be set in [Trend graph 

settings] → [High and low limits]. 

	Note

The target will be all trend groups and the left and right axes. •	

The same settings can be made in [Y axis high and low limits settings] in the •	

[Trend group] window. This operation can be used to make settings for trend 

group units and for each left and right axis. 

	 Handling Precautions

This operation can only be used when monitoring is being stopped.•	

Automatic clearing of displayed data●●

Select [Settings] → [Monitor settings] from the menu bar of the [Universal 

monitor] window. 

If a fixed sample number (10,000 items) of data is displayed, the graph display will 

be automatically cleared. 

Settings range, etc. 

 ■ List of Value Limits (page 8-2). 

	 Handling Precautions

This operation can only be used when monitoring is being stopped.•	

Zoom in, zoom out●●

Select the icon from the [Universal monitor] window tool bar. 

 Icon	 : Zoom in

 Icon	 : Zoom out

One click enlarges or reduces by 25%.

This can be used either when monitoring is being started or stopped. 

* The Universal monitor [Offline] can also be used. 

Manual horizontal scrolling●●

Select the icon from the [Universal monitor] window tool bar. 

 Icon	 : Return to start time

 Icon	 : Advance to most recent time

 /  Icon	 : Scrolls one-half of the screen

 /  Icon	 : Scrolls one-fourth of the screen

This can be used either when monitoring is being started or stopped. 

* The Universal monitor [Offline] can also be used. 
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Trend group window■■
The [Trend group] window groups registered data, and can perform display in the 

[Trend monitor] window and sampling status operations. 

Items are displayed in list format.

A maximum of 32 data items can be registered in a group.

A maximum of eight registered trend groups can be displayed at the same time in 

the [Trend monitor] window. 

To display data registered to a trend group, click either the leftmost  icon or the 

group name. 

Display items●●

Items are displayed from the left side in order as follows.

[Data sampling switchover] check box•	  

Switch the data sampling status of the trend monitor. There are two statuses, and 

their meanings are given below.  

 Icon :  Makes a trend group the target for sampling 

 Icon :  Does not make a trend group the target for sampling 

To switch the sampling status, click the icon portion.

[Graph update switchover] check box•	  

Switches the graph view/hide status. Checks can be selected for three levels. The 

meaning of each check is given as below. 

Check status of groups•	  

 Icon :  Views all data registered to a group 

 Icon :  Hides all data registered to a group 

 Icon :  Views some of the data registered to a group, and hides the other 

Changing the check mark for an entire group switches only between the two 

states of view/hide. To switch the view state, click the icon portion. 

Check status of individual data items•	  

 Icon :  Display target data in graph 

 Icon :  Do not display target data in graph 

To switch the display state, click the icon portion.
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Item names•	  

Displays group names and data names. 

If the name is longer than the display length, placing the mouse cursor over 

the name will display the entire name in a tool tip. 

For custom-registered trend groups, item names can be changed when 

monitoring is being stopped. 

<For a group name> 

Selecting [Data name change] from the right-click menu displays the [Data 

name change] dialog box in which a name can be changed. 

<For a data name> 

Double-clicking a cell or selecting [Data name change] from the right-click 

menu displays the [Data name change] dialog box in which a name can be 

changed.

Graph rendering color•	  

Displays the line color of the corresponding graph. 

If the graph color cell is double-clicked, the [Trend graph settings] dialog 

box is displayed, and the line color, the line type, and the display axis for the 

corresponding graph can be set. 

The latest data values•	  

The latest values of the corresponding data are displayed in real time. 

Values cannot be changed.

Functions●●

Select [Monitor] → [Start] from the menu bar of the [Universal monitor] window. 

The latest data values of the trend group and the trend graph are updated in real 

time.

Selecting [Monitor] → [Exit] from the menu stops monitoring and updating of both 

of the trend graph and the latest data values. 

The trend graph and latest data values will not be cleared until the start of 

monitoring is selected again.

The monitoring cycle can be changed to a desired value. The default is 400 msec 

via Ethernet, and 2,000 msec via a USB loader cable. 

The trend graph is automatically allocated depending on the number of graph 

display check boxes selected in each group name for trend groups.

The number of allocations is up to eight items vertically.

Allocated graphs are linked to trend group data in order from the top area.

The order in which items are displayed in trend groups can be changed by dragging 

and dropping header items when monitoring is being stopped.

By dragging and dropping definitions from the Numeric monitor or the Bit display 

monitor to the Trend group, data to monitor can be added.

	 Handling Precautions

Because data sampling for the [Trend group] window and [Numeric •	
Monitor] window are conducted individually, values for the same data 
may be displayed differently. 
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Trend group right-click menu●●

Menu items Functions Remarks

Full-screen display Displays only the selected group in the [Trend 
monitor] window.
The header of the group that is full-screen display 
in the window is displayed in yellow.

—

Y axis high and low limits 
settings

Displays the [Y axis high and low limits settings] 
dialog box.
Set the [Y axis high and low limits settings] for the 
selected group.
For details, refer to the  [Y axis high and low 
limits settings] dialog box (below).

—

Digital trend switchover Switch the selected group to the digital trend 
setting.
The header of the selected group when set is 
displayed in blue.

Enabled only when 
monitoring is being 
stopped.

Trend graph settings Displays the dialog box for setting the line color, 
the line type, and the display axis.
Set all information of data registered under a 
group.
For details, refer to the  [Trend graph settings] 
dialog box (below).

—

Data name change Displays the dialog box for changing the data 
name.
Set the name of the selected data.
For details, refer to the  [Data name change] 
dialog box (next page).

Enabled only when 
monitoring is being 
stopped.

Remove from trend monitor. Enabled only when a group is selected.
Removes the selected group from the trend 
monitor. (Groups registered by default cannot be 
deleted.)

Remove individual data Enabled only when data is selected, and then 
removes the selected data.

[Y axis high and low limits settings] dialog box •	

Set the Y axis high and low limits for the applicable group.

[Trend graph settings] dialog box •	

Set the line color, the line type, and the display axis for the graph of the 

applicable data.
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[Data name change] dialog box 

Set the name of the applicable data.  

Click the [OK] button. 

	Note

The [Return to default.] button will be enabled when a different name •	
is entered, and the name is returned to the name at the time that the 
dialog box was initiated. 

Crossline data window■■
Crossline data is displayed as follows.

Display items●●

Data name •	

Displays trend group data names when moving the cursor in the [Trend monitor] 

window, or those corresponding to double-click locations.

Start point value X, start point value Y •	

Displays trend group start point times and values at start point when moving the 

cursor in the [Trend monitor] window, or those corresponding to double-click 

locations. 

End point value X, end point value Y•	  

Displays trend group end point times and values at end point when moving the 

cursor or double-clicking when the start point has been established in the [Trend 

monitor] window. 

	Note

If no data exists, [–] is displayed.•	

Y axis difference value•	  

Displays the difference between start point value Y and end point value Y. 

Tilt•	  

Displays the tilt between start point values (X, Y) and end point values (X, Y). 

Functions●●

The crossline function is only enabled when monitoring is being stopped.

When the cursor is moved in the trend graph, perpendicular lines are rendered in 

the trend graph area, displaying corresponding each value for Y from the X axis 

value.

Displays the difference value/tilt between the point double-clicked on the trend 

graph and the point to which the mouse has been moved or which was clicked in 

coordinates.
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Bit display monitor window■■
The [Bit display monitor] window is described below. 

Example:  Controller module

If a category is selected in the [Monitor tree] window, the content for bit display is 

displayed in the [Bit display monitor] window. 

It is possible to register bit data to the [Trend monitor] window by selecting it 

in the [Bit display monitor] window and dragging and dropping it in the [Trend 

group] window. 

When registering data to the [Trend monitor] window, a message to confirm 

whether to set it as a digital trend will be displayed. 

If data rows are double-clicked when monitoring is being started, the [Bit display 

monitor -- online writing] dialog box is displayed and values can be changed.

[Bit display monitor -- online writing] dialog box •	

If data rows are double-clicked when monitoring is being started, the [Bit 

display monitor -- online writing] dialog box is displayed.

Select one of the choices and click the [OK] button, and when the dialog box 

closes the value is written to the module.  

If the [Cancel] button is clicked, the value entered is not applied. 
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[Alarm monitor] window■■
The [Alarm monitor] window is displayed in the following way. 

When an alarm occurs, the [Alarm Monitor] window is displayed in front. 

Set the integral multiple of the monitor cycle as the alarm cycle. The default value 

is 5,200 msec. The cycle can be changed in the [Monitor settings] dialog box by 

selecting [Settings] → [Monitor settings] from the menu bar of the [Universal 

monitor] window. 

	Note

When no alarm has occurred [Alarm monitor] tab will be displayed. •	

[Alarm monitor] tab display 

 7-3 Universal Monitor Window (page 7-3)
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Status bar■■
The following information is displayed in the status bar of the [Universal monitor] 

window. 

Monitor time display●●

At the left end of the status bar, the most recent time of data sampling based on the 

monitoring cycle is displayed in the “YYYY/MM/DD hh:mm:ss.msec” format.

The difference between the time of the previous data sampling and the current time 

is displayed following the hyphen in msec.

Display example:  

Monitor COM status display●●

The communications status is displayed at the right end of the status bar.

The following three types of status are displayed.

[Wait] : Monitoring is being stopped

[OK] : Monitoring is being started

[Break] : Response stopped due to a communications error when monitoring is 

being started

Display example:  

Zoom status display●●

The zoom status of Trend monitor is displayed at the right end of the status bar.

Operations for which [ZoomIn] is displayed are as follows.

Zooming while dragging and dropping within the trend monitor•	

When trend group header is right-clicked and [End full-screen display] is •	

selected

When the zoom in icon on the toolbar •	  is selected

Display example:  

Operations for which [ZoomOut] is displayed are as follows.

When the zoom out icon on the toolbar •	  is selected

Display example:  

Version information■■

To display the version information of the Universal monitor, select [Help] → 

[About (version info)] from the menu bar of the [Universal monitor] window.

>>	The version information of universal monitor is displayed as follows.
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7  -  6	 Settings

Communication destination■■

[1]	 Select [Settings] → [Communication destination] from the menu bar of the 

[Universal monitor] window.

>>	The [Communication destination] dialog box is displayed.

[2]	 The displayed content is as follows. 

[Server] •	

The set IP address and port number are displayed.

[Module] •	

Select the module to be edited from the combo box and confirm the IP 

address, port number and node address.

[3]	 After confirming, click the [OK] button.

Monitor settings■■

[1]	 Select [Settings] → [Monitor settings] from the menu bar of the [Universal 

monitor] window.

>>	The [Monitor settings] dialog box is displayed. 

[2]	 The displayed content is as follows. 

[Monitoring cycle] •	

Set the monitor data sampling cycle in msec. 

The initial value is “400”. *If the communication path is Ethernet

[Graph update freq.] •	

Select how frequently to update (once per # monitoring cycles). The 

initial value is every “2” cycles. 
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[Alarm cycle] •	

Set the alarm information data sampling cycle in msec. 

The initial value is “5,200” msec; set as an integral multiple of the 

monitor cycle.

[High and low limits] •	

Set the high and low limit values for data displayed in the graph area. 

The Y axis of the trend graph will be fixed within the range of set values 

if fixed values are selected. 

The initial setting is “Automatic”.

[Display time length] •	

Set the time range for data displayed in the graph area. 

The X axis displayed in the trend graph is determined according to the 

value selected in the combo box. 

The initial value is “1 min”.

[Fixed Sample] •	

Specify the number of data to be held in one graph area. 

The initial value is “10,000”.

[3]	 After making the settings, click the [OK] button. 

Trend monitor color settings■■

[1]	 Select [Settings] → [Trend color settings] from the menu bar of the 

[Universal monitor] window.

>>	The [Trend monitor color settings] dialog box is displayed.

[2]	 The displayed content is as follows.

[Line color] •	

Select the graph’s line color. 

Clicking the target displays the [Color settings] dialog box. 

[Line type] •	

Select the graph’s line type. 

The six types of line are continuous, dashed, dotted, continuous (thick), 

dashed (thick), and dotted (thick).

[Display axis] •	

Select the display axis for the graph’s line. 

Two types of axis (right, left) may be selected.
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	Note

To return all 32 colors to the default settings, click the [Return to default.] •	

button.  

Initial line types are continuous for tabs [1-16] and dashed for tabs [17-32].  

Initial display axes are the left axis for tabs [1-16] and the right axis for tabs 

[17-32]. 

[3]	 After making the settings, click the [OK] button. 

Options■■

[1]	 Select [Settings] → [Options] from the menu bar of the [Universal monitor] 

window. 

>>	The [Options] dialog box is displayed. 

[2]	 The displayed content is as follows.

[Trend time display settings]•	  

Set whether the trend monitor graph’s X axis will display absolute time or 

relative time from the start of monitoring.

[Trend log settings] •	

Set the trend log file’s core name and output target folder.

Output target folder path specification•	

1.  Direct input

Set the entered folder as the output target. 

* �If the entered folder does not exist, a folder will be created with 

the name entered. 

	Note

If “Log” is entered, \Log in the loader installation folder will be set as the •	

output target. 

2.  �If [Browse] button is clicked to select a folder 

The output target will be set to the location selected.

[Font settings] •	

Set the font displayed in the [Universal monitor] window. Character size 

is fixed. 

[Character code settings] •	

Displays the character code for writing and reading.

Chapter 7. UNIVERSAL MONITOR

7–27



[3]	 Once the settings have been made, click the [OK] button.

>>	The data sampled in the trend monitor is written to an external file as a 

log.  

The file name is [core name]_[time stamp].[file extension].  

The time stamp format is “YYYYMMDDhhmmss”. 

The data written to the log file can be read [Offline] later and displayed in 

a graph. 

Other settings■■
The docking state of each window in the [Universal monitor] window can be saved 

and called up. 

Positionally fix window●●

Select [Window] → [Fixed-position window] from the menu bar of the [Universal 

monitor] window. The docking status, position, and size of each window in 

Universal monitor is fixed. 

Floating windows are locked in the front position even if the [Universal monitor] 

window is moved.

To release a fixed window, select [Window] → [Fixed-position window] again 

from the menu bar of the [Universal monitor] window. 

Return windows to standard positions●●

Select [Window] → [Return to standard position] from the menu bar of the 

[Universal monitor] window. The docking status, position, and size of each window 

in the Universal monitor are returned to standard. 

Save current window status●●

Select [Window] → [Favorite] → [Add to favorites] from the menu bar of the 

[Universal monitor] window. The [Add to favorites] dialog box will be displayed, 

and with the specified name, the window position, size, and docking status will be 

saved. The initial name setting is “Favorite”. 

Data is saved in the loader installation folder.

Organize items registered to favorites●●

Select [Window] → [Favorite] → [Organize favorites] from the menu bar of the 

[Universal monitor] window. 

Registered items will be displayed in a list and can be organized (renamed or 

deleted).

Call up window docking status registered to favorites●●

Select [Window] → [Favorite] from the menu bar of the [Universal monitor] 

window and select the name of the window settings to call up.

The window will be displayed in the saved status.
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7  -  7	 Custom Monitoring

The custom monitoring function is used when customizing monitored items. This section explains the editing 

method for custom monitoring and the corresponding operations in universal monitor. Select the [Custom] tab in 

the [Monitor tree] window to monitor items registered to custom monitoring in the Numeric monitor, etc. Also, 

standard items (models) corresponding to the model numbers and the number of modules in use are automatically 

registered in the [Default] tab of the [Monitor tree] window. The items that can be registered to custom monitoring 

vary depending on user level settings. 

[Custom monitor editing] dialog box■■
To edit custom monitoring, select [Settings] → [Edit monitoring data] from the 

menu bar of the [Universal monitor] window.

>>	The following [Custom monitor editing] dialog box is displayed. 

Edited Data

Monitor Data Tree

Level View

Buttons 
for the Monitor Data Tree

 Handling Precautions
To use content registered to custom monitoring offline •	 (“7-9 Offline”, 
7-37), register it as a trend (trend group). Settings for numeric monitoring 
cannot be used, or this cannot be used offline even if registered to a 
monitor. 

Monitor data tree●●

Displays the tree configuration displayed in the [Monitor tree] window of the 

[Universal monitor] window. 

Monitor data tree button●●

The custom levels of the monitor data tree can be edited.
Button Icon Functions

Add category Creates a new category
Enabled when a custom level is selected in the monitor data tree

Add group Creates a new group
Enabled when a category of a custom level in the monitor data tree is 
selected, adds the group to the selected category level

Copy Copies the level and all settings targeted for monitoring of the selected 
category of group. Enabled when a category or group is selected

Paste Pastes the copied category or group information

Delete Deletes the category or group selected in the monitor data tree

Digital trend Sets the items registered to a category or group as a digital trend
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Right-click menu for monitor data tree●●

Menu Submenu Functions Remarks

New Category Creates a new category.
Enabled when a custom level is selected in the 
monitor data tree.

—

Group Creates a new group.
Enabled when a category is selected in the monitor 
data tree, and the group is added to the selected 
category.

—

Copy — Copies the level of the selected category or group 
and the setting items targeted for monitoring.
Enabled when a category or group is selected in 
the monitor data tree.

—

Paste — Pastes the copied category or group information
Enabled when a custom level item is selected in 
the monitor data tree.

—

Change 
name

— Renames the selected category or group.
Selecting a category or group enables editing of 
the name.
Enter the new name and press the [Enter] key.
The name of the category or group is renamed.
Pressing the [ESC] key cancels editing without 
changing the name.

—

Delete — Deletes the category or group selected in the 
monitor data tree.

—

Trend 
monitor 
settings

— Switches whether or not to view in the trend 
monitor.
The icons of tree items that are set to be viewed 
in the trend monitor are changed, and the 
background color is highlighted in blue.

—

Digital trend Sets or cancels the items registered to a category 
or group as a digital trend.

A check mark on the menu 
indicates that the item is 
set.

View/Hide — Views or hides the category or group in the 
[Monitor tree] window of the [Universal monitor] 
window.
When hide is selected (there is no check mark to 
the left of [View/hide] on the right-click menu), the 
applicable level is not displayed in the monitor data 
tree.

—

Register 
trends by row

— Enabled when a category is right-clicked in the 
monitor data tree.
The [Trend registration by column] dialog box is 
displayed, and registration to the trend group is 
performed.

See also the [Trend 
registration by column] 
dialog box items.

Edit data●●

This is enabled by selection of category items (settings, monitors, trends).

The upper limit for number of data that can be added is 64 for settings and 

monitors and 32 for trends.

To edit setting content, click the [Data] button with a category item (setting, 

monitor, trend) selected, or copy items existing in another category and register 

them. 

Add, delete, or copy data as in ■ “[Select data] dialog box” (7-32), or select a 

row header from the edit data grid in the [Custom monitor editing] dialog box, and 

edit using the right-click menu or the shortcut button.
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Level display●●

Currently, levels of the nodes selected in the monitor data tree are displayed.

Right-click menu for edit data●●

Menu Functions Remarks

Copy row Copies one or more selected rows Enabled when a row header is 
selected

Cut row Cuts one or more selected rows Enabled when a row header is 
selected

Insert copied row Inserts the copied row data above the selected row Enabled only when copied or cut 
row data exists

Delete row Deletes one or more selected rows Enabled when a row header is 
selected

Copy column data �Copies the data of the selected cell Enabled when column data or a 
single cell is selected

Paste column data Pastes the copied column data Enabled when column data or a 
single cell is selected

Shortcut buttons for edit data●●

Shortcut buttons that can perform the same operation as the edit data right-click 

menu are displayed.

From the left,

Copy	•	  button

Cut	•	  button

Paste	•	  button

Delete	•	  button 

the above buttons are displayed.

These buttons are enabled when a row header is selected.

[Data] button●●

This button is enabled when selecting category items (settings, monitors, trends) in 

the monitor data tree.

Custom data monitor parameters are displayed in the New list of the custom editor.

The range displayed in the [Custom monitor editing] dialog box differs depending 

on user level settings. 

Click the [Data] button. 

>>The [Select data] dialog box is displayed.

 ■ [Select data] dialog box (page 7-32).
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[OK] button●●

Clicking this confirms edited items and data and closes the [Custom monitor 

editing] dialog box. 

[Cancel] button●●

Clicking this discards edited items and data and closes the [Custom monitor 

editing] dialog box. 

[Select data] dialog box■■
Selecting category items (settings, monitors, trends) in the Monitor data tree of 

the [Custom monitor editing] dialog box and clicking the [Data] button call up the 

[Select Data] dialog box.

Items set in the [Select Data] dialog box are set as monitor display item candidates 

for new registration in relation to the [Custom monitor editing] dialog box selection 

items. 

 Handling Precautions
The items set in the [Select Data] dialog box are display candidates, •	
and clicking the [OK] button in the [Custom monitor editing] dialog box 
confirms them as display items. 

Search

Add Data

Tree Monitor

Registered Data List

Delete Data

Move Data

Search Data List Input Text BoxExact Match

[Tree monitor] •	

Displays data searched for in the database in a tree format.

[Data search list] •	

Displays all data in the levels selected in the tree monitor.
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[Registered data list] •	

Displays a list of data registered to items selected in the monitor data tree of the 

[Custom monitor editing] dialog box. 

[Search] •	

It is possible to narrow down the data search list with specified conditions 

([Perfect match] check box, [Text box for input]). 

[Perfect match] check box•	

 : �Displays only data that perfectly match the data in the data search list and 

the text input in the text box.

 : �Displays data in the data search list that include the text input in the text 

box.

[Text box for input] •	

Enter subsystem, category, type, and property character strings.

[Add data] button •	

Adds data selected in the data search list to the registered data list.

[Delete data] button •	

Removes data selected from the registered data list from the registered data list.

[Move data] button •	

Moves data specified in the registered data list up or down. 

Multiple items can be selected.

[OK] button •	

Adds items in the registered data list to items selected in the monitor data tree of 

the [Custom monitor editing] dialog box and closes the dialog box. 

[Cancel] button •	

Interrupts the operation and closes the dialog box.
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[Trend registration by column] dialog box■■
Right-clicking a category in the monitor data tree of the [Custom monitor editing] 

dialog box enables the [Register trends by row] menu. Selecting the [Register 

trends by row] menu displays the [Trend registration by column] dialog box, and 

registers the items registered in the [Setting] tab of the [Numeric monitor] of the 

applicable tree level as a trend group. 

Select the row header of the item name and click the [OK] button. 

>>Registered to the monitor data tree as a trend group candidate.
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7  -  8	 Trend Memo

Trend memo overview■■
Trend memo records comments from users and the history of PID parameter 

change.

Trend memo data is linked with a trend log file and saved (The file name is written 

to a trend log in the same way as a PID log).

Trend memos can be recorded by selecting [Record] from the menu bar of the 

[Universal monitor] window or using the right-click menu in the [Trend monitor] 

window. 

Register a trend memo■■
Trend memos can be registered by selecting [Trend memo registration] from the 

right-click menu in the [Trend] window, or by selecting [Record] → [Trend memo 

registration] from the menu bar of the [Universal monitor] window. 

The [Register Trend Memo] dialog box is displayed. 

 Handling Precautions
Trend memo registration is enabled during monitoring after receiving •	
the first trend data. If a trend memo is registered from the menu of the 
[Universal monitor] window, the latest value on the trend graph’s X axis 
(absolute time) is the registration time. 
If registration is done from the right-click menu of the [Trend monitor] 
window, the time at the mouse position will be the registration time.

Display a trend memo■■
To display a trend memo select [Record (R)] → [Trend Memo List (V)] from the 

menu bar of the [Universal monitor] window, or select [Trend Memo List (V)] 

from the right-click menu of the [Trend monitor] window.

>>	The [Trend memo list] dialog box is displayed.

[Delete selected items] Button

[Close] Button

[Push pin] Button

[Delete selected items] button •	

Select one or more row information items and delete them from the trend memo.

[Pushpin] button •	

While the pin is pushed in , the [Trend memo list] dialog box will be 

displayed in front on the [Universal monitor] window. 

Close button •	

Closes the [Trend memo list] dialog box.
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History of PID parameter change■■
Select groups in Numeric monitor column units and click [History of PID 

parameter change] on the right-click menu.

>>	The [History of PID parameter change] dialog box is displayed. 

The [History of PID parameter change] dialog box displays only data related to the 

selected data.
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7  -  9	 Offline

Offline overview■■
The offline function can be used to redisplay registered past trend graphs and 

numeric data. Graphs from multiple points in the past can also be displayed at the 

same time.

PID logs are log files storing data (settings and monitors) targeted to be displayed 

in the [Numeric monitor] window in a time sequence.

Trend data and PID logs are linked by units of groups or categories.

Read PID logs are displayed in the Numeric monitor window of Universal monitor 

[Offline] window.

In the same manner as online mode, the applicable log of the category selected in 

the [Monitor tree] window is displayed.

You can check the settings of log readouts and recorded PID parameters.

	 Note
The offline function cannot be used to write data to modules.•	

In the offline function display, the values of the Numeric monitor are the values •	

recorded when the monitor is stopped, and the Crossline data values are the 

values when perpendicular lines are drawn on the trend graph.

The relationship of files and the writing and reading of log files is as follows.

Trend start Trend stop

Trend log File

PID log File

The PID log file name is 
the same as the trend log 
file name.

Records the PID value of 
when the trend is stopped.

Generates a log file 
and records the PID 
value of when the trend 
is started.

• Writing of log files

Open the log file

Trend log file

PID log file

• Reading of log files
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Viewing Universal monitor [Offline] window■■

Tool Bar
Menu

Status Bar

Individual
Categories

[Monitor tree] 
Window

[Trend monitor] 
Window

[Trend group] 
Window

[Bit view monitor] 
Window

[Numeric monitor] Tab

[Crossline data] Tab [Numeric monitor] Window

The name of each window are as follows.

[Monitor tree] window•	

[Trend monitor] window•	

[Trend group] window•	

[Numeric monitor] window•	

[Crossline data] window•	

[Bit display monitor] window•	

	 Note
The names and functions are the same as •	 “7-3 Universal Monitor Window” 
(7-3). For details, refer to  7-3.

Window docking functions■■
The window docking functions are the same as the [Universal monitor] window. 

For details, refer to  7-6.

The docking functions can be set using [Window] from the menu and the mouse 

operations.

Status bar■■
The following information appears in the status bar.

Monitor time display •	

Displays [Offline].

Communication status display •	

There is no communication in offline mode. [Wait] is displayed at the right end 

of the status bar.

Zoom status display •	

The zoom status display is the same as that in online mode.
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Menu configuration list of the Universal monitor [Offline] window■■
The menu configuration in offline mode is as follows.

Menu Submenu 1 Submenu 2 Description Remarks

File Log file — Select [Open log file] or [Open log file [multi-
time mode](M)].

—

Log file conversion — Always disabled —

Copy graph to 
clipboard

— Copies the graph displayed in the trend 
monitor to the clipboard.

—

Start control profile — Not supported —

Exit — Closes the Universal monitor [Offline] window. —

Monitor — — Always disabled —

Settings Edit monitoring data — Always disabled —

Communication 
destination 

— Always disabled —

Monitor settings — Always disabled —

Trend color settings — Sets the line types and default colors to use 
in trend graphs.
For details, refer to  ■ “Trend monitor color 
settings” (7-26).

—

Options — Always disabled —

Record View trend memo — Displays the [Trend memo list] dialog box.
For details, refer to  “7-8 Trend Memo” 
(7-35).

—

Trend memo 
registration

— Always disabled —

Window Fixed-position 
window

— Prohibits floating of windows. Turn ON/OFF by 
adding/removing a 
check mark.

Return to standard 
position

— Returns the position of each window to their 
standard positions.

Enabled only when the 
[Fixed-position window] 
menu item is OFF.

View Monitor tree Displays the [Monitor tree] window. If the window is already 
displayed, it becomes 
active.

Trend monitor Displays the [Trend monitor] window.

Crossline Data Displays the [Crossline data] window.

Trend Group Displays the [Trend group] window.

Numeric monitor Displays the [Numeric monitor] window.

Alarm monitor Always disabled 

Bit display Monitor Displays the [Bit display monitor] window.

Favorite — Always disabled —

Help Show help — — Nothing is displayed.

About (version info) — Displays the [Version] dialog box. —
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Reading trend logs■■
Data collected at different times can be viewed on the same trend group with the 

offline function.

Select [File (F)] → [Log file (L)] → [Open log file (O)] or [File (F)] → [Log file 

(L)] → [Open log file [Multi-point mode] (M)] from the menu bar of the [Universal 

monitor] window.

When a trend log is read, the Universal monitor [Offline] window is displayed, and 

the data of the applicable log is displayed in the [Trend] window along with the 

trend group.

Other offline group data can be superimposed over a trend group in the Universal 

monitor [Offline] window.

When data is copied, the data set on the graph’s line is continued as is.

You cannot use data added from the Numeric monitor or the Bit display monitor to 

the Trend group in the Universal monitor [Offline] window.

In addition, monitor execution cannot be used in the Universal monitor [Offline] 

window.

Displaying the numeric monitor■■
You can check the recorded parameter values.

You cannot edit values displayed on the Numeric monitor, register data by drag and 

drop to a trend group, or write data to modules.
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Trend group display■■
You can use drag and drop to move parameters by group units. •	

The data to be moved is linked to the destination.

Destination

Drag

Drop

Time axis superimposition •	

The X-axis time can be freely changed and superimposed with the axis. 

Display the [Time axis superposition settings] dialog box from the right-click 

menu of the Trend group.  

The format differs depending on whether the value of the X axis is an absolute 

time or relative time according to the log read mode. 

You can operate and compare the values in real time.

Absolute time:	Displays the selected start time by the entered time.

Relative time:	 Displays the selected start time by the entered time and shift 

direction.

Both the trends collected at an absolute time and at a relative time are displayed 

with the recording start time of collection as the start point of the [Trend Monitor] 

window.

After a trend log is opened, the graph is shifted at the time interval specified with 

the shift time and shift direction settings.
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Examples of trend graph superimposition

 

➞

 

 

Display PID value on Numeric monitor •	

Right-click the group item provided as standard among the trend groups 

and select [Display PID value on numeric monitor] from the submenu. The 

applicable loop is selected in the Monitor tree and the applicable loop value is 

displayed in the Numeric monitor.

Displaying the Bit display monitor■■
The Bit display monitor information cannot be displayed in offline mode.

Displaying the crossline data■■
[Crossline data] tab displays the [Crossline data] window. The crossline cursor 

value on the Trend monitor is displayed. 

The window can switch between floating and docking modes.

For details, refer to 

 ■ Crossline data window (page 7-21).
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Chapter 8.	 RESTRICTIONS AND IMPORTANT NOTES ON USE

PC Power Management■■
In [PC Power Management] (the power conservation function), if the [Turn Off 

Monitor] option has been selected, errors may occur while monitoring using the 

Universal Monitor. 

Do not select the [Turn Off Monitor] option while monitoring. 

In addition, make sure that the hard disk does not go into the hibernation or 

standby mode,

Infrared Devices■■
If any infrared device is installed on your PC and [Use Infrared Communication] is 

selected, errors may occur while monitoring using the Universal Monitor. 

Do not select the [Use Infrared Communication] option while monitoring.

Restrictions on Using Actual Module Configuration Scan■■
When executing an actual module configuration scan, if (non network 

instrumentation) external devices are connected to network instrumentation 

modules without via communication boxes, diagnostic frames (Ethernet multicast 

frames) are sent to the external network for about 6 seconds every 2 msec. 

If any devices, other than this module, are on the external network and are unable 

to handle frames at that frequency, place a communication box in between.

Restrictions (IP Addresses) on Using Actual Module Configuration Scan■■
If an incorrect address has been set in a module using a process other than the 

loader, it may not be possible to scan the actual module configuration correctly.  

Connect to each module individually using a serial port, and perform the actual 

module configuration scan and IP address numbering again. 

Windows Firewall■■
If you are unable to scan the actual module configuration, even though you are 

connected to the network properly, the loader environment may not be registered 

correctly with Windows Firewall.

If this happens, open the Windows Control Panel, click [Security Center], and 

select [Windows Firewall]. In the displayed [Windows Firewall] dialog box, click 

the [Exceptions] tab and, register the [ICServer.exe] directory path name in the 

loader directory by clicking the [Add Program] button. 
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Prohibited Usage of Compressed Folders■■
Do not use Windows folder compression. It is possible that loader operations will 

result in an error.

List of Value Limits■■

Data Unit Limit

Project name and mapping name Characters Not exceeding 20 characters

Subsystem name, node name, and 
chain name

Bytes Not exceeding 16 bytes

Comments Characters 255 characters

Chain ID, subsystem ID, and node 
ID

Range 1 - 65535

No. of project modules No. of modules 31 or less

No. of workgroup modules No. of modules 31 or less

No. of simultaneous trend monitor 
data packets

Data packets 256 or less

1 logging file and No. of image 
samples (No. of fixed samples)

Samples 100 to 60000 or less *1

Monitor cycle Milliseconds 400 msec or more *2

Minimum communication interval Milliseconds 0-1000 *3

Timeout Milliseconds 10-10000 *3

No. of resend times No. of times 0-10 *3

Graph update cycle n times the monitor cycle 1 or more

Alarm cycle Milliseconds Not less than the monitor 
cycle

No. of custom monitor registrations No. of data packets 64 per grid

No. of custom trend registrations No. of data packets 32 per group

No. of trend monitor simultaneous 
displays

No. of trend groups 8

*1:	 Once a value has reached the upper limit, logging files are moved to a 

different file and the graph display is cleared. Samples may not be created to 

a maximum depending on environment factors such as the PC load and the 

number of modules.

*2:	 Data sampling may not be performed in accordance with the monitor cycle 

setting, depending on environment factors such as the PC load and the number 

of modules. 
The recommended monitor cycle settings for specific module numbers are 

shown below.  

Recommended settings:

(For Ethernet communication)

	 1 module	 : 400 msec

	 2-4 modules	 : 1 sec

	 5-16 modules	 : 2 sec

	 17 modules or more	 : 4 sec

(For loader jack communication)

			   2000 msec

*3:	 These are the settings for loader communication (Ethernet and serial). 

(The parameter read/write timeout values are fixed at Ethernet: 50 sec and 

Serial: 40 sec)
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Do not Stop SQL Server Service■■
The SQL Server (SQL EXPRESS) service must be operating to run the loader. Do 

not stop the SQL Server (SQL EXPRESS) service. After installing SQL Server, the 

service is set up to start automatically when starting up the PC. Do not change this 

setting. 

Monitoring of Modules with Error Status through Universal Monitor■■
If modules with a normal status are combined with modules with an error status 

(unable to communicate with the loader), in the [Trend group] window in the 

[Universal monitor] window, change the settings so that data is not sampled for 

modules with an error status. If the system is trying to sample data for modules 

that cannot be communicated with, many timeouts will occur. This will affect 

communication (monitoring) with normal modules. The communication status 

displayed in the status bar in the [Universal monitor] window will alternate 

between [In Progress] and [Interrupted].

Coexistence with Virus Security Software■■
If your PC is installed with security software that has functions such as personal 

firewalls, loader Ethernet communication will be limited and it may not be possible 

to read/write module parameters or execute monitoring through the Universal 

Monitor.

When using the loader, if you do not disable the Windows Firewall function or stop 

security software operations, unexpected errors might occur.

However, if you do disable firewall functions or stop security software, you need 

to consider the risk of computer viruses penetrating the system. We ask you to 

carefully consider this risk and assume full responsibility for any actions that you 

take. 

Yamatake is not responsible for any damages or errors that occur as a result of 

changing these settings. 

Communication Boxes for Ring Communications in Chain Connections■■
Communication boxes for ring communications in chain connections are displayed 

in the [Module configuration] window using the actual module configuration 

scan function in the loader. Communication boxes, terminal adapters, and 

communication adapters not used for ring communications in chain connections 

are not displayed in the [Module configuration] window.

Write Errors in Actual Module Communication Settings Using Saved Projects■■
Projects that have acquired module configuration information read the MAC 

address information in actual devices. If there are multiple sets of modules with the 

same configuration and you want to write actual module communication settings 

or replace a module that has failed, perform an actual module configuration scan in 

the [Actual module configuration] window.
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When PC Has Multiple User IDs with Administrator Privileges■■
If a PC has multiple user IDs with administrator privileges (administrators groups), 

an error might be displayed when you switch user IDs with administrator privileges 

and log in to the PC, and then run the loader.

Error message examples:	 Failed to create new (1) 

		  Failed to open system database (401) 

		  Failed to connect to database (411)

When there are multiple user IDs with administrator privileges, specify a fixed user 

ID with administrator privileges to be used for logging in to the PC, and then use 

the loader.

When PC Has Multiple Network Interface Cards of the Same Type■■
If a PC is installed with multiple network interface cards of the same type, and the 

network interface cards have multiple ports, the loader cannot be used.

If the network profile name needs to be renamed before creating a new ■■
network profile

If no appropriate profile exists in the list of registered profiles and a new profile 

will be created to configure a different network setting, it would be necessary to 

change the network profile name in advance. Confirm that the name “New Profile” 

is not being used by any existing profile. If a profile with the name “New Profile” 

already exists, change it to a different name. 

Refer to ● Edit Profile Name (page 5-35) for details on renaming a profile 

name.

Prohibition of network setting changes while SLP-NX is running■■
While SLP-NX is running, please do not modify the computer’s network settings 

such as IP address, etc.

Change of the module’s IP address while using the inter-module data transfer■■
Be aware of the following notes when changing the communication settings for IP 

address, node ID, workgroup ID and chain ID after setting the inter-module data 

transfer in the module.

The inter-module data transfer generates internal parameters which work in 

conjunction with IP address, node ID, workgroup ID and chain ID.

Remember to write these parameters after writing the communication settings to 

the module.

Without writing the parameters, inconsistencies may occur in the inter-module data 

transfer setting information, leading to unexpected operations.

Read the module parameter settings before changing the communication settings as 

necessary.

Notes on replacing the module■■
Communication may fail if reading or writing operation is executed immediately 

after replacing the module due to module errors.

This is because the relationship between MAC address and IP address for the 

computer will not be updated for a few minutes.

Wait a few minutes before resuming the module execution if the module has been 

replaced.
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Appendix
Explanation of Terminology

SLP-NX

Mapping information

Mapping

Scan

Write

Write parameter

Read parameter

IP address
Node ID, workgroup ID
Communication settings

Parameter

Actual module communication settings
IP address
Node ID, Chain ID
Workgroup ID
Communication settings

Actual module configuration windowProject window

Module

Parameter
Read/write parameter

Universal monitor window

Project An item handled by the loader, such as the parameter settings for modules, is called 

a Project.

Workgroup A group of modules handled by the loader is called a Workgroup. Each workgroup 

is assigned a unique number that is known as the Workgroup ID. The workgroup is 

a logical grouping of modules.

Chain A group of modules physically connected in a daisy chain is called a Chain. Each 

chain is assigned a unique number that is known as the Chain ID.

Multiple chains are separated using devices such as communication boxes.

Actual Module 
Communication Settings

Ethernet communication settings and RS-485 settings such as IP addresses for 

actual modules are called Actual Module Communication Settings.

Communication settings for modules are scanned and written to modules through 

the [Actual module configuration] window.

Mapping Associating a module configured in a workgroup with an actual module is called 

Mapping.

Node ID A Node ID is an identifier for each module when the inter-module data forwarding 

function is used.

Parameter The settings required to operate modules are called Parameters.

Node Address An ID that combines the Workgroup ID and Node ID is called a Node Address.
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We would like to express our appreciation for your purchase and use of Yamatake products.
You are required to acknowledge and agree upon the following terms and conditions for your purchase of Yamatake products 
(field instruments, control valves, and control products), unless otherwise stated in any separate document, including, 
without limitation, estimation sheets, written agreements, catalogs, specifications and instruction manuals.

1.	 Warranty period and warranty scope
1.1	 Warranty period

Yamatake products shall be warranted for one (1) year from the date of your purchase of the said products or the 
delivery of the said products to a place designated by you.

1.2	 Warranty scope
In the event that Yamatake product has any failure attributable to Yamatake during the aforementioned warranty 
period, Yamatake shall, without charge, deliver a replacement for the said product to the place where you 
purchased, or repair the said product and deliver it to the aforementioned place. 
Notwithstanding the foregoing, any failure falling under one of the following shall not be covered under this 
warranty:

(1)	Failure caused by your improper use of Yamatake product 
(noncompliance with conditions, environment of use, precautions, etc. set forth in catalogs, specifications, 
instruction manuals, etc.);

(2)	Failure caused for other reasons than Yamatake product;
(3)	Failure caused by any modification or repair made by any person other than Yamatake or Yamatake's 

subcontractors;
(4)	Failure caused by your use of Yamatake product in a manner not conforming to the intended usage of that 

product;
(5)	Failure that the state-of-the-art at the time of Yamatake's shipment did not allow Yamatake to predict; or
(6)	Failure that arose from any reason not attributable to Yamatake, including, without limitation, acts of God, 

disasters, and actions taken by a third party.
Please note that the term "warranty" as used herein refers to equipment-only-warranty, and Yamatake shall not be 
liable for any damages, including direct, indirect, special, incidental or consequential damages in connection with 
or arising out of Yamatake products.

2.	 Ascertainment of suitability
You are required to ascertain the suitability of Yamatake product in case of your use of the same with your 
machinery, equipment, etc. (hereinafter referred to as "Equipment") on your own responsibility, taking the 
following matters into consideration:

(1)	Regulations and standards or laws that your Equipment is to comply with.
(2)	Examples of application described in any documents provided by Yamatake are for your reference purpose 

only, and you are required to check the functions and safety of your Equipment prior to your use.
(3)	Measures to be taken to secure the required level of the reliability and safety of your Equipment in your use 

Although Yamatake is constantly making efforts to improve the quality and reliability of Yamatake products, 
there exists a possibility that parts and machinery may break down. 
You are required to provide your Equipment with fool-proof design, fail-safe design, anti-flame propagation 
design, safety design, or the like so that the said Equipment may satisfy the level of the reliability and 
safety required in your use, whereby preventing any occurrence of physical injuries, fires, significant 
damage, and so forth.

3.	 Precautions and restrictions on application
Yamatake products other than those explicitly specified as applicable (e.g. Yamatake Limit Switch For Nuclear 
Energy) shall not be used in a nuclear energy controlled area (radiation controlled area). 
Any Yamatake products shall not be used for/with medical equipment.
In addition,
you are required to conduct a consultation with our sales representative and understand detail specifications, 
cautions for operation, and so forth by reference to catalogs, specifications, instruction manual, etc. in case that 
you intend to use Yamatake product for any purposes specified in (1) through (6) below.
Moreover, you are required to provide your Equipment with fool-proof design, fail-safe design, anti-flame 
propagation design and other designs of protection/safety circuit on your own responsibility to ensure the 
reliability and safety, whereby preventing problems caused by failure or nonconformity.

(1)	For use under such conditions or in such environments as not stated in technical documents, including 
catalogs, specification, and instruction manuals

(2)	For use of specific purposes, such as:
* Nuclear energy/radiation related facilities 

[For use outside nuclear energy controlled areas] [For use of Yamatake Limit Switch For Nuclear Energy]
* Machinery or equipment for space/sea bottom
* Transportation equipment 

[Railway, aircraft, vessels, vehicle equipment, etc.]
* Antidisaster/crime-prevention equipment
* Burning appliances
* Electrothermal equipment
* Amusement facilities

(3)	Supply systems such as electricity/gas/water supply systems, large-scale communication systems, and 
traffic/air traffic control systems requiring high reliability

(4)	Facilities that are to comply with regulations of governmental/public agencies or specific industries
(5)	Machinery or equipment that may affect human lives, human bodies or properties
(6)	Other machinery or equipment equivalent to those set forth in items (1) to (5) above which require high 

reliability and safety
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4.	 Precautions against long-term use
Use of Yamatake products, including switches, which contain electronic components, over a prolonged period may 
degrade insulation or increase contact-resistance and may result in heat generation or any other similar problem 
causing such product or switch to develop safety hazards such as smoking, ignition, and electrification. 
Although acceleration of the above situation varies depending on the conditions or environment of use of the 
products, you are required not to use any Yamatake products for a period exceeding ten (10) years unless 
otherwise stated in specifications or instruction manuals.

5.	 Recommendation for renewal
Mechanical components, such as relays and switches, used for Yamatake products will reach the end of their life 
due to wear by repetitious open/close operations.
In addition, electronic components such as electrolytic capacitors will reach the end of their life due to aged 
deterioration based on the conditions or environment in which such electronic components are used. 
Although acceleration of the above situation varies depending on the conditions or environment of use, the number 
of open/close operations of relays, etc. as prescribed in specifications or instruction manuals, or depending on 
the design margin of your machine or equipment, you are required to renew any Yamatake products every 5 to 10 
years unless otherwise specified in specifications or instruction manuals.
Field instruments (sensors such as pressure/flow/level sensors, regulating valves, etc.) will reach the end of their 
life due to aged deterioration of parts.
For those parts that will reach the end of their life due to aged deterioration, recommended replacement cycles are 
prescribed. You are required to replace parts based on such recommended replacement cycles.

6.	 Other precautions
Prior to your use of Yamatake products, you are required to understand and comply with specifications (e.g., 
conditions and environment of use), precautions, warnings/cautions/notices as set forth in the technical 
documents prepared for individual Yamatake products, such as catalogs, specifications, and instruction manuals 
to ensure the quality, reliability, and safety of those products.

7.	 Changes to specifications
Please note that the descriptions contained in any documents provided by Yamatake are subject to change 
without notice for improvement or for any other reason.
For inquires or information on specifications as you may need to check, please contact our branch offices or sales 
offices, or your local sales agents.

8.	 Discontinuance of the supply of products/parts
Please note that the production of any Yamatake product may be discontinued without notice.
For repairable products, we will, in principle, undertake repairs for five (5) years after the discontinuance of those 
products. In some cases, however, we cannot undertake such repairs for reasons, such as the absence of repair 
parts.
For field instruments, we may not be able to undertake parts replacement for similar reasons.
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